サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
IIS Expressを強制終了する方法
Microsoft Visual Web Developer Express 2010に付属するMS IIS Expressサーバーを非アクティブ化しようとしています。サービスを停止するかプロセスを終了するだけで、すべての非奇妙なサーバーを停止できますが、Microsoftはそれを変えました。 私は試した: iisreset /stop iisreset /kill net stop w3svc また、iis構成マネージャーでデフォルトサイトのhttpポート80バインディングを削除しようとしました。それでもポート80はブロックされ、404エラーが表示されます。MS Visual Web Developer Express 2010とそのすべてのコンポーネントをアンインストールした後でも、サーバーはまだそこにあり、404サイトを表示しています。 これを削除するにはどうすればよいですか?
9 iis-7.5 

2
ニスヒストグラムの読み方
ワニスのヒストグラム/グラフはどのように読み取られますか?X軸は対数目盛であることを理解しています。 具体的には: 9個の「|」またはキャッシュヒットがで発生しy=1e-4ています。それぞれの「|」は何ですか 参照する?ページ?ファイル? これら9つの「|」の左側にヒットが少なく、右側にヒットがいくつかあります。それらは何ですか?彼らはより長い(右)とより短い(左)の時間を要しましたか? 上部にあるのは何1:2ですか?そしてn = 134 また、キャッシュヒットは常にキャッシュミスの左側にあります。つまり、1e-xキャッシュミスは+指数を下回っていますが、物事の側にあります。その意味は何ですか?その時、もしそうなら、何の時...? どうもありがとう! X軸 1:2, n = 134 hostname # # # # # | # | # | # | # | ### | ### || ### ## ||| ### ## # # ## |||| #### #### ## ## # ### +---------+---------+---------+---------+---------+---------+---------+---------+--------- …
9 varnish  graph 

5
SSH経由のVimで色を有効にする方法は?
2つのリモートサーバーがあります。 サーバー1:Linux 2.6.18-238.12.1.el5PAE i686 / VIM-Vi IMproved-バージョン7.0.237 サーバー2:Linux 2.6.18-338.19.1.el5.lve0.8.36 x86_64 / VIM-Vi IMprovedバージョン7.0。 237 私がサーバー2にsshし、vimを使用してa phpまたは.htaccessファイルを編集すると、美しい色で強調表示されます。以下は/etc/vimrcそのサーバー上のファイルです。 サーバー1にSSH接続すると、色が表示されません。以下のコードをサーバー1の〜/ .vimrcファイルにコピーしてみましたが、カラー構文が機能していません。他の機能(などset nocompatible)は機能していますが、色は機能していません。 サーバー1で色が機能しないのはなぜですか?どのようにテストして修正できますか?tput colors両方の端末で戻ります8。私は試しましたが、それも助けには:syntax onなり:syntax enableません。 ------------------------------------------------------------ /etc/vimrcファイルの内容: if v:lang =~ "utf8$" || v:lang =~ "UTF-8$" set fileencodings=utf-8,latin1 endif set nocompatible " Use Vim defaults (much better!) set bs=indent,eol,start " allow backspacing over …
9 linux  ssh  unix  vim  vi 

4
フォールトトレランスのために2つ目のRAIDコントローラーが必要ですか?
サーバーに3台のハードドライブが取り付けられており、合計容量は6台です。最大になる予定ですが、コンサルタントは、新しいドライブをサポートするために「冗長性のために」2番目のRAIDコントローラーを入手することを提案しました。私には、これはあまり意味がありません。2番目のRAIDコントローラーがディスクの半分を実行している場合でも、コントローラーの1つが停止した場合、ディスク/プログラム/データの半分だけでスタックします(何もない状態で実行するよりもはるかに優れています)。サーバーにvmwareを配置し、高度なフォールトトレランス/フェールオーバー機能について漠然と言及しましたが、コントローラーの障害が原因でディスクにアクセスできない場合、どのように機能するのでしょうか。 パフォーマンスではなく、冗長性の理由のみを数えますが、サーバーに2つ目のRAIDコントローラーが必要なのはなぜですか?

2
一意のキーを使用してMyISAMのパーティションでMySQL挿入を高速化する
大きなMyISAMテーブル(約3000万行)があります。ある時点で固定行形式に切り替えたので、テーブルはディスクで最大40Gb、インデックスで2Gbを使用します。テーブルには一意のインデックスがあり、1秒あたり100件の「重複キーの更新時に挿入」クエリがあります。テーブルが大きくなるにつれて、これらの挿入はますます遅くなります。 よくわかりませんが、パーティションを使用すると、挿入を高速化できますか?

3
Stunnelは一部のホストからのSSLv3で動作しません
警告: SSLv3は廃止されました。完全に無効にすることを検討してください。 StunnelをSSLキャッシュとしてサーバーに設定しようとしています。すべてがスムーズで、ほとんどが設計どおりに機能しました。 次に、ログファイルでエラーが発生しました。 SSL_accept: 1408F10B: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number 何らかの奇妙な理由により、すべてのクライアントがそれをトリガーするわけではありません。リンクを使用してCentOSから接続する-エラーが表示されます(複数のマシンを試しました)。リンクを使用してUbuntuから接続-エラーなし。 wgetを使用してみましたが、TLSv1ではすべてがスムーズですが、SSLv3ではエラーが表示されます。同時に、wgetは次のように報告します。 OpenSSL: error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure SSL接続を確立できません。 これが私の設定です: pid = /etc/stunnel/stunnel.pid debug = 3 output = /etc/stunnel/stunnel.log socket=l:TCP_NODELAY=1 socket=r:TCP_NODELAY=1 verify=3 ; fixing "fingerprint does not match" error fips=no [https] accept=12.34.56.78:443 connect=127.0.0.1:80 TIMEOUTclose=0 xforwardedfor=yes CAfile = /path/to/ssl/example.com.cabundle cert=/path/to/ssl/example.com.crt key=/path/to/ssl/example.com.key …

1
ProxyPassが404を返したときのApache HttpdカスタムErrorDocument 404
プロキシパスを使用して、別のアプリケーションサーバーの前にApache Webサーバーがあります。アプリケーションへのリクエストがエラー404を返したとき、アプリケーションサーバーからのエラーページではなく、Webサーバーからのカスタムエラーページを表示したいと思います。仮想ホストでErrorDocument 404をセットアップしようとしましたが、機能しません。どうすればよいですか?またはこれは不可能ですか? <VirtualHost *:80> ServerName servername DocumentRoot /somepath/ ProxyPass / http://localhost:8080/someapp/ ProxyPassReverse / http://localhost:8080/someapp/ ErrorDocument 404 /error.html </VirtualHost>

3
シスコとLinuxおよびVLAN
LinuxでVLANがどのように機能するかについて、いくつかの根本的な誤解があるようですが、ここの優秀な人々が私を教育してくれることを願っています。 キャスト:1つのCisco 3560、1つのVLAN、および1つのLinuxボックス[1]。 Cisco --------------- Linux ge0/1 eth0 Ciscoには、IPアドレス10.40.37.252/24のVlan 37インターフェイスがあります。Linuxボックスに10.40.37.1/24を配置します。 シスコがVLAN 37のカプセル化を解除すると、すべて正常に動作します[2]。 # Cisco interface Vlan37 ip address 10.40.37.252/24 interface GigabitEthernet 0/1 switchport mode access switchport access vlan 37 # Linux ip link set eth0 up ip addr add 10.40.37.1/24 dev eth0 $ ping 10.40.37.252 && echo It works ただし、ポートをトランキングに設定し、Linux側でvlan …
9 linux  cisco  vlan  trunk  802.1 


3
2つのパーティション間にシンボリックリンク(ln)を作成する方法
Ubuntu 10.04.3サーバーに2つのパーティションがあります。 パーティション1:/ mnt / storage / パーティション2:/ var / www / myweb / 次のコマンドを実行すると $ ln /mnt/storage/sourcefile.txt /var/www/myweb/linkedfile.txt 私はこれを得た ln:ハードリンクの作成 `/var/www/myweb/linkedfile.txt '=>` sourcefile.txt':無効なクロスデバイスリンク このシンボリックリンクを作成する方法のアイデア??

5
SPF-実装する必要がありますか?
SPF TXTレコードを含めるために、ドメインのDNSレコードがWeb開発者からリクエストされました。私はこれについて異なる意見を見つけました... あなたが提供できるコメントや洞察は高く評価されます。これは経験的な質問自体ではないことは承知していますが、それでも主観的な提供に感謝します...特に、ウェブポストやオンラインドキュメントなど、参考資料が含まれている場合は調べてみます。

1
Procurveスイッチの管理モード
ネットワークの専門家ではないので、間違いを見つけるまで、ネットワークの構成に少し時間を費やしました。HPProCurve Switch 1810Gでは、「管理モード」はこのポートから管理インターフェイスにアクセスできるかどうかを意味すると思いました。まあ、それはポートが有効になっているかどうかを意味します。ヘルプ機能から抽出: 管理モード-ポート制御の管理状態を有効にする場合に選択します。クリックして有効にし、ポートをネットワークに参加させます(デフォルト:有効) まあ、もちろん、私はヘルプを読みませんでした。なぜなら、それが管理インターフェース用であることに疑いはなく、どこか他の場所でエラーが疑われたからです。 とにかく、それがポートを有効/無効にするために一般的に使用される用語なのか、またはHPが私の人生をより困難にしたいと思ったのでしょうか。このオプションが「ポートを有効にする」だけではない理由を理解できません!? これは、Webインターフェースでの外観のスクリーンショットです(Webインターフェースを使用するのは残念です)

1
WAMPサーバー2.1:デフォルトのテキストエディターを変更する[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 7年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 Notepad ++を使用してhttpd.confおよびphp.ini構成ファイルを開き、WindowsでそれらのファイルタイプをNotepad ++に関連付けました。ウィンドウを介してそれらのドキュメントを開くと、Notepad ++が開きます。しかし、WAMP(Apache MySQLとPHP for Windows)サーバーのメニューを使用してこれらの構成ファイルにアクセスすると、許容できないエディターであるMicrosoft Notepadが開きます。WAMPサーバーがこれらのファイルを開く方法を変更する既知の方法はありますか?
9 windows 

5
3 TBドライブのSASまたはSATA?
新しい3 TBエンタープライズグレードドライブの購入を検討しており、SASまたはSATAモデルのいずれかを購入できます。 AFAIK、SASは一般的にSATAよりも優れたパフォーマンスを提供しますが、ベンチマークを検索すると、記事Seagate Constellation.2およびConstellation ES.2 Hard Drive Reviewが見つかりました。 要約すると、SATAはほとんどのテストでSASよりも高速でした。しかし、コメントを読んでみると、「プレスキャン」と呼ばれる機能があるように見えます。 パフォーマンスの観点から推奨できるのはSATAまたはSASですか?実際のパフォーマンスは許容範囲ですか? 私たちのシステムのワークロードの一種は、時々ランダムな読み取りアクセスを伴う、重いマルチスレッドのシーケンシャルな書き込みと消去です。
9 hard-drive  sata  sas 

4
DHCPサーバーはDHCPを介して自身にIPアドレスを割り当てることができますか
これはちょっとした質問のように思われるかもしれません(そして、私はそれがそうかもしれないと恐れています)が、ネットワークの唯一のDHCPサーバーとして機能しているサーバーがIPアドレスの要求をネットワークに送信し、独自の要求をキャッチしてそれに答えることは可能でしょうか? ? 私の直感はすべて答えを示さないので、理想的にはテストしてみますが、現在時間/余力がないため、他の誰かが同じことを考えて試してみたかったのです。 これは一般的な質問であることを意図していますが、誰かが興味を持っている場合は、ubuntu 11.04でisc-dhcpを実行しています
9 dhcp 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.