サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
終了時ではなく、着信時にApacheログリクエストを送信する
サーバーの再起動ですべてが正常に戻る、奇妙なサーバークラッシュの問題を診断しようとしています(サーバーはpingに応答しますが、再起動するまでSSH接続を受け入れません。0%CPU)。Apacheアクセスログ(または他のログ)に、クラッシュが発生したときに行われたすべてのリクエストを含めたいのですが、残念ながらApacheはリクエストが完了するまでログを記録しません。つまり、リクエストがサーバーをクラッシュさせている場合、そのリクエストは終了せず、ログに表示されません。 リクエストの到着時に書き込まれるログファイルを作成するようにApacheを設定する方法はありますか?

3
根本原因分析の実行
根本原因分析を実行する方法について詳しく知りたい。多くの場合、私たちの部門はユーザーに再起動(Windows XPシステムの3つ)を試みるように指示しています。これにより、実際には多くの問題が「修正」されます。私が急いでいるとき(そして時々給与を受け取ることがこれに寄与することがあります)、実際に根本原因分析を実行する代わりに、問題を迅速に解決するための回避策を見つけようとするかもしれません。 ほとんどの場合、ログファイルまたはイベントビューアでこの情報を探しています。Sysinternalsツールを使用したり、パケットスニファを実行したりすることもあります。おそらく、Sysinternalsプログラムを必要以上に使用していません。これらのツールをどのように使用するか、いつ、どのような理由で役立つかについての具体的な洞察。 これは幅広い質問ですが、使用する方法論、ツールなどについて簡単に説明していただけますか?SFの多くの管理者が、より詳細なプロセスを使用しているようです。これが質問の絞り込みに役立つ場合は、AD環境内のWindowsサーバーとクライアントに関連するツール、ヒント、トリックなどに最も興味があります。

1
Intel AMT-Linux経由でVNCを有効にする
古いサーバーにはすべてsupermicroボードがあり、IPMIを使用して帯域外管理を行いました。ほとんどの場合、シャットダウン/再起動に使用し、sol / kvmコンソールを介して一部の設定を変更することもありました。偶然にも、新しいサーバーの1つにvPro / AMTを搭載したIntelボードが搭載されています。私たちはそれを有効にし、それが提供するwebguiに本当にがっかりしました。これは、通常のIMPIソリューションと比較して非常に制限されています。 私たちの主な問題は次のとおりです:+#?=)(&/%$§ "kvm vncを有効にするにはどうすればよいですか?AMTはバージョン6からサポートします。7があります。BIOS設定kvm、SOL、IDERでアクティブ化しました。しかし、実行するvncサーバーがないようです(簡単にtelnet servername 5900これを示しています)。すべてを知っているインターネット上の本当に予備のサイトを掘り下げていると、Intelの管理ツールでBIOS設定に加えて有効にする必要があることを示しているようです。 (これがなぜこのようになっているか、それにBIOSオプションがないのかわからない)-しかし、そうである場合、Unix(Linux + Solaris)のみの環境があり、使用できないため、その方法はわかりませんそれ(そのWindowsツール)。 Intel経由のLinux用のドライバーがあるようですが、ネットワーク経由ではなくホスト上で直接見ることができますが、どうでしょうか?そのコンソールにシステムをインストールしたいので、マシン自体にはシステムがありません。 誰かがこれに対する解決策を知っていますか?他のマシンにはすでにamttoolsをインストールしていますが、SOL端末(BIOSメッセージは表示されません)のみを提供し、非常に限定されたwebguiの機能を反映しています。 更新:ソリューションとして、Windowsを搭載したプライベートラップトップを使用しました。Intelからバッチスクリプトを生成するこのSOAPメッセージをインストールし、一度アクティブにしました。これでvncが機能するようになりましたが、AMTが(部分的に)リセットされたときに(既に確認しました)設定もなくなったため、別の解決策を喜んで聞いています。
9 linux  vnc  intel  amt 

3
再構築中にRAID 6にデータを書き込んでも安全ですか?
非常に大きなRAID 6(11ドライブ、それぞれ3TB)をホストするテストRAIDコントローラーをネットワーク上に持っています。ドライブの1つに障害が発生し、アレイは現在再構築中です。このレートでは、完了するまでに約3日かかると思います。新しいデータをアレイに書き込んだ場合、再構築が成功する可能性が低くなりますか? たくさんの小さなファイルの形で約1 GBの新しいデータを書き込むかもしれません。これにより、再構築の進行が大幅に遅れますか?
9 raid  raid6 

4
このsshエラーはどういう意味ですか?
これが私の最後の手段であります。私は何時間もここで問題を理解しようとしました。 取引は次のとおりです。秘密鍵をマシン#1からマシン#2にコピーしました。マシン#1はsshを介して私の公開鍵でサーバーに問題なく接続できますが、マシン#2はサーバーに接続しようとすると次の出力を提供します。 $ ssh -vvv -i /home/kevin/.ssh/kev_rsa user@192.168.1.244 -p 22312 OpenSSH_5.3p1 Debian-3ubuntu6, OpenSSL 0.9.8k 25 Mar 2009 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 192.168.1.244 [192.168.1.244] port 22312. debug1: Connection established. debug3: Not a RSA1 key file /home/kevin/.ssh/kev_rsa. debug2: key_type_from_name: …
9 ssh  rsa  private-key  keys 

2
rsync「操作は許可されていません」
USBハードディスクへの単純なrsyncを実行しようとしています。コマンドは rsync -az --modify-window=2 /home /mnt/exthd/tmp/ これをrootとして実行しています。 しかし、私はすべてが不十分な権限に関連しているように見える多くのエラーを受け取ります: rsync: chown "/mnt/exthd/tmp/home/someuser" failed: Operation not permitted (1) rsync: chown "/mnt/exthd/tmp/home/someuser/.bash_logout" failed: Operation not permitted (1) rsync: chown "/mnt/exthd/tmp/home/someuser/.bash_profile" failed: Operation not permitted (1) rsync: chown "/mnt/exthd/tmp/home/someuser/.bashrc" failed: Operation not permitted (1) rsync: chown "/mnt/exthd/tmp/home/guest" failed: Operation not permitted (1) rsync: chown …
9 rsync 

1
古いSPARCマシンに新しい命を与える-関連する問題を起動してインストールする
私の問題はあなたが日常的に遭遇する問題ではありませんが、共有して助けを求めるのに十分興味深いと思います。最初から:私がメンバーになっている(私たちはネットワーク関連のものに焦点を当てています)学術科学グループが今日、ooold SPARCサーバーを取得しました。解決)。 これがその写真です:http : //i.imgur.com/s8iE9.jpg 大きな問題は、それが機能しているかどうかを確認し、OSをインストールする方法を教えてください。事は物事をより簡単にするVGAポートを持っていません。 DB-25-> COMケーブルのようなケーブルがありますが、ハイパーターミナルを備えたWindowsラップトップでは動作しないことが報告されています。私はあらゆる種類のトラフィックについてネットワークポートを監視して機能していることを確認し、ネットワークブートをいじってOSをインストールすることを考えていました。これは良いアイデアでしょうか。 助けてくれてありがとう:) アップデート#1の時間: 皆さまのアドバイスありがとうございました!それはすべて非常に役に立ちましたが、私は今日いくつかの問題に遭遇しました。最初の問題:http : //i.imgur.com/tFgv5.jpg ご覧のとおり、一番上のものはSun Netraではなく、StorEdge S1ディスクアレイでした。もう1つは、キーがないことです。また、マニュアル@lainによると、シリアルコンソールを取得するには診断モードでオンにする必要があります。診断モードをオンにすることに関する情報が見つからないため、Googleスキル@ voretaq7が悪いようです。 こちらが別の写真です:http : //i.imgur.com/eFsEf.jpg そこには大量のポートがあります:-o StorEdgeを4500に接続するにはどうすればよいですか?私はそれのマニュアルを閲覧しましたが、SCSIケーブルの一方の端をSEの出力ポートに接続し、もう一方を4500の,, 1 ''マークの付いたポートに接続することは良い考えのようです。 DB25-> COMケーブルについては、それはカスタムメイドであり、おそらくヌルモデムではありません。図を作成できるように、どこで図を見つけることができますか? 最終更新: 皆様のご意見に感謝します:)マシンを稼働させるために多くのことを助けてくれました。あなたなしではそれができなかったと思います。http://i.imgur.com/A9obl.jpg-現在OpenBSDを実行していますが、後でフリーにします:)乾杯!

1
AWSでレベル1 PCIコンプライアンスを達成した人はいますか?
AWSによって公開されたすべてのFAQ、ドキュメント、ステートメントは別として、レベル1の加盟店は実際にAWSでPCIコンプライアンスを実際に達成しましたか?一部のサービスをEC2 / VPCに移行することを評価していますが、監査人は、他のクライアントがコンプライアンスを達成しようとしてAWSが協力的でなく、代わりにRackspaceに移動する必要があったと述べています。彼らが遭遇した問題は、 AWSはAWSのPCI監査で評価された統制の項目別リストを提供していないため、監査人がAWSでカバーされている項目とクライアントの責任である項目をマークすることは不可能です AWSは、ハイパーバイザーがどのように評価され、どのテストがテナントの分離を保証するために実行されたかを明確にしていません 更新:この質問は、元々StackExchangeで質問されましたが、そのサイトには適切ではないと投票されました。

5
壊れたシンボリックリンクを自動的に見つけて報告するにはどうすればよいですか?
きちんとしたシステム管理者として、私たちは小さなことが大きなもの(時間の許す限り)と同様にカバーされることを保証したいと思っています。これらのことの1つは、システムが壊れたシンボリックリンクでいっぱいにならないようにすることです。 なぜこれらの小さな荒廃者が問題なのですか?ファイルが存在しないときにファイルがあると思わせるので、それらはより厄介なものを示している可能性があり、特定のコマンド(などgrep -r)を実行すると、私の(小さめの)OCD部分がすべての警告で狂ったようになります。 したがって、管理者が担当するシステムの部分全体で壊れたリンクを検出(および電子メールまたは監視システムを介して報告)するにはどうすればよいでしょうか(~jbloggs壊れたシンボリックリンクがたくさんあることを私に伝えても、それは彼の問題です) )?

3
LXCとは何か、そしてLXCが何のために役立つのかをプレーンな英語で説明する[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 6年前休業。 LXCとは何ですか? それは何のために便利ですか? LXCと一般的な仮想化の違いは何ですか?
9 linux  lxc  containers 

5
* source * IPに基づくApache仮想ホスト
ソース IPに基づいて、異なる仮想ホスト用にApacheを構成することは可能ですか?(つまり、ソース IP に基づいて、同じインターフェース、同じホスト名、ただし内容が異なる2つの異なる仮想ホスト) これの動機は、私のIPアドレスが適切にサイトにアクセスできるようにするためですが、他のすべての人は保留ページを取得します。従来の解決策はmod_rewriteを使用してビジターを同じdocroot内の別のページに誘導することですが、代わりに完全に異なるdocrootを保持ページに使用したいと思います。

3
私のADはすでにLDAPサーバーですか?
LDAPブラウザーをインストールして、AD情報を参照してみます(これは、Google Directory Syncプロセスを有効にするための一部です)。 ただし、接続エラーが発生し続けます(ポート:19389を使用)。 最初のQI:私のActive Directory(2003R2サーバー)は既にLDAPサーバーですか?(リーディングから、各ADはLDAPの実装であることを理解しています)-したがって、私の答えは「はい」になります。 その場合、接続できないのはなぜですか?このような「LDAP」接続を有効にする設定はありますか?(私は感じていません)重要な情報が欠けていると感じています。 * JXplorerをLDAPブラウザとして使用しています シンプルなLDAPサーバーとしてのこのAnsewr MS Active Directoryは、 ADAMを使用するように指示しますが、これがどのように役立つかわかりません。

2
Apacheは複数の条件を書き換えます
古いドメイン名(olddomain.comなど)から新しいドメイン名(newdomain.comなど)に移行したWebサイトがあります。 SEOの理由から、すべてのWebサイトトラフィックをプライマリの新しいドメイン名(www.newdomain.comなど)に書き換える必要があります。残念ながら、複数のORタイプの書き換え条件を追加する方法がわかりません。以下のサンプルコードのすべての条件を使用すると、AND条件が発生するようです。 <VirtualHost *:80> ServerAdmin webmaster@localhost ServerName newdomain.com ServerAlias www.newdomain.com ServerAlias olddomain.com ServerAlias www.olddomain.com DocumentRoot /var/www/newdomain.com/www/ <Directory /> Options FollowSymLinks AllowOverride All </Directory> ErrorLog /var/log/apache2/error.log # Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn RewriteEngine on RewriteCond %{HTTP_HOST} ^olddomain.com [NC] RewriteCond %{HTTP_HOST} ^www.olddomain.com [NC] …


1
IPTableを使用してソースIPごとのICMPを制限する
制限モジュールはソースIPごとであると誤って考えましたが、すべてのリクエストに基づいているようです: 577 36987 ACCEPT icmp -- * * 0.0.0.0/0 0.0.0.0/0 icmp type 8 limit: avg 3/sec burst 5 46 3478 LOG icmp -- * * 0.0.0.0/0 0.0.0.0/0 icmp type 8 LOG flags 0 level 4 prefix `INET-PING-DROP:' 46 3478 DROP icmp -- * * 0.0.0.0/0 0.0.0.0/0 icmp type 8 ... …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.