サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
debianで仮想パッケージを作成する最も簡単な方法は何ですか?
debianで「仮想パッケージ」を作成する最も簡単な方法は何ですか? 私の問題:ソースからmysqlをコンパイル/インストールし、mysqlがすでにインストールされていることを他のパッケージに通知する必要があります(そうしないと、mysqlもインストールしようとします...)。インターネットを検索しましたが、この質問に対する簡単な答えは見つかりませんでした。 aptitudeに何かをインストールするように指示するが、特定の必要なライブラリ/依存関係(mysqlなど)を除外する簡単なコマンドがあります。これは問題を解決するもう1つの方法です。

3
SQL 2008ログインパスワードはどこに保存されますか?
SQL Server 2008が実際にパスワードを格納しているファイルを知る必要があります。これはセキュリティ監査人によって尋ねられている質問です。 でパスワードハッシュを取得できることはわかっLOGINPROPERTY('bbellomo', 'PasswordHash')ていますが、それでも役に立ちません。それらがどのように保存されているかを知る必要があります。



8
MySQL:致命的エラー:特権テーブルを開いてロックできません:テーブル 'mysql.host'が存在しません[クローズ]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 4年前休業。 突然、ローカルのMySQL 5.5サーバーがWindows XP SP3で実行されなくなりました。 WAMP ApacheとWAMP MySQLもインストールしていますが、WAMP MySQLが実行されていません。エラーログは以下を示します: サーバーを起動できません:TCP / IPポートにバインド:そのようなファイルまたはディレクトリはありません ポート:3306で別のmysqldサーバーがすでに実行されていますか? ポートを3306から3307に変更しようとしましたが、サービスはまだ開始されず、エラーが発生しました。 イベントビューアに次のように表示されます。 致命的なエラー:特権テーブルを開いてロックできません:テーブル 'mysql.host'が存在しません mysql.pluginテーブルを開けません。mysql_upgradeを実行して作成してください。 どうやら、サーバーが実行されている場合にのみ、mysql_upgradeを実行できます。サービスを開始できない場合、どうすれば「mysql.host」を作成できますか? MySQLサーバーをアンインストールして再インストールしました。インストール後の構成ウィザードで、次のエラーが表示されます。サービスを開始できませんでした。エラー:0。 ここからどのように進めますか?

2
ApacheのMaxClients。プロセスのサイズを知る方法は?
http://httpd.apache.org/docs/2.2/misc/perf-tuning.htmlから Webサーバーのパフォーマンスに影響を与える最大のハードウェアの問題は、RAMです。スワップすると、ユーザーが「十分に速い」と考えるポイントを超えて各リクエストのレイテンシが増加するため、ウェブサーバーがスワップする必要はありません。これにより、ユーザーは停止してリロードする必要があり、負荷がさらに増加し​​ます。MaxClients設定を制御して、サーバーがスワッピングを開始するほど多くの子を生成しないようにすることができます。これを実行するためのこの手順は簡単です。topなどのツールを使用してプロセスリストを調べ、平均Apacheプロセスのサイズを決定し、これを使用可能な合計メモリに分割して、他のプロセスのための余地を残します。 主な問題は、サイズを知る方法を理解できないことです。なぜなら、私は3888を超えないようにhttpdのサイズを持っているからです。 しかし、MaxClientsの数を決定する必要があり、4GBのRAMがある場合、972を取得するので、MaxClientsで900のように使用する必要がありますか?

2
32ビット/ 64ビットサーバー間のASP.NETパフォーマンスの低下
現在、32ビットの運用サーバーをより強力な64ビットサーバーにアップグレードすると同時に、ASP.NET 4にアップグレードしています。ただし、軽負荷テストを行ったところ、パフォーマンスが低下しているようです。 簡単な使用例をいくつか実行して、20人のユーザーの一定の負荷で単純な負荷テストを作成し、結果を比較しました。 ご覧のとおり、最もパフォーマンスの高い構成は、ASP.NET 2.0を備えた既存の32ビットサーバーです。 64ビットマシンでIISを32ビットモードで実行することにより、既存の32ビットサーバーに相当しますが、64ビットサーバーでIISを64ビットモードで実行すると、パフォーマンスが大幅に低下します。新しいサーバーのほうが優れているため、これがなぜかはわかりません。 何らかの理由で、64ビットでIISを使用してテストを実行するたびに、最初に大きなスパイクがあり、その後均一になりましたが、32ビットよりも応答時間が長くなっています。IISを32ビットモードで実行すると、スパイクがなくなります。 アプリプール/アプリはテスト間で再起動されていませんが、スパイクは一貫してあり、応答は他の構成よりも高いことに注意してください。 だから-私の質問は:これがなぜなのか誰かが何か知っていますか?設定する必要がある構成設定はありますか?誰が私が違いを引き起こしているものを絞り込むことができるかについていくつかの指針がありますか? 現在の運用サーバー:Win Server 2003-32ビット-IIS6 新しいサーバー:Win Server 2003 R2-64ビット-IIS6

1
SSHサーバーへのログイン:権限が拒否されました。もう一度お試しください
ユーザー名とパスワードを使用してSSHサーバーにログインしようとしていますが、正しいパスワードを入力するとこのエラーが発生します。 Permission denied, please try again. 私はできるものの、別のマシン上でpubkeyでを使用してログインし、私は、通常のパスワード認証を無効にしていません。無効にしたのはrootログインだけでした。 これが私のsshd_configファイルです: #パッケージが生成した設定ファイル #詳細は、sshd_config(5)のマンページを参照してください #リスニングするポート、IP、プロトコル ポート22 #これらのオプションを使用して、sshdがバインドするインターフェース/プロトコルを制限します #ListenAddress :: #ListenAddress 0.0.0.0 プロトコル2 #プロトコルバージョン2のHostKeys HostKey / etc / ssh / ssh_host_rsa_key HostKey / etc / ssh / ssh_host_dsa_key HostKey / etc / ssh / ssh_host_ecdsa_key #特権分離はセキュリティのためにオンになっています UsePrivilegeSeparationはい #エフェメラルバージョン1サーバーキーの寿命とサイズ KeyRegenerationInterval 3600 ServerKeyBits 768 #ロギング SyslogFacility AUTH …
9 ubuntu  ssh 

3
Cisco IOSファームウェアの入手方法
すばやく簡単な質問ですが、答えを見つけることができませんでした。 Cisco ADSLルーター(モデル877)を持っています。 シスコのサポート契約はありません。 更新されたファームウェアを入手するにはどうすればよいですか? 必要なファームウェアを知っています。これは、同じ機能セットを使用した現在のファームウェア(15.0-> 15.1)からのマイナーアップデートです。だから私はそれを持つ権利があるはずです。それでも、シスコではダウンロードを許可していません。 何をすべきか? 単にCiscoルーターを所有するだけではファームウェアの更新に値しないというのは本当ですか? 補足:もちろん、インターネット上のソフトウェアを「見回す」方法は知っています。しかし、奇妙な場所からダウンロードされたファイルは、ルーターで実行したいものではありません。
9 cisco  ios  firmware 


4
DNSはホスト名を解決できません。nslookupは
Windows 7で、DNS名がwindows.csのローカルサーバーにアクセスしようとしているユーザーがいます。2つの内部DNSサーバーがあります。DHCPサーバーは、2つの内部DNSサーバーをプライマリとセカンダリとしてユーザーに割り当て、次にISPのDNSを3次DNSサーバーとして割り当てます。 ユーザーは時々、windows.csのWebサイトにアクセスできません。pingを実行すると、ホスト名を解決できないと表示されます。DNSキャッシュをフラッシュし、DNSキャッシュを表示すると、次のようになります。 windows.cs-名前が存在しません それでも、デフォルトでプライマリDNSサーバー(内部DNSサーバー)にクエリを実行し、windows.csにクエリを実行するnslookupを使用すると、正しいIPアドレスが返されます。 では、なぜpingを使用してWindowsがホスト名を解決できないのに、nslookupツールを使用すると解決できるのでしょうか。そして、どうすればこれを修正できますか?

2
リモートデスクトップネットワークレベル認証はサポートされていません
私はWindows XP Professional SP3 x86を実行していて、Windows 7 Ultimate SP1 x64のシステムに接続しようとしています。 最近、Windows 7ボックスへの接続にネットワークレベル認証(NLA)を使用することを期待して、XPシステムのリモートデスクトップ接続ソフトウェアを更新しました。更新後、RDPを介してWindows 7ボックスに接続し、更新されたクライアントがそれをサポートするはずであると信じてNLAを有効にしました。 切断して再接続しようとすると、次のエラーが表示されます。 リモートコンピューターにはネットワークレベル認証が必要ですが、コンピューターはこれをサポートしていません。サポートが必要な場合は、システム管理者またはテクニカルサポートにお問い合わせください。 そこで、リモートデスクトップ接続の[バージョン情報]ページをチェックして、更新が適用されていることを確認しました。これは私が見るものです。 リモートデスクトップ接続 シェルバージョン6.1.7600 コントロールバージョン6.1.7600 ©2007 Microsoft Corporation。全著作権所有。 ネットワークレベル認証はサポートされていません。リモートデスクトッププロトコル7.0がサポートされています。 NLAはRDP 7.0クライアントの一部であるはずだと思いました。どこかに足りないコンポーネントはありますか?

1
サーバーは正常に動作していますが、pingを実行できません
以前に気づいたのですが、EC2インスタンスの1つ(多く)がpingリクエストに応答しません。SSH、HTTP、FTP、データベースはすべて正常に動作しますが、pingは失敗します。 このインスタンスは、EC2の約40ノードで使用するイメージに基づいており、この問題が発生したことを覚えていません。NAGIOSの各サーバーのメインの「それである」チェックがPingを使用しているので気づきました。 機能的には問題ありません(別のインスタンスを開始しただけで問題なく動作しました)が、私の教育では(そして私が興味を持っていたため)、なぜ他のサービスが動作するときにpingを実行しないのですか? Sam-Rudges-MacBook-Pro:~ sam$ curl -i http://50.19.x.x/ HTTP/1.1 302 Found Date: Tue, 14 Jun 2011 16:38:36 GMT Content-Type: text/html; charset=UTF-8 Connection: keep-alive Content-Length: 0 Location: /dash Server: TornadoServer/1.2.1 Sam-Rudges-MacBook-Pro:~ sam$ ping 50.19.x.x PING 50.19.x.x (50.19.x.x): 56 data bytes Request timeout for icmp_seq 0 Request timeout for icmp_seq 1 Request …

1
計算された完全なApache httpd構成を表示していますか?
Apache httpdが使用している計算された構成を生成するコマンド/ツールはありますか?httpd.confやその他の構成ファイルを手動で確認できることはわかっていますが、含まれているすべてのファイルと適用されるセクションの構成を生成する標準ツールはありますか? おかげで、 ジェームズ 編集:ビルド済みのバイナリから、Windows x-64バージョンのApacheを使用していることにも言及したはずです。

2
Puppetを使用してUbuntuにopen-vm-toolsをインストールします。小悪は何ですか?
理想的な世界では、をインストールするためのパペットの設定open-vm-toolsは次のように簡単です: class vm-tools { package { 'open-vm-tools': ensure => installed } package { 'open-vm-dkms': ensure => installed } } しかし、それは依存関係の醜い醜い缶を開きます。Xをインストールしますが、これは明らかにサーバーには属していません。Ubuntu 10.04以降、これらのパッケージはどちらもopen-vm-toolboxGUIツールのパッケージを推奨しています。 # apt-cache depends open-vm-dkms open-vm-dkms Depends: dkms Depends: make Suggests: open-vm-toolbox Recommends: open-vm-tools # apt-cache depends open-vm-tools open-vm-tools Depends: libc6 Depends: libfuse2 Depends: libgcc1 Depends: libglib2.0-0 Depends: libicu44 Depends: …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.