サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
今夜のセキュリティ更新後にSQL Server Windows認証が失敗する:ログインは信頼されていないドメインからです
次の設定があります。 1つのドメインコントローラー(DC、Server 2003 R2 Standard x64) 1つのSQL Server(SQL、Server 2008 R2 Standard x64) 一部のクライアント。 すべてのマシンが同じドメインにあります。使用中のすべてのユーザーアカウントはドメインアカウントです。SQLは、SQL Server 2005、2008、2008R2、2012、2014の各インスタンスを1つ実行します。 今夜から(DCが再起動してWindowsの自動セキュリティアップデートをインストール)、Windows認証を介したSQL 2005、2008、および2008R2インスタンスへのアクセスは正常に機能しなくなりました。 これらのインスタンスの1つにアクセスするとき あるクライアントから Windows認証の使用 次のエラーが発生します(2008R2メッセージです。2005/ 2008メッセージも同様です)。 ログインに失敗しました。ログインは信頼されていないドメインからのものであり、Windows認証では使用できません。(Microsoft SQL Server、エラー:18452) ドメインが1つしかないため、メッセージテキストは適用されません。 ユーザーがSQLにログインすると(RDPセッションを開始するか、単純に実行runas /user:MYDOMAIN\someuser cmdしてウィンドウを開いたままにしておくと)、このユーザーは、プロセスが実行されるまで、すべてのクライアントからすべてのSQL Serverインスタンスに問題なくアクセスできます。そのユーザーの資格情報は閉じられます。 これは、SQLですべてのユーザーに対して上記のrunasコマンドを1回実行する(そしてウィンドウを開いたままにする)ことでこの問題を回避できることを意味しますが、明らかに何かが深刻に壊れています。今夜のDCのセキュリティ更新はそれと何らかの関係があるのではないかと疑っています(変更されたのはそれだけなので)。それぞれをアンインストールして再起動することは避けたいです(12個の更新がインストールされ、DCは本当に古くて遅い)。 誰かが以前にこの問題に遭遇し、永久に修正する方法を知っていますか?他のアイデア(Kerberosエキスパートになるために今後数日間を費やすこと以外)?

2
SSLクライアントがサーバー名表示をサポートしていないかどうかを検出し、その場合に標準のHTTP Webサイトを提供できますか?
私はSSL SNIを使用する必要がありますが、残念ながら最近のCloudflareブログポストから、ネットワークの90%だけがそれをサポートしています。(たとえば、nginxを使用して)クライアントがSNIをサポートしているかどうかを検出し、WebサイトのHTTPバージョンに提供/リダイレクトするにはどうすればよいですか?これは可能ですか?他にどのようにしてSNIを使用してトラフィックの10%を失うことができませんか?有効な証明書がないとHTTPSトラフィックをHTTPにリダイレクトできないため、この要求は不可能であると想定しても正しいですか? ありがとうございました。
8 tls 

2
PowerShellで既にマップされているネットワークドライブにアクセスする
VMWare Workstation内でWindows Server 2012インストールを実行しています。共有フォルダを有効にしているので、ドライブZ:はにマップされてい\\vmware-hostます。エクスプローラでこのドライブに正しくアクセスでき(Z:「通常」のcmd内にアクセスできます)、ファイルを適切に開くことができます。 PowerShellを開いてみましたcd Z:が、次のエラーが発生しました: cd:パス 'Z:\'が存在しないため見つかりません。 PowerShellが既にマップされたネットワークドライブを見つけられないのはなぜですか? 私は少しグーグル検索して、New-PSDriveコマンドを見つけました。私は以下を実行しました: New-PSDrive -Name 'Z' -PSProvider FileSystem -Root 'Z:\' しかし、それでも上記と同じエラーが発生します。PowerShell内のVMWare共有フォルダーにアクセスするにはどうすればよいですか。

3
DHCPサーバーに静的IPアドレスが必要なのはなぜですか?
VMを使用してさまざまなネットワーク設定を実験しています。Windows ServerでDHCPの役割を設定すると、静的IP が必要になります。これがなぜ技術的に必要なのか理解できません。 DHCPについての私の理解は、クライアントはネットワーク上でDHCP検出要求をブロードキャストし、ネットワーク上の任意のデバイスが応答できることです。したがって、DHCPサーバーにはIPアドレスが必要ですが、なぜこのIPを静的にする必要があるのですか?DHCPサーバーは他の場所でアドレスを取得し、IP がある限りブロードキャストに応答できます。 例えば サーバーA、サーバーB、クライアントXはすべて同じスイッチに接続されています サーバーAは10.0.0.1で、10.0.0.X / 24を提供します サーバーAは、MACフィルタリングを介してサーバーBにのみIPを提供するように構成されています サーバーBはサーバーAからIPを取得するため、10.0.0.X / 24上に存在します サーバーBは10.0.1.X / 24を提供します クライアントXが接続し、サーバーBからIPを取得します もちろん、クライアントXがサーバーBからIPを取得すると、異なるサブネット上に存在するため、サーバーBに直接接続することはできません。しかし、それは問題ではありません。DHCP要求は(最初は)ブロードキャストであるため、スイッチ上のすべての人がそれを受信します。 管理の観点を無視する、なぜ私はできないのか 静的IPを持つマスターDHCPサーバー、他のDHCPサーバーのみにサービスを提供 「セカンダリ」DHCPサーバーのアドレス範囲 「セカンダリ」DHCPサーバーから取得したクライアントのアドレス範囲 DHCPサーバーに静的IPが必要な技術的な理由はありますか?

2
500エラーおよび/またはサーバー停止時にバックアップするHAProxyスイッチ
特定の構成で、2台のバックエンドサーバーの前にHAProxyを設定しています。すべての要求はサーバーAに送信する必要があります。ただし、サーバーAが5xxエラーコードを返す場合、すべての要求はバックアップサーバーBに送られます。Aが「up」を返すと、すべての要求がAに送られます。 私はこの構成を試しています: backend example_cluster balance roundrobin option httpclose option forwardfor option httpchk HEAD /ping.html HTTP/1.0\r\nHost:www.example.com http-check disable-on-404 default-server error-limit 1 on-error mark-down redirect scheme https if !{ ssl_fc } server node1 1.2.3.4:80 check observe layer7 server node_back 5.6.7.8:443 backup ssl verify none ただし、次の2つの理由で機能しません。 node1(A)が起動している場合でも、すべてのリクエストはサーバーのnode_back(B)にルーティングされます。 サーバーAに対してhttpcheckが実行されていないようです。以上、syslogにサーバーAのダウンに関するエラーは表示されません。 「option httpchk」行とそのすぐ下の2行を削除すると、また、サーバーAの「observe layer7」も削除します。HAProxyはすべてのリクエストをノードAにルーティングすることで機能します。ただし、サーバーAが500を返す場合、HAProxyはBに切り替わりません。したがって、問題はオプションのhttpchk構成にあると想定しています。

3
Debianバックポートカーネルを自動的にインストールする
次のピンニングセットを持っています。 Package: linux-image-amd64 Pin: release a=wheezy-backports Pin-Priority: 1001 Package: * Pin: release a=wheezy-backports Pin-Priority: 499 次のエラーが発生します。 $ sudo apt-get install linux-image-amd64 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if …

2
Cisco DNSのドクターまたはヘアピニング?
私は次の構成を持っています:CISCO 881、IOS 15.2(4)M6。WANインターフェイスには、ISPからの86.34.156.48/29サブネットが構成されています。ルーターの背後には2台のWebサーバーが残っています。NAT:86.34.156.51 <> 10.10.10.100(プライベートIP、server1)。BIND DNSサーバーのAレコードにサーバーの外部IP(86.34.156.51)を設定すると、外部の世界からDNSサーバーからの応答が得られません(そこで何が起きているのかわからない、おそらくルーターがDNSの修正などを行っている)同様に(質問です))、DNSサーバーが構成され、正しく機能していることを確認します(TCPdumpでIPパケットをキャプチャしました)。しかし、DNSサーバーAレコードをサーバーのプライベートIP(10.10.10.100)で構成すると、パケットは常に適切な宛先に到着します(サーバーの外部IPを使用している可能性があり、DNSのドクターも使用しています)。 私は何ができますか??? +-----+ | | an other host somewhere on internet(C) | | +-----+ | | : : internet : | +-----+ | | ISP's router | | black box, without acces +-----+ | | 86.34.456.48/29 +-----+ | | CISCO 881, | | IOS 15.2(4)M6 …

2
Windows 2012 RDSサーバーは、すでに設定されている場合にライセンスモードを要求しますか?
私は混乱する状況にあります。私の環境用に2012 RDSライセンスサーバーをセットアップしています。RDライセンス診断ツールを使用して、すべてが適切であることを確認し、「リモートデスクトップセッションホストサーバーのライセンスモードが構成されていません」というエラーが発生し続けることを確認しています。また、ライセンスモードは「未構成」に設定されています。厄介なのは、これを複数回設定しても、「未構成」と表示され続けることです。行方不明のものはありますか? ありがとう

9
システムイベント通知サービスへの接続に失敗しました
いくつかのエンドユーザーがWindows 7マシンにログインしようとすると、「Windows通知サービスに接続できませんでした」というメッセージが表示され、黒い画面になり、実際にデスクトップが読み込まれません。これは6か月以上続いています。 そのユーザーをローカル管理者に昇格させると、ログインできますが、Aeroデスクトップテーマは緩んでしまいます。また、コンピューターがデスクトップから起動するまで数分かかり、次のエラーが表示されます。 問題を解決するために私が経験したいくつかの投稿があります。ここに私が役に立たないように試みたいくつかのステップがあります。 着信脳ダンプ ラン netsh winsock reset Windows以外のサービスをすべて無効にする すべてのスタートアップアプリを無効にする msconfig Symantec Antivirusをアンインストールする それはNvidiaドライバー関連(Dellラップトップ)だと思いましたが、Intelグラフィックスを持っているのは2人だけでした。 セーフモードブートはクリーンで高速です。 マシンはすべて同じOUにあります。問題のあるマシンを異なるGPのOUに移動して実行しましたGPUPDATE。変化なし。 問題は30分から2日で自然に解消します。 NIC /オーディオ/ビデオドライバを再インストール。 \Driver\WUDFRd failed to load for the device USB\VID_0A5C&PID_5800&MI_01\7&66de6c9&0&0001問題のあるほとんどすべてのラップトップでイベントが表示されます。スマートカードリーダーだと思います。 WMIリポジトリを再構築しました 蘭netsh catalogue resetとwinsock reset 修正プログラムKB2590550を試した ラン SFC /scannow 今日、ユーザーは再起動後にアップデートがあったと述べましたが、それは過去6か月を説明していません。 これはntbtlogで見ました。これらのいくつかのドライバーはロードされませんでしたが、ログはそれを50回以上繰り返します: Did not load driver @oem77.inf,%staccel%;ShoreTel Desktop Sharing Accelerator Did not load …

1
ADレプリカDCプロモーションストール
私は最近、一緒に働いている小さなスタートアップのインフラストラクチャの義務を引き継ぎました。私の伝統的な役割は開発でしたので、我慢してください... 私は右足から始めて、Active DirectoryをAzureで稼働させることを望んでいました。MicrosoftのTechNetのガイドに従って、Azure VPNにADフォレストをインストールしました。構造は次のとおりです。 ローカルネットワークを使用したサイト間VPN用に構成されたAzure VPNは、正しく接続されていると表示されます。 サブネット:192.168.5.0/24 HQNET サブネット:192.169.1.0/24サイト間VPNゲートウェイ サブネット:192.169.2.0/24 Auth サブネット:192.169.3.0/24アプリ サブネット:192.169.4.0/24データ サブネット:192.169.6.0/24 Middle Authサブネット、IP 192.169.2.4のA1標準VMにServer 2012 R2があります。ADインストールはうまくいき、新しいフォレストを開始しました。すべてがうまく機能しているように見えました。このVMはUsername1 / Password1で作成され、ADのインストール時にDomain Admin / Enterprise Adminとして自動的に追加されます。 同じ認証サブネット-IP 192.169.2.5内でレプリケーションを行うために、2番目のServer 2012 R2 A1標準VMを起動し、このVMをUsername2 / Password2で作成します。次に、このVMを最初のDCで作成されたドメインに参加させます。ドメインに参加した後、このVMをレプリカDCとして昇格させます。このアクションを実行するための資格情報を要求し、資格情報としてDOMAIN \ Username1:Password1を指定します。 昇格プロセス中に、ADが親AD VMで「NTDS設定オブジェクトの作成」であるステップに到達すると、インストールはこのステップで停止します。この記事によると、Active Directoryのインストールが「NTDS設定オブジェクトの作成」で停止します。これは、ドメインの資格情報がローカルの資格情報と同じであることが原因です。または、インストールにドメイン資格情報を誤って提供しました。 インストールを実行しようとして、何度もVMを削除して再作成しました。VM2にドメイン管理者としてログインし、昇格してみました。また、インストール中に何がハングしても、昇格時にドメイン資格情報を提供するほぼすべての手段(Username1 @ domain:Password1、DOMAIN \ Username1:Password1、domain.com \ Username1:Password1)を試しました。毎回、VM1のフォレストからVM2を削除する手順に注意深く従い、再度昇格を試みました。 足元が足りなかったり、足りない小さな部分が見えないのではないかと思いますが、未経験が光っています。 DC2をレプリカDCに昇格するときに何が欠けていますか?

2
SANに「必須」の空きスペースはありますか?
私はSANの専門家ではありません。サプライヤが解決できないと思われる継続的で苛立たしい問題についての手がかりを得るために、ここに書いています。 ビデオ監視システム用に提供されている16 x 2 Tbディスクを備えたENHANCE ES3160P4 SANを所有しています。SANは、サプライヤによってRAID 5アレイ内で14のディスクを使用するように構成されており、2つのディスクはグローバルスペアです。RAIDは通常、RAIDスペース全体にまたがる同じサイズの2つの仮想ディスクに分割されます。それぞれが12 Tbを超えるものになります。各仮想ディスクは単一のLUNに対応します。これは、ビデオデータを継続的に格納し、ユーザーが必要に応じて記録を取得できる単一のビデオサーバーに接続されています。LUNはNTFSでフォーマットされ、iSCSIを介してWindows Server 2012ビデオサーバーに接続されます。ビデオサーバーは、使用可能なスペースを完全に使用する傾向があります。 この構成では、SANのディスクに障害が発生し、障害が発生しています。その間、別のディスクに障害が発生したため、SANはRAIDを回復できません。ここ数か月でRAIDを4回も失いました。 同じ問題が発生しているように見える、同様に構成された同じタイプの他の3台のマシンを所有しているため、この問題は不正なSANサンプルが原因ではないようです。問題は1つだけですが、現在は十分に活用されていません。 数か月にわたる未知のテストとチェックの後、サプライヤーは結局、SANを100%使用するべきではない、または物理的にも急速に劣化することはよく知られていると述べ、問題を解決するには仮想ディスクを作成する必要があると述べましたRAIDで利用可能な総スペースの10-15%を残します。 私は問題をウェブで検索しましたが、これを言っている特定のステートメントは見つかりませんでした。RAID全体にまたがる仮想ディスクを作成してから、LUNを十分に活用すること(つまり、Windowsに空き領域を確保し、断片化を回避すること)の方が合理的であるように思えます。そうでない場合、「よく知られている」ために空き領域を残さなければならない場合に、ENHANCE SANがRAID全体にまたがる仮想ディスクを作成できる理由、およびサプライヤが最初にこのようにシステムを構成した理由がわかりません...しかし、それは別のポイントです。 結局、私たちはこの状況を解決したいと思っています。どんな提案も受け入れられます。すでに述べたように、私はSANの専門家ではありませんが、多くの問題が発生した後、サプライヤが何が起こっているかを知っているかどうかを本当に理解したいと思います。 よろしくお願いします!よろしく 編集:ディスクタイプ 回答から関連情報のようですが、ディスクはすべてWestern DigitalモデルWD2001FYYG-01SL3であると付け加えます。

1
Powershellを使用して既存のスケジュールされたタスクを変更するにはどうすればよいですか?
Powershellを使用して、さまざまなアプリケーションを実行する既存のスケジュールされたタスクを更新するいくつかのリリース自動化スクリプトに取り組んでいます。スクリプトでは、アプリケーションのパスと作業ディレクトリを設定できますが、変更をタスクに保存していないようです。 function CreateOrUpdateTaskRunner { param ( [Parameter(Mandatory = $TRUE, Position = 1)][string]$PackageName, [Parameter(Mandatory = $TRUE, Position = 2)][Version]$Version, [Parameter(Mandatory = $TRUE, Position = 3)][string]$ReleaseDirectory ) $taskScheduler = New-Object -ComObject Schedule.Service $taskScheduler.Connect("localhost") $taskFolder = $taskScheduler.GetFolder('\') foreach ($task in $taskFolder.GetTasks(0)) { # Check each action to see if it references the current …

4
Cygwin起動エラー/ usr / bin / id:グループIDの名前が見つかりません
私は仕事でcygwinを使用して、unixツールにすばやくアクセスし、ssh端末として使用しています。最近、いくつかの新しいCygwinパッケージをインストールしましたが、ターミナルを開こうとすると非常に遅くなり、次のエラーが発生します。 /usr/bin/id: cannot find name for group ID 10519 エラーの意味はわかりませんが、cygwinターミナルを開くには、通常よりも時間がかかります。

2
Windows Server 2012-外部アドレスからのWebアクセスを介したRDSへのアクセス
非常に奇妙な問題があります。概念実証のために、ADSでRDSサーバーをセットアップしています。azureから提供された外部URL(xxxx.cloudapp.net/RDWeb)を使用してWebアクセスを使用すると、正常にログインでき、タスクバーに小さなポップアップが表示されて接続済みであることを確認できますが、ページには、利用可能なremoteappsが表示されません-公開されたものがないかのように。 hostsファイルを変更して、外部IPアドレスを内部DNS名(xxx.domain.localなど)として処理し、それを使用してRDWebにアクセスすると、完全に機能します。remoteappカタログにアクセスしてアプリを選択し、まったく問題なく実行できます。 以前にインストールされていないrdsゲートウェイの設定を含め、考えられるすべてのことを試しましたが、何も違いはありません。誰か洞察力がありますか?

2
負荷分散されているサーバーを確認するにはどうすればよいですか?
ロードバランサーの背後にある2つのサーバー間の一方向の同期に対するいくつかの構成変更をテストしたいと思います(これはすべてRackspace Cloudインフラストラクチャの参考情報です)。私が持っている問題は、与えられたIPが常にロードバランサーのIPであるため、どのサーバーに負荷分散されているのかわからないことです。 実際にどのサーバーにリダイレクトされたかを確認する簡単な(またはそれほど簡単ではない)方法はありますか?技術者以外のチームメンバーも比較的簡単に問題を報告できるため、ブラウザの何かが理想的ですが、これに対する最善のアプローチについてのアイデアはありがたいです。 追加情報:両方のサーバーでApacheが実行され、ロードバランサーでセッションの永続性が構成されています。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.