サーバー管理者

システムおよびネットワーク管理者向けのQ&A

5
Apache SSLエラー:秘密鍵が見つかりません
Ubuntu 14.04でApacheを実行していて、SSLを実装しようとしています。どんな助けでも大歓迎です。 default-ssl.confには以下が含まれます。 SSLCertificateFile /etc/apache2/ssl/domain.crt SSLCertificateKeyFile /etc/apache2/ssl/domain.csr Apacheを再起動すると、/ var / log / apache2 / error.logのエラーメッセージは次のようになります。 [Sun Feb 01 19:31:06.443226 2015] [ssl:error] [pid 30927] AH02203: Init: Private key not found [Sun Feb 01 19:31:06.443408 2015] [ssl:error] [pid 30927] SSL Library Error: error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag [Sun Feb 01 19:31:06.443424 2015] [ssl:error] …

2
openWrtのDHCPクライアントにカスタムDNSを提供する方法 [閉まっている]
休業。この質問には、より焦点を当てる必要があります。現在、回答を受け付けていません。 この質問を改善してみませんか?質問を更新して、この投稿を編集するだけで1つの問題に焦点を当てます。 5年前休業。 カスタムDNSサーバーをDHCPクライアントに提供したいのですが。どのようにしてopenWrtでそれを実現できますか?

1
ESXi上のWindowsサーバー、年間ロールオーバー時のCPU使用率100%
ESXiサーバー上で実行されているWindows Server 2008 R2 SP1サーバーがいくつかあります。2014年から2015年の年末にロールオーバーすると、CPUが100%になり、マシンがハングします。 このソリューションは、Microsoftのホットフィックス(KB2800231)のようです。ただし、リストされているダウンロードはすべてVista(Windows 6.0)用で、サーバーは6.1です。言うまでもなく、MSUを実行しようとすると、サポートされていないオペレーティングシステムがあることを示すエラーが発生します。 修正プログラムのWebページ(http://support2.microsoft.com/kb/2800213/en-us)は、2008 R2のダウンロードが必要であることを示していますが、明確ではありません。 この問題の今後の修正、または正しいMSUをダウンロードできる場所を知っている人はいますか?

5
debian 7(wheezy)のCVE-2015-0235(GHOST)にパッチを当てる方法は?
この脆弱性はglibcで発見されました。詳細については、このハッカーのニュース投稿を参照してください。 debianバグトラッカーで説明されているように、この脆弱性はすでにテストでパッチが適用されており、不安定です。 できるだけ早くパッチを適用したいので、これらのバージョンのいずれかからパッチを適用したパッケージをインストールすることは可能ですか?


3
Server 2012 R2 Active DirectoryドメインSRV DNSレコードが突然消えた
最近構成したテストドメインがあります。突然、キャッシュされた資格情報を持つユーザーを除いて、ユーザーはログインできなくなります。ドメインには、相互に複製する両方のグローバルカタログである2つのドメインコントローラーが含まれています。 問題を調査した後、すべての_mcdcsドメインレコードが両方のDNSサーバーで完全になくなっていることがわかりました。これにより、_ldapや_kerberosなどのSRVレコードが解決できないため、ドメインコントローラーを見つけることができなくなります。 これがどのように発生したのかはよくわかりません...これは、DNSキャッシュまたはDNS清掃をクリアすることによって引き起こされるものですか? この時点で、なんとかしてレコードを復元する必要があります。別のドメインの設定を確認しましたが、手動で再作成できるようですが、一部のDNSレコードにはSID名が含まれているようです...それらを再作成するために使用されます。 このような状況から抜け出すために使用できるより良いプロセスはありますか?

2
Postfix→Dovecot LMTP:ユーザーが存在しない:uid @ domain
PostfixがDovecotのLMTPを介してローカルメールを配信するように試みています(とりわけprocmailをSieveで置き換えるため)。これまで、私はを使用してmailbox_command = procmail - a "$EXTENSION"、ローカル~/Maildirのに配信しています。 http://wiki2.dovecot.org/HowTo/PostfixDovecotLMTPに従って、(postfixがchrootされている)で構成しました/etc/dovecot/conf.d/10-master.conf service lmtp { unix_listener /var/spool/postfix/private/dovecot-lmtp { group=postfix user=postfix mode=0600 } に追加されました /etc/postfix/main.cf mailbox_transport = lmtp:unix:private/dovecot-lmtp これでほとんど機能しますが(PostfixはLMTPソケットとeudoxos@mydomain.eu通信します)、LMTPはドメインを含む「ユーザー」について混乱しています。 Jan 11 08:22:17 s18015955 postfix/lmtp[7374]: 3D84E19B0290E: to=<eudoxos@mydomain.eu>, orig_to=<fristname.lastname@mydomain.eu>, relay=iota.mydomain.eu[private/dovecot-lmtp], delay=0.01, delays=0/0/0/0, dsn=5.1.1, status=bounced (host iota.mydomain.eu[private/dovecot-lmtp] said: 550 5.1.1 <eudoxos@mydomain.eu> User doesn't exist: eudoxos@mydomain.eu (in reply to RCPT …

2
クライアントのIPに基づいてGmail SPFが失敗する
GmailはクライアントIPに基づくSPFチェックに失敗しています。これらは関連するヘッダーです: Received-SPF: fail (google.com: domain of johndoe@example.com does not designate 164.77.240.58 as permitted sender) client-ip=164.77.240.58; Received: from johndoe (unknown [164.77.240.58]) by mail.example.com (Postfix) with ESMTP id 993643FE2D クライアントIP(164.77.240.58)は、johndoeのコンピューターのIPです。送信者IP、mail.example.comのIPは、SPFレコードに含まれています。 Gmailが送信者IPではなくクライアントIPに基づいて失敗するのはなぜですか?これはSPFの動作方法ですか?
8 spf  gmail 

7
30分ごとに発生するスケジュールされた自動Puppet実行を無効にする方法は?
目的 目的は、30分ごとに実行されるPuppetエージェントの自動実行を無効にすることです。間隔を変更することは可能ですが、Puppetエージェントの自動実行は完全に無効にする必要があります。 1つを試行 このドキュメントによると、以下を構成することにより、自動Puppetエージェントの実行を無効にすることが可能であるはずです。 /etc/puppet/puppet.conf [agent] daemonize=false 結果は Notice: Run of Puppet configuration client already in progress; skipping (/var/lib/puppet/state/agent_catalog_run.lock exists) puppetがデフォルトの実行間隔30分で手動で実行された場合。 2回目 user@hostname:~$ sudo puppet agent --disable 結果は user@hostname:~$ sudo puppet agent -t Notice: Skipping run of Puppet configuration client; administratively disabled (Reason: 'reason not specified'); Use 'puppet agent --enable' …

3
AWSでのキーペアとセキュリティグループの価格?
無料のAWSアカウントの有効期限が切れました。私はすべてのS3やEC2のリソースを削除したが、私は残すことができた場合に放浪していますKey Pairsし、Security Groups彼らのために支払うことなく。(私のアカウントリソースは次のようになります:リソース) Amazonのドキュメントには、この問題についての記述がないようです。 これらのリソースには費用がかかりますか?

5
エラーの原因:無効な(古い?)テーブルまたはデータベース名 'lost + found'
MySQLログに重複したエラーが表示されます: 141223 5:47:21 [ERROR] Invalid (old?) table or database name 'lost+found' という名前のデータベースがありますが、#mysql50#lost+found削除できないようです。 mysql> show databases; +---------------------+ | Database | +---------------------+ | information_schema | | maindatabas | | maindatabas_help | | maindatabas_tracker | | gitlabhq_production | | locations | | #mysql50#lost+found | | mysql | | osticket | | performance_schema | …
8 linux  mysql 

2
DFS /フォルダリダイレクトを使用すると、なぜ問題が発生するのですか?
2つのわずかに異なるが、類似したシナリオを次に示します。 \\ server \ shareにマップされたS:\ドライブがあります。次に、DFS名前空間が実装され、S:\が\\ domain.local \ dfs \ share(レガシー共有を指している)に変更されます。現在、リンクされたファイル/埋め込まれたファイルを含む一部のファイルとさまざまなアプリケーションは、奇妙で誤動作します。なお、これらの埋め込みファイルリンク(リンクされたExcelテーブルなど)はレガシー共有を指し、親ファイルはDFS共有から開かれます。 2.マイドキュメントにあるPOP / IMAPアカウントのPSTがあります。その後、ドキュメントはネットワーク共有にリダイレクトされたフォルダです。現在、[データファイル]タブにファイルの正しいネットワークパス(\\ server \ share \ user.name \ Documents \ outlook.pst)が示されているにもかかわらず、Outlookはアカウントに関連付けられたPSTにアクセスできません。Outlookは読み込まれますが、PSTが見つからないため、関連付けられたアカウントの受信トレイを表示できません。* *これは特定の既知の問題でした。後でリンクを掲載します これらのタイプのリダイレクトを実行すると、フロントエンドの観点からはファイルへのパスが同じであるにもかかわらず、なぜ「壊れる」のですか?
8 dfs  unc 

1
グループを無効にしている間に特定のSSL暗号を有効にする方法は?
Windows XPでIE8をサポートするために、nginx SSL環境でSSL暗号EDH-DSS-DES-CBC3-SHA(別名TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA)を有効にしたいと思います。 nginxの基本SSL暗号は次のとおりです。 ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!3DES:!MD5:!PSK EDH-DSS-DES-CBC3-SHAで無効になってい!DESます。私は(間の無効ルールの前でその暗号を入れてみましたんDHE-RSA-AES256-SHAや!aNULLけど(非常に最後の引数として))と後のどちらも働きました。 他の暗号をEDH-DSS-DES-CBC3-SHAすべて有効にしDESたり手動で無効にしたりせずに暗号を有効にするにはどうすればよいDESですか? バージョン情報:nginx 1.7.8、OpenSSL 1.0.1e
8 nginx  openssl  ssl 

1
間違ったActive Directoryサイトを使用するExchangeサーバー
Exchange 2013サーバーは、サイト間のレプリケーションの不良(他のサーバーがないため、レプリケーションがないはずです)のエラーと、関連していると思われる他のいくつかの問題を突然ログに記録し始めました。 VPNで接続された2つのサイトがあります。これはActive Directoryサイトの構成です。 各サイトには複数のサブネットがあり、サブネットとサイト間のルーティングは正常に機能しています。 ExchangeサーバーのIPアドレスがあり10.10.0.26、それはIPとDCと同じHyper-Vホスト上で実行されている10.10.0.21の一部として設定されている(写真でXXXX-DC01という名前の1) Default-First-Site。 Exchangeサーバーは、それがYGXXXサイトにあると見なします。 NTLOGON.LOGを有効にしましたが、関連する情報は次のとおりです。 サーバーが間違ったサイトを選択している理由を知るにはどうすればよいですか?

2
OOMキラーログで完全なプログラムコマンドライン引数を表示する
OOMキラーログで完全なプログラムコマンドライン引数を表示することは可能ですか?/ var / log / syslogに今表示されているのは Memory cgroup out of memory: Kill process 29187 (beam.smp) score 998 or sacrifice child Killed process 29302 (cpu_sup) total-vm:4300kB, anon-rss:76kB, file-rss:272kB beam.smp invoked oom-killer: gfp_mask=0xd0, order=0, oom_score_adj=0 beam.smp cpuset=/ mems_allowed=0-3 私のマシンには多くのBeam.smpプロセスがあり、OOMキラーによってどのプロセスが強制終了されたかを調べるのはあまり便利ではありません。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.