サーバー管理者

システムおよびネットワーク管理者向けのQ&A



4
Test-Cluster Powershellコマンドレットリストと検証
PowershellコマンドレットTest-Clusterは無数のデータにクエリを実行し、検証テストを実行して、きれいなレポートにラップします。実行Test-Cluster -Listすると、項目のリストが表示され、コマンドレットを使用して個別にクエリを実行できます。を読むときの一般的な命名規則がありますDisplayName。それらはすべて"List"または"Validate"で始まります。 明らかに、「検証」は実際に失敗してフェイルオーバーをテストします。しかし、「リスト」という名前を付けると、実行時のデータのクエリにすぎないと思います。これを次のスクリプトでテストしました。 $TestList = Test-Cluster -List | Where-Object {$_.DisplayName -like "List*"} Test-Cluster -Include $TestList.DisplayName -ReportName "c:\cluster reports\report" このレポートが生成されている間、ログに記録されたクラスターエラーは表示されず、フェイルオーバーアクティビティも確認されません。Microsoftのtechnetもこれについてははっきりしていませんが、動作は私が考えていることと一致していると推測しています。この抜粋を参照してください(鉱山を強調): テスト結果は、指定したファイル名のファイルにキャプチャされます。検証テストを実行している、あなたは、ハードウェアや設定がフェールオーバークラスタリングと互換性があることを確認することができます。クラスタ、インベントリ、ネットワーク、ストレージ、システム、およびその他のタイプのテストを含む、複数のタイプのテストがあります。ストレージテストでは、クラスター化された役割で使用されているオンラインディスクまたはストレージプールはテストされません。このようなディスクをテストするには、まずStop-ClusterGroupを実行してクラスター化された役割を停止してから、Test-Clusterを実行します。テストが完了したら、クラスター化された役割(リソースグループとも呼ばれます)を再度開始します。 テストクラスターTechNetページ 「検証」という言葉の使用に注意を喚起します。さらに、そのスクリプトを実行すると、出力の一部として次のように表示されます。 Test Result: ClusterSkippedTestsCompleted 検証テストを含めると、結果は次のようになります。 Test Result: ClusterConditionallyApproved 私のテスト環境では、ネットワークテストでいくつかの警告が生成され、条件付き承認がトリガーされました。「Validate」と「List」の分割の背後にあるロジックを説明するドキュメントを見つけるためにかなりグーグル検索しましたが、何も調べていません。これは質問につながります... リスト要求はフェイルオーバーイベントをトリガーしますか?

2
PSリモートセッションからサーバーコアでWindows Updateを開始する方法
Windows Server 2012 R2 Coreマシンのリモートデスクトップ経由でログインしている場合、sconfig.cmdを実行してWindowsの更新をトリガーできます。ただし、PSリモートセッション内で呼び出されると、これは失敗します。 Enter-PSSession -ComputerName server2 これはsconfigが不満を言うものです。基本的に、特定のレジストリ値を見つけることができないと述べています。面白いことに、MicrosoftはPowerShellよりもVBScriptを選択してこのCLIインターフェースをプログラムしています... [server2]: PS C:\> sconfig C:\>echo off sconfig : FEHLER: Der angegebene Registrierungsschl?ssel bzw. Wert wurde nicht gefunden. + CategoryInfo : NotSpecified: (FEHLER: Der ang...nicht gefunden.:String) [], RemoteException + FullyQualifiedErrorId : NativeCommandError Microsoft (R) Windows Script Host, Version 5.8 Copyright (C) Microsoft …

8
Dell M6600:「インターネットアクセスなし」、インターネットの閲覧、リモートアクセス、Office 2013のアクティブ化、ドメインへの参加は不可
タイトルのようにネットワークに接続するだけで罰金、私は含めて、ウェブを閲覧するためにそれを使用できることを、私は、Windows 7を実行して、DellのM6600を持っている、と言うhttps://officesetup.getmicrosoftkey.com/、私はに接続することができますそれはRDPを介して、ドメインに参加しました(以下を参照)、ネットワーク接続の顕著な遅延はありません。問題は、アクティブなネットワークがアクセスタイプを報告していることです。インターネットアクセスがありません。「現在接続できません。ネットワークを確認して、試してみてください。Office2013をアクティブ化できないなど、一部の接続ができません。後でもう一度"。ソフトウェアファイアウォールが有効になっていません。 これが私が試したものです: ipconfig release & ipconfig renew 実行netsh int ip reset c:\temp\resetlog.txt(ログは決して生成されません) 有線イーサネットのみで接続 WiFiのみで接続 管理コンソールを使用してネットワークアダプターをアンインストール/再インストールする 次のような役に立たないGoogleの検索結果をたどります route delete 0.0.0.0 if 11 ドメインの再参加を試みますが、ドメインからコンピューターを削除することはできましたが、「ネットワークの場所に到達できません」として読み取ることができません(ローカルの資格情報を使用して、この時点でRDPを実行できますが、gpupdateエラーイベントがあります。これは失敗すると私に言っているはずです) NCSIの問題を確認します。IEでhttp://www.msftncsi.com/ncsi.txtに移動すると、「Microsoft NCSI」というテキストのページが表示され、dns.msftncsi.comは正しく解決されます DNSサーバーにpingを実行すると、要求がタイムアウトになりますが、nslookupを実行すると、そのDNSサーバーを使用しても問題なく機能します。 DHCP予約のIPアドレスを既知の未使用のIPアドレスに変更して、IPアドレスの競合を確認しました アンインストールされたAVソフトウェア スイッチポートの変更、有線アクセス用のスイッチは効果がありませんでした。別のポートに切り替えたときに動的アドレステーブルが正しく更新されました(スイッチ上のポートは、ネットワーク上で正常に通信している他のほとんどのコンピューターと同じ構成です) ping時にnslookupで正常に動作していたにもかかわらず、DNSサーバーへのpingが機能し、失敗しました (コンピューター/ドメイン名は以下で編集され、一部は省略のため省略されています)ipconfig / all: Windows IP構成 ホスト名。。。。。。。。。。。。: コンピューター プライマリDNSサフィックス。。。。。。。: ノードタイプ。。。。。。。。。。。。: ハイブリッド IPルーティングが有効。。。。。。。。: 番号 WINSプロキシが有効。。。。。。。。: 番号 DNSサフィックス検索リスト。。。。。。:contoso.com イーサネットアダプターローカルエリア接続: 接続固有のDNSサフィックス。:contoso.com 説明。。。。。。。。。。。:Intel(R)82579LM Gigabit Network …

1
特定の時間からサーバー統計を取得する
今朝の私のサーバーでは、アプリケーションの実行速度が遅いと報告されていることに気付きました。 WebとSQLのログを確認したところ、特別なものは何も見つかりませんでした。 今朝の午前2時頃に何が起こっていたか知りたいのですが。 特にCPUとメモリの統計情報を探していますが、CentOS6がログを保存する場所がわかりません。 / var / log /をチェックインしましたが、; loが見つかりません どこで罰金を科すことができるか教えてもらえますか?
8 linux  centos  logging 

1
Windows NT PCからWindows 2000 PCにネットワークドライブをマップできません
レガシー衛星通信機器のテストラックをセットアップしようとしています。構成の一部で、PCのネットワークドライブ(この場合は、Windows 2000 Professionalを実行しているIBM eServer xSeries 305)をマップする必要があります。 Windows NTを実行しているデバイス(非常に古いIPカプセル化装置)。 私は古いドキュメントから、Windows XPマシン上のネットワークドライブをマッピングして、(Windows NTの同じリリースを実行している)Windows NTデバイスのこの特定のモデルを指すことが可能であったことを知っています。ただし、Windows XPマシンと、Windows 2000の構成が異なるように動作することを示すドキュメントはありません。 [マイコンピュータ]の[ネットワークドライブの割り当て]ダイアログを使用してWindows 2000マシンのドライブを割り当てようとすると、「リモートコンピュータが利用できません」というエラーが表示されます。存在しないIPアドレスに意図的にマッピングしようとすると、代わりに「ネットワークパスが見つかりません」が返されます。 2つのデバイスは同じVLANにあり、同じネットワークにあり、ルーターのスイッチポートで接続されています。Windows 2000 PCでは、Windows NTデバイスへのVNC接続を問題なく開くことができます。 オンラインで該当するトラブルシューティングの手順をいくつか見つけましたが、問題は解決しませんでした: 「サーバー」サービスは、Windows NTマシンで実行されています。 ターゲットドライブとフォルダは、Windows NTマシン上の「全員」と共有されます。 Windows 2000マシンで「ファイルとプリンタの共有」を有効または無効にしても効果はありません。 両方のデバイスを同じワークグループに配置しても効果はありませんでした。 これはこのサイトには問題の範囲が狭すぎる可能性があることを理解しているので、より広い意味で問題をまとめるために、私が探しているのは次のとおりです。 「リモートコンピュータが利用できません」よりも有用で特定のエラーを生成するネットワークドライブをマッピングする方法はありますか? 異なるバージョンのWindows(特にWindows 7以前)間でのネットワークドライブのマッピングに下位互換性の制限はありますか? 後方互換性の制限がある場合、それを克服できますか? これら3つの幅広い質問に対する情報、または問題の絞り込みに役立つ可能性のある特定の問題に関するアドバイスに感謝します。

2
64k以上のWebソケット用にHAProxyを拡張
64k以上のWebソケットを処理できるアーキテクチャを設計しようとしています。 私たちは最初にAmazon ELBを試しましたが、その設計では、トラフィックやWebSocketの予期しないスパイクは許可されていません。(TCPモードでWebSocketが予期せずタイムアウトする) HAProxyではこれらの制限は適用されませんが、HAとバックエンドサーバー間で維持される〜64kのWebソケットに制限されます。 頭に浮かんだ複数のソリューション: 複数のHAProxyインスタンス、DNSによる負荷分散(Route53には加重オプションがあります) Keepalived、複数の内部IPアドレスを持つ2つのHAProxyインスタンス(実行可能かどうかは不明) これを行うより良い方法はありますか?

2
高レイテンシリンクを介した大容量ファイル転送の速度の向上
そのため、最近、海外のオフィスの1つからインターネットを介して大きなファイルをプルする必要がありました。どちらのオフィスにも両方向に50Mビットのファイバーリンクがありますが、往復時間は恐ろしいものであり、良い日に450ミリ秒、がらくたに750ミリ秒と異なります。 もともと、VPN接続を介してファイルをプルしようとしましたが、転送が失敗し(smbは実際には低速リンクを吸い込んで)、約128kBpsで速度が最大に達した後、グーグルはWindows TCPウィンドウスケーリングの問題に直面していることを示しました。 私はそれ以来、ここにファイルをすばやく取得できる商用プライベートクラウドタイプのサービスを介してファイルをプッシュしました。そのため、以下は何よりも好奇心のためのものです。 おもしろいことに、両端のインターネットアクセスはhttpプロキシを介して行われます。ただし、マシンの両端に管理者権限があります。 速度を上げるにはどうしますか? 私が試したこと: 1)2つのLinux仮想マシン間のプレーンSFTP。corkscrewを使用してhttpプロキシを介してパンチアウトし、3つ目の仲介者を使用して2つの端を接続します。達成された速度:約600kBps。 2)SFTPですが、HPN-SSHでパッチされたOpenSSHを使用します。コルクスクリューと中間構成は1)と同じです。速度の向上はほとんどない。 3)2と同じですがpget -c -n 10、転送をチャンクに分割するためにLFTPを使用します。これは3.5MBpsを見て、これまでで最高です... すべての改善を歓迎します。
8 linux  ssh  ssh-tunnel 

2
ZFSがディスクのダフセクターで何もしないのはなぜですか?
ZFSプールからの読み取り中にI / Oエラーが発生すると、次の2つのことが発生するという印象を受けました。 障害は、関連するデバイスのREADまたはCKSUM統計のいずれかに記録され、プールレベルに向かって上方に伝播します。 冗長データは、要求されたブロックを再構築し、要求されたブロックを呼び出し元に返し、ダフドライブがまだ機能している場合は、ブロックをブロックに再書き込みするために使用されます。または、 読み取りエラーを修正するための冗長データがない場合は、I / Oエラーが返されます。 ミラーセットアップのディスクの1つで不良セクターが発生しているようです。それ自体は驚くべきことではありません。そのようなことが起こり、それがまさに私が冗長性を持っている理由です(正確には、双方向ミラーです)。プールをスクラブするか、特定のディレクトリのファイルを読み取るたびに(どのファイルに問題があるかを正確に特定するためにまだ気にしていません)、次のようにdmesgにポップアップし、明らかにタイムスタンプが異なります。 Nov 1 09:54:26 yeono kernel: [302621.236549] ata6.00: exception Emask 0x0 SAct 0x9c10 SErr 0x0 action 0x0 Nov 1 09:54:26 yeono kernel: [302621.236557] ata6.00: irq_stat 0x40000008 Nov 1 09:54:26 yeono kernel: [302621.236566] ata6.00: failed command: READ FPDMA QUEUED Nov 1 09:54:26 yeono …

2
sshセッションの終了後にローカルコマンドを実行する
ssh経由でログインするHPスイッチがいくつかあります。スイッチはターミナルコマンドを送信してラインラップ(terminfoの用語では "rmam")を無効にしますが、再度有効にできず、sshセッションを終了した後に端末がねじ込まれます。を実行して端末を修正できますtput smam。 sshセッションが終了した後、sshにそのコマンドを自動的に実行させる方法はありますか? それをシェルの自動コマンドとして実行することは私を殺したりssh、常にそのコマンドを後で実行するエイリアスを殺したりはしませんが、既知に接続した直後に実行されるようにコマンドを制限できるように、sshを介して問題を解決したいと思います-悪いホスト。 私のsshクライアントはOpenSSH_6.2p2ですが、新しい機能がどこかにあれば、変更または更新できます。
8 ssh 

1
シリアルとOSエディションのマッチング
それが属しているビルド/バージョンをシリアルキーから判断する方法はありますか? 以前の管理者はキーのリストを提供しましたが、それらがどのOS用であるかを示していませんでした。 具体的には、Win VistaおよびWin 7

5
ジャンプホストでのSSH ForceCommandはどの程度安全ですか?
ネットワークに次の設定があります。 Internet <--> Bastion <--> Local Network 複数のユーザーがいて、各ユーザーが特定のマシンに割り当てられています。または言い換えると、各ユーザーはこれらのサーバーの1つにのみアクセスできなければなりません。例:User1-> Machine1、User2-> Machine2など。 これらのユーザーはネットワークの外部から接続します。要塞ホストを介して接続をネットワークに転送する方法については、多くのオプションを検討しました。 最終的に私は、Match Blocksとforcecommandを選択しました。 したがって、要塞の/ etc / ssh / sshd_configは次のようになります。 Match User User1 ForceCommand ssh User1@Machine1 $SSH_ORIGINAL_COMMAND User1は、Machine1との接続を自動的に確立する要塞ホストに接続します。 私がForceCommandを理解している限り、User1は要塞ホストに実際にアクセスできません。これは、彼のすべての操作が最初に一致ブロックによって処理され、Machine1に再ルーティングされるためです。しかし、これは本当に本当ですか?これで、安全なセットアップで十分ですか?ユーザーはとにかくMachine1で投獄されているので、そこでは多くの可能性はありません。
8 ssh  chroot 

2
OpenSSL Poodleの脆弱性に対応して、SSLv3を無効にする必要がありますか?
OpenSSLがメモリルーチンに新たな脆弱性を発表しました。あなたはそれについてここですべて読むことができます:https://www.openssl.org/news/secadv_20141015.txt 回避策は、SSLv3を無効にすることです。 これにより、当社のWebサイトでHTTPSが完全に無効になりますか? まだSSLv3に依存しているクライアントはありますが、それらのサポートについて心配する必要がありますか?

1
IPsecトンネルに3つのip xfrmポリシーだけが必要なのはなぜですか?
strongswan(v5.2.0)インスタンス(サイトA)とRouterOSルーター(サイトB)の間で稼働しているサイト間IPsecトンネルがあります。すべてが正常に機能し、サイトA(10.10.0.0/16)とB(10.50.0.0/16)の2つのプライベートサブネットセットアップ内のホストは、互いに正常に通信できます。 私が理解していないのは、ip xfrm policyサイトAのルーター(パブリックIPが難読化されている)の次の出力です。これらのポリシーはによって作成されましたがstrongswan、手動でインストールしたり変更したりしていません。 ip xfrm policy src 10.50.0.0/16 dst 10.10.0.0/16 dir fwd priority 2947 ptype main tmpl src <PUBLIC_IP_B> dst <PUBLIC_IP_A> proto esp reqid 1 mode tunnel src 10.50.0.0/16 dst 10.10.0.0/16 dir in priority 2947 ptype main tmpl src <PUBLIC_IP_B> dst <PUBLIC_IP_A> proto esp reqid 1 mode tunnel src …
8 ip  ipsec 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.