サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
遅いActive Directoryログインの診断
ドメインPCで断続的に遅いログインを診断するのに苦労しています。 この問題が発生しているネットワークに関する情報: 私のドメインは5つのサイトにまたがっており、すべてVPN接続です。 DCは2003、2008、2012の混合です。ドメインの機能レベルは2003です。 クライアントは主にWindows 7 x64です。 私たちは、WMI、グループ基本設定項目レベルのターゲティング、およびGPPプリンターの展開を使用するものを含むグループポリシーを使用します。 移動プロファイルは使用しません。 ほとんどの場合、以前にマシンを使用したことがあるユーザーにとっては、ログインは問題なく迅速に機能します。新しいコンピュータへの最初のログインは常に遅いですが、それは予想されています。 問題は主にラップトップにあるようです。自宅でドメイン以外のネットワーク接続を使用しているか、別の場所に移動した場合(まだドメインネットワーク上にありますが、ADサイトは異なり、有線でもワイヤレスでも問題ないようです)、ログインには3時間もかかります。ユーザーがパスワードを入力してから、実際にデスクトップが表示されるまでの時間。また、ターミナルサーバーで断続的に遅いログインが発生します。 残念ながら、それは断続的な問題であり、私はそれを再現する信頼できる方法を見つけていません。私の疑いは、それがグループポリシーの設定に関係しているということですが、実際にはそれを証明するものはありません。遅いログインの特定の種類のアイテムレベルのターゲティングを非難するマイクロソフトKBの記事を見ましたが、それが実際に原因であるかどうかを判断するためのガイダンスは提供されていません。 どのログとツールを使用して、ログインが遅い原因を特定できますか? ログインを高速化するために、どのグループポリシー設定を使用するか、可能であれば回避する必要がありますか?

1
rpmはカスタムgpgキーをどこにインストールしますか?
CentOS / RHEL 6はカスタムgpgキーをどこに保存しますか?/ etc / pki / rpm-gpgと思っていましたが、nginxのキーをインストールしましたが、見つかりませんでした。正しくインポートされたようですが、どこにありますか? wget http://nginx.org/keys/nginx_signing.key rpm --import nginx_signing.key [root@web1-ftl rpm-gpg]# rpm -qi gpg-pubkey-7bd9bf62-4e4e3262 Name : gpg-pubkey Relocations: (not relocatable) Version : 7bd9bf62 Vendor: (none) Release : 4e4e3262 Build Date: Wed 05 Feb 2014 03:26:35 AM UTC Install Date: Wed 05 Feb 2014 03:26:35 AM …
9 centos6  rpm  keys 

2
Java 6の最新のアップデートはどのように入手しますか?
私の会社が購入を検討しているアプリケーションにはJava 6が必要です。これはかなり古くなっているのではないかと心配しており、結果としてそのアプリケーションに対しては推奨していません。しかし、Oracleはまだv6のアップデートをリリースしているようです。 彼らは「Javaサポートを購入したか、Java 6を必要とするOracle製品を持っている顧客に対してのみ」アップデートを提供すると述べています。http://www.java.com/en/download/faq/java_6.xmlを参照してください。しかし、彼らはどのようなサポートオプションを参照していますか? 私はWebサイトを調べましたが、最も関連性の高いサポートオプションは「Oracle Java SE Advanced」です(https://shop.oracle.com/pls/ostore/f?p=dstore:product:0::)。 NO:RP、6:P6_LPI:123775498017471532635010)が、これの最小注文は£6,700です。 私はただ道に迷っていますか?このような、バージョン6の最新の更新にアクセスするためのより明白で安価な方法はありますか?:http ://www.oracle.com/technetwork/java/javase/2col/6u71-bugfixes-2100823 html ありがとう
9 java  oracle  update 

3
ログオンタイプ8(NetworkCleartext)での数千の4625ログオン失敗エラーの原因は何ですか?
私はWindows Server 2008 R2システムを使用しており、Windowsログの[セキュリティ]セクションで、ログオンタイプ8(NetworkCleartext)による4625ログオン失敗エラーを毎日何千も表示しています。ソースネットワークアドレスにリストされているアクセスを取得しようとしているシステムのIPアドレスがないため、失敗が多すぎるIPをブロックするために私が作成したスクリプトはそれらを見つけることができません。 これらのログイン試行はどのようなサービスから発生する可能性がありますか? 以下はそのうちの1つのサンプルです。 An account failed to log on. Subject: Security ID: SYSTEM Account Name: server-name$ Account Domain: example Logon ID: 0x3e7 Logon Type: 8 Account For Which Logon Failed: Security ID: NULL SID Account Name: Administrator Account Domain: Failure Information: Failure Reason: Unknown user name or …

2
最新のドライブを備えた最新のOSで、「トラックあたりのセクター」がまだ関連しているのはなぜですか?
新しいマシンを構築していて、RAIDコントローラがトラックごとのセクターを要求しています。私は長い間(1998年)ディスクの計算を扱う必要がなかったので、現代のハードウェアに関連するものは何も見つかりません。これらは、p420iコントローラーで2.8カーネルを実行する2TB SASドライブです。 32(デフォルトであり、私には間違っているように見える)とトラックあたり63セクターのオプションの違いは何ですか?どちらが必要ですか?

2
何が生成された/autoconf.hを作成していますか?
ヘッダーだけでなく、カーネルソースを必要とするソフトウェアを構築しようとしています。そこで、centos src rpmを使用してカーネルソースをダウンロードしました。 ただし、autoconf.hがありません。 試しました .configを配置します(/ bootからコピーします)。 走る make oldconfig では、autoconf.hファイルを作成しているものは何でしょうか。実際にカーネルを構築する必要がありますか?
9 linux  kernel  make 

2
サーバーがロックアップすると、他のサーバーがネットワークから切り離されるのはなぜですか?
数十台のProxmoxサーバー(ProxmoxはDebian上で実行されます)があり、月に1回程度、そのうちの1台にカーネルパニックが発生してロックアップします。これらのロックアップに関する最悪の部分は、サーバーがクラスターマスターとは別のスイッチ上にある場合、そのスイッチ上の他のすべてのProxmoxサーバーは、実際にクラッシュしたサーバーを見つけて再起動するまで応答を停止することです。 この問題をProxmoxフォーラムで報告したときに、Proxmox 3.1にアップグレードするようにアドバイスされました。私たちは過去数か月間それを行っています。残念ながら、Proxmox 3.1に移行したサーバーの1つは、金曜日にカーネルパニックでロックされ、クラッシュしたサーバーを見つけて再起動するまで、同じスイッチ上にあるすべてのProxmoxサーバーにネットワーク経由で到達できませんでした。 ええと、スイッチ上のほとんどすべてのProxmoxサーバー...同じスイッチ上のProxmoxサーバーが、Proxmoxバージョン1.9のままであったことは、影響を受けなかったことが興味深いものでした。 クラッシュしたサーバーのコンソールのスクリーンショットは次のとおりです。 サーバーがロックアップすると、同じスイッチ上にある、Proxmox 3.1を実行していた残りのサーバーが到達不能になり、次の問題が発生しました。 e1000e 0000:00:19.0: eth0: Reset adapter unexpectedly e1000e 0000:00:19.0: eth0: Reset adapter unexpectedly e1000e 0000:00:19.0: eth0: Reset adapter unexpectedly ...etc... uname-ロックされたサーバーの出力: Linux ------ 2.6.32-23-pve #1 SMP Tue Aug 6 07:04:06 CEST 2013 x86_64 GNU/Linux pveversion -v出力(省略形): proxmox-ve-2.6.32: 3.1-109 (running kernel: 2.6.32-23-pve) pve-manager: 3.1-3 …

6
vSphereデータセンター間でVMテンプレートをコピーするにはどうすればよいですか?
背景/環境アーキテクチャ: 私の現在の環境$corp_overlords$は、技術的に恵まれたホームオフィスハブ(SAN、bladecenter / bladesystem ESXiクラスター、ファイバーインターネット接続など)が、リモートサイトスポークの数に接続されているハブアンドスポークモデルで設定されています。それほどうまくいっていません。通常、単一のESXiホストサーバーが含まれ、T1経由でホームオフィスのハブに接続します。リモートサイトで発生するすべてのトラフィックは、「MPLSネットワーク」(実際には、リモートサイトをホームオフィスに接続する単なるT1)を介してホームオフィスにルーティングされます。 ホームオフィスのSAN上には、VMの展開元として作成したVMテンプレートがいくつかあります。それらは、vSphereデータストアであるNFSボリュームに保存され、vSphere内のホームオフィスデータセンターオブジェクトに接続されます。 各リモートサイトには、対応するvSphereデータセンターオブジェクトがあり、リモートサイトに物理的に配置されているESXiホストサーバー上のローカル接続ストレージに接続されているデータストアオブジェクトが含まれています。 これらのVMテンプレートはNFSボリューム上に存在するため、約40 GiB(シンプロビジョニング)を占有します。NTFS(またはLinux FS)上のファイルとして、それらは〜100 GiBを占有します。 質問: この40 GiBのシンプロビジョニングされたデータ(ファイルシステム領域の100 GiBを占める)をサイト間でコピーするにはどうすればよいですか? 私には約5日間の制約があり、「通常のネットワークトラフィック」に(特に)干渉することはできません。

2
SquidをHTTPSフォワードプロキシとして構成しますか?
これが私の問題の背景です: Herokuで動的IPアドレスを使用してWebサービスを実行しています。Herokuの静的IPはオプションではありません。 ファイアウォールの背後にある外部Webサービスに接続する必要があります。外部Webサービスを操作する人々は、特定の静的IPに対してのみファイアウォールを開きます。 私が試みた解決策は、静的IPを持つ別のサーバーでSquidを使用して、Herokuから外部サービスにリクエストを転送することです。このようにして、外部サービスは常に、Herokuサービスの動的IPではなく、プロキシサーバーの静的IPを認識します。 私のプロキシサーバーは認証のためにIPアドレスに依存することができないため(これは最初から問題です!)、ユーザー名とパスワードに依存する必要があります。さらに、ユーザー名とパスワードをクリアテキストで送信することはできません。攻撃者がそのクリアテキストを傍受した場合、攻撃者は私になりすましてプロキシに接続し、プロキシの静的IPを使用して送信要求を行い、外部を回避する可能性があるためです。 Webサービスのファイアウォール。 したがって、Squidプロキシは、HTTPではなくHTTPS経由の接続のみを受け入れる必要があります。(外部Webサービスへの接続は、HTTPまたはHTTPSの場合があります。) 私はCentOS 6.5.xでSquid 3.1.10を実行していますが、squid.confここまでです。トラブルシューティングのみを目的として、HTTPプロキシとHTTPSプロキシの両方を一時的に有効にしていますが、HTTPSのみを使用したいと思います。 # # Recommended minimum configuration: # acl manager proto cache_object acl localhost src 127.0.0.1/32 ::1 acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1 # Example rule allowing access from your local networks. # Adapt to list your (internal) IP networks from where …
9 proxy  https  squid  heroku 

3
GPOソフトウェアインストールでは、既にインストールされているアプリケーションを別のポリシーから再インストールしますか?
GPOソフトウェアインストールポリシーを使用して最新のAVスイートをインストールしたいと考えています。(以下のスクリーンクリップのように。) 残念ながら、DFSを使用する要求が拒否されたため、環境内のサイトごとにGPOを作成する必要があります(各サイトは独自のサブネットです)。私が抱えている問題は、多くのユーザーがサイト間を移動するため、別のサイトに移動すると、新しいGPOを取得し、以前のGPOのスコープから外れることです。 現在のPCにアプリケーションが既に存在する場合、GPOソフトウェアのインストールによってアプリケーションが再インストールされるかどうかに関する具体的なドキュメントが見つかりません。私は、コンピューターが範囲外になったときにアプリを終了するオプションを使用します。 私の調査から、GPOはGPOのバージョンが変更された場合にのみ適用されることがわかりましたが、実際のMSIはどうですか? 人々が先送りしたがバックアップできない2つのシナリオを見つけました。 GPOは、インストールされたプログラムのリストをチェックするWindowsインストーラーサービスを呼び出し、現在のMSIバージョンが存在しない場合にのみインストールします。 GPOのインストールでは、独自のソフトウェアのリストとともに独自のAPPキャッシュが保持され、アプリが既にインストールされている場合でも、そのリストにない場合はアプリがインストールされます。 誰かが私のために正しい情報を確認できますか? 編集:応答の人たちのおかげで、私はソフトウェアを展開する他の代替方法を知っていますが、私が求めているのは、GPO展開がパッケージが既にワークステーションに存在する場合にパッケージを再インストールするかどうかについての具体的な答えです。

1
ethtoolはeth0がMIIを使用しているがツイストペアが使用されていると言います
ethtoolは、「サポートされているポート:[TP MII]」および「ポート:MII」と表示します。TPはツイストペアとMedia Independent Interfaceを意味すると思います。しかし物理的には、ネットワークカードがこのMIIコネクタではなくツイストペアケーブルを使用していることがわかります。それでは、それをどのように説明できますか?

5
Iperf CSV出力フォーマット
-y Cおよび-r引数を指定してiperfを使用して双方向転送をテストし、CSVとしてエクスポートした場合。 一部の出力が表示されますが、問題は、列名が何であるかわからないことです。たとえば、3行のデータが表示されていますが、どちらが送信に対応し、どれが受信に対応するのかわかりません。 他の列は推測できますが、どちらかといえば確かです。 このドキュメントはどこにも見つかりません。
9 iperf 


1
スタッカブルでない複数のネットワークスイッチを接続する適切な方法は?
私は、ITスタッフまたはローカルコンサルタントがいる倉庫保管および産業用アプリケーションの多くのクライアントを扱っています。これらのサイトの多くは、まだ10/100メガビットのスイッチングバックボーンを使用しています...私は、より大きな、より目に見えるイニシアチブの一部として、一部のクライアントにネットワーキングに投資してもらうことに成功しました。たとえば、セキュリティ、倉庫管理、VoIP(PoEのおかげ)。 私の質問は、サーバールーム/クローゼットに3つ以上のスタンドアロンスイッチのグループを配置する方法についてです。これらのスイッチがWeb管理のレイヤー2フルギガビットカテゴリ(HP ProCurve 1800-24G)であり、専用のスタッキングインターフェイスがないと仮定します。通常の範囲のサーバーと、インターネット接続用のCisco ASAファイアウォールへの1つのアップリンクを想定しています。多くの場合、このようなスイッチは単純にデイジーチェーン接続されています。 中小企業のITの現実... :( スイッチが2つしかないので、ユニット間にLACPボンドを設定します。サポートされている場合は、スパニングツリー。しかし、3つ以上のユニットはどうですか? 私自身の環境では、PoEまたはより複雑なルーティングが必要なため、高品質のスタッカブルギアを使用するか、フルシャーシスイッチ(Cisco 4507、HP 5400zl)を活用するだけの贅沢がありました。しかし、上記の状況に適切なプロセスは何ですか?

1
MySQL(MariaDB)が頻繁にクラッシュする
最近、MySQLを実行している古いサーバーをMariaDB 5.5を実行している新しいVPSに移行しました。サーバーで実行している量は多くなく(わずかなPHPサイトのみ)、空きメモリは問題ないようですが、DBがクラッシュし続けることがあります-場合によっては数日ごと、場合によっては数時間以内。 ログに次のエラーが表示されます。 131231 1:43:04 [ERROR] mysqld: Out of memory (Needed 128917504 bytes) 131231 1:43:04 [ERROR] mysqld: Out of memory (Needed 96681984 bytes) 131231 1:43:04 [ERROR] mysqld: Out of memory (Needed 72499200 bytes) 131231 1:43:04 [ERROR] mysqld: Out of memory (Needed 54362112 bytes) 131231 1:43:04 InnoDB: The InnoDB memory heap …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.