サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
Linux cd ..コマンド
これをたくさん行う必要がある場合は、次のように言います。 cd ../../../../foo/sub1/bar/dest/ cd ../../../../foo2/sub1/bar/dest/ cd ../../../../foo3/sub1/bar/dest/ cd ../../../../foo/sub1/bar/dest/ いつも../../../../そんなに何度も入力しないようにするより速い方法はありますか?クリエイティブなアイデアはありますか?
9 unix 

3
SQL Serverをハッカーから保護する方法
問題が発生し、その処理方法がわかりませんでした。Windows 2008 R2サーバー上にSQLサーバーがあります。このSQL Server 2005は、インターネット上の他の場所にある別のSQL ServerからDBサブスクリプションを受信するために使用されています。ファイアウォールを介してSQLサーバーのポートを開いていますが、スコープでは、他のSQLサーバーのIPを入力しています。そうすることで、他のSQL Server(ファイアウォールルールのスコープにリストされているIP)からの要求でない限り、そのポートを介した接続要求がSQL Serverに到達しないことを望みました。しかし、ログを見ると、何百もの「login failed user sa」エントリがあります(そして、それらは1秒ごとに来ています)。一部のハッカーがユーザーのパスワードを推測するためにブルートフォースを試みているようです。しかし問題は、ファイアウォールスコープにリストされているIPアドレスからではないのに、Windowsがこれらの要求をSQL Serverに到達させているのはなぜですか?このSQL Serverを保護する正しい方法は何ですか。他のSQL ServerのIP以外のIPは、このSQLサーバーに接続する必要はありません。 編集-詳細情報: 別のマシンからsqlサーバーポートでtelnetを実行しました。Telnetは、ファイアウォールスコープで具体的に言及されているマシンから実行された場合を除き、失敗します。したがって、ファイアウォールがSQLサーバーポートを正常にブロックしているようです。しかし、なぜSQL Serverログに異なるIPアドレスからのユーザー "sa"への失敗したログイン要求が表示されるのですか?ハッカーがポート80経由でマシンに侵入し、SQLサーバーに接続しようとしている可能性はありますか?ポート80と443は誰でも利用できます。SQLサーバーポートを除いて、他のすべてのポートは閉じられています(特定のIPに対してのみ開かれています)。訪問者をSQLサーバーに導く可能性のあるポート80のWebサーバー上で実行されているものはありません。実際、Webサーバーにはindex.html(SQLに接続されていない純粋なHTML)ファイルが1つだけあります。これは、将来使用するためにセットアップされたテストサーバーにすぎません。SQL Serverでのみデータをテストします。 編集: ファイアウォール接続を有効にして、ドロップ接続と成功接続の両方を含めました。現在、すべてをトレースしています。次に、SQL Serverログに移動し、中国のさまざまなIPアドレスからの失敗したログイン試行を確認します。ただし、ファイアウォールログにこれらのIPアドレスのエントリはありません。これはどのようにして可能ですか?ファイアウォールを完全にバイパスしてSQLサーバーにアクセスできますか?ファイアウォールのポートが開いていて、そこから入る可能性がある場合、ファイアウォールのログにそのIPアドレスのエントリが表示されます。私は完全に途方に暮れています。

2
Amazon EC2マイクロインスタンスのCPU使用率は100%
私のAmazon EC2マイクロインスタンスは、非常に頻繁に100%のCPU使用率を持っています。私はそれにワードプレスをインストールしているだけです。私はまだプロダクションモードなので、ユーザーはいませんが、CPU使用率は100%です。 誰かがそれを減らす方法を知っていますか?300秒以上続くため、Amazonメール通知を毎時間受け取ります。 すでにデータベースをRDSに移動しましたが、その問題は解決しませんでした。少し良くなっただけです。データベースを使用してRDSに移行する前に、Webページを1つだけロードすると、Webサイトが常に完全にクラッシュしました。 私のmysqld.logがerrno 12エラーを出力するため、my.cnfでinnodb_buffer_pool_size = 256Mも実行しましたが、何も出力されませんでした。 すべてのヒントに感謝されます。


2
CentOS 6にルート証明書をインストールする
私はそれがすでに尋ねられたことを知っています、しかし何時間もの研究にもかかわらず私は実用的な解決策を見つけることができませんでした。ルート証明書をサーバーにインストールしようとしています。内部サービスがSSLを使用して相互にバインドできるようにしています。 新しいルートCAについて知っておくべきこと: Apache httpdおよびPHP OpenLDAPクライアント Node.js Apacheの場合、ルート証明書について知るにはPHPアプリケーションが必要です。そのため、サイトが別のSSL Webサイト(同じCAによって署名されている)に接続する場合、サイトは正常に機能し、自己署名証明書について不満はありません。 OpenLDAPの場合、それはPHPと同じだと思います。使用するモジュールはかなり古く、PEARとともにインストールされるNet_LDAP2です。ローカルのopenldap設定を編集してみましたが、システムで使用されていないようです。 最後のNode.js。これはパーソイドに使用します。node.jsサーバーは、適切なSSL接続を確立するためにCAを信頼する必要があります。 /etc/pki/tls/certs/ca-bundle.crtに証明書を追加しようとしましたが、ほとんど成功しませんでした。 httpdにはルートCAが表示されませんが、tomcatや389などの他のサービスを使用してなんとかすることができました。 ご支援いただきありがとうございます。

1
パスワードは本当に期限切れですか?
Windowsドメインでパスワードの有効期限(パスワードの最大有効期間)を有効にできます。 いわゆる有効期限の意味について少し戸惑っています。パスワードが本当に期限切れになっていないようです。単に、「有効期限」後の最初のログイン時に、ユーザーは自分のパスワードを変更する必要があります。言い換えると、パスワードが11月18日に期限切れになった場合でも、11月20日にログインできます(ただし、すぐにパスワードを変更する必要があります)。 ユーザーアカウントは、有効期限が切れてもロックされません(または他の同様の状態)。 これは正しいです?または私は何かを逃したのですか?

1
「curl:(56)SSL read:errno -5961」エラーの根本的な原因
私はいくつかのSSLの失敗を評価していてcurl、失敗したサイトの1つを使用するとcurl: (56) SSL read: errno -5961、ただし、そのエラーに対するGoogleのクエリでは、opensslの失敗の理由は表示されませんでした。 質問:カールが失敗した場合、どういう意味curl: (56) SSL read: errno -5961ですか? curl以下を完全に含めます... [mpenning@mpenning-lnx ~]$ curl -vk https://192.0.2.168/ * About to connect() to 192.0.2.168 port 443 (#0) * Trying 192.0.2.168... connected * Connected to 192.0.2.168 (192.0.2.168) port 443 (#0) * Initializing NSS with certpath: sql:/etc/pki/nssdb * warning: ignoring value of …
9 ssl  tcp  timeout  curl 

1
Windows Server 2012で「Webデプロイ」を使用できないHTTPエラー404.7
Windows Server 2012とWeb Deploy 3.5を使用しています。Visual Studioからパブリッシュしようとすると、404が表示され、次のリンクをたどることを勧めます http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_DESTINATION_NOT_REACHABLE wmsrvとリモートエージェントの両方が実行され、適切に構成されている。wmsrvログを確認した後、同じエラーが繰り返し表示されます。 2013-11-27 18:11:41 10.7.140.235 HEAD /msdeploy.axd site = DevStatsDashboard 8172-10.7.141.48--404 7 0 1388 サポートサイトhttp://support.microsoft.com/kb/943891から、これはHTTPエラー404.7 – FILE_EXTENSION_DENIEDを意味します しかし、私はIIS8を使用しており、.axdファイルを許可しています 誰か提案はありますか?

1
DOSプリンターのテキスト出力に「新しい」コンピューターで誤った文字が含まれる
私はもともと486 DX2コンピューターで実行されていた古いDOS 6.2アプリケーションを救出しようとしています。ハードドライブを比較的新しいCeleron 633に移動しました。標準の印刷コマンドを使用してパラレルポート(LPT1)に印刷しようとした場合を除いて、すべてが正常に動作しているようです。信号はプリンターに送られますが、紙に間違った文字が出ます。具体的には: 0123456789 prints correctly. áéíóú prints correctly. abcd prints ☺☻♥♦ ABCD prints !"#$ (is 0x2 off) ロードされたコンソールコードページは850です。問題のプリンターはHP DeskJet 940Cです。残念ながら、テストするための2番目のパラレルポートプリンターはありません。 OSが完全に同じであるのに、なぜこれが1台のコンピューターから別のコンピューターに変更されるのですか?また、DOSを正しく印刷するように構成するにはどうすればよいですか? 前もって感謝します。

1
RHEL6を搭載した12G Dellサーバーでの「電力制限通知」の妨害
サーバー:Poweredge r620 OS:RHEL 6.4 カーネル:2.6.32-358.18.1.el6.x86_64 実稼働環境でアプリケーションアラームが発生しています。重要なCPUを必要とするプロセスでリソースが不足し、処理バックログが発生しています。この問題は、最近導入されたクラスター内のすべての第12世代Dellサーバー(r620)で発生しています。私が知る限りでは、これが発生するインスタンスは、CPU使用率のピークに一致し、大量の「電力制限通知」スパムがに伴っていますdmesg。これらのイベントの1つの抜粋: Nov 7 10:15:15 someserver [.crit] CPU12: Core power limit notification (total events = 14) Nov 7 10:15:15 someserver [.crit] CPU0: Core power limit notification (total events = 14) Nov 7 10:15:15 someserver [.crit] CPU6: Core power limit notification (total events = 14) Nov 7 …

1
key_bufferまたはkey_buffer_sizeですか?
my.cnfファイル内の正しい変数に関してインターネットを検索します。key_buffer_size廃止予定だと言う人もいれば、それkey_buffer_sizeがの正しい変数だと言う人もいますmy.cnf。 それで、ここで本当に正しい変数は何ですか?それはありますkey_bufferかkey_buffer_size? Ubuntu 12.04を使用しています。 またkey_buffer、my.cnfファイルに2つの変数があります。これは、MySQLをインストールした後に取得したものです。 最初のものはこの下にあります: [mysqld] key_buffer = 16M もう1つはこの下にあります。 [isamchk] key_buffer = 16M

2
スクリプトが見つからないか、統計できない:/ usr / lib / cgi-bin / php-cgi
私は新しいシリーズのエラーを見ました /var/log/apache2/error.log [2013年10月31日木曜日06:59:04] [エラー] [クライアント203.197.197.18]スクリプトが見つからないか、統計できない:/ usr / lib / cgi-bin / php [2013年10月31日木曜日06:59:08] [エラー] [クライアント203.197.197.18]スクリプトが見つからないか、統計できない:/ usr / lib / cgi-bin / php5 [2013年10月31日木曜日06:59:09] [エラー] [クライアント203.197.197.18]スクリプトが見つからないか、統計できない:/ usr / lib / cgi-bin / php-cgi [2013年10月31日木曜日06:59:14] [エラー] [クライアント203.197.197.18]スクリプトが見つからないか、統計できない:/usr/lib/cgi-bin/php.cgi [2013年10月31日木曜日06:59:14] [エラー] [クライアント203.197.197.18]スクリプトが見つからないか、統計をとることができない:/ usr / lib / cgi-bin / php4 このサーバーはUbuntu 12.04ltsを実行しています。 これまでこの種の攻撃を見たことがありませんが、システムを心配したり、何らかの方法でシステムを保護したりする必要がありますか? ありがとう、ジョン

4
sshdに別のポートをリッスンさせたときに、ポート22を偽造するにはどうすればよいですか?
サーバーをポートスキャンしてハッカーの可能性を作る代わりに、sshdがポート22でリッスンしていることを偽装し、試行をログに記録したいと思います。それを行うことは理にかなっていますか?はいの場合、積極的に開発されているツール/ライブラリを利用できます。
9 security  ssh 

3
メインファイルシステムが読み取り専用モードになる原因を見つける方法
Ubuntu 12.04 ファイルシステムは頻繁に読み取り専用モードになります。まず第一に、私はこの質問を読みました。ファイルシステムは、すでに頻繁に読み取り専用モードになっています。しかし、それが以外の原因ではないのかどうかを知る必要がありdying hard driveます。これは私のクライアントによって提供されるサーバーであり、私はそこでいくつかnode.js workers+ 1を実行しnode.js server、私はを使用していmongodbます。 ときどき(20〜50時間ごとに)システムが突然ファイルシステムを読み取り専用にし、mongodbプロセスが失敗し(読み取り専用fsのため)、私のノードワーカー/サーバー(によって起動されますforever)が強制終了されます。 これがdmesgからのログです-FSが読み取り専用になるエラーとメッセージがいくつかあります。JOURNALエラーもいくつかありますが、それらのエラーの原因を見つけたいと思います。 http://speedy.sh/Ux2VV/dmesg.log.txt 編集する smartctl -t long /dev/sda smartctl 5.41 2011-06-09 r3365 [x86_64-linux-3.5.0-23-generic] (local build) Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net SMART support is: Unavailable - device lacks SMART capability. A mandatory SMART command failed: exiting. To continue, add one or …

2
多くの接続を処理するようにWindows Server 2008 R2を改善するにはどうすればよいですか?
私がこの問題を解決する方法を理解しようとしているのは、ここ数日です。まず、1日の平均ページビューが350,000のWebサイトを実行しています。以前は、すべての広告管理(各広告が配信したクリックとインプレッションの追跡)とコンテンツは、次の仕様で単一のサーバーに配信されていました。 サーバー1 OS:Windows 2008 R2 64ビット CPU:Intel®Core™i5-4コア RAM:8 GB ストレージ:2 x 1 TBハードドライブ 帯域幅:10 TB /月 Webサイトの速度を向上させるために、広告管理スクリプトを別の専用サーバーに分離することにしました。各ページに15を超える広告主から30の広告主がいるためです。 サーバー2 OS:Windows 2008 R2 64ビット CPU:Intel®Core™i5-4コア RAM:4 GB ストレージ:2 x 300 GBハードドライブ 帯域幅:10 TB /月 問題は 、問題はそれがある Server 1コンテンツや広告システムの両方を扱うことができます。今、私は広告システムを取り除き、それをに置いていServer 2ます。Server 2かろうじて広告システムしか提供できません。 テスト まず、広告の75%をに移動しましたServer 2。次に、サーバーへのpingを実行しますping -t xxxxx。[私は10分間pingを実行し、以下のような類似のパターンを実行しました] xxxxxバイトからの応答= 32時間= 290ミリ秒TTL = 116 xxxxxバイトからの返信バイト数= 32時間= …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.