サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
メールがGmailのDKIMテストに合格しないのはなぜですか?
Gmailで拒否されたメッセージがありますが、理由はわかりません。SPFに合格。DKIMは使用していません。DKIMをセットアップする必要がありますか? 「example.com」を管理しています。私たちのメールサーバーは「server.example.com」です(bluehostでホストされています) 私たちのSPFレコードは v=spf1 +a +mx ?include:bluehost.com -all ただし、Gmailは次のメッセージを拒否しました。 550-5.7.1ドメインのDMARCポリシーにより、example.comからの認証されていない電子メールは受け入れられません。example.comの管理者に連絡してください... メッセージヘッダー: Return-path: <sabrina@example.com> Received: from [99.127.228.246] (port=61813 helo=[192.168.1.66]) by server.example.com with esmtpsa (TLSv1:AES128-SHA:128) (Exim 4.80.1) (envelope-from <sabrina@example.com>) id 1VMLM8-0007ok-5c; Wed, 18 Sep 2013 17:16:03 +0000 From: Sabrina <sabrina@example.com> Content-Type: multipart/alternative; boundary="Apple-Mail=_2FE0763D-B160-49C4-8202-B8258851AFAD" Subject: positive self thoughts/talk Date: Wed, 18 Sep 2013 …
10 gmail  spf  dkim  dmarc 

2
Puppetエージェントの証明書検証の失敗
Puppetマスター/エージェントをセットアップし、マスター上のエージェントの証明書に正常に署名しました。しかし、実行するpuppet agent --testと、次のようなエラーが発生します。 Warning: Unable to fetch my node definition, but the agent run will continue: Warning: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: [certificate signature failure for /CN=hostname.domain.com] Info: Retrieving plugin Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate: SSL_connect returned=1 errno=0 state=SSLv3 read …

3
サーバー全体を誤って圧縮しました
誰かが神を演じて奇跡を起こしたいのなら、私はダウンしています。 そのため、6か月以上経過したファイルを見つけ、それらを圧縮してから削除するスクリプトを作成するタスクが与えられました。スクリプトを作成する途中で、私はこれを実行しました: find / -type f -mtime -400 ! -mtime -180 | xargs gzip blablabla そして、それはすべての単一ファイルに.gz拡張子を与えました。気づいたらすぐに元に戻しましたが、ちょっと遅すぎました。コマンドが完了すると、$ PATH変数が空になったため、bashコマンドはどれも機能しません。何が問題なのか気づく前に、いろいろと試しました。 だから私はまだ起動できないすべてのものを解凍します。私はそれをなんとかして救出することができました、その後、私は次のオンライン指示に従いました: root (hd0,0) setup (hd0) kernel (hd0,0)/boot/vml[...] initrd (hd0,0)/boot/initrd.im[...] Linuxが部分的に起動した後、次のエラーが表示されます。 Begin : Running /scripts/init-bottom ... mount : mounting /dev on /root/dev failed : No such file or directory mount: mounting /sys/ on /root/sys …
10 linux  boot  gzip 



1
Puppetでの代替CA(Microsoft証明書サービスのような)の利用
どういうわけか、パペットエコシステムに、独自のCAではなく、既存のMicrosoftエンタープライズCAを利用させることができるかどうかを調査しています。 パペットはすべてのシステムが「標準SSL」であると宣伝しているので、パペットをあまり変更せずにこれを完全に実行できると思いますが、パペットを編集して企業に適切な呼び出しを行わない限り、手動による大きな頭痛の種になる可能性があります。 CA。 これまでに誰かがこれを試しましたか?「こっちはドラゴンよ、背を向けろ!」状況?

6
サーバーがダウンしていてもCDNは機能しますか?
私は、Amazonのcloudfront S3を使用することを計画しているWebサイトの所有者です。私はCDNが何ができるかについてすべてのものを読んでいますが、未回答の質問があります。 メインサーバーがダウンしている場合でも、CDNは機能しますか?それが私がそれに興味を持っている主な理由です。というのも、ここマリでは、サーバーの電源障害が原因で、サーバーが頻繁に停止するからです。
10 backup  amazon-s3  cdn 

2
仮想化ホストにサービスの実行を許可する必要がありますか?
最近、実行している小さな会社用に仮想化サーバーをセットアップしました。このサーバーは、開発、テストなどに使用されるいくつかの仮想マシンを実行します... 私のビジネスパートナーは離れた場所から作業しているため、仮想化ホストにVPNサーバーをインストールして、彼が会社のサービスに安全にアクセスできるようにしました。また、仮想化ホストにもデータのバックアップを行うためにバキュラをインストールしました。 そうすることをお勧めしますか、または良い習慣ですか、またはバックアップとVPNを行うためにもう1つの仮想マシンを作成する必要がありますか?ホスト自体でこれらのサービスを実行することは悪い考えですか?はいの場合、なぜですか?

1
TCPキープアライブとファイアウォールによるアイドルセッションの強制終了
顧客サイトでは、ネットワークチームがクライアントとサーバーの間にファイアウォールを追加しました。これにより、アイドル時間の約40分後にアイドル接続が切断されます。ネットワークの人々は、ファイアウォールにはアイドル接続のタイムアウトがないと言っていますが、実際にはアイドル接続が壊れています。 これを回避するために、最初にサーバー(Linuxマシン)を構成し、tcp_keepalive_time = 300、tcp_keepalive_intvl = 300、およびtcp_keepalive_probes = 30000でTCPキープアライブをオンにしました。これは機能し、接続は数日以上実行可能です。ただし、サーバーが死んだクライアントを検出して接続を強制終了するようにしたいので、設定をtime = 300、intvl = 180、probes = 10に変更し、クライアントが実際に生きている場合、サーバーは300秒ごとにプローブすると考えました(5分)クライアントはACKで応答し、ファイアウォールはこれをアイドル接続と見なして強制終了することを防ぎます。クライアントが停止している場合、10回のプローブの後、サーバーは接続を中止します。驚いたことに、アイドル状態で生きている接続は、以前のように約40分後に強制終了されます。 クライアント側で実行されているWiresharkは、サーバーでキープアライブが有効になっている場合でも、サーバーとクライアントの間でキープアライブをまったく表示しません。 ここで何が起こっているのでしょうか? サーバーのキープアライブ設定がtime = 300、intvl = 180、probes = 10の場合、クライアントがアクティブでアイドル状態の場合、サーバーは300秒ごとにキープアライブプローブを送信し、接続をそのままにし、クライアントは死んでいます。300秒後に1つ送信し、接続を終了する前に180秒ごとにさらに9つのプローブを送信します。私は正しいですか? 1つの可能性は、ファイアウォールが何らかの理由でサーバーからのキープアライブプローブをインターセプトし、それらをクライアントに渡すのに失敗し、プローブを取得したという事実により、接続がアクティブであると見なされることです。これはファイアウォールの一般的な動作ですか?どのようなファイアウォールが関係しているかはわかりません。 サーバーはTeradataノードであり、接続はTeradataクライアントユーティリティからデータベースサーバー、サーバー側のポート1025への接続ですが、SSH接続で同じ問題が発生したため、すべてのTCP接続に影響すると考えられます。

4
nginxでのSlashdot効果の検出
リファラーからのヒットがしきい値を超えた場合にNginxに通知させる方法はありますか? たとえば、私のウェブサイトがスラッシュドットで特集されていて、突然1時間に2Kヒットが来る場合、1Kヒットが1時間を超えたときに通知を受ける必要があります。 Nginxでこれを行うことは可能ですか?おそらくルアなし?(私の製品はluaコンパイルされていないため)
10 nginx  traffic 

2
UPSが要件に対して十分かどうかを計算するにはどうすればよいですか?
私は電気知識のある人ではないので、できるだけ多くの情報を掲載するようにします。 1800ワットのラックマウントUPSを持っていますモデル:PRP 3050 RM(合計で2つあります-具体的には1つについて話します) 今日はバッテリーを交換する必要があり、それに接続されているハードウェアをサポートできるかどうかを考えました。 *各メーカーのサイトで見つけた仕様を追加します。PDFへのリンクは次のとおりです: Netgear 1100 仕様 は生産終了 QNAP U-859 RP + 仕様 *アンペア表示なし Dell R610 仕様 デル1950 スペック Dell 2850 仕様 画面L1710S *最小画面ワット-<0.5A 私が持っているハードウェアのマップであるデルの電力計算機ESSAで作成しました: 使用されるAMPSの合計は5.8です 3つすべてのDellにはそれぞれ冗長PSUがあります デルのサイトによると、これは、各PSUが上記/必要なワット数の半分を使用することを意味します。 各デルは2台のUPSに接続されています(どちらもPRP 3050です)。 Q: UPSの仕様では8.5Ahと記載されていますが、MAXに到達するまで、さらに多くのアプライアンスを接続できるということですか? 私が提供したこの情報から何を学ぶことができますか? @amotzg http://www.jobsite-generators.com/power_calculators.htmlによって提案された電力計算機へのリンクを追加する


1
Windows RPCポート135、137、139(およびそれ以上のポート)のシーケンスは何ですか?ポート145の変更点
Windows RPCポートのそれぞれがいつどのくらいの頻度で使用されるかを誰かが説明できますか?私が理解している「コア」なものは: ポート135 ポート137 ポート139 ポート135の「カタログ」によって公開されている上位のポート 次に、ポート145がNBT / TCPを使用して「状況を改善する」ために導入されたと聞きましたが、これがRPCアクションを開始するWindowsクライアントのシーケンスとどのように一致するかはわかりません。 誰もがRPCポートに関する私の理解を一度だけ修正する手助けをしてくれますか?
10 windows  netbios  rpc 

5
Ubuntu 12.04以降、/ dev / urandomはrootのみが読み取り可能であり、「修正」できるのはなぜですか?
以前は、多くのサーバーでUbuntu 10.04テンプレートを使用していました。12.04に変更してから、現在は問題を切り分けています。 / dev / urandomデバイスはrootのみがアクセスできます。 これにより、少なくともPHPではSSLエンジン、たとえばfile_get_contents(https:// ...)が失敗しました。 また、レッドマインを壊しました。 chmod 644の後は正常に動作しますが、再起動しても残りません。 だから私の質問。 どうしてこれなの?セキュリティリスクはないので...ランダムデータを盗むのですか? どうすれば「修正」できますか?サーバーは分離され、1つのアプリケーションだけで使用されるため、openvzを使用しています。ランレベルスクリプトなどのことを考えていますが、どうすれば効率的に実行できますか?dpkgまたはaptのMaby? / dev / shmでも同様です。この場合、なぜアクセスできないのかを完全に理解していますが、/ dev / urandomを修正するのと同じ方法で「修正」できると思います

2
CentOS 6はCentOS 5よりも多くのIOを実行
私は2つの同じサーバーでアプリケーションをベンチマークしています。1つはCentos 5.8で、もう1つはCentos 6.2です。私のアプリケーションは、Centos 6.2マシンで非常に遅く(50%以下)実行されています。 問題を診断するために、ベンチマークの実行全体を通じてCPU、RAM、およびIOを追跡しています。Centos 6.2ボックスでは、iostatで測定すると、ディスクの読み取りが大幅に多いことがわかります。 どちらのシステムも、ベンチマークが実行されている場所でXFSを実行しています。どちらも、512 MBキャッシングRAIDコントローラーを搭載したHPサーバーで、RAID 10を実行する8 x 300GB SAS 以下は、それぞれのxfs_infoの出力です。 centos5 meta-data=/dev/cciss/c0d0p5 isize=256 agcount=32, agsize=8034208 blks = sectsz=512 attr=0 data = bsize=4096 blocks=257094144, imaxpct=25 = sunit=32 swidth=128 blks, unwritten=1 naming =version 2 bsize=4096 log =internal bsize=4096 blocks=32768, version=1 = sectsz=512 sunit=0 blks, lazy-count=0 realtime =none extsz=4096 blocks=0, …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.