サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
FUSEマウントがLinuxサーバーを不安定にする可能性は何ですか?
私は、学部の学生がシェルアカウントを持っているマルチユーザーサーバーのシステム管理者です。ユーザーの1人が、インストールsshfsを要求しています。sshfs提案どおりにインストールするのが賢明かどうかを議論しています。 私の主な懸念は、FUSEマウントによってサーバーの信頼性が低下する可能性があるかどうかです。私の経験では、NFSサーバーが突然使用できなくなると、サーバーに悪いことが起こります。負荷平均が急上昇し、ハードリブートが必要になるほどクリーンにアンマウントできない場合があります。FUSEがマウントされたサーバーが突然消えた場合、混乱を一掃するのはどれくらい難しいでしょうか?他に考慮すべき大惨事や落とし穴はありますか? 少なくともNFSでは、rootのみがマウントでき、合理的に信頼できると思われるNFSサーバーをマウントすることを選択できます。 ユーザーに敵意はないが、誤って愚かなことをするかもしれないと仮定しましょう。また、私たちのユーザーはすでにシェルアクセスを持っているので、マウントするファイルシステムの内容についてはあまり心配していません。必要なものはすべてホームディレクトリにコピーできます。
11 linux  sshfs  fuse 

1
Linux-ホスト名を変更した場合、どのサービスを再起動する必要がありますか?
私はいくつかの環境にわたってシステムのホスト名を変更していますが、これは私に考えさせられました... サーバーのホスト名(ライブ)を変更する場合、何を変更する必要があり、どのシステムサービスを再起動する必要がありますか?これは再起動せずにオンラインで行われると仮定します。 実行中にホスト名の変更が行われる他の人々によって構築された多くのシステムに遭遇しますが、変更は再起動後も持続しないか/var/log/messages、別のホスト名がスタンプされています。 私は定期的にフォローします: 走る hostname <new-short-hostname> /etc/hosts これらのガイドラインに従って変更します。 変更する /etc/sysconfig/network デーモン側で... sendmail / postfix(一致するホスト名が必要です) cups(不正なホスト名で印刷デーモンが停止する場合があります) syslog / rsyslog(ホスト名はシステムメッセージとともに記録されます) httpd(適切なホスト名が必要です) 他に注意が必要なものは何ですか?

1
Active Directoryのコンピューターオブジェクトのマネージャーフィールドを設定すると、どのような影響がありますか?
Active Directoryのユーザーオブジェクトにマネージャーを設定すると、ユーザーとそのマネージャーの間に明確な関係が作成されます。これは、特にExchangeのグローバルアドレス一覧で報告されます。 グループオブジェクトの場合、Managerは、Outlookのアドレス一覧を有効にすると、グループのメンバーを編集できます。 Active Directory内のコンピューターオブジェクトに対して同じマネージャーフィールドが存在します。これはどこかの機能に関連していますか?

1
HP Proliant Microserverでビデオ出力もステータスライトもありません
「N40L」HP Proliant Microserverに問題があります。サーバーの電源がオンになると、電源ライトは緑色に変わりますが、マシンのステータスライト(前面のHPロゴ)はオフのままで、オンボードVGAからのビデオ出力はありません。システムファンが作動し、ネットワークに接続されている場合、リンクランプにアクティビティが表示されます。余分なボード(iLOカード、グラフィックカード)はありませんが、4GB PNYの非標準のRAMしかありません。
11 hp  hp-proliant 

5
アクセスが拒否されたため、Windowsでのnginxの停止/再読み込みに失敗しました
WindowsサービスとしてWindows Server 2008 R2(x64)でnginxを実行しています。そのためにWindows Service Wrapperを使用しています。(実際、私はこのチュートリアルに従っています:http : //mercurial.selenic.com/wiki/HgServeNginxWindows。) サービスは正常に実行されています。ただし、サーバーは信号を処理しません(例:停止/リロード)。 つまり、サービスを停止しても、nginxは停止しません。(私はそれを殺さなければなりません。) そして、コマンドラインから設定をリロードしたい場合: C:\Users\Administrator>E:\apath\nginx\nginx.exe -p E:\apath\nginx -c E:\apath\nginx.conf -s reload 以下を出力します: nginx: [error] OpenEvent("Global\ngx_reload_4268") failed (5: Access is denied) 管理者としてコマンドを実行していますが、サービスはNETWORK SERVICEユーザーで実行されています。 ヒントや同様の問題はありますか?

2
bind9-フォワーダーが機能していません
バインドの問題が発生しています。ゾーンファイルにあるドメイン名を解決したい場合。正常に動作します。ただし、ゾーンファイルに属さないものを解決しようとすると。転送されている実際のDNSサーバーが正常に機能していることを知っています。しかし、どういうわけかbind9はそれらの使用に失敗します。/etc/bind/named.conf.optionsの内容は次のとおりです。 options { directory "/var/cache/bind"; forwarders { 131.181.127.32; 131.181.59.48; }; dnssec-validation auto; auth-nxdomain no; # conform to RFC1035 listen-on-v6 { any; }; }; また、IPアドレスを1つだけ使用しようとしましたが、まだ機能しませんでした。また、/ etc / bind / named.confの内容は次のとおりです。 include "/etc/bind/named.conf.options"; include "/etc/bind/named.conf.local"; include "/etc/bind/named.conf.default-zones"; したがって、オプションファイルを含めても問題はありません。この問題を修正するための推奨事項はありますか?

4
ロングギガビットイーサネットラン
約260フィート離れた2つの建物間にGig-Eネットワークを取得しようとしています。一部のTRENDnetスイッチは、その距離でCat 6を介して相互に接続できませんでしたが、2つのNetgear 5ポートGig-Eスイッチは正常に接続できます。ただし、回線が各スイッチに接続する前に、両端にAPC PNET1GBイーサネットサージプロテクターを配置した後でも、まだ失敗します。そのため、信号をそれほど劣化させないより優れたサージプロテクターを単に見つける必要があるのか​​(もしそうなら、どのような種類をお勧めしますか)、銅線をあきらめて建物間でファイバーを使用する必要があるのか​​疑問に思います。 後者のルートを選択した場合、実際にいくつかのポインターを使用できます。LCコネクタが最も一般的であるように見えますが、私は他のいくつかにも出会っています。両端のメディアコンバーターは最も単純なソリューションのように見えますが、おそらくSFPポートを備えたGig-Eスイッチの方が理にかなっていますか?予算が非常に限られていることを考えると、既存の銅線に固執するのが最善のように思えますが、頭痛の種にならなければ、100メートルのファイバーケーブルはコスト的に賢明に振れると思います。

2
Linuxでr—ディレクトリのアクセス許可はどのように機能しますか?
作成したディレクトリにこれらの権限があります-他のユーザーが持っています drwxr--r-- 5ユーザーuser 4096 2012-09-15 19:30サイト 別のユーザーとしてディレクトリでls -lを実行する場合 ls -l / home / user / sites これはディレクトリ出力です。そのディレクトリにxビットが設定されていないと、ファイル名はまったく表示されません。 d????????? ? ? ? ? ? dev.user.com -????????? ? ? ? ? ? user.20120914_082804.sql.gz d????????? ? ? ? ? ? shared -????????? ? ? ? ? ? shared.tar.gz -????????? ? ? ? ? …

1
現在実行中のスクリプトの素晴らしいレベルを変更する
現在実行中のスクリプトの素晴らしいレベルを変更したいと思います。 #!/bin/bash nice_it ( ) { nice ps -o "%p %r %y %x %n %c %a" } nice_it それniceによって開始されたコマンドのナイスレベルを変更しようとするため、これは機能しません。 これをbashで達成することは可能ですか?
11 bash  nice 

2
iptablesチェックスクリプトの構文
実際のファイアウォール構成を変更せずにiptablesルールスクリプトの構文をテスト/チェックする方法はありますか(各ルールを追加および削除することは最良の方法ではないと思います...)。 -Cオプションについては知っていますが、チェーンなどのオプションはチェックしません。また、1が構文が正しいことを常に意味するわけではないため、戻りコードについて少し注意が必要です。 THX!
11 iptables 

4
AWSのスポットインスタンスの価格が「オンデマンド」価格を上回るのはなぜですか?
スポットインスタンスの不整合に関するAmazonの価格設定 これは、インスタンスの価格設定の履歴チャートのスクリーンショットを通して最もよく説明されるものです。 スポットインスタンスのインスタンス価格の多くを見ると、スパイクの規則的なパターンに気づくでしょう。こちらをご覧ください: ご覧のとおり、このコンピューティングメディアインスタンスの価格は、オンデマンド価格を定期的に上回っています。 c1.medium(オンデマンド)のインスタンスは、唯一のコストがかかる$0.186時間あたり。しかし、数週間の間、ゾーンBでは、価格は定期的に$ 1.20に急上昇します。これは、実際のオンデマンド価格の約6倍です。 また、孤立していません。小さいインスタンスでもう一度zone-bを見ると、同様のスパイクが頻繁に発生しています。オンデマンド料金の4倍になります。 なぜこれが起こるのか誰にも分かりますか? ここにいくつかの提案があります 誰かが0.12ドルではなく1.2ドルを入力しました(3週間で20回発生したため、これを割引します)。 アマゾンは、自分のインスタンスに入札することで定期的に価格を人為的に膨らませて、最高の収益を得ています。(ばかげて悪いビジネスになるので、私はこれを割引します) 一部の会社は、一度に1000台のサーバーを起動し、それらすべてが起動することを確認したいと考えています。(おそらく、彼らは最小オンデマンド価格よりも低い価格でそれらを起動するので、これを割引します。なぜあなたは単一のサーバーに対してオンデマンドで支払うのですか?)。 レポートのバグですか?

2
ビジーなインターフェイスでtcpdumpingを実行すると、多くのドロップされたパッケージ
私の挑戦 大量のデータのtcpdumpを実行する必要があります。実際には、多くのトラフィックを見ることができる無差別モードのままの2つのインターフェースからです。 まとめると 2つのインターフェイスからの無差別モードのすべてのトラフィックを記録します これらのインターフェイスにはIPアドレスが割り当てられていません pcapファイルは〜1Gごとにローテーションする必要があります 10 TBのファイルが保存されたら、最も古いファイルの切り捨てを開始します 私が現在していること 現在、私は次のようにtcpdumpを使用しています。 ifconfig ethX promisc ifconfig ethX promisc tcpdump -n -C 1000 -z /data/compress.sh -i any -w /data/livedump/capture.pcap $FILTER に$FILTERはsrc / dstフィルターが含まれているため、を使用できます-i any。この理由は、2つのインターフェイスがあり、2つではなく1つのスレッドでダンプを実行したいからです。 compress.sh tarを別のCPUコアに割り当て、データを圧縮し、適切なファイル名を付けて、アーカイブの場所に移動します。 2つのインターフェイスを指定できないため、フィルターを使用してanyインターフェイスからダンプすることを選択しました。 現在、私はハウスキーピングを行いませんが、ディスクの監視を計画しており、100Gが残っているときに最も古いファイルの消去を開始します-これで問題ありません。 そしていま; 私の問題 ドロップされたパケットが表示されます。これは、数時間実行され、およそ250ギガバイトのpcapファイルを収集したダンプからのものです。 430083369 packets captured 430115470 packets received by filter 32057 packets dropped by …

6
病気のNTPサーバーソースの交換と再同期(現在の内部時間は2分遅れ)
ソースとして使用している外部NTPサーバーの1つ(現在はプライマリサーバー)は、NTP呼び出しに応答していないようです。残念ながら、コアルーター(Cisco 6509)では、NTP機能は予想どおりにセカンダリNTP外部サーバーに切り替わりませんでした。その結果、主要な内部NTPソースであるコアルーターは2分遅れています。 外部NTPソースを現在動作しているものにすることで、外部ルーターの問題を修正する予定です。 2分間の変更がユーザーとサービスにどの程度影響するのでしょうか?特に最近では、証明書ベースの認証に大きく依存しています。 私たちはWindows / Ciscoのショップです。 内部NTPセットアップ: [コアルーター1 / Cisco 6509]: 2つの外部NTPサーバー(プライマリサーバーがNTP呼び出しに応答していない)を監視 [コアルーター2]: コアルーター1(プライマリ)と同期、動作中の外部ルーター(セカンダリ) [その他のシスコネットワークデバイス]: コアルーター1(プライマリ)、コアルーター2(セカンダリ)との同期 [ドメインコントローラー]: コアルーター1との同期 [すべてのWindowsクライアント/サーバー]: ドメインコントローラーとの同期

1
Nginx 1.2.2:try_filesを動作させる方法は?
最近nginxをバージョン1.2.2に更新しましたが、次のエントリが壊れているようです。おそらくバージョン間の構文の変更? location / { # First attempt to serve request as file, then # as directory, then fall back to index.html try_files $uri /index.html; } Iブラウザときhttp://www.mysite.com/a-non-existent-urlは、私が「500内部サーバーエラー」エラーページにリダイレクトされます。次のログエントリが作成されます。 2012/08/13 09:20:29 [error] 18457#0: *60 rewrite or internal redirection cycle while internally redirecting to "/index.html", client: 10.0.14.1, server: mysite.com, request: "GET /a-non-existent-url HTTP/1.1", host: …
11 nginx  redirect 

4
ZFSがLinuxとFreeBSD間で一貫していると信頼できますか?
近いうちにFreeNASボックスを構築する予定ですが、Linux上のZFSの信頼性が最終的に証明された場合は、より使い慣れたOSにするために切り替えることができます。 したがって、ZFSのさまざまな実装に互換性があると信頼できるかどうか疑問に思っています。言い換えると、FreeNASからLinuxまたはOpenIndianaにブートディスクを交換するだけで、データに何も悪いことが起こらないことを信頼できますか? これはばかげた質問のように思えるかもしれませんが、明らかに互換性があるはずですが、ドライブをコンピューター間で移動する場合にはZFSは一般的に使用されないので、誰かがより良い答えを提供できることを望んでいますただ「あるべき」。
11 linux  freebsd  zfs  freenas 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.