サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
クックブック間の共有ファイル/テンプレート
同じファイルとテンプレートを参照する複数のクックブックがあり、これらのすべてが同じファイルであることを保証する合理的な方法があるかどうか疑問に思っていました。単一のファイル/テンプレートを複数のレシピ/クックブックで参照することは可能ですか?シンボリックリンクの使用を考えましたが、Gitはシンボリックリンクをサポートしていないため、これは機能しません。
11 automation  chef 


3
RHEL 4で実行されているApache 2.0でのBEASTの脆弱性の修正
RHEL4でApache 2.0を実行しているWebサーバーがあります。このサーバーは最近PCIスキャンに失敗しました。 理由:SSLv3.0 / TLSv1.0プロトコルの脆弱なCBCモードの脆弱性の解決策:この攻撃は、2004年およびそれ以降のTLSプロトコルの修正版で修正されています。可能であれば、TLSv1.1またはTLSv1.2にアップグレードします。TLSv1.1またはTLSv1.2にアップグレードできない場合、CBCモード暗号を無効にすると、脆弱性が削除されます。Apacheで次のSSL構成を使用すると、この脆弱性が緩和されます。SSLCipherSuite RC4-SHA:HIGH:!ADHのSSLHonorCipherOrder 簡単な修正、私は思った。Apache構成に行を追加しましたが、機能しませんでした。どうやら 「SSLHonorCipherOrder On」はApache 2.2以降でのみ動作します。私はApacheをアップグレードしようとしましたが、すぐに依存関係に陥りました。Apache2.2にアップグレードするにはOS全体をアップグレードする必要があるようです。数か月以内にこのサーバーを廃止するため、その価値はありません。 ソリューションは、「TLSv1.1またはTLSv1.2へのアップグレードが不可能な場合、CBCモード暗号を無効にすると脆弱性が削除されます」と述べています。 Apache 2.0でこれを行うにはどうすればよいですか?これも可能ですか?そうでない場合、他の回避策はありますか?
11 apache-2.2  ssl  tls 

1
ASP.NETアプリケーションを自動起動するにはserviceAutoStartProvider属性が必要ですか?
私は、ASP.NET 4.0アプリケーションを自動起動するようにセットアップする方法の例を提供する、ASP.NETアプリケーションの自動起動に関するScott Guthrieの投稿を読んでいます。 <applicationPools> <add name="MyAppWorkerProcess" managedRuntimeVersion="v4.0" startMode="AlwaysRunning" /> </applicationPools> <!--...--> <sites> <site name="MySite" id="1"> <application path="/" serviceAutoStartEnabled="true" serviceAutoStartProvider="PreWarmMyCache" /> </site> </sites> <!--...--> <serviceAutoStartProviders> <add name="PreWarmMyCache" type="PreWarmCache, MyAssembly" /> </serviceAutoStartProviders> 彼の投稿から不明な点は、次の構成がASP.NETアプリケーションを自動起動するかどうかです。 <applicationPools> <add name="MyAppWorkerProcess" managedRuntimeVersion="v4.0" startMode="AlwaysRunning" /> </applicationPools> <!--...--> <sites> <site name="MySite" id="1"> <application path="/" serviceAutoStartEnabled="true" /> </site> </sites> ここでの違いは、起動するように指定されたクラスがないことです。理想的には、アプリケーションがロードされるだけです。サイトのアプリケーションに関するドキュメントは、serviceAutoStartEnabled属性が機能するために属性が必要であることを暗示していますserviceAutoStartProvider。ただし、追加の属性が提供されていない場合に何が起こるかは示されていません。 …



4
ケーブル配線:サーバーアームを通して電源ケーブルとネットワークケーブルを配線できますか?
電源ケーブルがネットワークケーブルに干渉する場合があることを知っています。ケーブルを配線するときは、ネットワークケーブルから電源を分離するのが最適です。 ケーブル管理アーム(下図のような)を使用する場合、ネットワークと電源ケーブルの両方を配線できますか?

1
PCRE制限とは何ですか?
ModSecurityにはPCRE limits exceededエラーがあります。 次のようなルールを設定することでこれを修正できることを知っています。 SecPcreMatchLimit 150000 SecPcreMatchLimitRecursion 150000 しかし、これらのルールは実際に何をしているのでしょうか?PCRE制限再帰が150,000に設定されているとはどういう意味ですか?これらを非常に高く設定することで、どのセキュリティホールを通過できますか?何をしてないrecursionとはlimitどういう意味ですか? ドキュメントがあることは知っていますが、ドキュメントは実際に何が起こっているかを教えてくれません。ディレクティブをどのように扱うかを単に教えてくれます。

2
UbuntuにVarnishモジュールをインストールする方法
Varnish Cache用の追加モジュール、Shield moduleをインストールしたい。 どうやってやるの?UbuntuリポジトリからVarnish 3.0をインストールしました。 モジュールがコンパイルする必要があるVarnishソースを取得するにはどうすればよいですか?Varnishもソースからコンパイルする必要がありますか?これにより、リポジトリを介したVarnishの更新が無効になりますか? 誰かが段階的な指示を与えることができますか?
11 ubuntu  varnish 

4
Windowsで壊れたシンボリックリンクを自動的に見つけるにはどうすればよいですか?
これが悪いスタイルかどうかはわかりませんが、他の場所で答えを見つけることができなかったので、ここでこの質問をしています。他の人の解決策に興味がありますが、数日後に自分の解決策を投稿します。 私の特定のケースでは、Windows 7で実行していますが、Windowsの他の/古いバージョンの回答に興味があります。1つの答えは「Unix findのバージョンをインストールしてから、Unixの場合と同様に解決する」ということですが、もっと「ネイティブ」なソリューションが必要でした。 編集2012-07-17:明確化:「自動的に」とは、ボタンを押すだけですべての作業を行うGUIツールではなく、スクリプトの一部として実行できるものを意味します。これは無人です。

2
drbdをセカンダリに切り替えることができません
私はdrbd83一緒ocfs2に走っていて、彼らと一緒centos 5に使うつもりpackemakerです。しばらくして、私はdrbdスプリットブレインの問題に直面しています。 version: 8.3.13 (api:88/proto:86-96) GIT-hash: 83ca112086600faacab2f157bc5a9324f7bd7f77 build by mockbuild@builder10.centos.org, 2012-05-07 11:56:36 1: cs:StandAlone ro:Primary/Unknown ds:UpToDate/DUnknown r----- ns:0 nr:0 dw:112281991 dr:797551 al:99 bm:6401 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:60 drbdをセカンダリに切り替えることはできません。 drbdadm secondary r0 1: State change failed: (-12) Device is held open by someone Command 'drbdsetup 1 secondary' terminated …

1
ユーザーに完全なログインアクセス権を与えずに、単一のコマンドを許可するようにSSHdを構成するにはどうすればよいですか?
SSH経由でリモートコマンドを呼び出す最適な方法を探しています。ユーザー「rpcall」を作成し、新しい証明書を生成してauthorized_keysに入力します。でもう少し安全に from="ip",no-agent-forwarding,no-X11-forwarding,no-port-forwarding,no-pty ssh-rsa ...... 現在、ユーザーrpcallは端末にログインできません ssh -l rpc 192.168.12.1 PTY allocation request failed on channel 0 しかし、任意のコマンドを実行することは可能です ssh -l rpc 192.168.12.1 cat /etc/passwd コマンドの実行を1つの処理スクリプトのみに制限できるソリューションはありますか?たとえば、/ home / rpcall / bin / command.sh このユーザー用にbashシェルをセットアップし、.bashrc強制実行処理スクリプトを使用しましたが、ssh呼び出しからパラメーターを渡す方法がわかりません。 ユーザーrpcallの.bashrc /home/rpcall/bin/command.sh $params1 $params2 exit 他のマシンからのssh呼び出し ssh -l rpcall 192.168.12.1 "param1" "param2"
11 ssh  remote  exec 

4
グループポリシーとネットワークに関するネットワークログオンの問題
私はあなたの助けと援助を大いに必要としています。 Windows 7 Enterpriseシステムへのログオンと起動に問題があります。キャンパス周辺の約20以上の建物に3000以上のWindowsデスクトップがあります。キャンパスのほぼすべてのコンピューターには、これから説明する問題があります。Windows Performance Analyzer(優れた製品)からのetlファイルと数十万のイベントログを1か月以上ピアリングしました。今日、私はこれを理解することができなかったことに謙虚にあなたに来ます。 ログオン時間を簡単に言えば問題は非常に長いです。平均的な初回ログオンは、インストールされているソフトウェアに応じて約2〜10分です。すべてのコンピューターはWindows 7であり、最も古いコンピューターは5歳です。さまざまなコンピューターでの起動時間は、良好(1〜2分)から非常に悪い(5〜60)の範囲です。2回目のログオンの範囲は30秒から4分です。 ネットワーク上の各コンピューター間にギガビット接続があります。DNSサーバーとしても機能する5つのドメインコントローラーがあります。 最初のテストでは、これがソフトウェアの問題であると考えました。そのため、xperfviewのetlファイルから一貫性のない結果を見つけるためだけに、マシンを数日間テストしました。キャンパス内のコンピューターの各サブセットには、ソフトウェアの問題の異なるサブセットがあり、起動時のログオンを妨げるものはありませんでした。 そこで、グループポリシーを調べ始め、非常に興味深いイベントIDを見つけました。 グループポリシー1129:ドメインコントローラーへのネットワーク接続がないため、グループポリシーの処理に失敗しました。 グループポリシー1055:グループポリシーの処理に失敗しました。Windowsはコンピューター名を解決できませんでした。これは、次のうちの1つ以上が原因である可能性があります。a)現在のドメインコントローラーでの名前解決の失敗。b)Active Directory Replication Latency(別のドメインコントローラーで作成されたアカウントが現在のドメインコントローラーにレプリケートされていません)。 NETLOGON 5719:このコンピューターは、次の理由により、ドメインOURDOMAINのドメインコントローラーとの安全なセッションを設定できませんでした。現在、ログオン要求を処理できるログオンサーバーがありません。これにより、認証の問題が発生する場合があります。このコンピューターがネットワークに接続されていることを確認してください。問題が解決しない場合は、ドメイン管理者に連絡してください。E1kexpress 27:Intel®82567LM-3ギガビットネットワーク接続–ネットワークリンクが切断されています。 NetBT 4300 –ドライバーを作成できませんでした。 WMI 10-エラー0x80041003のため、クエリ "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA" Win32_Processor "AND TargetInstance.LoadPercentage> 99"がネームスペース "//./root/CIMV2"で再アクティブ化できませんでした。問題が修正されるまで、イベントはこのフィルターを介して配信できません。 タイムスタンプが多かれ少なかれ、ネットワークに問題がある可能性があることが明らかになります。 1:25:57-グループポリシーはドメインコントローラー情報を検出しようとしています 1:25:57-ネットワークリンクが切断されました 1:25:58-ドメインコントローラーへのネットワーク接続がないため、グループポリシーの処理に失敗しました。これは一時的な状態である可能性があります。マシンがドメインコントローラーに接続され、グループポリシーが正常に処理されると、成功メッセージが生成されます。数時間成功メッセージが表示されない場合は、管理者に連絡してください。 1:25:58-LDAP呼び出しを行って、Active Directoryに接続およびバインドします。DC1.ourdomain.edu 1:25:58-0ミリ秒後に呼び出しが失敗しました。 1:25:58-ドメインコントローラーの詳細の再検出を強制します。 1:25:58-グループポリシーは1030ミリ秒でドメインコントローラーを検出できませんでした 1:25:58-コンピューターOURDOMAIN \%name%$の定期的なポリシー処理が1秒で失敗しました。 1:25:59-全二重で1Gbpsのネットワークリンクが確立されました …

3
CentOS 6.2を使用したHyperVでのTimesync
HyperVで実行されているCentOS VM(リリース6.2)があります。インテグレーションサービスをインストールし(現在ベースの一部)、CentOSは現在のクロックソースがhyperv_clocksourceであることを示していますが、VMでの私の時間は1週間の稼働後約10分です。新しいICとプラグ可能なクロックソースについての私の理解では、これはもう起こらないはずです。プラグ可能なクロックソースを「機能させる」ために必要な追加の構成はありますか? カーネルオプションをPITなどに設定することに関するリンクがたくさんあることは知っていますが、それらはすべて統合されたクロックソースサポートよりも前のものであるように思われます。ntpdもadjtimexもすべきではありません。 編集:3.2のIC(Centos 6.2で出荷)を実行していたが、今日3.3にアップグレードされ、マシンは1時間22分間稼働し、クロックはすでに5秒速い。だから私は現在、最新のICを実行していますが、それでも同じ問題を抱えています。

2
debian:致命的->フォークに失敗しました
私の人生で初めてこのようなことがあります: root@peklan:~# aptitude install git-core No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used. FATAL -> Failed to fork. 誰かがこのメッセージを取り除く方法を説明できますか?
11 debian  git 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.