サーバー管理者

システムおよびネットワーク管理者向けのQ&A


1
サーバーのadd_headerディレクティブを上書きする場所のadd_headerディレクティブ
使用nginxの1.2.1を私が使用して複数のヘッダを追加することができる午前add_header、次のように: server { listen 80; server_name localhost; root /var/www; add_header Name1 Value1; <=== HERE add_header Name2 Value2; <=== HERE location / { echo "Nginx localhost site"; } } 結果 GET / HTTP/1.1 200 OK Name1: Value1 Name2: Value2 ただし、add_header内部locationでディレクティブを使用するとすぐに、add_header下の他のディレクティブserverは無視されます server { listen 80; server_name localhost; root /var/www; add_header Name1 Value1; …

6
rootパスワードを必要とせずにMySQLトラフコマンドラインに接続する
いくつかのタスクのBashスクリプトを作成しています。これらのタスクの1つは、同じbashスクリプト内からMySQL DBを作成することです。私が今やっていることは、2つの変数を作成することです。1つはストアユーザー名用で、もう1つはストアパスワード用です。これは私のスクリプトの関連部分です: MYSQL_USER=root MYSQL_PASS=mypass_goes_here touch /tmp/$PROY.sql && echo "CREATE DATABASE $DB_NAME;" > /tmp/script.sql mysql --user=$MYSQL_USER --password="$MYSQL_PASS" < /tmp/script.sql rm -rf /tmp/script.sql しかし、パスワードなしでユーザーrootのアクセスが拒否されたことを示すエラーが常に表示されます。PostgreSQLでも同じことをする必要があります。

4
ディスクの縮小がESXiゲストで機能しない
EHLOみんな!StackOverflowネットワークに関する最初の投稿:) ext3パーティションを持つDebian 6 / amd64ゲストシステムを主にホストし、Debian バグ471784open-vm-toolsごとにソースからコンパイルされたESXi 5.0 / vCenterインフラストラクチャを実行しています。 インターネット全体で提起されている問題がありますが、どこにも決定的な答えはありません。 スナップショット、親、クローンをまったく使用せずに、シンプロビジョニングされたディスクを独立永続モードで縮小しようとすると、一貫して次のエラーが表示されます。 root@linux64:~# vmware-toolbox-cmd disk list Shrink disk is disabled for this virtual machine. Shrinking is disabled for linked clones, parents of linked clones, pre-allocated disks, snapshots, or due to other factors. See the User's manual for more information. (ちなみに、「その他の要因」とは何ですか。また、大量のホワイトペーパーと技術マニュアルのうち、ユーザーズマニュアルはどれですか。) パーティションにゼロを詰め込んで(実際、shred …

1
MariaDBとPerconaサーバー-主な違いは?
今日、本番環境でMysqlを実行していますが、新しいサーバーに移動するときにMariaDBまたはPerconaサーバーに切り替える予定です。この切り替えの主な理由は、Oracleから距離を置くことですが、パフォーマンスと新機能を向上させるためでもあります。 PerconaサーバーとMariaDBはかなり似ているように見えますが、お互いのソリューションを促進しています。それらの主な違いは何ですか?
11 mariadb  percona 

1
LinuxでPCIeレーンを見つける
PCIe(ver 2)Linuxシステムがあります。ネゴシエートされ、デバイスとホストコントローラーの間で使用されているPCIeレーンの数を確認したいと思います。(デバイスがサポートするレーンの数、またはスロットに含まれるレーンの数はわかりません)
11 linux  pci  pci-express 

1
旅客ログはどこに行きますか?
Apache / Passengerを使用してCentOSで実行しているRailsアプリケーションがあり、少し問題があります。Railsアプリケーションのログがありません。何が欠けていますか? これは私のApache confです: <VirtualHost *:80> ServerAdmin info@domain.com ServerName domain.com ServerAlias www.domain.com Include /home/ftpanel/conf/alias/domain.com.alias DocumentRoot /home/mgimmo/public_html/immo/public/ #Configuration PHP FastCgiExternalServer /home/mgimmo/ftpanel-config/php5.fpm -socket /home/ftpanel/conf/sock/mgimmo.sock Alias /ftpanel-config/ /home/mgimmo/ftpanel-config/ <Directory /home/mgimmo/public_html/immo/public/> Options -Indexes FollowSymLinks -MultiViews AllowOverride All </Directory> ServerSignature Off

1
複雑なプロセス名のpgrep / pidofの使用法?
私はpidofまたはpgrepを使用して、システムのプロセスにHUPを送信しようとしています。問題は、正確なパラメーターでプロセスを強制終了したいだけだということです。 これは「ps awx」の出力です 657 ? S 0:00 processname software 658 ? S 0:00 processname demo 659 ? S 0:00 processname test これらのいずれかを実行することにより: pidof processname pgrep processname プロセス名で始まるすべてのプロセスのリストを取得しますが、次のようなことをしたいです: pidof processname test pgrep processname test 必要なPIDのみを取得するには(この例では659になります) 更新 pgrepで-fフラグを使用することにより、次の操作を行うことで、私が望んでいたことを実行できます。 pgrep -f "processname test" 正しい答えが得られます。

3
Windows展開サービス用のリモート管理コンソール
PXEとWDSを介して新しいマシンを展開するたびに、リモートデスクトップを介してSever 2008 R2 WDSサーバーにログオンしてマシンを承認する必要があります。 これは煩わしいことであり、誰もが知っているはずですが、可能な限りサーバーへのログオンを避ける必要があります。 ただし、私のgoogle-fuのすべてが失敗しており、リモートマシンからWDSを管理するためのMMCコンソールへの参照が見つかりません。RSATモジュールにも存在しません。 それで、そのようなものは存在しますか?私はそれが好きではありませんが、必要に応じて元のサーバーからコンソールを実行するために必要なファイルを抽出することで解決します(このようなものですが、完全に必要な場合を除き、これを行いたくありません。文書化の苦痛)。 クライアントマシンはすべてWindows 7 SP1です
11 windows-7  wds  windows 

2
Gitがhttpを介してプッシュし(git-http-backendを使用)、Apacheが機能しない
私はgit-http-backendを使用して "smart-http"モードでgitのプッシュを必死にしようとしていました。しかし、何時間もテストとトラブルシューティングを行った後、私はまだ残っています error: Cannot access URL http://localhost/git/hello.git/, return code 22 fatal: git-http-push failed` Ubuntu(12.04)、Apache2(2.2.22)、Git(1.7.9.5)の最新バージョンを使用しており、インターネット上にあるさまざまなチュートリアル(http://www.parallelsymmetry.com/howto/gitなど)に従っています。 .jspという。 現在、私のVHostファイルは次のようになっています。 <VirtualHost *:80> SetEnv GIT_PROJECT_ROOT /var/www/git SetEnv GIT_HTTP_EXPORT_ALL SetEnv REMOTE_USER=$REDIRECT_REMOTE_USER DocumentRoot /var/www/git ScriptAliasMatch \ "(?x)^/(.*?)\.git/(HEAD | \ info/refs | \ objects/info/[^/]+ | \ git-(upload|receive)-pack)$" \ /usr/lib/git-core/git-http-backend/$1/$2 <Directory /var/www/git> Options +ExecCGI +SymLinksIfOwnerMatch -MultiViews AllowOverride None Order …
11 apache-2.2  ubuntu  http  git 

3
サーバー上のgitリポジトリを暗号化する(物理ハードウェアの盗難に対して安全)
私は、Gitリポジトリと、このリポジトリの作業用コピーを備えたクライアントコンピューターを備えた運用サーバー(24時間年中無休のUbuntu)を所有しています。クライアントコンピューターでは、ホームフォルダーの暗号化を使用するだけで、ハードウェアが盗まれた場合にgitのファイルに誰もアクセスできないという問題を解決できるようです。 盗まれたハードウェアの場合に誰もgitリポジトリを再構成および複製できないように、gitリポジトリのリモート側を暗号化するにはどうすればよいですか? 最初はgitユーザーのホームディレクトリを暗号化することを考えましたが、いつ、誰によって復号化する必要があるのか​​、これは意味をなさないことに気付きました。 gitリポジトリを自分のホームディレクトリ/リンクに配置して、SSH経由でサーバーにログインしたときにのみ使用できるようにできますか?または、この問題に同様の解決策がありますか? 事前にヒントをありがとう!
11 ubuntu  git  encryption 

1
単一のマシンへのペアではなく、複数のマシン用の1つのsshキーファイル?
現在、サーバーへのキーペアログインを次のように実装しています。 ローカルラップトップからキーペアを生成します。 me@macbook:~ $ ssh-keygen -t rsa パブキーをラップトップからサーバーに転送します。 me@macbook:$ scp ~/.ssh/id_rsa.pub user@myserver.com:~/id_rsa.pub サーバーで、pub_keyをauthorized_keysファイルに追加します $ cat id_rsa.pub >> ~/.ssh/authorized_keys そして、sshのパスワードログインを無効にしました。 問題は、キーが私のラップトップで使用できるのはサーバーでsshするためだけであり、Macbookラップトップにバインドされているように見えることです。つまり、別のコンピューターを使用している場合、その秘密鍵をsshに使用することはできません。最悪の場合、ラップトップを紛失した場合、ロックされ、sshでログインすることはできません。(間違っている場合は修正してください。混乱します) 秘密鍵を複数のマシンで使用できるようにするにはどうすればよいですか?(AWS ec2のように、どこでも.pemファイルを使用してsshすることができます) ありがとう。 以下はauthorized_keysファイルの内容です
11 ssh-keys 

1
仮想ホストごとのログファイルに書き込むようにNGINX経由でPHP-FPMを構成する方法
Fedora 16にはNginxとPHP-FPMがあります。すべてが非常にうまく機能しています。PHPの通知、警告、エラーなどのログはすべてにあり/var/log/php-fpm/www-error.logます。 Nginxのエラーログとして設定された適切なログファイルにエラーを書き込むようにPHP-FPMを設定する方法はありますか?そのため、1つのグローバルファイルではなく、仮想ホストごとに PHPエラーを記録します。(Apache HttpdやPHPなど)。
11 linux  nginx  logging  php-fpm 

2
SSL終了ロードバランサーの背後にあるEC2インスタンスでのSSLリダイレクト
WebアプリケーションですべてのURLをhttpsにリダイレクトしようとしています。 エラスティックロードバランサーの背後にec2インスタンスがあります。SSLはロードバランサーで終了します。 リダイレクトを試みると、なじみのある「このページは決して完了しない方法で要求しています」という結果になります。 ロードバランサーは、443と80をインスタンスのポート80に転送します。 これが私の.htaccessにあるものです。 RewriteCond %{X-FORWARDED-PROTO} !=on RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] 誰もこれを達成する方法を知っていますか?どうもありがとう、

4
Debian SqueezeでIPtables TRACEターゲットを有効にする方法(6)
IPtablesのTRACEターゲットを使用しようとしていますが、トレース情報をログに記録できないようです。ここで説明されているものを使用したい: Debugger for Iptables。 TRACEのiptables男から: This target marks packes so that the kernel will log every rule which match the packets as those traverse the tables, chains, rules. (The ipt_LOG or ip6t_LOG module is required for the logging.) The packets are logged with the string prefix: "TRACE: tablename:chain- name:type:rulenum " …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.