サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
Nginx + PHP-FPMは、致命的なエラーの代わりに502の悪いゲートウェイを生成しますか?
現在、NginxとPHP-FPMでSymfony2をテストしています。Xdebugも使用します。 Symfony2にはデモバンドルが付属しています。Acme/ Demoバンドルに構文エラーを作成して、Symfony 2.2.0に付属する致命的なエラーの新しい処理をテストしたかったのです。なぜそうするのか、サーバーの応答は502の悪いゲートウェイです。 しかし、ファイルapp_dev.phpで構文エラーを作成すると(フレームワークが起動する前に)、Xdebugは致命的なエラーについて通知します。 そして驚くべきことに、そのタイプミスを修正し、Acme / Demoバンドルで構文エラーを再作成すると、Symfonyエラーハンドラーが期待どおりに表示されます。そして最後に、すべてのタイプミス(ページが機能する)を修正し、その同じタイプミス(Acme / Bundleでも同様)を再度作成すると、悪いゲートウェイになります。 これについて何か手がかりはありますか?
11 php  nginx  php-fpm  xdebug  symfony 

1
典型的な組み立てられたコンピューターの衝撃定格/ g力負荷とは何ですか?
TLDR:保険の目的で、出荷された組み立て済みコンピューターの受取人に、ショックウォッチラベルを介してコンポーネントに損傷がある可能性があることを警告します。 どのGフォース評価を使用する必要がありますか? 粗い取り扱いにより、内部コンポーネント(特にGPUがマザーボードからPCI-Eスロットを外している)が損傷しているため、標準出荷サービスで組み立てられたコンピューターを移動する際に問題が発生しています。配送業者に梱包の外側の層を提供しても、助けにはなりませんでした。 保険では、開梱プロセスを文書化する必要がありますが、パッケージを開けずに文書化が必要になることを伝えるのは困難な場合があるため、外部のパッケージにショックウォッチラベルを貼って受取人に警告します。 ただし、どの評価を使用すべきかは明確ではありません。これを自分で判断するための機器がありません(実験的に判断するために数千ドル相当のハードウェアを破壊したいという欲求もありません)。キャリアは、明らかに、最大落下高さなどについては一切主張しておらず、これまでのところ、私たちがオンラインで見つけた唯一の衝撃評価情報は、ドライブ(これまで損傷を受けていない)専用です。 衝撃の定格について非常に正確である必要はありません。損傷の原因となるほとんどの滴をキャッチするのに十分なだけ低く、出荷されたすべてのマシンでトリガーされないほど高い必要があります。また、ショックウォッチのラベル​​が存在することで、パッケージのキャバリアー扱いが少なくなることを期待しています。 明らかに、損傷の可能性を減らすためにパッケージを繰り返し処理しています。 Shockwatchの営業担当者に状況を説明した後、彼は50ポンドのパッケージの通常の取り扱いにより毎回25Gがトリガーされると述べ、50Gラベルを提案しました。

3
不規則なインターネットの中断:特定の画像とJSが読み込まれない
ServerFaultを初めて使用しましたが、ちょっとした難問があります。 数か月前から、インターネット接続に問題がありました。 環境: Servers: 2 Terminal Servers as an RDSFarm running Windows Server 2008 R2 Browser: Internet Explorer 9 Test/debug browser: Chrome AntiVirus: Avast 7.0.1455 問題: 不規則な間隔で、Webサイトは読み込みを拒否し、ページにアクセスできない、または一部の画像が完全に読み込まれないというエラーを表示します。また、検査後、サーバーの.jsファイルのロードに失敗します。 調査結果と試したこと: 第一印象: その間隔でChromeを使用すると、サイトを更新すると、net :: Error 101またはError 103が返されます。また、エラーが発生していない場合、いくつかの画像が表示されず、X画像が表示されます。IEは、ページを表示できないとだけ言っています。 Chrome開発者ツールの使用: いくつかのリソースが利用できないことがコンソールに表示されますが、不足している画像を右クリックして「画像を表示」を選択すると表示されます。直接URLで写真を開くと、それらも表示されます。 Chrome開発者ツールによる監査: ページがバグのある状態であるときにページで監査を実行したところ、いくつかの.jsファイルがいくつかの.png、.jpg、および.gifファイルとともにロードされなかったことがわかりました。ChromeとIEでは異なる画像が読み込まれます。 難読化されたJSファイルとアバスト: それを確認した後、それらの.jsファイルのほとんどが難読化されたJSファイルであることがわかりました。Avast7.0.1455を実行しているので、Webシールドが混乱しないかどうか疑問に思いました。 繰り返しますが、それは最初のTSでのみ発生し、2番目のTSでは発生しません。 そこで、私は1日間WebShieldをオフにし、改善が見られるかどうかを確認しました。しませんでした。振り出しに戻って。 ファイルのキャッシュ有効期限なし: ロードされていないファイルのいくつかは、キャッシュの有効期限がないことが示されました。 キャッシング: システム管理者の1人がIEキャッシュサイズを10MBに変更しましたが、これが問題の原因であると考えられました。彼はそれを65MB程度に戻しましたが、それでも人々は自分の画像で問題に直面します。また、1つのTSでもChromeでも発生するため、グループポリシーがキャッシュがChromeに影響を与えるとは思わないでしょうか? ネットワークの問題: ネットワークまたはルーティングの問題の可能性も考えましたが、TSサーバーは両方とも同じチーム化されたNIC上にあり、もう一方は正常に機能しています。 助けて! 誰かが問題を探す場所についてのヒントを持っている場合、または詳細情報が必要な場合は、私を助けてください。これは今や数週間私を悩ませています。 …

3
レート制限時に429 httpコードを返すようにnginxを設定するにはどうすればよいですか?
スロットル/レート制限時にデフォルトの503(サービス利用不可)の代わりにhttpステータスコード429(Too Many Requests)を返すようにnginxを設定するにはどうすればよいですか? 参考までに、HttpLimitReqModuleでリバースプロキシとしてnginxを使用しています。429ステータスコードのドラフト仕様はRFC6585です。 stackexchanged に関するこの(閉じた)質問は、error_pageディレクティブを使用できることを示しています。ただし、実際にサーバーの問題があり(顧客が私たちに過度に当たらない)、サーバーが503 Service Unavailableを返す必要がある場合、429を返したくありません。 助言がありますか?

4
リモートデスクトップセッションからのリモートアシスタンス:制御できません
リモートコントロール(別名セッションシャドーイング)はServer 2012リモートデスクトップセッションホストで完全になくなっているため、クロスドメイン環境のユーザーをサポートするための代替品を探しています。 リモートアシスタンスはリモートデスクトップセッションでも機能すると想定されているため、グループポリシーを介してすべてのリモートデスクトップセッションホストに対して一方的なリモートアシスタンスを有効にすることで、サポート目的で活用しました。 リモートデスクトップセッション自体からリモートアシスタンスセッションが開始されたときに、「エキスパート」が実際にマウスまたはキーボードの制御を実行できないように見えることを除いて、すべてがうまく機能しているようです。「エキスパート」セッション(Server 2012)からのマウスクリックとキーボードストロークは、アシストされたユーザーが制御要求を承認した後でも、単に無視されるようです。 いくつかの理由により、サポートスタッフのRDセッションを通じてこれが機能することを確認したいと思います。 すべてのサポートエージェントが特定のターミナルサーバー上のユーザーをサポートする適切なクライアントシステムバージョンを持っているわけではありません(たとえば、エージェントにWindows VistaまたはWindows 7ステーションがあり、Server 2012 RDSH上のユーザーに支援を提供できない場合があります) サポートエージェントは、特定の宛先ドメインのメンバーであるステーションを必ずしも持つ必要はありません(主に、複数のドメインのユーザーがサポートされているため) 私は何が欠けていますか?

5
Salt(Saltstack)は、Graphite、Ganglia、またはZenossのデータを収集して中継できますか?
新しいプロジェクトを開始し、AnsibleまたはSaltを使用して展開の自動化を検討しています。おそらく、より洗練されたオーケストレーション(サーバー管理とフェデレーション)を検討しています。 Saltを使用する場合、Salt 0mq接続を使用して、Saltの「ミニオン」からMonitoring / Graphingデータベース/コレクターにデータを中継するために、Salt 0mq接続を使用して、SiteとGraphite、Zenoss、またはGangliaの間に統合があるかどうか疑問に思っています。 他の誰かがこれを見ましたか?

1
Amazon Ec2 Elastic IP-アウトバウンドIP?
Amazon EC2インスタンスでエラスティックIPを使用して一種のプロキシを作成しようとしています。私の質問は、エラスティックIPをAmazonインスタンスに関連付けてから、EC2インスタンスからサーバー、たとえばwww.yahoo.comへのアウトバウンド接続を確立することです。 www.yahoo.comに表示されるIPアドレス、元のAmazon EC2サーバーIP、またはそれに関連付けられているエラスティックIP。 これが基本的な質問であれば申し訳ありませんが、これは私にとってすべて新しいものです。

2
IOATは有効ですが、Linuxで使用されていませんか?
igbバージョン4.1.2を搭載したR610では、ioatdmaモジュールがロードされています(lsmodでロードされています)。 ioatdma: Intel(R) QuickData Technology Driver 4.00 ioatdma 0000:00:16.0: irq 80 for MSI/MSI-X ioatdma 0000:00:16.1: irq 81 for MSI/MSI-X ioatdma 0000:00:16.2: irq 82 for MSI/MSI-X ioatdma 0000:00:16.3: irq 83 for MSI/MSI-X ioatdma 0000:00:16.4: irq 84 for MSI/MSI-X ioatdma 0000:00:16.5: irq 85 for MSI/MSI-X ioatdma 0000:00:16.6: irq 86 for MSI/MSI-X ioatdma …

2
スパム送信者は、Googleアプリドメイン(DKIMさえも!)でメールを偽装しました。
私は最近多くの反発を受けています。 Googleアプリアカウントが侵害されたと思ったが、アプリアカウントにアクティビティはなく、悪意のあるユーザーが確認できることはありません。 電子メールは常にランダムなユーザー名(onSecNtV1@mydomain.comなど)から送信されるため、未登録ユーザーからの電子メールの送信を禁止する方法を見つけようとしました。何も見つかりませんでした。 心配なのは、メッセージにX-Google-DKIM-Signatureがあり、「Googleがメッセージを配信しようとしました」ということです。これは、信頼できるクライアントから送信された電子メールを意味しますか?(Gmailのみを使用) AFAIKスパマーは電子メールのあらゆるフィールドを自由に偽装できますが、DKIMは(現代の)サーバーにこれらの検証不可能な電子メールをドロップさせるべきです。 リークがどこにあるか考えていますか? バウンスバックの例を次に示します。 Delivery to the following recipient failed permanently: spoonbillzi7@etisbew.com Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the server for the recipient domain 174.133.125.2 [174.133.125.2]. The error that the other server returned was: 553 sorry, that …

8
ウェブサーバーがフリーズせずに非常に大きなファイルを削除する
私のWebサーバー(Apacheが実行されているLinux CentOS)には、非常に大きなログファイル(50 Gbyte)があります。このWebサーバーには、運用中のWebサービスがいくつかあります。 ログファイルを削除しようとしたときに、Webサーバーから約10秒の応答がありませんでした。(サービス停止時間。) rm -f monthly.log Apacheフリーズせずにこの大きなファイルを削除する方法はありますか?

2
サーバー負荷が高い-[jbd2 / md1-8] 99.99%IOを使用
先週、負荷が急上昇しています。これは通常、1日に1回または2回発生します。[jbd2 / md1-8]が99.99%のIOを使用していることをiotopから特定できました。高負荷時には、サーバーへの高トラフィックはありません。 サーバーの仕様は次のとおりです。 AMD Opteron 8コア 16 GB RAM 2x2.000 GB 7.200 RPM HDDソフトウェアレイド1 Cloudlinux + Cpanel MySQLは適切に調整されています スパイクは別として、負荷は通常最大で約0.80です。 私はあちこち検索しましたが、[jbd2 / md1-8]が正確に行うことを見つけることができません。誰かがこの問題を抱えていたり、可能な解決策を知っていますか? ありがとうございました。 更新: TIME TID PRIO USER DISK READ DISK WRITE SWAPIN IO COMMAND 16:05:36 399 be/3 root 0.00 B/s 38.76 K/s 0.00 % 99.99 % [jbd2/md1-8]

5
/ etc / fstab設定を復元または再読み込みする簡単な方法は?
私は/etc/fstabRHEL 6.xベースのサーバー上の複合施設で作業しています。システムには、複数のバインドマウントを含む、8つのパーティションで使用されるさまざまなマウントオプションがあります。作業中の画像に対するオプションとその効果をテストしています。 例えばオプションが好きnodev、nosuid、noexec、nobarrierおよびいくつかのXFSファイルシステムのパラメータが所定の位置にあります。 特定のオプションで再マウントすることは可能ですが、すべてのマウントをハードコーディングされた永続的な設定に戻す簡単な方法はあります/etc/fstabか? たとえばsysctl -p、/etc/sysctl.conf値をロードして適用します。mount同等のものはありますか? 編集: 設定例: # # /etc/fstab # UUID=e6ca80cd / ext4 noatime,nobarrier 1 1 UUID=a327d315 /boot ext4 defaults 1 2 UUID=333ada18 /home ext4 noatime,nobarrier,nodev 1 2 UUID=7835718b /tmp ext4 nodev,nosuid,noexec 1 2 UUID=4dd2e9d4 /usr ext4 defaults 1 2 UUID=c274f65f /var ext4 noatime,nobarrier 1 2 UUID=5b5941e0 /var/log …
11 linux  redhat  mount 

2
Outlook Email Abuse-メールのエチケットのガイド?
ITにほとんど注力していないか、一般的な問題を処理するフルタイムのスタッフがいない企業のために、メールの移行に多くの時間を費やしました。その結果、電子メールの使用と最高のプロセスを管理するポリシーは制定されませんでした。これらの環境のエンドユーザーは技術的ではなく、変化に抵抗する傾向があります。 メールプラットフォームの変更/移動/アップグレードの仕組みを理解しています。ほとんどの場合、LinuxベースのPOP3またはIMAPからMicrosoft Exchangeへの移行を支援します。このタイプの動きは、多くのユーザーの悪い習慣を明らかにします。 私の懸念は、私が過去に遭遇した電子メールの蓄積問題に関係するディスク容量だけではありません。すべての会社に常に1つあります。特定の会社と仕事をしているときによく見られる問題や悪用についてです。 最後の移行中に、私は見た: CC:すべてのメールで自分自身を使用しているユーザー(おそらく、メッセージスレッドを追跡する方法として?) 300メガバイトのメッセージで送信されたアイテムフォルダ?!? Outlookを送信するユーザーは、すべての送信メッセージの領収書を読みます。 対応するすべての連絡先のサブフォルダーを保持するユーザー。時々手動で。時には非常に壊れたクライアント側のルールがあります。 サブフォルダーの過剰編成。(メッセージが1つしかないフォルダもあります)。 受信トレイの下のサブフォルダー(これが悪い習慣かどうかはわかりませんが、間違っているように感じます)。 優先フラグの無償使用。すべてが 重要です!! [ 送信済みアイテム ]フォルダーにある4年以上の電子メール。 受信ボックス内の25,000以上のアイテム(それらの大部分は未読)。 15,000以上のメッセージで削除済みアイテムフォルダ。 下書きフォルダに24,000個のアイテムがあるユーザー!(クライアント側のルールを誤って適用した結果)。 自動アーカイブは制御不能になります。 これはどのように起こりますか? メールは比較的新しく、ユーザーはそれをうまく利用する方法について教育されていないのでしょうか? 削除済みアイテムフォルダーが単なるワンキーファイリングシステムであるUIの問題ですか? 管理者は、正しい行動をやさしく助けるために自分の役割を果たしていませんか? ユーザーが基本的な電子メールに問題がある場合、不在時の返信やグループカレンダー(gulp)の操作方法を教えるという課題に取り組むにはどうすればよいですか? 私の質問は、電子メールを管理する方法に関するガイドラインの標準セットがあるかどうかです。(パンフレットでも?) ユーザー教育の問題は、さまざまな方法で人々が到達したワークフローを変更しているため、これらの展開が遅くなる傾向があります。そして、これが組織のすべてのレベル/役割の人々に影響を与える場合、標準が整っていないようです。

4
/ runのスペースが少ない
Ubuntu Preciseでは、/ runのスペースが不足しています: admin@foo:~$ df -h Filesystem Size Used Avail Use% Mounted on /dev/sda1 19G 6.6G 12G 38% / udev 10M 8.0K 10M 1% /dev none 50M 40M 11M 79% /run none 5.0M 0 5.0M 0% /run/lock none 249M 0 249M 0% /run/shm もっと割り当てる必要がありますか?どうやって? 編集:ここに私のfstabがあります: admin@foo:~$ cat /etc/fstab proc /proc …

2
Apache / httpdが起動時に自動的に起動しない
Amazon Linux AMIリリース2012.03にapache2をインストールしています。を使用してエラーを発生させることなく、手動で正常に起動でき/etc/init.d/httpd startます。ただし、マシンの起動時に自動的には起動しません。 rc * .dディレクトリですべてが適切に設定されているようです。結果はfind /etc/rc.d -name "*httpd*" | xargs ls -l次のとおりです。 -rwxr-xr-x 1 root root 3371 Feb 16 2012 /etc/rc.d/init.d/httpd lrwxrwxrwx 1 root root 15 Apr 14 2012 /etc/rc.d/rc0.d/K15httpd -> ../init.d/httpd lrwxrwxrwx 1 root root 15 Apr 14 2012 /etc/rc.d/rc1.d/K15httpd -> ../init.d/httpd lrwxrwxrwx 1 root root 15 …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.