サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
apt-checkが私の記憶をすべて食うのを防ぐ
512MB RAMのサーバーを搭載したUbuntu 12.04 LTSでは、apt-check最大250個のメモリを使用しているため、毎晩システムが使用できなくなります。 ps ax | grep apt 14895 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check --human-readable 14896 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check --human-readable 14899 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check --human-readable 14902 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check --human-readable 14906 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check --human-readable 14912 ? DN 0:02 /usr/bin/python /usr/lib/update-notifier/apt-check …

2
誰かが私のサーバーにrootとしてログインしたときの対処
logcheckがインストールされたDebian 6.0を実行しているサーバーがあります。昨日、私はこのメッセージを受け取りました: Jan 19 19:15:10 hostname sshd[28397]: Authentication tried for root with correct key but not from a permitted host (host=4.red-2-140-77.dynamicip.rima-tde.net, ip=2.140.77.4). これが誰なのかわかりませんが、彼が偶然そこにいたのではないかと思います。 さて、どうすればいいですか? 最初にしたことは、sshパスワード認証を無効にして、公開/秘密キーに切り替えたことです。また、authorized_keysファイルを確認し、公開鍵のみを見ました 次は何? 他の人が私のマシンで何をしたかを知るにはどうすればよいですか?

5
NTPがリモートサーバーではなくローカルに同期するのはなぜですか?
そのため、現在のNTPセットアップをデバッグしようとしていますが、単一の構成済みサーバーからのオフセットが3秒を超えており、調整できないことがわかりました。ntpq出力のLOCAL(0)のアスタリスクは、システムが10.130.33.201サーバー(すべてを同期するシステム上の別のlinuxボックス)ではなく、システム自体とうまく同期していることを示しているようです。 ntpq -p remote refid st t when poll reach delay offset jitter ============================================================================== 10.130.33.201 LOCAL(0) 9 u 49 64 377 0.242 -3742.2 1.049 *LOCAL(0) .LOCL. 10 l 2 64 377 0.000 0.000 0.001 そして、これは私のntp.confファイルです。他の誰かによって書かれたので、私はすべてが正しいと100%確信していません。 server 10.130.33.201 burst iburst minpoll 4 maxpoll 11 driftfile /mnt/active/etc/ntp.drift restrict -4 default nomodify nopeer …
11 ntp  ntpd 

1
指示対象が存在しない場合でも、rsyncにシンボリックリンクをコピーさせる
私はrsyncでこのメッセージを受け取っています: symlink has no referent: "/a/path" まあ、rsyncは正しいです:ソースファイルシステムでは、(シンボリック)リンクは存在しない場所を指しています。それは意図されています。リンクのターゲットは、宛先ファイルシステムにのみ存在します。そして、rsyncがその事実を無視し、宛先にシンボリックリンクを作成するようにします。 rsyncにそれを強制するにはどうすればよいですか?

3
Windows Server 2012でtsconfig / tsadminをローカルで使用する
私は以前のWindowsバージョンに慣れていtsconfig.mscてtsadmin.msc(別名ターミナルサービス管理 / ターミナルサービス管理 MMCスナップイン)、したがってドキュメント(Hyper-Vは要件として?ターミナルサーバーでHyper-Vが必要になるのはなぜですか?!)。 Server 2012では、それらは永久になくなっているようです。ローカルに戻す方法はありますか?Server 2008 R2マシンからのリモート接続は両方のコンソールを使用して機能しているように見えますが、Server 2012 Remote Desktopロールホルダーでもローカルに実行することを希望します。

1
BIND9:フォワーダーに優先順位はありますか?
BIND9-Serverをセットアップするだけで、今のところうまく機能しています。DNSの機能に少しの仕掛けを統合することにしました。ISPのDNSサーバーによって* .comや* .netなどのIANA準拠ドメインを解決したいのですが、OpenNIC-DNS-Serverを使用して.geekや.projectなどのOpenNICドメインを統合したいフォワーダー。したがって、フォワーダーセクションは基本的に次のようになります。 forwarders { IP.OF.ISP.DNS; IP.OF.OPENNIC.DNS; } OpenNIC-DNSはIANAドメインを解決できるという事実にもかかわらず、paypal.comやebay.comのような重要なドメインをハイジャックするのは簡単すぎるため、それらを信頼したくありません。Bind9は、(最初​​のIPから最後のIPまで)順を追ってフォワーダーのレコードを要求していますか、それとも任意に要求していますか?ドメインを解決する際には、ISPのDNSが最優先事項であることを確認したいと思います。 DNSサーバーでDNSクエリを直接「デバッグ」して、要求されたドメインを検索するために使用するサーバーを確認する方法はありますか?

2
SDカードの破損防止
私の組み込みLinuxデバイスは、特定の診断データを保存するためにSDカードを使用しますが、内部フラッシュにはあまりにも多すぎます。 問題は、デバイスの電源が予期せずオフになった場合、カードのファイルシステム(FAT32)が破損することです。 予期しない停電やユーザーがそのように電源を切ることを防ぐ方法はなく、デバイスは比較的メンテナンスフリーである必要があります。さらに悪いことに、データは継続的に書き込まれるため、破損は非常に頻繁に発生し、Linuxは障害のあるFSを検出すると、読み取り専用でサイレントに再マウントします。 これを軽減するためにどのような方法を提案しますか?起動時にfsck.vfatを自動的に実行するだけで十分ですか? 詳細情報: ユーザーがカードを取り外し可能と見なさないでください。それは内部ディスクと考える必要があります。その上に保存されたデータはすべて、ネットワーク経由またはusbドライブ経由でダウンロードできるようになり、システムは自動的に最も古いエントリを削除します。つまり、平均的なPCで読み取る必要はありません。 システムは現在、FAT、yaffs、jffs2をサポートしています。カーネルに他のファイルシステムを追加することは可能ですが、他の手段が存在する場合は、最初にそれらを優先します。 書き込みは、データ損失なしで数分間でもオンデマンドで中断できます。 部分的なデータ損失または軽微な破損は許容されます。ロギングの完全な停止はそうではありません。 ほとんどの場合、電源オフイベントは完全に予測不能です。 システムはARM9、200MHZ、64MB RAM、32MBの内部フラッシュで実行されており、主な役割のためにCPUパワーのほとんどを使い果たします。凝ったリソースを大量に使用するソリューションを検討する際には、これを考慮してください。

1
「rm」でimapサーバー上のメールを削除しても安全ですか?
dovecot IMAPサーバーを使用しており、大きな不要なメールを削除したい: cd /var/spool/foouser; du -a | sort -rn > /var/tmp/du-mail-foouser.log 今、私は上部に大きなメールを見て、それらを見た後、それらを削除したい。 ただ電話しても安全ですか "rm ./foofolder/1318412893.M857530P4656.hz1,W=14463815,S=14268320:2,S"?
11 dovecot  imap  maildir 

2
Linuxでntpdateとntpdがクロックの同期に失敗する
サーバーの1つに奇妙な問題があります。 ntpd動作しntpdateませんが、デバッグではエラーはまったく表示されません。最初は、ローカルまたはネットワークファイアウォールがUDPポート123をブロックしているのではないかと考えましたが、そうではありません。このサーバーはUDPポート123(ntpプロトコル)をインターネットに接続して回答を得ることができます。 問題を実証させてください。 date -s "30 DEC 2012 02:30:00" -動作するため、エラーなしで正常にクロックを設定できます。 ntpq -pn pool.ntp.org -動作します。タイムサーバーから詳細な時間データを取得し、UDPパケットが機能していることを証明します。 ntpdate -d pool.ntp.org -デバッグモードが機能し、大量のデバッグデータと現在の時間オフセットが表示されます。 30 Dec 02:38:56 ntpdate[19267]: step time server 208.97.140.69 offset 228.234554 sec 次の状態になるまで、すべて正常に見えます。 ntpdate pool.ntp.org-4.7秒の休止後、次のように戻ります。 30 Dec 02:41:29 ntpdate[19274]: no server suitable for synchronization found 実行中の同様の問題ntpdは、クロックを更新しません。 ntpdが開始されるとntpq -pn、すべてのrefidが永久にスタック.INIT.することになり、同期できなくなります。 / var / lib / …
11 ntp  ntpd  ntpdate 

2
BINDネームサーバーとのパケットキューパフォーマンスの不一致
バックグラウンド: 一貫性のないリングバッファー設定(eth0の場合は1020、eth1の場合は255)が一貫していない大容量キャッシングネームサーバー環境(Redhat Enterprise Linux 5.8、IBM System x3550)を継承しました。eth0はそのローカルデータセンターのスイッチ1に接続され、eth1は同じデータセンターのスイッチ2に接続されます。クラスター内のすべてのサーバーは、eth0またはeth1がアクティブなインターフェースであるかどうかを交互に切り替え、すべてのクラスターは異なるリージョンに配置されます。リングバッファは明らかに一貫性を保つ必要があります。 ISCナレッジベースがアウトバウンド輻輳に関連していると示唆している「エラー送信応答:設定解除」エラーを多くのネームサーバーが頻繁に記録している理由を調査したときに、上記の問題を発見しました。高いリングバッファ設定(1020)のサーバーは、ifconfigでドロップするパケットは(予想どおり)少なくなりますが、上記のエラーをログに記録する傾向があります。これを「グループ1」と呼びます。リングバッファ(255)の設定が低いサーバーは、1日あたりの受信パケットを大幅にドロップしますが(予想どおり)、BINDエラーのインスタンスははるかに少なく、通常は同じ負荷グループで0〜150です。 ここでも大きな謎ではありません。DNSのキャッシュは再帰的なサービスです。何かがキャッシュされない場合、サーバーはその1つの質問に代わって最終的に回答を返すまで複数のクエリを作成する必要があります。これは、(1つの入力)->(多くの出力)クエリ関係です。RXリングバッファーを修正すると、この数値がボード全体で新しい値に等しくなり、そこからproc(wmem_max / wmem_default)でカーネルの送信ネットワークキューを調整することをお勧めします。 パフォーマンスの問題に対する構成変更の影響を測定できるのが好きなので、実稼働環境の変更を開始する前にいくつかのデータを収集するレポートを作成しました。以下は、グループ1の最初の2台のサーバーの出力例です。 group1-01 RX: 7166.27/sec av. TX: 7432.57/sec av. RXDROP: 7.43/sec av. unset_err: 27633 group1-02 RX: 7137.37/sec av. TX: 7398.50/sec av. RXDROP: 9.94/sec av. unset_err: 107 これらは式です。これはローカルスクリプトであり、サーバーごとに維持する必要があるシェルスクリプトに依存しないことに注意してください。 RXPACK=$(ssh $server "sar -n DEV -f /var/log/sa/sa$(date --date=yesterday '+%d') | grep \"Average: .*\$(awk …

2
KVMゲストとホスト間のジャンボフレーム?
KVMゲストとホストシステム間のストレージ通信用に9000バイトのMTUを実装しようとしています。ホストには、br19000バイトのMTUを持つブリッジ()があります。 host# ip link show br1 8: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc noqueue state UP link/ether fe:54:00:50:f3:55 brd ff:ff:ff:ff:ff:ff inet 172.16.64.1/24 brd 172.16.64.255 scope global br1 inet6 fe80::21b:21ff:fe0e:ee39/64 scope link valid_lft forever preferred_lft forever ゲストには、このブリッジに接続されたインターフェイスがあり、9000バイトのMTUもあります。 guest# ip addr show eth2 4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc pfifo_fast state UP qlen …

1
なぜrsync自体がフォークするのですか?そして、そのような分岐したプロセスの1つが(iotopで見られるように)ほぼアイドル状態になっているのはなぜですか?
これはここで述べた問題を指しているので、私も同じことを経験しています。 私のサーバーの1つで、rsyncを実行し、同じマシンにマウントされた別のディスクに巨大なディレクトリ(サイズが300 Gbを超える)をバックアップしました。rsyncされるディレクトリには、数千のディレクトリとファイルが含まれます。「nohup」を指定して単一のrsyncコマンドを発行し、「&」コマンドを使用してバックグラウンドでプッシュしました。(パテを使用して)リモートbashシェルで指定された完全なコマンドは次のとおりです。 nohup rsync -avh /some/local/dir /backup/ >> /opt/rsync.dec22.log & 次に、データがコピーされる速度を確認するために、「iotop」コマンドを使用しましたが、同じパラメーターで3つのrsyncが実行されていることがわかりました。検索すると、それが正常であると言う上記のリンクを見つけました。 しかし、iotopを実行して、システム上で実行されているrsyncプロセスのみを監視すると、1つのプロセスがファイルを読み取り、1つがファイルを書き込み、1つがアイドル状態であることがわかります。1つのプロセスが一度に1つのことだけを実行するため、動作は良好であるように見えますが、3番目のプロセスは何をしていますか(下の画像の中央のプロセスとして表示)。 私が使用したiotopコマンドは次のとおりです。 iotop -p22250 -p22251 -p22252 iotopコマンド出力のスクリーンショットは次のとおりです。 私はこの原因にrsyncを頻繁に使用し、長期的な利益のためにその動作を理解したいと考えています。私もマニュアルを読みましたが、フォークについては何も言っていません。
11 linux  rsync  command 

8
前のrsyncジョブが終了するまでcronjobを待機させます
rsyncを使用して、あるサーバーから別のサーバーにデータをバックアップしています。すべて正常に動作しますが、転送するデータの量によっては、完了するまでに時間がかかる場合があります。 前のコマンドがcronjobの使用を終了する前にrsyncコマンドが開始しないことを保証する保証された方法はありますか? たとえば、rsyncコマンドを1時間ごとに実行していますが、転送が完了するまでに1時間以上かかる可能性があるため、次のコマンドは前のコマンドが終了する前に開始されます。
11 linux  cron  rsync 

1
DNSサーバーに対する増幅された反射攻撃
この用語Amplified reflected attackは私にとって初めてのものであり、いくつかの質問があります。 ほとんどがDNSサーバーで起こると聞きましたが、本当ですか? どのようにそれから保護しますか? サーバーがこのような攻撃で使用できるかどうかをどのように確認しますか?それは構成の問題ですか?

1
mod_proxyにエンコードされたスラッシュ(/)文字を正しく転送させることができません(%2f)
リダイレクトするように仮想ホストを設定していますntung-gitblit.localhost-> myserver:1279。ただし、フォワードエンコードされたスラッシュ(%2f)では機能しません。私がアクセスしようとしているURLは、 http://ntung-gitblit.localhost/ABC%2fXYZ がなければAllowEncodedSlashes、失敗します-Apache /error/HTTP_NOT_FOUND.html.varはサーバーにアクセスしようとします。に設定AllowEncodedSlashesするOnと、次の内部URLヒットが発生します。 http://myserver:1279/ABC/XYZ に設定AllowEncodedSlashesするNoDecodeと、次のURLがヒットします。 http://myserver:1279/ABC%252fXYZ 言い換えれば、それは過剰なエスケープまたは過小なエスケープです。質問:どうやってヒットさせるのmyserver:1279/ABC%2fXYZですか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.