サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
cronジョブのタイミング
cronジョブを9:30に開始し、5分ごとに作業し、毎日16:30に停止したいと思います。この種のスケジューリングは1つで可能ですか、それとも2つのcronジョブが必要ですか?
8 cron 

2
リンクを介して複数のVLANを渡すHP Procurveの問題
まず、私はHPプロジェクトに参加したシスコの人です。 外部からの基本的なトポロジの概要: 2610スイッチへの2つのイーサネット接続を備えたASA 5505。 次に、このスイッチは2626スイッチにトランキング*し、vlan 1(タグなし)と100(タグ付き)を渡します。(*-HPのトランキングの定義ではなく、シスコのトランキングの定義) テストのために、両方のVLANの各スイッチにSVIを作成しました。 このリンクを通過するVLAN 100を取得できません。また、スイッチに接続されたAPに設定されたトランクがあり、AP上のVLAN 100 BVIにpingできませんが、VLAN 1 BVIに到達できます。 アクセス層2626のポート25は、配布層2610のポートA1に物理的に接続します。 STPはどのスイッチでもまったく実行されていません(これは私のネットワークではないため、これを変更することも、設計することもできませんでした) ディストリビューションSw 2610: MP1-0# show run ip default-gateway 10.100.100.100 vlan 1 name "DATA" untagged 1-22,24-A1,B1 ip address 10.100.100.6 255.255.255.0 no untagged 23 exit vlan 100 name "GUEST" untagged 23 tagged 24-A1 ip address 10.100.102.6 255.255.255.0 exit …
8 hp  vlan  hp-procurve  trunk 

3
Puppetは.erbファイル変数のリソースをエクスポートしましたか?
シナリオ:私の構成ファイルは.erb、以下のスニペットを含むファイルによって定義されています。 <% backupclients.each do |backup_files| -%> Job { Name = "Server" JobDefs = "DefaultJob" Client = <%= backup_files %>-fd Pool = TeraMonth Write Bootstrap = "/var/lib/bacula/<%= backup_files %>.bsr" } <% end -%> サーバーの構成ファイルには、クライアントホストごとにエントリを繰り返す必要があります。単純な配列を作成する場合、これは問題なく機能します。しかし、私がやりたいことは、各ホストにそれ自体を登録さ<<| |>>せ、nagios_*タイプで行うのと同様のプラグマを使用してデータを収集することです。 この標準的な例には、タイプのエクスポートが含まれます。 class ssh { @@sshkey { $hostname: type => dsa, key => $sshdsakey } Sshkey <<| …
8 puppet 

3
EC2インスタンスでの/ tmpのサイズの増加
EC2 ebsでUbuntuサーバーを実行していますが、アプリケーションには/ tmpに割り当てられた大量の一時ディスク領域が必要です。ただし、ec2では、/ tmpも含むルートドライブはかなり小さく、約10GBです。残りのディスク領域はすべて/ mntの下にマウントされます。その結果、/ tmpがいっぱいになっているように見えるため、アプリケーションで「ディスク領域不足」エラーが返されます。 この問題を解決する最良の方法は何ですか?私が考えることができる1つのことは、/ mnt / tmpを作成してシンボリックリンクを作成することです /tmp --> /mnt/tmp しかし、私は非常に多くのLinuxプログラムやツールで使用されているものをいじくり回すことに少し消極的です。すべてのプログラムがシンボリックリンクを正しく解決するかどうか、またそれがパフォーマンスにどう影響するかはわかりません。

5
Nginx / FPM / PHPすべてのphpファイルは「ファイルが見つかりません」と言います。
私はちょうどcentos 5.8最終64ビットマシンにnginx 1.1.13とphp 5.4.0をインストールしました。NginxとPHP / Fpmが実行されており、sshコマンドラインを介してphpスクリプトを実行できますが、ブラウザで「ファイルが見つかりません」というメッセージが表示され続けます。すべてのPHPファイルのエラー。 これは私がnginx.confにPHPスクリプトを処理させる方法です: location ~ \.php$ { root /opt/nginx/html; fastcgi_pass unix:/tmp/fpm.sock; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /opt/nginx/html$fastcgi_script_name; include fastcgi_params; } これは、他のサーバーからの直接のコピー/貼り付けであり、この設定で正常に動作します(ただし、古いバージョンのphp / fpmを実行します)。 これらのエラーが発生するのはなぜですか?
8 php  nginx  php-fpm 

3
キャプティブポータルネットワーク接続はどのように機能しますか?
ホテル、空港のカフェでのインターネットアクセスは、多くの場合、キャプティブポータルによってゲートされ、最初の使用時に特定のWebページ(たとえば、支払いページや、利用規約や認証/承認ページに同意するためのページ)に強制的にアクセスします。これは、無線接続と有線接続の両方で見られます。 これはどのように作動しますか?

1
コマンドラインのPHPに「メモリ不足」と表示され、ファイル名、行番号、メモリ値が表示されない
私は最初にこれを/programming/9665189/php-on-command-line-displays-out-of-memoryに投稿しましたが、代わりにここに投稿することをお勧めしました。 これは、ファイル名、行番号、または使用されたメモリの量を提供しないため、スクリプトでメモリが不足した場合の通常の致命的なエラーではありません。スクリプトを渡すか、単純にphpを単独で実行したときに、コマンドラインでphpを実行しようとすると、「メモリ不足」と表示されます。存在しないスクリプトを実行しようとしても、同じメッセージが表示されます。 言い換えれば、私はこれを得る: dan@server [~]# php Out of memory dan@server [~]# php test.php Out of memory dan@server [~]# php doesntexist.php Out of memory dan@server [~]# php -v Out of memory ただし、Apacheを介したPHPはまったく問題なく動作します。このエラーが発生するのはCLIだけです。 問題のマシンは64ビットのCentOSリリース5.7(Final)とPHP 5.3.10を実行しています。専用サーバーです。 私はulimit -aをdanとして実行してみましたが、これが出力です。 core file size (blocks, -c) 200000 data seg size (kbytes, -d) 200000 scheduling priority (-e) …

6
CentOSのフレッシュインストールでのDNSの問題
CentOS 6.2でインストールする新しいボックスでDNSの問題が発生しています。 nslookup、dig、またはhostを使用して名前を検索できます。名前またはIPアドレスでマシンにpingできます。ただし、ssh、wget、yumなどの他のツールを試したところ、名前を解決できません。例えば: # wget http://www.google.com --2012-03-08 14:48:06-- http://www.google.com/ Resolving www.google.com... failed: Name or service not known. wget: unable to resolve host address `www.google.com' # ssh www.google.com ssh: Could not resolve hostname www.google.com: Name or service not known # ping -c 1 www.google.com PING www.l.google.com (74.125.113.106) 56(84) bytes of data. …

3
Apache + PHP-FPM =ランダムな「エラー解析スクリプトヘッダー」+セグメントフォールト
私は、proxy_fcgiを使用して、Apache 2.4でPHP-FPMを設定していますが、すべて正常に動作しますが、4〜6リクエストのすべてで、Apacheは空白のページを返します。これは私のメインサイトhttp://danielhe.com/で発生しますが、サブドメインvhostsでは発生しません。 これは、Apacheのエラーログ[クライアントx]を表示しますAH01070:スクリプトヘッダーの解析エラー そして最終的には、Apache segfaults AH00052が時々発生します:子pid 9740終了信号セグメンテーション違反(11) 「エラー解析スクリプトヘッダー」はページを数回更新することで非常に簡単に再現できますが、「エラー解析スクリプトヘッダー」を数回実行すると、セグメンテーション違反がランダムに発生します。 更新 セグメンテーション違反の修正を見つけました。WSODは明らかにそれ自体を修正しました。mod_deflateにはいくつかの問題がありますが、Apacheドキュメントのこの構成により修正されました SetOutputFilter DEFLATE BrowserMatch ^Mozilla/4 gzip-only-text/html BrowserMatch ^Mozilla/4\.0[678] no-gzip BrowserMatch \bMSIE !no-gzip !gzip-only-text/html # Don't compress images SetEnvIfNoCase Request_URI \ \.(?:gif|jpeg|jpg|png)$ no-gzip dont-vary # Make sure proxies don't deliver the wrong content Header append Vary User-Agent env=!dont-vary

4
ローカルSQLサーバーのWindows認証に自分を追加するにはどうすればよいですか?
最近、私のラップトップを64ビットウィンドウで再セットアップしました。彼は私のためにSql Server開発版をインストールし、ユーザー名とパスワードを設定しました。ログインしてSQL ServerをWindows認証に変更してSQLサーバーを再起動したところ、ドメインアカウントでログインできなくなりました。 ローカルシステムのSQLServerSQLAgentUserグループとSQLServerMSSQLUserグループに自分を追加しようとしましたが、SQL Serverは引き続き私のドメインアカウントが承認されていないと言っています。私のアカウントはローカルシステム管理者です。 Sql Serverにログインさせるにはどうすればよいですか?

6
DebianでPHP 5.4から5.3にダウングレード
サーバーでDebian dist-upgradeを実行する必要がありました...その過程で、PHPは5.4にアップグレードされました。5.3 atmまでしかサポートしていないioncubeを使用していますが、5.4から5.3にダウングレードする方法を見つけるのに苦労しています。誰か知ってる?
8 php  php5  debian 

1
交通機関の選択
私の組織は、主要なデータセンタープロバイダーからの単一ホームIPトランジットに非常に過剰な料金を支払う立場にあります。私たちは今、交通機関との直接の関係への切り替えを検討する準備ができている状態にあります。 質問はここで少し被写体にタッチを行くが、それは非常に包括的ではありません。たとえば、受け入れられた回答では、CogentとHurricane Electricは安価なプロバイダーと見なされていますが、Level(3)、AT&T、Teliaはより優れていると見なされています。それが行わないことは、あるプロバイダーが他のプロバイダーよりも優れている理由を正確に説明することです。 私はBGP、マルチホーミング、ピアリングとトランジットの概念に精通していますが、これらのプロバイダーのいくつかが他のプロバイダーよりも優れている理由を理解していません。 明確にするために、私はプロバイダーへの提案や、その件に関して言及されている名前を求めているのではありません。私は外に出て、自分の「買い物」調査をすることができてとても幸せです。リンゴとリンゴを比較する必要があるという問題があり、何を探すべきかわかりません! それが違いを生むなら、私たちの組織は英国にあります。

2
lsof出力にwebminが表示されるのはなぜですか?
私はサーバーアプリケーション(Cで記述)を実行していますが、これは私のサーバーのlocalhostアドレスにバインドされて127.0.0.1おり、最初のケースではポート10000で、2番目のケースではポートでリッスンします。20000 コマンドを実行するとlsof | grep IP、最後の列は次のようになります。 localhost:webmin(LISTEN)(最初のケース) localhost:20000(LISTEN)(2番目のケース) したがって、ポートの代わりに10000がありwebminます。 これは何を意味するのでしょうか?私はこれを見つけました。 WebminはUnixのシステム管理用のWebベースのインターフェースであると述べています。これは私には役に立ちません。ポートリストに表示されるのはなぜwebminですか?

4
MySQLサーバーを自動スケーリングする方法は?
トラフィックが急増しているサイトを運営しています。そのため、この場合、自動スケーリングソリューションは非常に有益です。現在、Webサーバーは水平方向に自動スケーリングできますが、ボトルネックはMySQLサーバーにあります。 私はAmazon RDSマルチAZを試してみましたが、12 GBのデータベースをアップグレードするには、数分のダウンタイムで15分程度かかります。ある特定の瞬間にトラフィックの急増が起こることをすでに知っていたとき、それは多くの助けとなりました。 Xeroundも検討しました。このサイズのデータ​​ベースでは非常にコストがかかりますが、これはおそらく最良のソリューションです。とにかく、データベースをEUに置くことを法的に必要とするため、これは選択肢ではありません。 私はScalrについて読みましたが、それが役立つかどうか、またどのように役立つかはわかりません。 多くのクラウドホスティングプロバイダーが垂直スケーリングソリューションを提供し、ダウンタイムがゼロであると考えています(Xenハイパーバイザーを使用している限り、それが本当に可能かどうかはわかりません)。それは解決策になるかもしれませんが、ダウンタイムがないのか、MySQL構成(およびOS上の他の多くのこと)がダウンタイムなしでもアップグレードできるのかと思います。 MySQLスレーブサーバーを試しましたが、まったく役に立ちませんでした。 memcacheを使用していますが、これは非常に役立ちますが、それだけでは不十分です。読み取りのためだけでなく、書き込みのためにアップグレードする必要があります。 助言がありますか?前もって感謝します

3
dhcp-snoopingオプション82は、2610シリーズProcurveスイッチの有効なdhcp要求をドロップします
HP ProCurve 2610シリーズスイッチでdhcp-snoopingの実装を徐々に開始し、すべてR.11.72ファームウェアを実行しています。「クライアントからの信頼できないリレー情報」が原因で「ダウンストリーム」スイッチから発信されたときに、dhcp-requestまたはdhcp-renewパケットがドロップされるという奇妙な動作が見られます。 完全なエラー: Received untrusted relay information from client <mac-address> on port <port-number> より詳細には、48ポートのHP2610(スイッチA)と24ポートのHP2610(スイッチB)があります。スイッチBは、スイッチAポートの1つへのDSL接続により、スイッチAの「ダウンストリーム」です。dhcpサーバーはスイッチAに接続されています。関連するビットは次のとおりです。 スイッチA dhcp-snooping dhcp-snooping authorized-server 192.168.0.254 dhcp-snooping vlan 1 168 interface 25 name "Server" dhcp-snooping trust exit スイッチB dhcp-snooping dhcp-snooping authorized-server 192.168.0.254 dhcp-snooping vlan 1 interface Trk1 dhcp-snooping trust exit スイッチは、承認されたDHCPサーバーが接続されているポートとそのIPアドレスの両方を信頼するように設定されています。これはすべて、スイッチAに接続されているクライアントには問題ありませんが、スイッチBに接続されているクライアントは、「信頼できないリレー情報」エラーのために拒否されます。これは、いくつかの理由で奇妙です。1)dhcp-relayがどちらのスイッチでも構成されていない、2)ここのレイヤー3ネットワークはフラットで同じサブネットです。DHCPパケットには、オプション82の属性を変更しないでください。 ただし、dhcp-relayはデフォルトで有効になっているようです。 SWITCH A# show dhcp-relay …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.