サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
コマンドラインから.isoファイルのボリュームIDを変更する方法はありますか?
.isoLinuxにファイルがあり、ファイルを再作成せずにボリュームIDを変更する方法を見つけようとしてい.isoます。などのオーサリングツールのほとんどは、たとえばmkisofs音量(-V)を設定するためのスイッチを備えています。しかし、既存の.isoファイルでそれを変更する方法がわかりません。 明確にするために、私が変更しようとしているのはこのVolume id:文字列です。次に、isoinfoコマンドからのダンプの例を示します。 % isoinfo -d -i /usr/share/virtualbox/VBoxGuestAdditions.iso CD-ROM is in ISO 9660 format System id: Win32 Volume id: VBOXADDITIONS_4.1.8_75467 Volume set id: Publisher id: Data preparer id: Application id: MKISOFS ISO 9660/HFS FILESYSTEM BUILDER & CDRECORD CD-R/DVD CREATOR (C) 1993 E.YOUNGDALE (C) 1997 J.PEARSON/J.SCHILLING Copyright File id: Abstract File …
8 linux  iso  disk-image 

4
apt-get update mdadm怖い警告
私の専用サーバーの1つでapt-get更新を実行しただけで、比較的恐ろしい警告が残ります。 Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.26-2-686-bigmem W: mdadm: the array /dev/md/1 with UUID c622dd79:496607cf:c230666b:5103eba0 W: mdadm: is currently active, but it is not listed in mdadm.conf. if W: mdadm: it is needed for boot, then YOUR SYSTEM IS NOW UNBOOTABLE! W: mdadm: please inspect the output of …
8 debian  apt  mdadm  update 

3
完全に再起動せずにハートビートでシステムに新しいIPアドレスを追加する方法はありますか?
高可用性のためにハートビートを利用します。ハートビートクラスターに追加のIPアドレスを追加したいのですが、プロセス中にクラスターを完全に再起動したくありません。「haresources」ファイルの再解析とそのアクションの実行を促す信号をハートビートに送信できますか?heartbeat -rはトリックを実行していないようです。

1
NTPは同期せず、サービスの再起動時にのみ同期します
私のubuntu 11.10サーバーは、過去3〜4か月間、非常に喜んでそこに座っていましたが、突然、時刻が1時間ずれ始めました。理由はわかりませんが、サーバーの構成は何も変更されていません。システムリソースの使用状況に原因があると思います。 とにかく、これを打ち消すために、多くの人がNTPとNTPデーモン(ntpd)をインストールして、時刻が自動的に同期されるようにすることを勧めています。NTPDをインストールしましたが、1日動作するように見えた後、突然動作しなくなりました。 一日ぐらいしたら ntpq -q 接続されているピアを一覧表示するには、エラーが発生します ntpq: read: Connection refused もし私がそれからサービスを再試行するなら sudo service ntp restart 次のメッセージが表示されます * Stopping NTP server ntpd start-stop-daemon: warning: failed to kill 26915: No such process * Starting NTP server ntpd 約5分以内にこれを実行すると、時刻が再び同期されます。もう一度サービスを再起動すると、上記のメッセージが表示されず、ただ取得します * Stopping NTP server ntpd * Starting NTP server ntpd そして、ntpq -pをもう一度試すと、 remote …


6
FIFOを介してログに記録し、ファイルにリダイレクトしますか?
各トランザクションをログに記録する必要があるアプリケーションがあります。クラッシュに至るまでに何が起こったかを記録する必要があるため、すべてのログメッセージがフラッシュされます。同僚と私は、ログメッセージがプロセスを離れたことを保証しながら、バッファリングのパフォーマンス効果を達成する方法に興味を持っていました。 私たちが思いついたのは: アプリケーションが書き込み可能なFIFOを作成し、 経由でそのFIFOの内容を通常のファイルにリダイレクトしますcat。 つまり、通常は次のとおりでした。 app --logfile logfile.txt 今でしょ: mkfifo logfifo cat logfifo &> logfile.txt & app --logfile logfifo このアプローチに落とし穴はありますか?テスト時に機能しましたが、元のアプリケーションがクラッシュした場合でも、メッセージがリダイレクトファイルに到達することを確実に確認したいと考えています。 (アプリケーションのソースコードがないため、プログラミングソリューションは問題外です。また、アプリケーションはに書き込みを行わないstdoutため、別のコマンドに直接パイプすることは問題外です。そのsyslogため、可能性はありません。) 更新:バウンティを追加しました。受け入れ答えはなりません伴うlogger単純な理由loggerではない私が尋ねたもの。元の質問が述べているように、私はFIFOを使用する上での問題点のみを探しています。
8 linux  logging 



5
HTTP / 1.1 ETagおよびIf-None-Matchヘッダーをサポートするリバースプロキシはどれですか。
キャッシングにリバースプロキシを使用するeコマースプラットフォーム用のキャッシングシステムを開発しています。適切なHTTP / 1.1ヘッダーを使用して無効化を処理する予定です。つまり、コンテンツの最初の世代にETagを設定し、そのETag値をアプリケーションにキャッシュします。Cache-Controlヘッダーは「must-revalidate」を指定するため、プロキシはETagを使用した後続のリクエストでIf-None-Matchヘッダーを設定する必要があります。アプリケーションはキャッシュされたETag値を検索し、一致する場合は304応答を送信し、それ以外の場合は完全な200応答を生成します。 私はnginxを使用したいと思っていましたが、それがETagをサポートしていることを確信できません(ドキュメントはそれがサポートしていないことを示していますが、おそらく古くなっていますか?)。ワニスは別のオプションですが、私もここでは前向きではありません。 ETagを完全にサポートしているリバースプロキシサーバーはどれですか。実際に複数のバージョンをキャッシュして、キャッシュを無効にせずにスプリットテストなどを実行できるようにしたいと考えています。つまり、HTTP / 1.1は、クライアントが複数のETag値を持つIf-None-Matchを送信でき、サーバーが一致するETag(存在する場合)で応答する必要があることを指定します。リバースプロキシが最後に表示された値だけでなく複数のコピーを保持し、使用するリクエストごとにサーバーに指定させる場合、それは理想的です。

3
別のドメインコントローラが必要
私がサポートする部門のほとんどが存在する1つのサイトに2つのドメインコントローラー(Windows 2003)があります。私の部署が存在する別の建物(別のサイト)がありますが、DCがありません。 これは、会社が複数のサイトに分散している場合に追加のDCをインストールするかどうかという典型的な疑問です。 ログインスクリプトがドライブをマッピングしない、ユーザーがログインする前に何度かログインに失敗する(正しいパスワードを入力しているにもかかわらず)など、さまざまな問題が発生しています。 クライアントでさまざまなエラーが発生します。それらのいくつかは: Netlogon、5719、次の理由により、このコンピューターはドメインdomain.comのドメインコントローラーとのセキュリティで保護されたセッションをセットアップできませんでした:現在、ログオン要求を処理できるログオンサーバーがありません。これにより、認証の問題が発生する可能性があります。このコンピュータがネットワークに接続されていることを確認してください。問題が解決しない場合は、ドメイン管理者に連絡してください。 GroupPolicy、1055、グループポリシーの処理に失敗しました。Windowsはコンピューター名を解決できませんでした。これは、次の1つ以上が原因である可能性があります。a)現在のドメインコントローラでの名前解決の失敗。b)Active Directoryの複製の待ち時間(別のドメインコントローラーで作成されたアカウントは、現在のドメインコントローラーに複製されていません)。 サーバーでこれらのエラーが発生し続けます: Netlogon、5722、コンピューターSOMEPCNAMEからのセッションセットアップが認証に失敗しました。セキュリティデータベースで参照されるアカウントの名前はSOMEPCNAME $です。次のエラーが発生しました:アクセスが拒否されました。 *(この上記のエラーは同じコンピューターで繰り返されます。おそらくこれをドメインに再度追加する必要があるだけです。)* NTDSレプリケーション、1864、これは、ローカルドメインコントローラー上の次のディレクトリパーティションのレプリケーションステータスです。ディレクトリパーティション:CN = Schema、CN = Configuration、DC = domain、DC = com 最後の1つは、完全に削除されなかったDCに関係しているようです。dcdiagを実行したところ、存在しないサーバーで複製しようとしていることがわかりました。ただし、これによってこれらのログオンの問題がすべて発生することはないと思います。 別のDCをインストールする必要があるのか​​、それとも別の方法を試す必要があるのか​​と思います。私たちのクライアントは主にWindows 7を実行していますが、一部のXPおよびVistaクライアントも同様です。 帯域幅は、異なるサイトのPC間で37.4 Mbsであるように見えます(このユーティリティiperfで検証済み)。 どんな助けでもありがたいです。

2
rsyncのデフォルトのリモートシェルは何ですか?
奇妙なことに、デーモンモードで使用していないときにrsyncが使用するデフォルトのリモートシェルは何ですか?manページによると、rshまたはsshを介して実行できます。ただし、manページのどこにも、どれを使用するかを設定する方法が指定されていません。そのため、実行するとパスワードの入力を求められますが、どのリモートシェルが使用されているかを示していないようです。これはおそらくダミーの質問であることは知っていますが、いくつかの説明を実際に使用することができます。ありがとう!
8 rsync 

3
tcpdumpがpcapファイルを書き込まないのはなぜですか?
接続できないように見えるpython ircボットをデバッグする過程で、「わかっています。tcpdumpを実行して、何が実行されているかを確認します」と考えました。だから私はいつものようにtcpdumpを実行しました、そしてそれはそれがキャプチャされたパケットであると言います、しかし実際にはcapファイルを書きません。 akraut@lance ~/pcaps $ sudo tcpdump -w pyhole -s 0 "port 6667" tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes ^C17 packets captured 17 packets received by filter 0 packets dropped by kernel 4294966881 packets dropped by interface akraut@lance ~/pcaps $ ls -la total 8 drwxr-xr-x …

3
nginxはPDFの提供に適していますか?
これはダミーの質問です。PDFへの公開アクセスを許可する必要があります。たとえば、ファイルあたり8 MBとします。静的である限り、nginxはあらゆる種類のファイルを提供するように思えます。しかし、nginxはこれには適していないと誰かが言った。 私/彼が間違っていることを証明するためにいくつかのドキュメントを提供できますか?
8 nginx  pdf 

2
ldap_addエラー(80)<olcModuleLoad>ハンドラーが1で終了しました
このチュートリアルに従って基本的なLDADサーバー(OpenLDAP)をセットアップしてクレイント認証をしようとしていますが、バックエンド構成を追加するステップで立ち往生しています。 指定されたとおりにbackend.ldifファイルを作成し、次のように追加しようとしています。 sudo ldapadd -Y EXTERNAL -H ldapi:/// -f backend.ldif しかし、私は得ます: SASL/EXTERNAL authentication started SASL username: gidNumber=0+uidNumber=0,cn=peercred,cn=external,cn=auth SASL SSF: 0 adding new entry "cn=module,cn=config" ldap_add: Other (e.g., implementation specific) error (80) additional info: &lt;olcModuleLoad&gt; handler exited with 1 完全なLDIFは次のとおりです。 #Load dynamic backend modules dn: cn=module,cn=config objectClass: olcModuleList cn: module olcModulepath: …
8 openldap 

4
RHEL6でFedoraまたはCentosリポジトリをセットアップできますか?
Red Hat NetworkのサブスクリプションがないRHEL6ボックスを持っています。すべての複雑な依存関係を解決するために、yumを使用してgccをインストールしたいと思います。FedoraまたはCentosリポジトリに接続してソフトウェアをインストールできますか?もしそうなら、どうですか?
8 centos  redhat  fedora  yum  rhel6 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.