サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
40以上のCentos5.5サーバーをどのようにバックアップしますか?
この質問をするのは恥ずかしいです。UNIXの専門知識の欠如に対する謝罪。私たちは40以上のcentos 5.5サーバーを継承しており、それらをバックアップする方法がわかりません。HDなどを交換する必要がある場合にサーバーを最初から復元できるように、低レベルのクローンタイプのイメージが必要です。 「dd」コマンドを使用しましたが、これは、外部USB HDが接続された1台のサーバーではなく、40台のサーバーではなく、1つのローカルディスクを別のローカルディスクにバックアップする場合にのみ機能すると想定しています。 40台のサーバーすべてに、ミラーリングされたディスクのペアがあります(そのHWまたはSW RAIDかどうかはわかりません)。ほとんどが100MBしか使用していません。サーバーはapache、zend、tomcat、mysqlなどを実行しています。理想的には、バックアップするためにシャットダウンする必要はありません(しかし可能です)。 tar、cpio、rsync、scpなどの標準的なUNIXコマンドは、パーティション、すべての属性、グループなどではなく、ファイルのみをコピーするため、役に立たないと想定しています。つまり、単にSererを完全に回復させる新しいHD。 大規模なSAN、予備のWindowsボックス、予備のUNIXボックスがありますが、これらはネットワーク内の1つのレイヤーからしか見えません。未使用のDell DL2000モンスターテープユニットがありますが、swやドキュメントはありません。私たちはsymantec backup execのコピーを持っていますが、UNIXクライアントライセンスの予算はありません。(会社には負の金額があります)。 サーバーに直接アクセスできるのは、緊急時にのみ(つまり、復元するため)、リモートでバックアップを開始できる必要があります。 Googlingはこれを行うためにいくつかのアプリケーションを返します(例:clonezilla)-インストールが難しく侵襲的です。モンドは、あなたがマシンにローカルである場合にのみバックアップをサポートするようです。アマンダはオプションかもしれませんが、学び、セットアップするために何日/何週間もの作業のように見えますか? Centosに組み込まれているものはありますか?それとも、一連のバックアップソフトウェアをインストール、学習、構成する必要がありますか? 何か案は?これはかなり標準的な問題であるに違いありません。
8 centos  backup 

4
パブリッククラウドとプライベートクラウドの正確な技術的な違いは何ですか?
しばらくの間、パブリッククラウドとプライベートクラウドの正確な技術的な違いを理解しようとしています。それがどのように機能するかを正確に説明する記事を見つけることができたと思いますが、今のところ運がありません。すべての記事はまた別のことを言っているようです。 パブリッククラウドでは、複数のユーザーが同じ物理マシン上にいるため、プライベートデータを操作する場合は非常に危険です。プライベートクラウドの方が安全であることは知っていますが、その理由はわかりません。プライベートクラウドに仮想プライベートネットワークのようなものがあるからですか?それとも、物理マシン上に他のユーザーがいないためでしょうか?
8 cloud 

1
Server 2012 Core(GUIなし)-ディスクを管理する方法
GUIがないServer 2012で作業しています。今のところ、2つのハードディスクがあります。私の最初のものはすでにフォーマットされており、Cと表示されます。 次に、2台目のハードドライブをフォーマットして、D:パーティションを作成します。 コマンドライン(cmdやpowershellなど)を使用してこれを実現する方法はありますか?

2
AWS VPC-なぜプライベートサブネットがあるのですか?
Amazon VPCでは、VPC作成ウィザードを使用して、単一の「パブリックサブネット」を作成するか、ウィザードに「パブリックサブネット」と「プライベートサブネット」を作成させることができます。最初は、セキュリティ上の理由から、パブリックサブネットオプションとプライベートサブネットオプションは適切であるように見え、Webサーバーをパブリックサブネットに配置し、データベースサーバーをプライベートサブネットに配置できるようになりました。 しかし、Amazon ElasticIPをEC2インスタンスに関連付けない限り、パブリックサブネット内のEC2インスタンスにインターネットから到達できないことを知ってからです。したがって、1つのパブリックサブネット構成だけで、ElasticIPをデータベースサーバーに関連付けずに、同じ種類のセキュリティを選択することができます。 誰もがパブリック+プライベートサブネット構成の利点を説明できますか?この構成の利点は自動スケーリングとより関係があるのですか、それとも単一のパブリックサブネットを使用する方が実際には安全性が低くなりますか?

3
サイトが異なるブラウザーに異なるSSL証明書を提供しているのはなぜですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 4年前休業。 SSL証明書はmenswearireland.com、www.menswearireland.comSafari、Chrome、SeaMonkey、K-Meleon、QtWeb、Firefox、およびOperaで正常に機能します。ただし、Internet Explorerはエラーがあると主張しています。 このWebサイトによって提示されたセキュリティ証明書は、信頼された認証局によって発行されたものではありません。このWebサイトから提示されたセキュリティ証明書は、別のWebサイトのアドレスに対して発行されました。 セキュリティ証明書の問題は、ユーザーをだましたり、サーバーに送信したデータを傍受したりする試みを示している可能性があります。 Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.0; Trident/5.0) :別のサイトでは、同じ管理対象サーバのショーエラーなしでホストされているachill-fieldschool.comと、www.achill-fieldschool.comたとえ私の知る限り、証明書が同一に設定されて言うことができるように、IEの作業罰金。 何が悪いのですか? これはPleskを実行するLAMPPサーバーです。 サーバーがクライアントごとに異なる証明書を表示しているようです。いくつかのクライアントにはに作ったRapidSSLの証明書を示しwww.menswearireland.com持つmenswearireland.com有効な代替名として。他のクライアントには、に作成されたParallels Panel証明書が表示されParallels Panelます。いくつかの異なるオンラインSSLチェッカーの結果を以下に示します。ほとんどは問題ないと言っていますが、2つはエラーを示しています。 3人のオンラインチェッカーが有効であると述べています Comodo SSL Checkはそれを有効と表示します DigiCert SSLチェックで有効と表示される SSLショッパーSSLチェックで有効と表示される 一般名: www.menswearireland.com SAN: www.menswearireland.com、menswearireland.com 2012年10月2日から2013年11月4日まで 有効 シリアル番号: 559425(0x88941) 署名アルゴリズム: sha1WithRSAEncryption 発行者: RapidSSL CA 別のオンラインチェッカーが完全に異なる証明書を表示しているようです GeoCerts SSLチェックで無効と表示される 一般名: Parallels Panel 組織: Parallels …

3
「コンピューターを再起動して更新のインストールを完了する」ポップアップをGPOで無効にするにはどうすればよいですか?
ドメイン上にあり、永続的にログインしているキオスクコンピューターがいくつかあり、WSUSを介してFEPの更新を受信します。これはうまくいきますが、時々、右下隅にこのダイアログが表示されます: No auto-restart with logged on users for scheduled automatic updates installationsGPOを「有効」に設定すると、これらは表示されなくなると思いましたが、まだ表示されているようです。以下は、適用しているWindows Update GPOのスクリーンショットです。 何が欠けていますか?これらの通知をオフにするにはどうすればよいですか?

2
Hyper-Vホスト接続に影響を与える仮想化pfSense 2.0.1?arp?
セットアップ Hyper-VのホストとしてpfSense 2.0.1(64ビットAMDイメージ)をセットアップしました。他のブログで説明されているように、ネットワークを稼働させるには、「ifconfig down deX」、「ifconfig up deX」を実行する必要がありました。 サーバー(Windows 2008 R2を実行するHP)には2つの物理NICが搭載されています。 最初の物理NIC(ポート1)はホストで構成されていません(Hyper-Vスイッチとしてのみ、下を参照)。 2番目の物理NIC(ポート2)は、リモート管理用のネットワーク(標準Cクラスネットワーク)で構成されています。両方のNICが同じスイッチとVLAN = defaultに接続されていると思います(物理的な配線はコロケーションプロバイダーによって行われました)。 Hyper-Vでは、次の仮想ネットワークが定義されています。 internal:VM間の通信に使用される仮想マシンの内部ネットワーク(Windowsサーバーを接続する「LAN」)。 インターネット:pfSenseのWAN接続として使用される仮想ネットワーク。このネットワークは、サーバーの最初の物理NIC(ポート1)に割り当てられます。仮想ネットワークはHyper-V専用であり、ホストと共有されません。 私のセットアップでは、同じHyper-Vホストで実行されているいくつかの仮想マシン(Windowsサーバー)のインターネットに面するファイアウォールとしてpfSenseを使用しています。 WindowsボックスはデフォルトゲートウェイとしてpfSenseを使用しており、pfSenseファイアウォールを介してすべてのVMにWindows更新を正常にダウンロードしました。 着信サービスをリダイレクトするために、pfSenseは、ISPのIPアドレスをWindowsボックスの内部172.16.0.0/16アドレスにマップするように1-1 NATでセットアップされています。 問題 私が抱えていた問題は、管理ネットワーク(ポート2)を介したRDP接続を正常に処理した後、接続が停止し、サーバーとVMへのすべてのネットワーク接続が失われることです。問題が発生する前に、2つの構成変更を行いました。 管理IPアドレスをポート1からポート2に移動しました。この変更は、1時間後に新しいインターフェイス(上記のポート2)でRDPを再接続することで確認されました。 pfSenseの仮想IPの一部の構成(1-1 NATに必要)。 数分後、マシンへの接続が失われました。 私を困惑させるのは、Hyper-Vと統合されていないため、管理ネットワーク接続(ポート2)はHyper-Vによって変更されないことになっているということです。ただし、pfSenseからのエラー伝搬があるようです(ポート1でNICを使用)。 今日の初めに、NICを1つだけ使用するときに同様の問題がありました(Hyper-V / pfSenseとホスト間で共有されるポート1)。そのとき得られた問題は、pfSenseが停止したときにホストにpingを実行でき、ホストが再度開始されたときにpingが機能しなくなったことです(IPの競合がないことがわかっています)。 pfSenseはISOからインストールされ、「MACアドレススプーフィング」はデフォルト=オフです。 2つの物理ポート間で伝搬するシームの問題から、これはARPが正しく機能していないことに関係している可能性があると推測しています。 洞察はこれについて非常に高く評価されています。 / J

3
個々のプロキシパスルールのProxyPreserveHost
私のWebホストには2つのプロキシパスルールがあります。1つはキャッシュの目的でローカルワニスインスタンスを指し、これをProxyPreserveHostを有効にし、もう1つはサードパーティのホストサイトを指し、ProxyPreserveHostを無効にします。とにかく私はこれをルール/パスごとに行うことができますか?

2
「cat / proc / net / dev」と「ip -s link」は異なる統計を表示します。どちらが嘘をついていますか?
/proc/net/deveth3には1753 drop秒あると言っています。ip -s link0を示しますdropped。なぜ違いがあるのですか?さまざまなデータはどこから取得されますか?どちらが正しいか? 余分なデータを取り除きました。 # uname -a Linux example09 2.6.32-5-amd64 #1 SMP Thu Mar 22 17:26:33 UTC 2012 x86_64 GNU/Linux # lsb_release -a Distributor ID: Debian Description: Debian GNU/Linux 6.0.4 (squeeze) Release: 6.0.4 Codename: squeeze # cat /proc/net/dev Inter-| Receive | Transmit face |bytes packets errs drop fifo frame …
8 linux  networking  ip 

4
taskhost.exeが実行していることを確認するにはどうすればよいですか?
週に1〜2回taskhost.exeを実行すると、コンピューターが停止します。それは私のCPUパワーの25%を占めます(つまり、1プロセッサ)。私はそれを殺すことはできず、それが何をしているのか分からない。それはある種のウィンドウの予定された活動だと思います。 この問題の原因を特定するにはどうすればよいですか?どうすれば停止できますか?

1
HP P400から論理ドライブ/アレイを削除できない
これが私の最初の投稿です。この件に関してご協力いただきありがとうございます。 SmartアレイP400から論理ドライブ(論理ドライブ2)とアレイ(アレイ「B」)を削除しようとしています。ホストは、64ビットのRed Hat Enterprise Linux Serverリリース5.7(Tikanga)を実行するDL580 G5です。hpacucliまたはcpqacuxeを使用してアレイを削除できません。「OSステータス:LOCKED」が原因だと思います。このアレイに存在するファイルシステムはマウント解除されています。ホストを再起動したくない。アレイを削除できるように、この論理ドライブを「解放」する方法はありますか?論理ドライブ2のデータを保存する必要がないことに注意してください。ドライブを物理的にマシンから取り外し、より大きなドライブに交換するつもりです。 Red Hat 5.7に同梱されているccissカーネルモジュールを使用しています。 以下は、ホストとP400構成に関する情報です。 [root@gort ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 5.7 (Tikanga) [root@gort ~]# uname -a Linux gort 2.6.18-274.el5 #1 SMP Fri Jul 8 17:36:59 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux [root@gort ~]# rpm -qa | egrep '^(hp|cpq)' cpqacuxe-9.30-15.0 …

1
SQL Server Expressサービスが開始されていません[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 7年前休業。 昨日、最初のVPSを購入し、それにMicrosoft SQL Server 2012 Expressをインストールしました。 次に、VPSを再起動しました。しかし、SQL Serverサービスは開始されませんでした。手動で起動しようとしましたが、起動できません。 何が問題ですか?それを解決するには? PS:これは私の最初のサーバー管理であり、私は初心者です。これに関する詳細が必要な場合は、コメントを残してください。質問を更新します。 更新1:これは、この問題に役立つ可能性があると私が考えた、イベントビューアからのログの詳細です。 FCB :: Openに失敗しました:ファイル番号1のファイルe:\ sql11_main_t.obj.x86release \ sql \ mkmastr \ databases \ objfre \ i386 \ MSDBData.mdfを開けませんでした。OSエラー:3(指定されたパスが見つかりません。 )。 リソースデータベースのビルドバージョンは11.00.3000です。これは情報メッセージです。ユーザーの操作は必要ありません。 FileMgr :: StartLogFiles:ファイル 'e:\ sql11_main_t.obj.x86release \ sql \ mkmastr \ databases \ objfre \ i386 \ MSDBLog.ldf'を作成または開いているときに、オペレーティングシステムエラー2(指定されたファイルが見つかりません。)が発生しました。オペレーティングシステムエラーを診断して修正し、操作を再試行してください。 データベース「モデル」を起動しています。 …

4
io.cでのrsyncエラーの原因不明のエラー(コード255)
スクリプトを使用してでrsyncを実行していましたsudo crontab。スクリプトは、双方向のrsyncを実行します(serverAからserverBへ、およびその逆)。両方のサーバーマシンを再起動した後、rsyncがで機能しませんsudo crontab。新しいcronjobもセットアップしましたが失敗します。エラーは次のとおりです。 rsync error: unexplained error (code 255) at io.c(600) [sender=3.0.6] rsync: connection unexpectedly closed (0 bytes received so far) [receiver] ただし、ターミナルから実行すると、ryncスクリプトは問題なく期待どおりに動作します。助けてください。

1
16コア/プロセッサの2プロセッサコンピュータ上のSQL Server 2012でのCPU使用率が非常に不均一
サーバー+ Calライセンスモデルを使用してSQL Server Enterprise 2012をインストールした後、それぞれ16コア(ハイパースレッディングを含まない)の2プロセッサーを搭載したコンピューターにサーバーを非常に大きな負荷にかけた場合、最初のプロセッサーの16コアは十分に活用されていませんでした。 2番目のCPUの最初の4コアは頻繁に使用され、最後の12コアはまったく使用されませんでした(このsqlサーバーバージョンには20コアの制限があるため)。合計CPU使用率は約25%と表示されていました。残念ながら、20個のコアにタスクが均等に分散されていたとしても、サーバーのパフォーマンスは非常に悪くなりました。 Windows ServerはESX Serverの下のVMWare仮想イメージで実行されていましたが、すべてのCPUがWindows Serverに割り当てられていました。 アフィニティ設定の変更(たとえば、ほとんどのコアをCPUに割り当て、他のコアをI / Oに割り当てるなど)を試みましたが、パフォーマンスの問題の解決には役立ちませんでした。 製品エディションをSQL Server Enterprise Core 2012にアップグレードすると、SQL Serverは2番目のプロセッサで以前に使用されていなかった12個のコアを利用できるだけでなく、すべてのプロセッサにタスクがより均等に分散されました。リクエストのバックログを処理するために、cpU使用率は約90%に跳ね上がり、追いつかれると約33%に下がりましたが、新しく更新されたバージョンにフェイルオーバーしたため、パフォーマンスは劇的に向上し、パフォーマンスの問題はなくなりました。 SQL Serverが負荷を不均一に分散させる原因を誰かが知っていて、12コアがアイドル状態である2番目のプロセッサの最初の4コアにほぼ独占的に依存していて、最初の16コアのそれぞれにいくつかのタスクのみを割り当てているのではないかと思いました。プロセッサ。また、製品エディションをアップグレードせずに使用されていた20コアに負荷をより均等に分散させる方法はありますか? その質問の裏側は、SQL Serverが認識したすべてのコアに負荷を均等に分散し始めた原因となった製品アップグレードによって何が行われたのでしょうか。 これらの質問やリンクに回答するための洞察に感謝します。これにより、起こったことを理解する方法をよりよく理解するのに役立ちます。

2
Kerberos委任のリスク
IIS 7.5では、Windows認証、Kerberos、SPN、および制約付き委任について学び、理解するために何時間も費やしてきました。管理者やCEOなどに対して委任を有効(つまり、デリケートなアカウントの委任を無効にしない)のままにしておくのが「危険」である理由がわかりません。誰かに簡単に説明してもらえますか?イントラネット環境に関してあなたの答えを組み立ててください。 たとえば、委任によってフロントエンドWebサーバーが他のサーバーと通信するときに、Windows認証されたユーザーに代わって動作することを許可するだけなので、これは問題にならないはずです。その人がアクセス権を持っている場合、彼らはアクセス権を持っていますが、なぜこれが問題になるのか理解できません。 私の無知を許してください。私は主に開発者ですが、私の会社は最近非常に無駄のない状態で運営されており、サーバー管理者の帽子も着用せざるを得ません...

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.