サーバー管理者

システムおよびネットワーク管理者向けのQ&A


3
NTLM認証プロキシを介したapt-get
私は何かが欠けているに違いありません...以前にこれを行ったことを誓うことができますが、以前使用していたVMをトーチしました。 NTLMのみをサポートするプロキシ経由でapt-getを認証するにはどうすればよいですか?他の認証メカニズムもサポートするようにプロキシ設定を変更する必要がありますか? Ubuntu 10.04。

1
debconf:DbDriver“ config”:/var/cache/debconf/config.datは別のプロセスによってロックされています
私のdebian / testingシステムでapt-get upgradeを実行したところ、上記のエラーが発生しました。どうすれば修正できますか?シェルのトランスクリプトは次のとおりです。 136 upgraded, 0 newly installed, 0 to remove and 40 not upgraded. 1 not fully installed or removed. Need to get 182kB/143MB of archives. After this operation, 3671kB disk space will be freed. Do you want to continue [Y/n]? Get:1 http://ftp.us.debian.org testing/main libtiff4 3.9.4-3 [182kB] Fetched …
9 debian 


3
ビルド環境を借りる[終了]
この質問が今後の訪問者を助けることはほとんどありません。それは、地理的に狭い地域、特定の瞬間、またはインターネットの世界中のオーディエンスに一般的に適用できない非常に狭い状況にのみ関連しています。この質問をより広く適用するためのヘルプについては、ヘルプセンターにアクセスしてください。 8年前休業。 特定のニーズがあります。大規模なオープンソースC ++プロジェクトを構築したいのですが、そのための強力なLinuxコンピューターがありません。妥当なビルド時間のために、私は6GB(ish)のRAMと4-8コアのCPUを高い周波数で実行する必要があります。私はこのためにコンピュータを構築することに興味はありません。それは趣味のプロジェクトであり、私がそれを追求するかどうか、またはどれだけ行うかわかりません。VPSは私のニーズに合わず、必要なリソースは非常に高価になります。 問題の一部は、私の使用パターンがWebホスティングと同じではなく、高い稼働時間を必要とするがリソースが少ないことです。週に1〜2時間程度サーバーを使用するだけで済みます。すべてのビルドツールがインストールされている限り、ルートアクセスは必要ありません。多分10-20ギグのディスクスペース。 予算内でこれらの要件を満たすことができるサービスはありますか?1か月あたり約20ドルを費やすことができます。私はこれをグーグルで試しましたが、私のgoogle fooは弱すぎます。前もって感謝します。 (これが間違ったスタック交換サイトである場合は申し訳ありません)
9 linux 

3
FQDNがIPv6として解釈されるかIPv4として解釈されるかを決定するものは何ですか?
URLバーに完全修飾ドメイン名(FQDN)を入力すると、ブラウザーは、要求されたファイルがホストされている場所を決定するマッピングテーブル(このテーブルはどこに保存されているか?サービスプロバイダーと一緒に?)に接続します。 したがって、IPv6アドレスがサポートされているかどうかは、サービスプロバイダー(変換テーブルを持っていると想定している人)によって異なります。本当?

3
EC2インスタンスを自動的にバックアップする最も簡単な方法は何ですか?
ある日ログインすると、完全に構成されたインスタンスが削除されるのではないかと心配です。毎日S3にバックアップできるようにしたいのですが、これはコンソールでの簡単な設定ではありません。 バックアップを処理できるシンプルなマネージドソリューションはありますか。考えられない事態が発生した場合に、すぐに簡単に復元できますか?

6
wgetがファイルを上書きできるようにする方法
ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 wgetコマンドを使用して、起動回数に関係なく、ローカルファイルを毎回上書き/許可する方法を教えてください。 たとえば、http://server/folder/file1.htmlの場所からファイルをダウンロードするとします。 ここで、と言うときはいつでもwget http://server/folder/file1.html、file1.html変更された時間やダウンロード済みの時間などに関係なく、ローカルシステムでこれを上書きします。ここでの意図/使用例は、wgetを呼び出したときに、既存のファイルを置換/上書きします。 以下のオプションを試してみましたが、各オプションは他の目的のために意図された/意味があります。 -nc => --no-clobber -N =>タイムスタンプをオンにする -r =>再帰的な取得をオンにします

11
素人や初心者に複雑な専門用語を伝えるためにどのような比喩を使用しましたか?[閉まっている]
休業。この質問は意見に基づいています。現在、回答を受け付けていません。 5年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 システム管理者は、複雑な技術用語や状況を素人や初心者に常に伝えざるを得ません。私たちは、あなた方一人一人が私たちが毎日目にするかもしれないものを説明するためにどのような比喩を考案したのか疑問に思っていました。 たとえば、悪名高い水冷レイド図を覚えていますか? 私は各回答に1つのトピックまたは用語と、それに対応する素人の言葉のメタファーが欲しいと思っていました。
9 untagged 

6
ファイアウォールのアンチパターン?
ファイアウォールを構成する最も一般的で間違った方法は何ですか?次のリストから始めます。 ICMPを盲目的にブロックする。これは、スマーフ攻撃が大流行した1998年の一般的な慣行でした。今日、PMTUブラックホールを作成し、問題の診断を困難にするリスクを負っています。ICMPをブロックする必要がある場合は、少なくともフラグメント化を許可し、要求/応答をエコーし​​ます。 古いルール。ルールに有効期限を設定できないのは残念です。サービスを移行するとき、古いサービスのルールを削除することを忘れがちです。
9 firewall 

5
ラックレイアウトの推奨事項
私たちのラボには24Uラックがあり、大規模なハードウェアのアップグレードが予定されているため、来週中に完全に再設計する予定です。 サーバーコンポーネントのレイアウトについていくつか質問があります。 UPS。この時点で、すべてのUPS(非ラックマウントを使用)はラックの上部近くの棚に設置されています。UPSを常に下に置くことを勧める人もいますが、最も近いサーバーがその上にあるとしたらどうでしょうか。サーバーがダウンしているときに問題が発生したことは一度もありませんが、決して言ったことはありません。1つはラックスタンドに落下したときの話、もう1つは機器がクラッシュしたときの話です。 スイッチ。通常、人々はそれらをラックの上部に置くことを勧めますが、これを行う唯一の実用的な理由を見ることができます:ラックマウントKVMを開くと、スイッチのフロントパネルにアクセスできなくなります。スイッチ以外の機器。一方、すべてのケーブルは下から出ているため、ラック全体に引き伸ばす必要があります。ケーブルを頻繁に変更する場合(ラボ/開発環境で行う)、頭痛の種になる可能性があります。 パッチパネル-使用するかしないか。そして使用する場合、どうやって?通常、人々はすべての入力ケーブルをパッチパネルに接続し、次にパネルRJソケットを使用してそれらをラック内に配線します。大規模な設置には便利だと思います。しかし、実際には約8本のケーブルが出入りします。なぜスイッチに直接接続しないのですか? 機器を接続するためだけに短いケーブルを使用しますか、それとも切断せずにサーバーを引き出すためにケーブルを長くしますか?最初の選択は、将来的にケーブルの問題を引き起こすことは決してありませんが、サーバーの電源を切らずにサーバーを停止することはできません。これは開発ラボ用ですが、一部の機器をオフライン(つまり、SAN)にすると、ラボ全体が1時間まで停止する可能性があります。 おそらく1つの質問には十分です。すべての回答をありがとう。
9 hardware  rack 

3
Windows Server 2008-127.0.0.1への接続
Windows Server 2008 R2を実行している場合、サーバー上のパブリックIPから127.0.0.1:8334に接続(バインド)するアプリケーションがあります[0.0.0.0:8334でリッスンしているサービスに接続します] Windows 2003では、この問題はありませんでした。1.2.3.4 [eg]から127.0.0.1:8334までのTCPを使用して接続できます。 Windows 2008では、パブリックIP(例:1.2.3.4から127.0.0.1:8334)へのTCP接続が失敗することさえあります。ただし、サービスは127.0.0.1から127.0.0.1:8334、および127.0.0.1から1.2.3.4:8334への接続を受け入れます。 Windowsファイアウォールをオフにして、そのロギングなどを設定しようとしましたが(有用なログエントリは表示されません)、役に立たなかった。これは新しいネットワークスタックの問題ですか? 編集 1.2.3.4が同じマシンのlocalhost [127.0.0.1]に接続しようとしています ホストファイルは、デフォルトのWindows 2008ホストファイルです。 ループバックチェック情報、興味深い。試してみました... IDがすべてを正しく行ったことを確認するためにクロスチェック-私は持っています。 NATを使用するか、ポートを転送する他の方法があるかどうか疑問に思います-127.0.0.1:portを1.2.3.4:portに転送すると、それは機能しますか?アプリが0.0.0.0:portでリッスンすると、1.2.3.4:portで接続をピックアップします HOSTSファイルにはlocalhost 127.0.0.1が含まれていますが、hostsファイルはホスト名ルックアップでのみ使用されます。この場合、アプリケーションはホスト名を検索しません。これは、127.0.0.1のIPアドレスが(localhostホスト名ではなく)ハードコードされているためです。したがって、HOSTSファイルはここでは機能しません。 1024を超えるポートについては(おそらくMaxUserPortの問題を参照していると思いますか?)ポート445への単純な接続を試行してこれをテストしました-127.0.0.1からは機能しますが、ソースIP 1.2.3.4から接続すると機能しません。445は標準のWindowsサービスなので、動作するはずです。 現在、マシンでNATまたはRRASを実行していません...再ルーティングを行う方法があったかどうか疑問に思っていました-再ルーティングするループバックインターフェイスに到達する前にTCP / IPスタックがパケットを拒否するため、機能しないと思います。 私がチェックしたルートプリントは問題ないようです。パブリックIPが最初にルーティングされ、最後に127.0.0.0ネットマスク255.255.255.0と127.0.0.1ネットマスク255.255.255.255の両方がループバックされます。 編集は 私が問題の原因にとしての答えを発見したようです。私はeventvwr.mscを使用し、Winsockログを有効にし、他のサービスをオフにし、この接続テストを試しました。エラーが発生しましたが、16進数でSTATUS_INVALID_ADDRESS_COMPONENTにマップすると、グーグルしたときにエラーが発生しました。 それで私は次のようになりました:http : //social.msdn.microsoft.com/Forums/en-US/wfp/thread/d7cb6138-3f67-4467-a068-8325f56739ba これにより、これはVista / 7 / Server 2008 [Windows Filtering Platform]のWFPの仕様による変更であることが確認されました。 [Anupama Vasanthによる応答を参照] 私はハードなルートに行き、コードを書き直さなければならないようです[マネージャーと取引することを意味するため、ハードです!] 問題の特定/確認を手伝ってくれてありがとう!

1
Ubuntu Server 10.04でのMySQLデータディレクトリの変更
ubuntuサーバー10.04でデータディレクトリを変更しようとすると、次のエラーが発生しました。 100809 19:33:00 [Note] Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13) 100809 19:33:00 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it. 100809 19:33:00 InnoDB: Operating system error number 13 in a file operation. InnoDB: The error means mysqld does not have the …

2
ZFSとキャッシュデバイス
SSDドライブをキャッシュとしてZFSストレージに追加します。誰もがこれで何か経験がありますか?キャッシュデバイスが停止した場合、データは影響を受けますか?
9 cache  ssd  zfs 

1
LinuxでのプロキシPACファイルのサポート
私の企業環境は、外部インターネットアクセスをブロックし、NTLM認証を必要とするプロキシでセットアップされています。内部アドレスはプロキシとしてルーティングされないため、直接アクセスする必要があります。 この環境(通常はWindowsのみ)でLinuxマシンをセットアップし、外部インターネットアクセスを必要とするコマンドラインツールを使用しようとしています。プロキシへの認証に優れたNTLMapsを見つけました。ただし、問題はLinuxのHTTP_PROXY環境変数を設定するときです。これは、多くのプログラムがプロキシを決定するために使用し、常にプロキシサーバーを使用します。代わりに、PACファイルに基づいてプロキシ/ダイレクト接続を使用する必要があります。 非常に手作業による解決策は、イントラネットにアクセスしたいときにHTTP_PROXY環境変数をクリアし、インターネットにアクセスしたいときに入力することですが、それは面倒です。 誰でもこれを行う方法を知っていますか?(Linuxグローバル.pac設定など...)
9 linux  proxy 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.