サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
より重い仮想化の下でLXCを使用する(Xen、KVM、Hyper-V、VMVare)
より重い仮想化(Xen DomU、KVM、Hyper-V、VMVare)の下でLXCを使用することは可能ですか?セキュリティ(分離)ツールとして使用したいのですが、リソースの消費を制限する機能は優先されません。それが簡単な方法で行えるかどうかだけに興味があります。非仮想化サーバーでのLXCの使用に似ています。本番サーバーでトリッキーなセットアップを使いたくありません。

2
受信者が電子メール転送を持っている場合のSPFハードフェイルとDKIMの失敗
ドメインにhardfail SPFを構成し、SMTPサーバーにDKIMメッセージ署名を構成しました。これは私のドメインからの送信メールに使用する必要がある唯一のSMTPサーバーであるため、複雑さは予測していませんでした。 ただし、次の状況を考慮してください。SMTPサーバーを介して、同僚の大学の電子メールに電子メールメッセージを送信しました。問題は、私の同僚が大学のメールをGMailアカウントに転送していることです。これらは、GMailメールボックスに到達した後のメッセージのヘッダーです。 Received-SPF:失敗(google.com:me@example.comのドメインは192.168.128.100を許可された送信者として指定していません)client-ip = 192.168.128.100; Authentication-Results:mx.google.com; spf = hardfail(google.com:me@example.comのドメインは、192.168.128.100を許可された送信者として指定していません)smtp.mail=me@example.com; dkim = hardfail(テストモード)header.i=@example.com (ヘッダーはGoogle以外の関係者のドメインとIPアドレスを保護するために無害化されています) GMailは配信チェーンの最後のSMTPサーバーをSPFおよびDKIMレコードと照合します(正しくそうです)。配信チェーンの最後のSTMPサーバーは大学のサーバーであり、私のサーバーではなかったため、チェックの結果、SPFハードフェイルとDKIMエラーが発生しました。幸い、GMailはメッセージをスパムとしてマークしませんでしたが、これが将来的に問題を引き起こす可能性があることを懸念しています。 私のSPFハードフェイルの実装はおそらく厳しすぎるでしょうか?他に知っておくべき推奨事項や潜在的な問題はありますか?それとも、大学の電子メール転送手順にもっと理想的な構成があるのでしょうか。転送サーバーがエンベロープ送信者を変更する可能性があることは知っていますが、混乱することがわかります。

3
Windows 7でLDAPサーバーをセットアップする方法 [閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 質問:開発目的で、Windows(7)マシンにLDAPサーバーをセットアップする必要があります。 それ、どうやったら出来るの?そして、そこにデータをどのように取得しますか?
9 windows-7  ldap 

1
SGEでユーザーごとに実行中のジョブの最大数を設定するにはどうすればよいですか?
SGE(Sun Grid Manager)を使用しています。すべてのユーザーからの同時ジョブの合計数にはいくつかの制限があります。 特定のユーザーの同時実行ジョブの数に一時的な任意の制限を設定できるかどうかを知りたいのですが。 たとえば、ユーザーdaveは500個のジョブを送信しようとしていますが、たとえば、ジョブがファイルシステムをスタックする大量のI / Oを実行していることを知っているため(実際の話、残念ながら)、100個以下のジョブを同時に実行したいと考えています。 それは可能ですか?


4
ボリュームシャドウコピーを使用したSQL Serverバックアップ
Windowsの多くの有名なバックアップユーティリティは、新しいバージョンのWindowsに組み込まれているボリュームシャドウコピーサービスを使用して、開いているファイルを安全にバックアップするために、ディスクの特定の時点のスナップショットを作成します。 しかし、このメカニズムはSQL Serverでどの程度うまく機能しますか?SQL Server VSS Writerは、バックアップシステムとSQL Serverの相互運用を支援するために存在しますが、すべてのバックアップシステムがSQL Serverについて知っていて、SQL Serverが提供するバックアップ関連のAPIを利用しているわけではありません。 だから私の質問は、SQL Serverについて何も知らないプログラムについてはどうですか? おそらく、MDFファイルとLDFファイルが1つの瞬間に存在していたため、それらのポイントインタイムスナップショットを取得します。そしておそらくSQL Serverのデータ形式は十分に堅牢であり、そのようなスナップショットは一貫性があり使用可能であることが保証されます。 それは物事が機能する方法ですか、それとも何か不足していますか?そのようなバックアップメカニズムを使用することについての「落とし穴」はありますか、それとも私は安全ですか?

6
ソフトウェア配布を管理するWebアプリケーション
私は小さなソフトウェア開発会社のIT担当者です。当社のWebサイトからライセンスを購入したお客様がダウンロードできるソフトウェアがあります。ソフトウェアのダウンロードプロセスをより適切に管理するための解決策を見つけようとしています。新しいリリースごとに、さまざまなプラットフォームと構成用のビルドがあります(合計で約50の個別にダウンロード可能なコンポーネント)。各顧客は、これらのコンポーネントの小さなサブセットにのみアクセスできます。私は現在、いくつかのperlスクリプトを使用してこれらすべてを「管理」していますが、かなり大雑把です。 顧客がログインして、購入したダウンロード可能なコンポーネントを表示できるWebアプリケーションについて考えています。私たちのWebサイトなどでソフトウェアを購入することに特別な手間をかける必要はありません。少なくとも最初は、個々のダウンロードへのアクセスは顧客ごとに手動で管理されます。Project Drupalモジュールの使用を考えていますが、必要なことを行うには、いくつかの大きな変更が必要になります。これにより適したものはありますか?

1
mod_proxyとmod_proxy_ajpとmod_jk
次の環境からの移行の準備をしています。 Apache 2.0.2 --AJP-> JBoss4.2.2 に Apache 2.2.3-???-> JBoss 5.1.0 2つをどのように結合しますか? オプションは次のとおりです。 クラシックAJP(Apache用のmod_jkの構築を意味) mod_proxy(HTTPリクエストをJBossに転送) mod_proxy_ajp オプション2は現時点で最も人気のあるソリューションです。これは、AJPからのJBossの応答を変換する必要がなくなるため、処理が少なくなるようであり、CPU時間は、インフラストラクチャで注意深く監視する必要があるものです。オプション2および3には、Red HatがサポートするApacheビルドも付属しています。 現時点では、オプション3で「無料」のAJPを取得しているため、オプション1に進むことはできません。 したがって、オプション2と3の長所と短所は何ですか?CPU負荷に関する懸念は本当に心配する必要があるのでしょうか?バイナリデータ(AJPトラフィック)の処理で失われたものは、帯域幅とIOの低下で回復できますか 私たちのインフラストラクチャーは、プライベートクラウドで仮想化された同じRHEL 5マシン上で、Apache から最大 9つの高度に調整されたJBosses(通常はその約半分)に向かいます。 ポインタ/アドバイスを事前に感謝します。 リッチ
9 apache-2.2  ajp 


5
OS Xにデーモンアカウントを追加する
自分のマシンにデーモン(Oracle Grid Engine)を手動でインストールしようとしていますが、分離されたアカウントで実行したいのですが。OS Xのローカルマシンに「システム」アカウントを追加するには、ディレクトリサービスを使用してどのような方法が推奨されますか?それらのプレンティは、/ etc / passwdファイル(中に存在する_www、_dovecotなど)が、これはシングルユーザーモード以外で使用されていないこと、そのファイルの発言の先頭のコメント。 10.6で実行しており、特別なネットワークアカウント管理を必要としません。私は何か単純なものを望んでいます- useradd他のほぼすべてのUnixライクなOSに相当するものです。

3
mysqldumpエラーロックテーブル
mysqldumpを実行すると、次のエラーが発生します。 mysqldump -u root -ppassword --databases information_schema > test.sql mysqldump: Got error: 1044: Access denied for user 'root'@'localhost' to database 'information_schema' when using LOCK TABLES どうすれば修正できますか?
9 database  mysql 

5
最初の試行時のSQL Serverタイムアウト
Visual StudioのデータソースまたはSQL管理コンソール自体を介して、2台目のコンピューター(Win7 64ビットを実行する両方のコンピューター)で実行されているSQL Server 2008に接続しようとすると、奇妙な問題が発生します。 最初に接続しようとすると、タイムアウトします。2回目の試みはうまくいきます。 2台目のコンピューターの共有に問題なくアクセスできます。アプリケーションインスタンスごとにSQLに接続しようとしたのは初めてのようです。つまり、2つのVisual Studioインスタンスを開くと、どちらも最初の接続では失敗しますが、2回目の接続では成功します。インスタンスごとに2回接続する必要があります(他のアプリケーションでの失敗/成功のシーケンスに関係なく)。 私はそれが理にかなっていると思います。 何かアドバイス?

7
C:\はOS用、D:\はデータ用ですか?
「昔に」私たちは常にOSドライブ(Windows)をデータドライブから分離しました。Linuxの世界では、あまり慣れていませんが、知恵によって、ベストプラクティスの構成で定義および使用されるボリュームがさらに増えることがわかっています。 サーバーストレージがSAN(ディスクリソースが多くの個々のオペレーティングシステムとアプリケーションによって共有されている)上にある可能性が高いので、OSとデータパーティションをボリュームレベルで分離することは本当に重要ですか? あなたの考えは何ですか?

1
失敗した完全バックアップは、将来のトランザクションログバックアップを無効にしますか?
SQL Server 2005を実行しているサーバーがあります。トランザクションログのバックアップを15分ごとに毎晩行う完全バックアップがあります。これは比較的小さなサーバーなので、差分バックアップは行いません。 毎晩のフルバックアップの1つが失敗した場合、前の夜のバックアップと両方の日のすべてのトランザクションログを使用してデータベースをリカバリできますか、それとも見つからないフルバックアップに問題がありますか?

2
Windowsサービスがネットワーク共有にアクセスできない
ローカルマシンでWindowsサービスを実行しています。NT AUTHORITY \ NETWORK SERVICEで実行するように構成されています。プログラムは、同じサブネット内のコンピューター上のネットワーク共有ドライブにアクセスします。その共有ディレクトリでは、Everyoneがフルコントロールに設定されています。 File.Exists()でFalseを取得していますが、ファイルは存在します。これは許可の問題だと思います。忘れ物はありますか?共有ドライブのあるコンピュータはドメイン上にないことに注意してください。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.