サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
SQL Server 2008のデフォルトのスキーマが尊重されていませんか?
テストのために、SQL 2008データベースを別のサーバーにコピーしました。ログインする一般的なユーザーは、特定のスキーマのいくつかのオブジェクトを使用します。それがユーザーfooとスキーマだとしましょうbar。 fooのデフォルトのスキーマはbar、インスタンスレベルとデータベースレベルの両方にあります。ただし、fooログインするとbar、完全修飾名を使用しないとスキーマ内のオブジェクトを見つけることができません。 ここでデフォルトのスキーマが機能しないのはなぜですか?

5
Webサーバーのセキュリティオーバーキル?
私はLinux Webサーバーのセキュリティ保護について「広範囲」の調査を行ってきました。「基本」と見なされるもの(未使用のサービスの削除、ssh、iptablesの強化など)に加えて、ルートキット対策(Tripwire)とウイルス対策(ClamAV)を含めることは賢明ですか?これらはWebサーバーにとってはやり過ぎですか?これは非常にあいまいな質問であることは知っていますが、他の意見に興味があります。 私の将来の環境:-ubuntu 10.04-fail2ban-nginx 0.8.x-php 5.3.x(suhosin、apc、memcached)-mongodb 1.6.x 可能なアプリケーション:-Webサービス-ユーザーがアップロードするWebアプリ(写真、PDFなど)-典型的なWebサイト(フォームなど) 他にヒントがあれば、遠慮なく追加してください! ありがとう

3
SSDでの安全な削除
磁気HDDの物理セクターを上書きする「従来の」安全な削除ユーティリティはSSDで機能しますか、それともSSDはセクターを単に「再マッピング」して、高価な削除操作を回避し、不確定な期間データをそのまま残しますか?

3
誰もがMySQLフォークをプロダクションで使用した
MySQLはOracleが所有するようになったため、MariaDBやDrizzleなどの人気のあるフォークの使用を検討し始めています。 これらの製品を長期間使用した人はいますか?もしそうなら、機能は安定していて、経験はMySQLに匹敵しますか?
9 mysql  mariadb 

2
LDAP認証:Windows Server2k3と2k8
私たちには約70%のLinuxユーザーがおり、そのすべてがLDAPを介してActive Directoryに対して認証するように構成されています。これが機能するために、Windows Server 2003で「Windows Services for Unix」を使用しましたが、すべて正常に機能します。 この仕掛けを実行しているサーバーが少し疲れてきて、Windows Server 2008を実行している新しいマシンに置き換えられる段階になりました(ユーザー名のマッピングやパスワードの変更などの関連サービスが統合されています) OS)。 ここに問題があります。Win2k3サーバーを介して新しいユーザーが構成されている場合、すべて正常に動作します。同じことがWin2k8サーバーを介して行われる場合、次のようになります。 2k3サーバー上のADSプラグインはそれを認識せず、UNIX属性が設定されていないかのように動作します。 ユーザーはLDAPを使用してADSに対して認証できません。 誰かがこの問題に遭遇しましたか?もしそうなら、これをどのように克服しましたか? さらにサポートを提供するために追加情報が必要な場合は、お問い合わせください。私が提供します。

4
ADのACEで孤立したSIDをクリーンアップする方法は?
私の質問のフォローアップとして、削除されたユーザーに対してADでバックリンクをクリアしてください。 回答で、削除されたオブジェクトのSID(グループまたはユーザー、つまりグループに権限を割り当てると問題が最小限に抑えられ、修正されない)が通知されるため、割り当てられたACE内に残り、孤立したままになります。 Lotus Dominoには、後方参照に関して同様の問題があり、孤立した参照をクリーンアップするためのadminpプロセスがあります。 ドメイン内に浮かぶこのような孤立したSIDをクリーンアップできるようにするADの同様のプロセスはありますか?


3
nginx、x-accel-redirectおよびmimeタイプ
私のnginx 0.8.34セットアップでは、X-Accel-Redirect機能を使用して、アプリケーション自体でダウンロードを処理せずに、アプリケーションコードでファイルのダウンロードを制御しています。 多くの苦痛の後、これは今や基本的に動作しますが、nginxは常にtext/htmlコンテンツタイプのファイルを返します。 デフォルトのコンテンツタイプは、httpブロックで指定されたapplication / octet-stream です。 サーバーブロックには、特に、ファイルが格納されているディレクトリの定義が含まれています。 location /files { default_type application/octet-stream; alias /srv/www/uploads; internal; } したがって、ここでもコンテンツタイプを指定しましたが、何も変更されていません。 アプリケーションでContent-Typeを設定したくないので、速度が低下します(最初に確認する必要があります)。したがって、理想的には、nginxはファイル拡張子に基づいて正しいmimetypeを返します(httpブロックにはmime.typesを含めます)。
9 nginx  mime  mime-type 

2
LinuxとSVN:KEEPディレクトリ構造以外のすべてのバージョン付きファイルを削除する方法、.svn dirsを無視?
リポジトリからバージョン管理されたすべてのファイルを削除したいのですが、バージョン管理されたディレクトリ構造を保持します。明らかに、すべての.svnディレクトリはそのままにしておきたいです。 つまり、ディレクトリ構造自体に害を与えることなく、作業コピーのディレクトリ構造を完全に空にしたいのです。 たとえば、次の構造からファイルを削除します。 dir/ .svn/ [files] svsubdir1/ file1 .svn/ [files] subdir2/ file2 file3 file4 .svn/ [files] subsubdir1/ file5 .svn/ [files] 結果として: dir/ .svn/ [files] svsubdir1/ .svn/ [files] subdir2/ .svn/ [files] subsubdir1/ .svn/ [files] findこれを達成するためのコマンドや何かを探していますが、コマンドの作成に問題があります。助けてくれてありがとう!
9 linux  svn  find  recursive 

4
WindowsにシームレスなRDPモードはありますか?
rdpを介して複数のマシンに同時に接続しています。どういうわけか各マシンに一度ログインしてから、すべてのリモートウィンドウをローカルデスクトップとタスクバーに直接表示して、異なるマシンのウィンドウ間で直接alt + tabなどを行うことはできますか? (追加のソフトウェアが必要な場合は、管理者権限を必要としないフリーウェアが推奨されます) 編集 harrymcのおかげで、基本的にはリモートデスクトップサービス(別名Application Virtualization)のクライアントサイトの管理者不要のフリーウェア実装を検索することがわかりました。

2
MySQLデータベースへの接続エラー
私のアプリケーションは、別のマシンのmysqlデータベースにかなり頻繁に接続する必要があります。ただし、接続時に頻繁にエラーが発生します。通常は最終的に接続できますが、何度も再試行した後です。私が得るエラーメッセージは: Mysql.mysql(): Couldn't connect to SQL-server: Lost connection to MySQL server at 'reading authorization packet', system error: 2 私はここで情報を読みました:http : //dev.mysql.com/doc/refman/5.0/en/error-lost-connection.htmlとバグへのコメントhttp://bugs.mysql.com/bug .php?id = 28359。 あなたが見ることができるように、中止された接続の数はかなりあります: mysql> SHOW GLOBAL STATUS LIKE 'Aborted_connects'; + ------------------ + ------- + | 変数名| 値| + ------------------ + ------- + | Aborted_connects | 2540 | + …

6
PATH変数から重複するエントリを削除する
私は頻繁に.bashrcを変更してから、それを調達しています。ただし、export PATH="~/bin:~/perl5/bin:$PATH"ファイルに次のようなものがある場合 、ファイルを読み込むPATHたびに環境変数が大きくなります。 たとえば、最初に.bashrcが読み込まれるとき、PATH変数はで構成され~/bin:~/perl5/bin:/usr/bin:/binます。 2回目はで構成され~/bin:~/perl5/bin:~/bin:~/perl5/bin:/usr/bin:/binます。 3回目は~/bin:~/perl5/bin:~/bin:~/perl5/bin:~/bin:~/perl5/bin:/usr/bin:/bin。 PATHに含まれていないものを追加するだけの簡単な方法はありますか?
9 bash  shell  path  bashrc 


5
Apacheは特定のサイトのServerNameディレクティブを尊重していません
Apacheを使用してVirtualHostsとして構成されているサイトがいくつかありますが、しばらくの間は正常に機能しています。私は最近、サーバーのホスト名をサービスされているドメイン名の1つに変更し、サーバーの外部IPアドレスを指す/ etc / hostsにも追加しました。 私がそうしたので、私のラップトップからドメインにアクセスすると、Apacheのデフォルトの「It works!」に移動します。ページ。/ etc / apache2 / sites-enabled /から000-defaultを削除すると、正しいサイトが表示されます。「www」でサイトにアクセスしようとしています。接頭辞は、000-defaultがサイト対応であるかどうかに関係なく、正しいサイトに移動します。 これらすべてに基づいて、ホスト名または/ etc / hosts(またはその両方)を構成した方法が原因で、デフォルトの構成がデフォルトのページを提供していると思いますが、それを無効にする方法がわかりませんそれらの設定をそのまま残します。どんな提案も歓迎します! 編集-現在のVirtualHost構成は次のようになります。 <VirtualHost *:80> ServerName domain.com ServerAlias www.domain.com ServerAdmin me@domain.com DocumentRoot /srv/www/domain ErrorLog /srv/www/domain/logs/error.log CustomLog /srv/www/domain/logs/access.log combined </VirtualHost> 要約すると、いくつかのVirtualHostsがセットアップされていますが、これが正しく機能しない唯一のVirtualHostsです。http://www.domain.comには問題なくアクセスできますが、http://domain.comを使用すると、Apacheのデフォルトの "It works!"が表示されます。ページ。000-default構成を無効にすると、適切なページが表示されます。これは、サーバーのホスト名をdomain.comに設定し、domain.comがサーバーの外部IPアドレスを指すように/ etc / hostsに行を追加した後にのみ発生し始めました。できればそのままにしておきたいです。 編集:私は走ったapache2ctl -Sので、/usr/sbin/apache2 -S「:悪いユーザ名$ {} APACHE_RUN_USER apache2の」私を与えました。出力は次のとおりです。 VirtualHost configuration: wildcard NameVirtualHosts and …

4
QAテスト用のWindowsデスクトップ(XP、VistaまたはWin7)EC2 AMI
WindowsデスクトップクライアントでWindowsベースのアプリケーションのQAテストを実行する必要があります。また、EC2がサーバーベースではないWindowsイメージ(Server 2003など)をサポートしているかどうかを知りたいです。私は、Amazonのロードマップにデスクトップクライアントがないことを示唆する多くの投稿を検索して見つけましたが、Amazon自身からの決定的なものはありません。 EC2がWindowsのデスクトップインストールをサポートしていない場合、それをサポートするサービスはありますか? ありがとう

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.