サーバー管理者

システムおよびネットワーク管理者向けのQ&A

8
CentOSにPHP 5.3をインストールするにはどうすればよいですか?
CentOSサーバーにPHP 5.3をインストールする必要があります。実行するyum install phpと、ベースリポジトリは5.1.6をインストールしますが、これはインストールする必要があるアプリケーションには古すぎます。したがって、私はIUSからの公式の指示に従って、IUSリポジトリを使用しようとしています。 root@linuxbox ~]# wget http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/x86_64/ius-release-1-2.ius.el5.noarch.rpm root@linuxbox ~]# wget http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/x86_64/epel-release-1-1.ius.el5.noarch.rpm root@linuxbox ~]# rpm -Uvh ius-release*.rpm epel-release*.rpm OK。今yum install php53、私は必要なすべてのことを行うなどしています...しかし、私はこのエラーを受け取ります: Running rpm_check_debug Running Transaction Test Finished Transaction Test Transaction Check Error: file /usr/bin/php from install of php53u-cli-5.3.4-3.ius.el5.x86_64 conflicts with file from package php-cli-5.1.6-27.el5_5.3.x86_64 file /usr/bin/php-cgi from install of php53u-cli-5.3.4-3.ius.el5.x86_64 …

2
OSXドメインにログインするときにユーザーグループを要求する
ユーザーが複数のグループのメンバーである場合、10.6マシンにログインすると、設定を適用するグループを尋ねるプロンプトが表示されます。 ユーザーメンバーシップに基づいて、グループを使用して、Productionおよびなどのさまざまな共有をマウントAccountsしています。多くの場合、ユーザーは複数のグループのメンバーであり、使用可能なすべてのドライブが必要です。 Open Directoryサーバーも10.6を実行しています。 このプロンプトをスキップしてすべてのグループに設定を適用する方法はありますか?グループ設定間で競合が発生する可能性があると予測できますが、優先度も設定できるでしょうか?または、これはこれについて完全に間違った方法ですか?

9
SQL Serverの "sa"アカウントにログインしようとブルートフォースで攻撃しようとするユーザーについてはどうすればよいですか?
誰かまたは何かが、 'sa'アカウントを使用して本番SQL Serverインスタンスにログインしようと力ずくで試みているようです。「sa」アカウントが無効になっているために成功しませんでしたが、セキュリティを確保するためにどのような手順を踏む必要がありますか?


5
MSMQメッセージキューのプロパティを編集するとアクセスが拒否される
コンピューターの[コンピューターの管理]を使用して、メッセージキューのプロパティ(具体的には、メッセージの保存制限)を調整しようとしています。次のメッセージで失敗します。 のプロパティを設定できません。 エラー:アクセスが拒否されました。 ローカルのAdministratorsグループの一部であるアカウントでログインしています。私が試した他のすべての管理タスクを実行できます。これらの設定を変更できない原因は何ですか? プラットフォーム:Windows Vista Business SP2(x64)

4
htaccessに配置されるルールの順序は重要ですか?
これが単純な「はい」または「いいえ」の答えであることを願っています(理由を明記してください) Q1:ルールがhtaccessに配置される順序は重要ですか? それらは完全に分離されたアイテムなので、例えば Q2:はいの場合、正しい注文を適用していますか? htaccesエンジンを高速化し、不必要なルールで過負荷にしないために? Q3:ここで無効にする/追加するためのヒントは、大歓迎です+1! # DirectoryIndex index.php /index.php AddDefaultCharset UTF-8 RewriteEngine on # Options All # Options +FollowSymLinks # Options +FollowSymLinks -Indexes -ExecCGI # RewriteBase / ##################################################### <IfModule mod_headers.c> ExpiresActive On ExpiresDefault M172800 Header unset ETag FileETag None Header unset Pragma ##### STATIC FILES <FilesMatch "\\.(ico|jpg|png|gif|svg|swf|css|js|fon|ttf|eot|xml|pdf|flv)$"> ExpiresDefault M1209600 …

6
コマンドラインからの「このアクセス制御リストは正規の形式ではありません」エラーの修正
私たちのいくつかの開発ワークステーションでは、「このアクセス制御リストは正規の形式ではないため、変更することはできません」という恐ろしいことがありました。特定のフォルダにアクセス許可を設定しようとすると、エラーが発生します。これらのACLを破損している原因を特定することはできません。 今のところ、私がそれを修正する唯一の方法は、破損したフォルダー/ファイルを右クリックし、[プロパティ]を選択して[セキュリティ]タブをクリックすることです。その後、Windowsは破損を認識し、修正を提案します。これは手動なので、ユーザーがいくつかの調査を行って、どのフォルダー/ファイルが破損しているかを調べる必要があるため、私はこれが好きではありません。 これを自動的に行うスクリプトまたはプログラムはどこにありますか?パラメータが表示されていますが、ファイル/フォルダのACLが破損しicaclsていることがわかり/verifyます。何かを修正することはできません。

6
vSphereコンソールの表示がとても遅いのはなぜですか?
vSphereクライアントのコンソールビューが遅いのはなぜですか?コンソールの速度が原因でVMの1つで作業するたびにRDPセッションを確立する必要があるのは残念です(vSphere ClientでVMへのRDPセッションを右クリックして開くツールを見ました) / ESXですが、これは信頼できませんでした)。 ワークステーションコンソールビューは非常にスムーズなので、vSphere Clientコンソールビューは非常にスムーズであると思います。

2
ext3ファイル名に無効な文字はありますか?
ext3ファイル名にはどの文字が無効ですか?私は少なくとも/無効な文字であり、おそらくそうだと思い\0ます。公式リストはどこにありますか? この情報をどこで探すか正確にはわからないので、どこで見つけたのか教えてください。
9 linux  ext3 

1
デフォルトでrootユーザーがrootという名前になっているのはなぜですか?
これはばかげた質問のように思えるかもしれませんが、これは混乱しているように見えます。例えば: 「ルートディレクトリに移動」 次のように解釈できます: に行く / に行く~root(通常/root/) 私はsuperより良いデフォルトの管理者ユーザー名のために作られたようなものだと思います。これにより、ディレクトリ構造のあいまいさが回避されます。 もう一度:ばかげた質問ですが、私は本当に興味があります。

3
v2をv3にアップグレードする方法FSFS Subversionファイルシステム
まず、(TortoiseSVNを使用して)ブランチをトランクに再統合しようとしていますが、「マージ情報のクエリにはバージョン3のFSFSファイルシステムスキーマが必要です。ファイルシステムE:/ MyRepository /はバージョン2のみを使用しています」というエラーメッセージが表示されます。 以前のバージョンのsubversionでブランチを再統合することは本当に不可能でしたか?またはこれを行う別の方法はありますか? とにかく、どうすればファイルシステムをバージョン2からバージョン3にアップグレードできますか?
9 svn 


3
tcを使用した低速接続のシミュレーション
ネットワークトラフィックを制限するLinuxボックス(Centos 5.5)があります。クライアントに配布するアプリケーションがあり、256Mbit /秒の最小推奨帯域幅でテストしたいと思います。これまでのところ、私が見たtcチュートリアルでは、特定の基準に従って帯域幅を制限できるようですが、すべての状況で(IPヘッダーの外観に関係なく、すべてのIPアドレスとの間で)帯域幅を制限したいと思います。 私が使用することを示唆した1つのチュートリアル: tc filter add dev eth0 protocol ip parent 10: prio 2 flowid 10:2 しかし、私は次のエラーを受け取ります: Unknown filter "flowid", hence option 10:2 is unparsable すべての状況でeth0に出入りする帯域幅を制限する方法に関するアイデアはありますか?


2
SSH Key Exchangeはパスワード認証よりも安全ですか?
リモートユーザーは、SSHを使用してインターネット経由で本社のいくつかのサービスに接続します。SSHパスワードは、LAN A / Dアカウントと同期されます。 ユーザーがパスワードを入力するよりも、CDや紙などを使用してSSHキーのコピーを自宅に持ってくる方が安全でしょうか?それとも両方必要ですか? 私の質問はおそらく次のように再定式化できます。SSHのパスワード認証プロトコルに脆弱性はありますか? 疑わしいのはこのメッセージです: The authenticity of host 'xxx.xxx.xxx.xxx (xxx.xxx.xxx.xxx)' can't be established. RSA key fingerprint is xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:. Are you sure you want to continue connecting (yes/no)?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.