サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ファイバーチャネルファブリック上のデバイスの正しい配置
ファイバーチャネルファブリック用の新しい8 Gbスイッチのペアを取得しています。プライマリデータセンターのポートが不足しているため、これは良いことであり、2つのデータセンター間で少なくとも1つの8Gb ISLを実行できるようになります。 2つのデータセンターは、ファイバーが走るときに約3.2 km離れています。私たちはここ数年、4Gbの安定したサービスを利用しており、8Gbも維持できることを期待しています。 私は現在、これらの新しいスイッチを受け入れるようにファブリックを再構成する方法を考えています。数年前のコスト決定により、完全に独立したダブルループファブリックは稼働していません。完全な冗長性のコストは、スイッチ障害のありそうもないダウンタイムよりも高価であると考えられていました。その決定は私の時間の前に行われ、それ以来、物事はあまり改善されていません。 この機会に、スイッチの障害(またはFabricOSのアップグレード)に備えてファブリックの回復力を高めたいと思います。 これが、レイアウトについて私が考えていることの図です。青色の項目は新しいもので、赤色の項目は(削除)される既存のリンクです。 (ソース:sysadmin1138.net) 赤い矢印の線は現在のISLスイッチリンクであり、両方のISLは同じスイッチからのものです。EVA6100は現在、ISLのある16/4スイッチの両方に接続されています。新しいスイッチにより、リモートDCに2つのスイッチを配置できるようになり、長距離ISLの1つが新しいスイッチに移動します。 これの利点は、各スイッチが別のスイッチから2ホップ以内であり、EVAレプリケーション関係にある2つのEVA4400が互いに1ホップであることです。グラフのEVA6100は古いデバイスであり、最終的にはおそらく別のEVA4400と交換される予定です。 グラフの下半分は、ほとんどのサーバーが配置されている場所であり、正確な配置についていくつか懸念があります。そこに入る必要があるもの: 10 VMWare ESX4.1ホスト EVA6100上のリソースにアクセスします 1つのフェールオーバークラスター(ファイルサーバークラスター)内の4つのWindows Server 2008サーバー EVA6100とリモートEVA4400の両方のリソースにアクセスします 2番目のフェールオーバークラスター内の2台のWindows Server 2008サーバー(Blackboardコンテンツ) EVA6100上のリソースにアクセスします 2つのMS-SQLデータベースサーバー EVA6400のリソースにアクセスし、夜間のDBエクスポートをEVA4400に送信 2つのLTO4テープドライブを備えた1つのLTO4テープライブラリ。各ドライブには独自のファイバーポートがあります。 (このリストに含まれていない)バックアップサーバーはそれらにスプールします 現時点では、ESXクラスターは、スペースのためにVMのシャットダウンを開始する必要がある前に、最大3つ、場合によっては4つのホストのダウンを許容できます。幸い、すべてでMPIOがオンになっています。 現在の4Gb ISLリンクは、私が気づいた飽和に近づいていません。これは、2つのEVA4400の複製によって変わる可能性がありますが、ISLの少なくとも1つは8Gbになります。EVA4400-Aから得られるパフォーマンスを見ると、レプリケーショントラフィックがあっても4Gbのラインを越えるのは難しいと確信しています。 4ノードのファイルサービスクラスターは、SAN1SW4に2つのノード、SAN1SW1に2つのノードを持つことができます。これにより、両方のストレージアレイが1ホップ離れます。 私がやや頭を悩ませている10個のESXノード。SAN1SW4に3つ、SAN1SW2に3つ、SAN1SW1に4つはオプションであり、レイアウトに関する他の意見を聞きたいと思います。これらのほとんどはデュアルポートFCカードを備えているため、いくつかのノードを二重に実行できます。それらのすべてではありませんが、すべてを殺すことなく単一のスイッチが失敗するのに十分です。 2つのMS-SQLボックスは、プライマリストレージに近い必要があり、db-exportパフォーマンスはそれほど重要ではないため、SAN1SW3およびSAN1SW2に配置する必要があります。 LTO4ドライブは現在、メインのストリーマーから2ホップと2ホップ上にあるので、どのように動作するかは既に知っています。これらはSW2とSW3に残すことができます。 グラフの下半分を完全に接続されたトポロジにしないでください。これにより、使用可能なポート数が66から62に減少し、SAN1SW1は25%ISLになります。しかし、それが強く推奨されている場合は、そのルートに進むことができます。 更新:おそらく役立ついくつかのパフォーマンスの数値。私はそれらを持っていました、私はそれらがこの種の問題に役立つと間隔をあけました。 上の図のEVA4400-Aは次のことを行います。 就業日中: ファイルサーバークラスターのShadowCopyスナップショット(平均約​​15〜30秒)の間に、I / Oオペレーションは平均で1000以下でスパイクは4500に急上昇します。 MB / sは通常10〜30MBの範囲にとどまり、ShadowCopies中に最大70MBおよび200MBのスパイクが発生します。 夜間(バックアップ)は、実際に速くペダルを踏むときです。 I / Oオペレーションの平均は約1500で、DBバックアップ中のスパイクは最大5500です。 MB …

7
中央のソースリポジトリをどこに維持しますか?
ソースコードへのアクセスのセキュリティ保護に関する業界のベストプラクティスは何ですか?Apacheを介したSSLのみの接続が、他と競合しない不明瞭なポートでサーバーに許可されていると考えています。面倒なのは、ソースコードをパブリックサーバーに保存することです。つまり、LAN経由でのみアクセスできるわけではありません。さらに、このサーバーにはいくつかの用途があります。Apacheはすでに他の社内Webサイトを提供しています。正しい資格情報を持っている限り、誰もがどこからでも(自宅、空港など)ソースコードにアクセスできるようにしたいと思います。提案?

1
Mac OS Web共有-Apacheログはどこにありますか?
Mac OS Xマシン(10.6)でWeb共有を有効にしました([システム環境設定] / [共有] / [Web共有])。Apacheのログを調べてユーザーエージェント文字列を確認します。これらのログはどこに保存されますか?ここでの回答は/ var / log / httpdを示唆しているようですが、私のマシンには何もありません。 誰もが彼らがどこにいるか知っていますか? ありがとう!
10 mac-osx 


5
RAIDアレイが機能低下しているときにDebianを起動する
最近、Ubuntu Serverのインストールに遭遇しました。インストール中に、劣化したRAIDアレイからのシステムの起動を許可するかどうかを尋ねられました(おそらく、システムをRAID1 / dev / md0デバイスにインストールしたためです)。これはちょうど、無人サーバー用の強力な、便利なオプションである必要があり、そのRAIDアレイは、(長いそれは完全に失敗していないとされる)劣化しているかどうか、オンラインに。 高速検索の後、私はそれを読んでいずれかの方法で動作することがわかった/etc/initramfs-tools/conf.d/mdadm設定ファイル(BOOT_DEGRADED = trueオプション)、または(=真bootdegraded)カーネルブートライン引数を読み込むことで。 質問: Debianで機能する同様のもの(機能が低下したアレイでシステムを起動する方法)はありますか?この正確な方法が適用できるかどうか、またはこの特定の機能があるかどうかさえわかりません。 以前はいくつかのシステムにRAID5アレイがあり、不適切なシャットダウン時に手動でアレイを「修正」するまでこれを起動できなかったので、これを求めています。これは、サーバーが遠隔地に無人だったため、主要なPITAであることが判明しました。 UPSがなく、停電が起こりました。ですから、今後このような問題を防ぐことができるようにお願いします。

4
Puppetホスト名がサーバー証明書と一致しません
ローカルで本番環境のセットアップをテストできるように、puppetがインストールされたUbuntu VMをセットアップしようとしています。PuppetmasterとPuppetが互いに会話するのに問題があります。私の手順を説明します。(サーバーのhostnameFQDNは「web1.xxx.xxx.net」形式です)。 したがって、最初に、/etc/puppet/sslディレクトリからすべてのPEMファイル(もちろん、CA PEMを除く)をクリアして、新たに開始できるようにします。 puppetca --list結果は返されません。 次に、puppetd --testpuppetmasterのCSRを生成するために実行します。puppetca --list現在、ホスト名( "web1.xxx.xxx.net")が含まれています。 次に、実行しpuppetca --sign web1.xxx.xxx.netます。これpuppetca --listで再び空になりました-これまでのところすべて正常に動作しています。 最後にpuppetd --testもう一度走ります。次の出力が表示されます。 err: Could not retrieve catalog from remote server: hostname was not match with the server certificate warning: Not using cache on failed catalog err: Could not retrieve catalog; skipping run /etc/puppet/sslディレクトリの内容をリストすると、myに一致する正しいサーバー名のPEMファイルが表示されますhostname。この問題を攻撃する方法について誰かがアイデアを持っていますか?
10 puppet 

5
あるフォルダーから別のフォルダーに特定の拡張子を持つファイルをコピーするPowerShellスクリプトを作成する
次のパラメーターを入力として取得するPowerShellスクリプトを記述したいと思います。 コピー元のフォルダー、拡張機能、コピー先のフォルダー、および変更によりIIS、ユーザー名、パスワードを再起動するかどうかを示すブール値。 リモートサーバーにコピーしていることを考慮して、どのコマンドレットを確認する必要がありますか? パラメータを変数に読み込むにはどうすればよいですか? IISを再起動するにはどうすればよいですか? 複数のフォルダーをコピーしたいと思うかもしれませんが、powershellスクリプトを呼び出すpowershellスクリプトをどのように記述すればよいですか?
10 powershell 


4
nginx + fastCGI + Django-クライアントに送信された応答のデータ破損を取得
FastCGIを使用してnginxの背後でDjangoを実行しています。クライアントに送信された応答の一部で、ランダムなデータ破損が応答の途中で発生していることを発見しました(途中で数百バイト程度になる可能性があります)。 この時点で、私はそれをnginxのFastCGIハンドラーまたはDjangoのFastCGIハンドラーのバグ(つまり、おそらくflupのバグ)に絞り込みました。スタンドアロン(つまりrunserver)モードでDjangoサーバーを実行すると、この問題は発生しないためです。FastCGIモードでのみ発生します。 その他の興味深い傾向: より大きな応答で発生する傾向があります。クライアントが初めてログインすると、1 MBのチャンクがサーバーDBに同期するために送信されます。最初の同期後、応答ははるかに小さくなります(通常、一度に数KB)。破損は常に、最初に送信された1MBのチャンクで発生しているようです。 これは、クライアントがLANを介してサーバーに接続されている場合(つまり、低遅延、高帯域幅接続)に頻繁に発生します。これにより、nginxまたはflupには、データレートの増加によって悪化するある種の競合状態があると思います。 現時点では、応答ヘッダーにSHA1ダイジェストを追加し、ヘッダーが本文のチェックサムと一致しない場合にクライアントに応答を拒否させることで、これを回避する必要がありましたが、これは恐ろしい解決策の一種です。 他の誰かがこのようなことを経験しましたか、または適切なチームにバグを報告できるように、ここで問題があるのがflupであるかnginxであるかを識別する方法に関する指針がありますか? 助けてくれてありがとう。 注:私も同様にlighttpd + FastCGI + Djangoに同様のバグを投稿しました:https : //stackoverflow.com/questions/3714489/lighttpd-fastcgi-django-truncated-response-sent-to-client-due-to -予期しない ...これは同じことではありませんが(切り捨てvs破損)、一般的な原因はWebサーバーではなくflup / Djangoであるように見え始めています。 編集:私の環境もメモする必要があります: Mac Mini上のOSX 10.6.6 Python 2.6.1(システム) Django 1.3(公式のtarballから) flup 1.0.2(flupサイトのPython eggから) nginx + ssl 1.0.0(Macportsから) 編集:Jerzykのコメントに応じて、応答を組み立てるコードパスは次のようになります(簡潔にするために編集されています)。 # This returns an objc NSData object, which is an array.array # when pushed …


1
Etagsをいつ使用し、使用しないのですか?
私はWebPageTest.orgで私たちのサイトを見ていましたが、ウェブサイトを高速化するための推奨事項の1つは次のとおりです。 ETagヘッダーは、それを必要とする明確な理由がない限り、通常は使用しないでください。 これはどういう意味かと思っていました。それはあなたが知っている静的なコンテンツがそれらを持っているべきではありません変更されることはありませんか、それはあなたが知っている平均コンテンツはそれらを持っているべきではありません定期的に変更されない、またはそれはあなたがそれらを使用してはならないことを意味しない意味しています一般的にあなたがAを持っていない限り、特定のニーズ。 後者の場合、それらを使用する適切なタイミングはいつですか?

2
ifconfig出力でのRXの「エラー」と「フレーム」の正確な意味は?
(RHEL)ノード(パケットがドロップされた)でネットワークの問題が発生しています。これは、ifconfig出力の「エラー」フィールドと「フレーム」フィールドのゼロ以外のカウントによって明らかになるようです: eth2 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx ... RX packets:277593775 errors:1049 dropped:0 overruns:0 frame:536 「エラー」と「フレーム」の正確な意味はどこにあるのですか? 編集:の出力ethtool eth2: Settings for eth2: Supported ports: [ TP ] Supported link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Supports auto-negotiation: Yes Advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Advertised auto-negotiation: Yes Speed: 1000Mb/s Duplex: Full …

5
信頼性の低い低速のWANを介したZFS同期。ZFSレプリケーション、またはrsync?
私はWANを介してオフサイトのバックアップ作業を行う任務を負っています。どちらのストレージボックスも、ZFSを実行するFreeBSDベースのNASボックスです。 週に1〜2回、15〜60ギガの写真データがオフィスのNASにダンプされます。私の仕事は、非常に遅いDSL接続(約700Kb / sのアップロード)を使用して、このデータを可能な限り確実にオフサイトで取得する方法を理解することです。受信ボックスは、30Mb / sダウン、5Mb / sアップで、はるかに良い形になっています。 ハードドライブをオフサイトに持ち運ぶと、データの移動がはるかに速くなることはわかっていますが、この場合はオプションではありません。 私のオプションは次のいずれかです: ZFS経由のZFS増分送信 Rsync rsyncは昔からのソリューションであり、何かが中断された場合に送信を再開する非常に重要な機能を備えています。多くのファイルを反復処理し、重複除去について知らないという欠点があります。 ZFSスナップショットの送信では、転送されるデータが少し少なくなる可能性があり(ファイルシステムについて多くのことを理解し、重複排除を実行でき、メタデータの変更をrsyncよりも効率的にパッケージ化できます)、単にコピーするのではなく、ファイルシステムの状態を適切に複製できるという利点があります個々のファイル(ディスクをより集中的に使用します)。 ZFSレプリケーションのパフォーマンスが心配です[1](その記事は1年前のものです)。何かがダウンした場合に転送を再開できるかどうかも心配です。スナップショット機能にはそれが含まれていないようです。システム全体が完全にハンドオフである必要があります。 [1] http://wikitech-static.wikimedia.org/articles/z/f/s/Zfs_replication.html どちらのオプションを使用しても、指定したポートを介してルーティングし、ルーターでQOSを使用することにより、トラフィックの優先順位を下げることができます。転送には数日かかるので、各転送中に両方のサイトのユーザーに大きな悪影響を与えないようにする必要があります。 だから...それは問題についての私の考えです。良いオプションを見逃しましたか?他の誰かが似たようなものを設定しましたか?

3
共有ホスティング環境(Dreamhostなど)でmod_railsとApacheを使用してGollumを実行する方法は?
Gollumは、Rubyで書かれたGitHubの新しいwikiエンジンです。ローカルにデプロイされ、Sinatraインスタンスを使用してWebインターフェイスを提供します。 Apacheとmod_rails(Phusion Passenger)を使用して、Dreamhostなどの共有ホスティング環境で実行することはできますか?

9
CentOSでNICを無効にする方法
私は、次のことを行う必要があるスクリプトの「ワンライナー」を探しています。 eth0を無効にします。 起動時に起動しないようにします。 IPアドレスを奪う このアドレスを再度使用しないようにしてください。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.