サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
リモートSSH接続でrsyncを使用する場合のリモートパス内のスペースのエスケープ
SSHを使用してrsyncをリモートサーバーに接続する場合、リモートパスのスペースなどをどのようにエスケープしますか?単純なバックスラッシュは、ローカルのbashプロンプトのスペースをエスケープしますが、リモートマシンでは、スペースはパスの区切りとして読み取られるため、そのパスの終わりを示します。 つまり、実際に宛先が「一部」ではなく「一部のディレクトリ」であるため、rsync -avz /path/to/source/some\ dir/ user@host.tld:/path/to/dest/some\ dir/リモートサーバーが/path/to/dest/some/その宛先をリモートで読み取っているので、宛先をリモートで見つけることができません。 同じコマンドを試してバックスラッシュとスペースをエスケープしてローカルのbashプロンプトを通過し、リモートサーバーのバックスラッシュを維持すると(合計3つのバックスラッシュ:)/path/to/dest/some\\\ dir/、実際にリモートサーバーにバックスラッシュが送信されますが、リモートサーバー次に、パスとその後のスペースと文字を削除するの/path/to/dest/some\/ではなく、パスを解釈します/path/to/dest/some\ dir/。 パスを引用符でラップしようとすると、パスはほぼ同じように動作し、パスをスペースで効果的に切り離します。したがって、ローカルのbashプロンプトを通過するためにのみ機能します。 最初は "-"(スペース-ハイフン-スペース)セグメントが含まれるパスを使用していましたが、リモートサーバーがエラーrsync: on remote machine: -: unknown optionを返していましたが、そもそもこのスペースをエスケープする作業全体が開始されました。 では、リモートパスからスペースやハイフンなどの誤った文字を削除せずに、これをリモートサーバーで正しく機能させるにはどうすればよいですか。
10 ssh  bash  rsync  remote  path 

8
最も強力なオープンソースのWeb分析ツールですか?[閉まっている]
現在のところ、この質問はQ&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、議論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 ページのタグ付けとログファイルの分析タイプの両方を含む、オープンソースのウェブ分析ツールの選択に関するアドバイスが必要です。私はそれらのいくつかを知っています:piwik、オープンウェブ分析、awstatsなど...それらの中で最も良いものは何ですか(ページのタグ付けタイプとログファイル分析タイプ)?
10 logging 

6
コマンドラインSIPダイヤラ
SIPサーバーに接続して電話をかけ、メディアファイル(wav / mp3)を再生できる、UNIX用のシンプルなコマンドラインSIPダイヤラーはありますか?理想的には次のようになります。 sip-dailer +1xxxxxxxxxx /path/to/message.mp3

5
SSH経由でサーバーに接続できない-「サーバーがptyの割り当てを拒否しました」
Ubuntu 10.10でSTRATO V-PowerServerを実行していますが、最近、sshを介したサーバーへの接続に問題があります。 基本的に私が持っているのはサーバーへのsshアクセスだけであり、必要に応じてすべてのものが/ repairにあるリカバリモードで起動して、システムで修正を行うことができます。 問題は、ssh経由でサーバーに接続しようとすると、次のエラーが発生することです。 Using username "florian". florian@mydomain.de's password: Server refused to allocate pty Linux hwn36335 2.6.18-028stab070.5 #1 SMP Fri Sep 17 15:37:23 MSD 2010 i686 GNU/Linux Ubuntu 10.10 Welcome to Ubuntu! * Documentation: https://help.ubuntu.com/ /home/florian/.zlogin:1: command not found: display_info そのため、シェルが開かず、コマンドを入力できません。私はすでに「サーバーがptyの割り当てを拒否しました」でグーグルしようとしましたが、問題は以前に他の人に起こりましたが、役立つものを見つけることができませんでした。さらに、他のエラーの代わりに、「pty割り当て要求がチャネル0で失敗しました」という別のエラーが発生することもあります。この問題について私が見つけたすべてはこれでした: http://blog.dinotools.de/2010/10/03/fehler-pty-allocation-request-failed-on-channel-0 しかし、残念ながらそれは助けにはなりませんでした... 誰かがこのエラーが発生する理由と私がそれを修正しようとすることができるものを知っていますか? あなたが私にヒントを与えることができれば素晴らしいでしょう。私はいくつかの基本的なことを知っており、サーバーでの作業方法を知っていますが、これが問題解決に深く関わる場合、私は限界に達しています... ;-)ありがとうございます! オプション1: /var/log/auth.log …

2
cronジョブが間違った時間に実行されるのはなぜですか?
Ubuntuサーバーで毎日実行するcronjobsセットアップがあります。 例えば。0 4 * * *コマンド 彼らは8時間早く実行していることを除いて実行しています。サーバーを設定するとき、最初はUTC時間に設定されていました。私は走ったsudo dpkg-reconfigure tzdata6時間のUTCの後ろにあるCSTにサーバーを設定します。興味深いことに、私はUTCから8時間遅れているPSTにいますが、サーバーがそれをどのように認識できるかわかりません。 コマンドを実行するとdate、CSTで時間が表示されます。 時間が正しく設定されていない場所があるはずです。これはどこで解決できますか?

3
市場シェアが最も高いのはどのサーバーディストリビューションですか?[閉まっている]
閉まっている。この質問は、オフトピック。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 9年前休業。 Linuxサーバーディストリビューションの市場シェアを知りたい。CentOSはまだ最高ですか? 信頼できるドキュメントはどこにありますか。-そして着実に維持されます。 素敵なウェブサイトを知っていますか?
10 linux 


5
UDPサーバーの負荷分散
私はudpサーバーを持っています。これは私のビジネスプロセスの中心的な部分です。本番環境で期待している負荷を処理するために、サーバーのインスタンスが2つまたは3つ必要になるでしょう。サーバーはほぼ完全にステートレスであり、ほとんどの場合データを収集し、その上の層は、複数のサーバーインスタンスから発生する可能性のある最小限の古くなったデータを処理する方法を認識しています。 私の質問は、サーバー間で負荷分散を実装するにはどうすればよいですか?サーバー間でリクエストをできるだけ均等に分散したいと思います。また、忠実に再現したいと思います。つまり、クライアントXがサーバーyにルーティングされた場合、それ以降のXのすべてのリクエストはサーバーYに送られるようにします。 ちなみにそれは.NETシステムです...何をお勧めしますか? 状態はサーバー内の内部であり、何らかのトランザクションではありません。状態とは、サーバーが受信したデータからサーバーが集計するいくつかのデータであり、単純なWCF WebServiceでクエリ可能です。アプリケーションはUDPに基づいており、決定には同意しませんが、その「給与水準より上」 私は現在、MSのNLBを試していますが、問題なく動作します。箱から出して忠実に動作しますが、ネットワーク全体でノイズが発生します... DNSもありません...ああ、それは完全にコスチュームプロトコルです。

3
SPFレコードの適切な形式は何ですか?
私が得る私のドメインをクエリする: The TXT records found for your domain are: v=spf1 ip4:50.22.72.198 a mx:wordswithfriends.net ~all 表面的には問題ないようです。ただし、次のメッセージも表示されます SPFレコードは、タイプSPFレコードとしてDNSでも公開する必要があります。 タイプSPFレコードが見つかりません。 気密性を確保したい。TXTレコードに加えて、純粋なSPFレコードも必要です。しかし、私はフォーマットを理解することができません。同じテキストをSPFレコードに配置しても機能しないようです。 編集: 現時点では、TXTレコードはありますが、SPFレコードはありません。TXTからSPFに直接カットアンドペーストすると、ある種のクレイジーな再帰DNSエラーが発生するため、SPFをすぐに削除しました。正しいフォーマットを知りたいだけです。コピーしています v=spf1 ip4:50.22.72.198 a mx:wordswithfriends.net ~all SPFレコードに直接入力しても機能しません。

6
開発者ビルドの最速のファイルシステムは何ですか?
私は、継続的インテグレーションビルドサーバーとして機能するLinuxボックスをまとめています。主にJavaのものを構築しますが、この質問はコンパイルされたすべての言語に当てはまると思います。 どのファイルシステムと構成設定を使用する必要がありますか?(たとえば、私はこれに時間をかける必要がないことを知っています!)ビルドサーバーは、小さなファイルの読み取りと書き込み、およびディレクトリのスキャンを行って、変更されたファイルを確認します。 更新:この場合、データの整合性は優先度が低くなります。それは単なるビルドマシンです...最終的なアーティファクトは圧縮され、別の場所にアーカイブされます。ビルドマシンのファイルシステムが破損してすべてのデータが失われた場合は、ワイプしてイメージを再作成するだけです。ビルドは以前と同様に実行され続けます。

4
.htaccessリダイレクトがhttpでは機能するが、httpsでは機能しないのはなぜですか?
単純な.htaccessファイルがあり、httpバージョンのサイトでは適切に機能しますが、httpsにアクセスすると機能しません。どうして? RewriteEngine on #This is so if the file exists then use the file RewriteCond %{REQUEST_FILENAME} -f RewriteRule ^ %{REQUEST_FILENAME} [L] #These conditions check if a file or folder exists just for reference #RewriteCond %{REQUEST_FILENAME} !-f #RewriteCond %{REQUEST_FILENAME} !-d #if someone adds ".php" to the slug get rid of it …

3
OS XでCTRL-rが奇妙に動作する(コマンドの一部のみが表示される)理由
Ctrl+ rは、.bash_history以前に実行したコマンドを検索するための優れた小さなツールです。 しかし、OS X Terminal.appで使用すると、奇妙な動作が見られ、他の誰かが同じものを見たり、修正方法を知っているのではないかと思っていました。 Ctrl+r 次のように入力します find ああクール、見て...それは私が欲しかったコマンドです find . -exec grep -q "hello world" '{}' \; -print そのコマンドを実行したいのですが、hello worldを別のものに変更します。 だから私はヒット←または→ コマンドはコマンドラインでSORTAになっていますが、常に次のように、コマンドの一部が省略されたバージョンのように見えます-q "blog_posts_by" '{}' \; -print。ここでは、コマンド全体がそこにあり、カーソルキーを使用して行を移動できますが、すべてではありません印刷されています。行に表示されている内容と、端末が実際に編集していると見なしている内容との間に不一致があります。 なぜこれが起こるのか、誰か手がかりはありますか?ウェブを検索するのは簡単なことではありません。
10 bash  mac-osx  terminal 

2
1台のサーバー、2台の冗長電源のAPC UPS:シャットダウンをトリガーする方法?
サーバーをラックに搭載し、その冗長電源を2つのAPC Smart-UPS 3000 XLMに差し込みました。各UPSは2つの異なる主電源に接続されています。 apcupsdの2つのインスタンスが実行されており、それぞれが独自のUPSに接続されています。どちらもUPSがバッテリーに接続されていることを検出でき、各UPSはサーバーのシャットダウンをトリガーできます。 質問は次のとおりです。UPSが1つだけバッテリ切れになった場合、シャットダウンしないようにするにはどうすればよいですか。 注:Smart-UPS 3000 XLMには、ピアに接続してステータスを検出できる「電源同期」機能があります。しかし、私がそれらの1つからプラグを抜いたとき、シャットダウン命令はとにかく送られました。他のアップがダウンしているかどうかを「apcaccess」でチェックするようにシャットダウンスクリプトを変更することを考えています。これに関するどんな経験でもありがたいです!

9
FTPに接続できません-MLSD後の接続タイムアウト
これが私の問題です。これまで見たことのない状況では、FTPサーバーに接続できません。ここに状況があります: MLSDコマンドの直後に「接続がタイムアウトしました」と表示されます。 私は通常UbuntuでFilezillaを使用しますが、問題がこの特定のクライアントに関連していないことを確認するために、ubuntuでのgftpとWindows 7でのwinscpとfreeftpをいくつか試しました。すべて同じ結果です。 また、アクティブモードまたはパッシブモードで試すことも確認しました。同じ結果。 この時点で、私は現在のネットワークに何か問題があると思う傾向があります(さらに、同僚によると、FTPサーバーは大丈夫です)。しかし、http://ftptest.net/で確認したところ、ディレクトリリストを取得できました(FTPクライアントでは取得できません)。 結局、私が試していない最後のことは、別のネットワークに行くことです。解決策はうまくいくようですが、長期的にはあまり実用的ではありません。ルーターに問題があると思いますが、何が原因でしょうか? 注:この質問を最初に登録してfilezillaの掲示板に投稿しようとしましたが、Gmailアカウントやhotmailアカウントでアカウントを作成できません。WTF?
10 ftp 

3
Busybox、netstat、-pなし
DreamBoxに超古い(理由は尋ねない)BusyBox (BusyBox v1.01(2008.12.19-21:31 + 0000)組み込みシェル(灰))があります。netstatを使用して、どのプロセスがどの接続を開いたかを確認したいと思います。しかし、BusyBoxのnetstatには-pオプションが含まれていないことがわかりました。どのプロセスが対応するソケットを開いた(そして使用している)かを知るために、他にどのような可能性がありますか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.