サーバー管理者

システムおよびネットワーク管理者向けのQ&A


5
MySQLプロセスがCPU使用率の100%を超える
LAMPサーバーで問題が発生しています。私のウェブサイトの訪問者数はそれほど変わっていませんが、最近すべてが非常に遅くなりました。topコマンドを実行すると、MySQLプロセスがCPUの150〜200%を占めていると表示されます。それはどうして可能ですか、100%が最大だといつも思っていましたか? 1.5 GBのRAMを搭載したUbuntu 9.04サーバーエディションを実行しています。 my.cnf 設定: key_buffer = 64M max_allowed_packet = 16M thread_stack = 192K thread_cache_size = 8 myisam-recover = BACKUP max_connections = 200 table_cache = 512 table_definition_cache = 512 thread_concurrency = 2 read_buffer_size = 1M sort_buffer_size = 4M join_buffer_size = 1M query_cache_limit = 1M # the maximum size of …

3
リバースDNSとは何ですか?
OpenDNSアカウントに* .in-addr.arpaドメインのリクエストがたくさんあります。これは正常なはずで、リバースDNSに関するものです。 私はあちこちを読んでいましたが、それでも実際にはどのように機能するのか、なぜ多くのリクエスト(www.google.comよりも多い)を受け取るのかを理解できません。アインシュタインが提案したような、彼が祖母に説明するように、この逆引きDNSが何に使用されているかを説明してください。

1
certutil -pingが30秒のタイムアウトで失敗する-どうすればよいですか?
Win7ボックスの証明書ストアが常にハングしています。観察する: C:\> 1.cmd C:\> certutil-?| findstr / i ping -ping-Active Directory証明書サービス要求インターフェースにpingを実行します -pingadmin-Active Directory証明書サービスの管理インターフェイスをpingします C:\> set PROMPT = $ P($ t)$ G C:\(13:04:28.57)> certutil -ping CertUtil:-pingコマンドが失敗しました:0x80070002(WIN32:2) CertUtil:指定されたファイルが見つかりません。 C:\(13:04:58.68)> certutil -pingadmin CertUtil:-pingadminコマンドが失敗しました:0x80070002(WIN32:2) CertUtil:指定されたファイルが見つかりません。 C:\(13:05:28.79)> PROMPT = $ P $ Gを設定 C:\> 説明: 最初のコマンドショーあなたがあること–pingと–pingadminします。certutilへのパラメータ pingパラメータの試行が30秒のタイムアウトで失敗する(現在の時刻はプロンプトに表示されます) これは深刻な問題です。それは私のアプリのすべての安全な通信をねじ込みます。これを修正する方法を誰かが知っている場合は、共有してください。 ありがとう。 PS 1.cmdは、これらのコマンドのバッチです。 certutil -? | findstr …

3
サブフォルダー内のnginxプロジェクト
私はnginx設定に不満を感じているので、同じルートのサブディレクトリから複数のプロジェクトにサービスを提供するための設定ファイルの作成について助けを求めています。それらはすべて同じホスト値を使用しているため、これは仮想ホスティングではありません。おそらく例が私の試みを明確にするでしょう: 要求192.168.1.1/役立つはずであるindex.phpから、/var/www/public/ 要求192.168.1.1/wiki/役立つはずであるindex.phpから、/var/www/wiki/public/ 要求192.168.1.1/blog/役立つはずであるindex.phpから、/var/www/blog/public/ これらのプロジェクトはPHPを使用しており、fastcgiを使用しています。 私の現在の構成は非常に最小限です。 server { listen 80 default; server_name localhost; access_log /var/log/nginx/localhost.access.log; root /var/www; index index.php index.html; location ~ \.php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /var/www$fastcgi_script_name; include fastcgi_params; } } 私はいろいろなことを試してみたaliasし、rewriteしかし、FastCGIのために正しく設定物事を取得することができませんでした。場所のブロックを書き込み、複製よりも雄弁な方法があるはずと思われるroot、index、SCRIPT_FILENAME、など 私を正しい方向に導くための指針はありがたいです。
10 php  nginx  fastcgi 

3
Mac OS Xを使用してIPv6ホストにTelnetするにはどうすればよいですか?
企業ネットワークでIPv6をテストしていますが、OS Xで問題が発生しています。telnet -6またはなどのほとんどのIPv6コマンドでtraceroute6、次のエラーが発生します。 connect: No route to host たとえば、Webサーバーがあります。これは失敗します: $ telnet -6 fe80::… 80 # this fails ping6動作するのでサーバーに到達できることはわかっています(-I引数を使用する必要があることに注意してください)。 $ ping6 -I en1 fe80::… # this works また、WindowsからTelnetを実行できるため、Webサーバーが実行されていることがわかります。 C:\> telnet fe80::… 80 # this works いくつかの構成フラグまたはコマンドライン引数がないと思います。

5
すでに起動されているプロセスのネットワークスループットを制限しますか?(Linux / FreeBSD)
起動後にプロセスのネットワークスループットを制限するユーティリティはありますか?簡単な例:ユーザーがscpを使用してすべてのアップロード帯域幅を取得し、レートを制限したり、転送の優先度を下げたりしたいとします。 私はそれを達成するためにiptables / tcまたはpfの組み合わせを使用できると思いますが、「--pidオプションを指定したトリクルのような^^) "ワンショット"ツールが利用できるかどうか疑問に思っていましたか?

4
EC2 VMインポート:VirtualBox
ec2クラウドにvirtualbox vmをインポートすることが現在可能かどうか知りたいのですが、virtualbox vmdkで試してみましたが、成功しませんでした。どうやら、それはVMwareのvmdkファイル用に設計されています。 インスタンスを変換してAmazonにインポートするために使用できるトリックはありますか? よろしくお願いします!

4
Apacheサーバー上のすべてのドメインのrobots.txtファイルを作成する方法
仮想ホストを備えたXAMPP Apache開発Webサーバーのセットアップがあり、serpsがすべてのサイトをクロールしないようにしたいと考えています。これはrobots.txtファイルで簡単に行えます。ただし、すべてのvhostにdisallow robots.txtを含めたくないので、別のサーバーでサイトを公開するときにそれを削除する必要があります。 Apache構成ファイルを使用して、すべてのvhosts上のrobots.txtへのすべてのリクエストを単一のrobots.txtファイルに書き換える方法はありますか? もしそうなら、私に例を挙げてもらえますか?私はそれはこのようなものになると思います: RewriteEngine On RewriteRule .*robots\.txt$ C:\xampp\vhosts\override-robots.txt [L] ありがとう!

5
2GB RAM E6500 CPUで1日あたり10K以上のワードプレスビュー用にApacheを最適化
私はubuntuにapache / phpを備えた専用サーバーを1日あたり約10K以上のページビューでWordpressブログに提供しています。APCにW3TCプラグインがインストールされています。 しかし、時々サーバーが応答を停止するか、非常に遅くなり、私はそれを元に戻すためにApacheを再起動する必要があります。 私の設定は何ですか? ServerRoot "/etc/apache2" LockFile /var/lock/apache2/accept.lock PidFile ${APACHE_PID_FILE} TimeOut 40 KeepAlive on MaxKeepAliveRequests 200 KeepAliveTimeout 2 <IfModule mpm_prefork_module> StartServers 5 MinSpareServers 5 MaxSpareServers 8 ServerLimit 80 MaxClients 80 MaxRequestsPerChild 1000 </IfModule> <IfModule mpm_worker_module> StartServers 3 MinSpareServers 3 MaxSpareServers 3 ServerLimit 80 MaxClients 80 MaxRequestsPerChild 1000 </IfModule> <IfModule …

1
3ノードクラスタの構成管理が行き過ぎですか?
ロードバランサーとさまざまなWebアプリケーション用に2〜3個のノードクラスターがあります。最初にQAを変更し、次にステージング(2-3サーバー上)、次に運用(2-3サーバー上)で変更を行う必要があります。シェフや人形などの構成管理ツールはここで適切ですか?それともやりすぎですか?それがやりすぎの場合、これを簡単にするためのヒントがあります。

2
LinuxおよびNginxの最大ファイル記述子と、worker_rlimit_nofileの最適値を理解する
nginxで一見一般的な「ファイル記述子が多すぎる」エラーが発生しました。多くの検索の後、解決策は明らかにnginxが利用できるファイル記述子の数を増やすことです。しかし、これを意味のある安全な方法で快適に行うのに十分な情報はありません。ほとんどのフォーラム/メールスレッドがカバーする主なポイントは次のとおりです。 OSには独自の合計ファイル記述子制限があります(私のシステムでは、cat /proc/sys/fs/file-max「100678」を出力します) 各ユーザーは独自の制限を持つこともできます(ただし、私のシステムでは、ulimitユーザーが「無制限」を出力するときに実行されます。詳細は下部の更新を参照してください) 少数の人々は何の線に沿って何か言ったこの人は言った:「ディレクティブworker_rlimit_nofileは、それがないオペレーティング・システムの制限である『どのように多くの』指定されていません。ディレクティブworker_rlimit_nofileは、この制限が十分でない場合に、この制限を拡大する迅速で汚い方法を許可します。つまり、設定ではなくnginx OSユーザーの制限を設定するほうが「より良い」ということです。 ワーカーあたりの接続数よりも大きいworker_rlimit_nofile値をスローして1日で呼び出すことができますが、ここで何が起こっているのか本当にわかりません。 ワーカーあたりの制限がOSの制限よりも小さいのはなぜですか? 現在の制限を確認するにはどうすればよいですか? update:rootと通常のユーザーの両方で、ulimitは「無制限」を出力しますが、BUT ulimit -Hnとulimit -Sn両方が1024を出力します
10 linux  nginx  ulimit 

1
BINDでは、特定のドメインのDNSクエリを特定のネームサーバーに転送します
Windows Server 2003にはこの機能があり、ドメイン "example.com"のクエリを特定のネームサーバー(デフォルトのDNSサーバーではない)に転送できます。 これをBINDで設定するにはどうすればよいですか?たとえば、ローカルTLDから特定のローカルネームサーバーへの転送を設定したいとします。 バインドバージョン9.6 作業構成 Khaledが指摘したように、ゾーン条項ではフォワーダーステートメントを使用できます。次の構成で動作しました: zone "local." IN { type forward; forward only; forwarders { 10.10.1.9; }; };

7
ソース管理への移行
私たちの会社はかなり小さな会社(3〜4人のプログラマーと3〜4人のサイトデザイナー)で、約100以上のWebサイトに機能を提供する単一目的のPHP Webアプリを開発しています。私たちは、かなりうまく機能している別の開発環境と本番環境で数年間運用してきました。開発者が開発するのに十分な個別の機能が常にあるため、プログラマーが実際に衝突することはなく、ソース管理なしで作業する方が便利でした。データ損失のリスクがあり、不注意による移動でファイルの公平な共有が失われても、 もう1つの考慮事項は、デザイナーが技術に精通していないことです(WYSIWYGを使用する代わりに、HTMLマークアップを紹介しました)。これは、バージョン管理への移行をためらう理由の1つです。 しかし、100以上のサイトに到達し、開発チームが成長している今、手順とソース管理を標準化しようとしているところ、プログラマーにとっては論理的なステップのようです。これにより、パッチの展開もスピードアップすることを期待しています。 残念ながら、私はソース管理システムをセットアップする経験が非常に限られています。同様の設定、または切り替えの経験のある人から聞いて知りたいことは何ですか。 1)すべて(サイト、CSS、HTMLテンプレート、アプリコード)をバージョン管理し、設計者にバージョン管理を習得させますか?それとも、アプリケーションコードに取り組むのは開発者だけですか? 2)ソース管理を最初にセットアップするときに注意すべき落とし穴は何ですか? 3)devの配備=>ソース管理のための本番のヒント。 すべての洞察をありがとう。 編集1:ダン。これまでのところ、すべてを制御することをお勧めしています。それは私が私の髪を早く失うことになるでしょう。それはおそらく近い将来に新しい質問を引き起こすでしょう。これまでのアドバイスをありがとうございます。 編集2:良い答えがたくさんあります。さまざまなバージョン管理システムを調べます。皆様のご返信ありがとうございます!

2
EC2インスタンスが停止して開始したときにIPが変更された
EC2インスタンスに関して奇妙な問題があります。インスタンスを起動した後ではなく、起動ドライブを拡張した後、WindowsのEC2インスタンスを停止して開始したところ、stop-startフェーズの前に割り当てられていたIPが新しいIPに変更されました。誰もが同様の問題を抱えていましたか、それともストップスタートシナリオでは普通ですか?
10 amazon-ec2  ip 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.