サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
Windows XP EOL / EOSはビジネスとそのドメインにとってどのような意味がありますか?
この投稿を改善してみませんか?この質問に対する詳細な回答を提供します。これには、引用と、回答が正しい理由の説明が含まれます。詳細が不十分な回答は編集または削除される場合があります。 私は誰かが簡単な言葉で説明できることを望んでいます、それは本当にウィンドウズXPが人生の終わりになることを意味しますか? SP2にはまだパッチが適用されていないようですが、おそらくSP3は2014年4月18日までパッチが適用される予定ですか? だから私はそれがその日まで利用可能なWindowsアップデートパッチがあることを意味すると思いますか? その後はどうなりますか、パッチはまったくありませんか? つまり、ハッキング、ウイルスなどの可能性が大幅に増加しますか?


3
タイムスタンプとファイルリストをrsyncログに追加する方法
タイムスタンプとファイルリストの両方をログに追加したい。現在、入手できるのは1つだけです。次のコマンドは、更新されたファイルリストを追跡できますが、タイムスタンプは追加しません。 rsync -avz --progress --delete / web / path / public_html / $ newhost:/ web / path / public_html >> /var/log/rsync.log sent 2345743 bytes received 43205 bytes 530877.33 bytes/sec total size is 14828110173 speedup is 6206.96 sending incremental file list error_log 5740980 100% 36.98MB/s 0:00:00 (xfer#1, to-check=1405/1524) sent 2344322 bytes …
10 rsync 

2
Linuxで最後にログインしたユーザーに8文字しか表示されない
Linuxで最後のコマンドを使用して、最後にログインしたユーザーを取得しています。しかし、最後のコマンドでは、ユーザー名フィールドに8文字しか表示されません。画像の下には、ユーザ名の管理者がにトリミングされadminist。 最後にログインしたユーザーのフルネームを取得する他の方法はありますか? 私もlastlogを試しました。
10 linux 

1
PHP-FPMのchrootおよびchdirディレクトリ
私はphp-fpmをchrootingを有効にして設定しています。これで2つのオプションがあることがわかりました。正確な違いを知りたいのですが。 セットアップには以下があります。 chroot = /var/www/domains/domain.tld/ ; Chdir to this directory at the start. This value must be an absolute path. ; Default Value: current directory or / when chroot chdir = /docroot/ ここに2つの異なる場所がある理由と、phpがアクセスを許可されているパスはどれですか。/var/www/domains/domain.tld/PHP Webサイトにアクセスできますか、それともdocrootディレクトリ内のファイルにのみアクセスできます。 === 多分私にいくつかの具体的なアドバイスがあります。このような設定をしたい: ウェブルートの場所: /var/www/ domain.com/ |---conf/ | |--nginx.conf | |--php-fpm.conf | |---ssl/ |---logs/ |---session/ |---domains/ |---www/ …
10 php-fpm  chroot 

6
VMware VMFS5とLUNのサイジング-複数の小さなデータストア、または1つの大きなデータストア?
VMFS5にはVMFSボリュームの2TBの制限がなくなったため、どのシナリオが全体的により有益になるかを検討しています:- より大きなサイズの少ないLUN、または 小さいサイズのより多くのLUN。 私の場合、600 GBのディスクを備えた新しい24ディスクストレージアレイを持っています。私はRAID10を使用するので、およそ7.2TBで、1つの大きな7TBデータストアを使用するか、それともそれぞれ1TBの複数のストアを使用するかを決定しようとしています。 各アプローチの長所と短所は何ですか? 更新:もちろん、計算にホットスペアを含めなかったため、7.2TB未満になりますが、一般的な考え方は同じです。:-) 更新 2:60個のVMと3個のホストがあります。私たちのVMはどれも、特にI / O集約型ではありません。それらのほとんどはWeb /アプリケーションサーバーであり、監視(munin / nagios)、最小負荷の2つのWindows DCなども含まれます。I / O要件が非常に低い場合を除いて、DBサーバーが仮想化されることはほとんどありません。現在、私が持っている唯一の仮想DBサーバーはMSSQLボックスであり、そのボックスのDBは1GB未満だと思います。 アップデート3:アレイとFC接続の詳細。アレイはIBM DS3524で、それぞれ2GBキャッシュを備えた2つのコントローラーです。コントローラあたり4x 8Gbit FCポート。各ESXiホストには2x 4Gbit FC HBAがあります。

4
ロギングを備えたグラフィカルPingユーティリティ
ホスト間の接続の品質を継続的にテストする必要があります。問題が発生したときに確認するために、pingを使用したいと思います。 各pingのタイムスタンプとともに、pingのLOGを提供する必要があります。 そのようなユーティリティの提案はありますか? うん、ごめん、ウィンドウズ!できればインストールして実行します。同様に、ダミーの管理者の場合:)

3
スワイプカードアクセスのためのオープンソースシステム?[閉まっている]
現在のところ、この質問はQ&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、議論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 キャンパス全体の磁気スワイプカードシステムをより堅牢なものに置き換えることを検討しています。私の「プログラマー」側は、すでにこれを実行するオープンソースのスケーラブルなソリューションが必要だと言いますが、私が見つけたものはすべて、ベンダー固有の独自のソリューションです。 理想的には、次のようになります。 幅広いカードリーダー(IMAPやHTTPなど)から選択できるいくつかのオープンスタンダードに基づいています。 さまざまな種類のカードアクセスをサポート(磁気ストリップ、RFIDなど) 将来を見据えた(可能な範囲で) 私が見つけている情報の欠如は、私が正しいものを検索していないと信じるようにします...またはそのような解決策は存在しません。これに対する基本的なオープンソースソリューションはありませんか(データベースのMySQL、LMSのMoodle、WebサーバーのApacheなど)。

2
Ubuntu 11.04、adduser myuser:管理グループがありません
こんにちは、ルートアカウントを使用して新規インストールした後、myuserをsudoersに追加しようとしています。 # adduser myuser admin それは与える: adduser: the group `admin' does not exist. ただし、これは機能します: # adduser myuser root しかし、それはmyuserをsudoerにしません。 さらに、/ etc / sudoersには次の行が含まれています。 # User privilege specification root ALL=(ALL:ALL) ALL # Members of the admin group may gain root privileges %admin ALL=(ALL) ALL しかし、かなり奇妙です- / etc / groupファイルにはadminが含まれていません。 それを手動で編集して、次のようなものを追加する必要があります: admin:x:120:myuser
10 ubuntu  users 

1
HAProxyヘルスチェック:httpchkを使用して監視しますか?
HAProxy 1.4.18を次のバックエンド構成で使用しています backend staging option httpchk HEAD /check.txt HTTP/1.0 http-check disable-on-404 default-server error-limit 1 on-error mark-down server staging01 x.x.x.x:80 check observe layer7 server staging02 x.x.x.x:80 check observe layer7 サーバーは、apache / passenger上で複数のアプリケーションを実行しています。 httpchkとdisable-on-404の組み合わせにより、正常にシャットダウンし、直接(つまり、テストのために)アクセスできる状態のまま、サーバーをlbから簡単に削除できます。 アプリケーションが動作していないときにサーバーを無効にするために監視を設定しようとしています。staging02のアプリケーション構成を壊したので、常に500を返します。最初の500の後で正しくDOWNとマークされていますが、次のhttpchkでUPとマークされています。 ログファイルは次のとおりです。 Server staging/staging02 is DOWN, reason: Health analyze, info: "Detected 1 consecutive errors, last one was: Wrong …
10 haproxy 

2
Postfix 'before-queue' SpamAssassinフィルタリングを実装する推奨方法?
同僚や関連部門とのいくつかの議論の後。私のオフィスでは、私の場合Postfix server、before-queueフィルタリングを実装する必要があるという結論に達しました。その理由は、after-queueフィルタリングを使用すると、電子メールが失われ、送信者(誤検知の場合)がそれを決して認識しないためです。 それは私の会社には受け入れられません。falsely accused送信者に通知が届いた場合は、他のチャネルを介して電子メールを再送信してみてください。彼/彼女が通知を受け取らない場合、彼/彼女は再送を試みません。 さて、でさまざまなドキュメントを熟読した後SpamAssassin、私はSpamAssassin before-queueフィルタリングを実装する複数の方法に遭遇しました。例えば、 SA + amavisd-new(smtpdプロキシとして実行) SA + amavisd-new + amavisd-milter SA + MIMEdefang(milterとして実行) SA + spampd(smtpdプロキシとして実行) SA + milter-spamd そして、あなたはそれを実装する他の方法を見つけるかもしれないと確信しています。 上記のうちどれが推奨されていますか? その長所/短所を知っていますか?それとも、何か良いことを考えていますか?

6
HTTPSベースの内部APTリポジトリに自己署名SSL証明書を使用する
私はいくつかのプライベートパッケージで内部使用するためにDebianリポジトリ(実際にはUbuntu)を設定しましたが、特定のサーバーがWeb経由で利用できるようにしたいと考えています。apt-get / aptitudeをHTTPSを使用して接続したいのですが、お金を使いたくないので自己署名証明書を使用しています。 apt-getで自分のルートCA証明書を使用してホストを検証するようにapt.confのマニュアルページを試してみましたが、動作しないようです。 私のapt.confファイルは次のようになります。 #Acquire::https::repo.mydomain.com::Verify-Peer "false"; Acquire::https::repo.mydomain.com::CaInfo "/etc/apt/certs/my-cacert.pem"; Acquire::https::repo.mydomain.com::SslCert "/etc/apt/certs/my-cert.pem"; Acquire::https::repo.mydomain.com::SslKey "/etc/apt/certs/my-key.pem"; 私もクライアント証明書を使用していますが、Verify-Peerを「false」に設定すると(上記でコメント)、すべてが機能するため、問題はないようです。 同じCA証明書を使用すると、クライアント証明書とキーはcurlでうまく機能します。 aptデバッグ(Debug :: Acquire :: https "true")を有効にしましたが、情報はほとんど提供されません。 続行する方法について何か提案はありますか?

1
否認コマンドを確認する
^z; bg; disown非常に重要な実行時間の長いプロセスを実行しているsshセッションを閉じるために、シーケンスを発行しました。このプロセスは、ステータス出力をstderrに書き込みます。デタッチされた後も書き込みを続けます(lsofで確認、stderr fdはr / wに対して開いています)。 プロセスが実際に否認されていることを確認する方法はありますか(シェルが1を受信した場合、SIGHUPを受信しません)?
10 bash  process 

2
小型シャーシスイッチのケーブル管理戦略
HP ProCurve 4200vlシャーシスイッチを1つ含む小さなサイトビルドアウトで作業しています。データ配線の請負業者はケーブル管理を提供していません。下の写真のラックを見ていて、垂直管理者なしで下のスイッチにきれいにパッチを当てる方法についていくつかの提案をお願いします。このセットアップでは40〜50本のケーブルしか使用しないため、完全な垂直管理を避けたかったのです。これを行うクリーンな方法はありますか?NeatPatchのようなものが最善のアプローチでしょうか?答えがベルクロの場合、私もそれはうまくいくと思います...

3
winrmおよびMicrosoft.Update.Sessionを使用してリモートでサーバーにパッチを適用する際の問題
Windows 2003、2008、2008r2サーバーのネットワークがあります。「Microsoft.Update」comオブジェクトを使用してローカルマシンにパッチを当てるために書いたPowerShellスクリプトがあります。(Windows Update PowerShell Remotingに似てい ます。)私のスクリプトはローカルでうまく機能しますが、管理するサーバーの数がかなり多いため、リモートでその機能を使用したいと思います。その場合は落ちます(解決されなかった他の投稿と同様)。 ただし、失敗を特定のクラスの2つのメソッドに絞り込むことができました。 (New-Object -ComObject "Microsoft.Update.Session").CreateUpdateDownloader() (New-Object -ComObject "Microsoft.Update.Session").CreateUpdateInstaller() これらを管理者としてローカルでPowerShellで実行しても、問題はありません。invoke-command(またはenter-session、またはwinrs)を使用しようとすると、次のエラーが発生します。(これはlocalhostでテストしていますが、どのホストでも実行できます。credsspやkerberosなどのさまざまな認証方法も試しました。) PS C:\> Invoke-Command -ComputerName localhost -ScriptBlock { (New-Object -ComObject "microsoft.update.session").createUpdateDownloader()} Exception calling "CreateUpdateDownloader" with "0" argument(s): "Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))" + CategoryInfo : NotSpecified: (:) [], MethodInvocationException + FullyQualifiedErrorId : ComMethodTargetInvocation これはブログでバグとして言及されているのを見たことがありますが、その主張に対するバックアップはありません。2つの回避策があり、どちらも私を幸せにしません。 …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.