サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
CSSイメージなどではなく、ページのみをwgetにダウンロードさせるにはどうすればよいですか?
wgetを使用してウェブサイト全体をダウンロードしたいのですが、画像、動画などをダウンロードしたくありません。 私は試した wget -bqre robots=off -A.html example.com –user-agent=”Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6″ しかし、そうすると.phpファイルはダウンロードされず、静的な.htmlファイルがダウンロードされるだけです。 wgetを使用したこの問題の解決策はありますか?
10 linux  wget 

1
Windows 7で信頼されたルート証明機関に証明書を追加できない
信頼されたルート証明機関セクションにプッシュ通知を送信するためのApple開発者証明書を追加しようとしています。次のようなエラーが表示されます:「ストアが読み取り専用であったか、ストアがいっぱいだったか、ストアが正しく開かなかったため、インポートが失敗しました」 管理者としてログインしています。これを解決する方法は考えられません。誰かが以前に同様の問題を修正することができましたか? 御時間ありがとうございます...

3
エントロピーキーがオーバーロードされたことを確認する方法は?
いくつかのエントロピーキーの前にegdがあり、haproxyによってすべての負荷が分散されています。そして、エントロピーのネットワークソースとしてhaproxyサービスIPを使用している多くのクライアントマシンがあります。彼らがどれほどのエントロピーを要求しているのか私にはわかりません。 エントロピーキーは、限られた量の使用可能なエントロピーを生成できます。仕様では最低約30キロビット/秒とされています。私の知る限り、エントロピーキーには、要求されている量を照会する方法がありません。EGDプロトコルは、この情報を見つけるために盗聴するのが非常に難しいようです。クライアントは可変量のエントロピーを要求でき、同じ量を返さない場合があります。 エントロピーキーから要求されている量を測定する簡単な方法を見つけた人はいますか? いつ追加のキーが必要かを計画し、ヘイワイヤークライアントを特定できるようにしておくとよいでしょう。

5
ipv4およびipv6 iptablesの並列ルールを管理していますか?
私たちは最近IPv6の実験を開始しました。私たちが対処しなければならない最初の問題の1つは、2つのプロトコルスタックのファイアウォール(Linux iptables / ip6ables)ルールの完全に別個のセットを処理することです。私たちのファイアウォールロジックは、主にいくつかの目的固有のネットワークに基づいています(たとえば、10.0.0.0 / 24はスタッフワークステーションネットワーク、10.1.0.0 / 24はデータベースネットワーク、10.2.0.0 / 24はWebサーバーネットワークなど) )、IPv6とIPv4の両方のロジックは、ほとんど同じで、モジュロが異なるネットワークプレフィックスになります。 このような状況を管理するために、人々は何をしていますか?理想的には、同じソースファイルからiptablesとip6tableの両方のルールセットを生成できるようにしたいと考えています。私はすでにbashを使用して何かを一緒に投げましたが、それは必ずしもきれいではなく、もっと良い解決策がどこかに存在しているはずだと思います。 ルール(またはルールのグループ)の相対的な順序を実装するためにPuppetの独自の依存メカニズムをうまく活用するPuppetベースのソリューションに特に興味があります。

4
ゲートウェイを介して接続すると、RDPクライアントアドレスが不明になる
RDPクライアントアドレスに基づいてTSセッション内のプリンターをマップするプリンターGPOを作成するために、壮大なタスクでshowtopperに遭遇しました-ゲートウェイサーバーを使用している場合、アドレスは不明です:( RDゲートウェイ経由のセッションで+ステータスを右クリックします。 RDゲートウェイを通過しないセッションで同じこと: これが回避できるかどうか誰か知っていますか?この情報を渡すために、ゲートウェイサーバーでドキュメント化されていないレジストリの変更を行うことができますか?

2
信頼性の低い接続によるトラフィックルーティング
コストを節約するために、遠端でDSLリンクを介してすべて本社に接続されているオフィスのグループがあります。(私たちは非営利団体ですので、質問しないでください) これまで、リモートサイトを処理するISPとOpenVPNが動作するT1回線を処理するISPとの間のリンクアップに顕著な問題があったため、これらのリンクが頻繁にダウンします。 私たちのメールサーバーのパブリックインターフェイスは、最初のプロバイダーのネットワーク上にあるため、正常に機能しましたが、DSLであるため、速度が大幅に低下します。 アップストリームネットワークの信頼性の問題に対処するために、リモートサイトのDNSレコードを変更して、トンネルが起動している場合は内部IPを、メインサイトへのVPNトンネルが停止している場合はパブリックIPをポイントするスクリプトを作成しました。 これをよりエレガントな方法で行うことができます(これは、(cron駆動のスクリプトではなく)瞬時に行われ、ユーザーに対して透過的です)。 編集:リモートオフィス:ベンダーが提供するさまざまなActiontecとMotorola、およびNetgearsとLinksysファイアウォールを備えたいくつかを実行しているUbuntu 9.10 LTSPサーバー。本社:/ 27上の各IPに個別のファイアウォールを備えた複数のNetgear FVS318 / 338シリーズファイアウォールを備えたほぼ100%Linux(この場合はCentOS)。(別の質問はありません。私がここに到着する前でした)
10 vpn  routing  openvpn 

4
磁石はHDDとSSDにどのような影響を与えますか?[閉まっている]
閉まっている。この質問は、オフトピック。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 8年前休業。 マグネットは、ハードディスクドライブやソリッドステートドライブに接触するとどうなりますか?

2
OpenLDAP-slapd.confはどこにありますか?
Unbuntu 10.04にOpenLDAPをインストールしました。LDAP を設定したかったのですが、slapd.confが見つかりません/etc/ldap/ 。このディレクトリにはldap.confがありますが、同じではないようです。 どうすればLDAPを設定できますか?
10 ubuntu  openldap 

3
Linux:ファイルを読み取るのにいくつのディスクI / Oが必要ですか?それを最小化するには?[重複]
この質問にはすでに回答があります: Linux:ファイルを読み取るのにいくつのディスクI / Oが必要ですか?それを最小化するには? (5つの答え) 5か月前に閉鎖。 FacebookのHaystackに関するこの論文によると、 「NASアプライアンスがディレクトリメタデータを管理する方法が原因で、ディレクトリのブロックマップが大きすぎてアプライアンスで効果的にキャッシュできないため、ディレクトリに数千のファイルを配置することは非常に非効率でした。その結果、10以上のディスク操作が発生して、単一のイメージ。ディレクトリサイズをディレクトリあたり数百のイメージに減らした後でも、結果のシステムでは、通常、イメージをフェッチするために3つのディスク操作が発生します。ファイルの内容を読む。」 私はファイルシステムディレクトリのメタデータとiノードが常にOSによってRAMにキャッシュされ、ファイルの読み取りには通常1つのディスクIOしか必要としないと想定していました。 この論文で概説されている「複数のディスクIOが単一のファイルを読み取る」という問題はNASアプライアンスに固有のものですか、それともLinuxにも同じ問題がありますか? イメージを提供するためにLinuxサーバーを実行する予定です。何らかの方法でディスクIOの数を最小限に抑えることができます。理想的には、OSがすべてのディレクトリとiノードデータをRAMにキャッシュし、各ファイルの読み取りに必要なディスクIOは1つだけであることを確認します。

1
2.5インチドライブと3.5インチドライブ
2.5インチドライブと3.5インチドライブの比較を公開しています。私が想定していたのは、2.5インチ15kドライブと3.5インチ15kドライブのパフォーマンスは同じであることですが、最近2.5インチ15kはかなり高速であり、10k 2.5インチは15k 3.5とほぼ同じ速度であると主張するベンチマークが表示されましたインチ。問題は、これらのベンチマークが実行されたプラットフォームが原因で、ほとんどの人がこれらのベンチマークを再現できないことです。 基本的に、いくつかの3.5インチ15kドライブを使用するメインフレームは、同じ設定の10k 2.5インチドライブを使用するメインフレームとほぼ同じように動作しますか?

1
特定の送信者/サーバーでのみスキャンするようにamavisd-newを構成するにはどうすればよいですか?
特定のクライアント(IP、CIDR、またはホスト名)または送信者の電子メールドメインのスパムのみをスキャンするようにamavisd-newを構成する方法を教えてください。 私は受信者のメールアドレスでそれを行うことが可能であることを知っていますが、送信者のメールアドレスに対してそれを行う方法についてはできません。ポリシーバンクを使用して、受信者のIPアドレスでそれを行うことも可能です。しかし、私のアプローチは、受信者から独立し、送信者にのみ中継することです。 私が達成したいのは、Yahoo、Google、Hotmail、その他の大きな送信者からのメールのみをスキャンすることです。したがって、監視すべきでない送信者よりも監視すべき送信者を設定する方が簡単です。 MTA側で達成する方が簡単であることはわかっていましたが、MTA側で既に解決策を講じているため、これは問題の一部ではありません。amavisd-newでやりたいです。また、送信者をホワイトリストに登録する方法を知ることは役に立ちません。これは、メールがすべてのスキャンを通過することになりますが、否定的なスコアが高くなることを意味します。大手企業から送信されない限り、メールはまったくスキャンされるべきではありません。 それでは、amavisd-newのどのパラメーターが、特定の送信者のスキャンを有効にし、これらのパラメーターのみを有効にするのに適切なパラメーターですか?

3
LinuxからMacにSSH転送されたX11ディスプレイがしばらくして失われる
Mac(10.7.2)からLinux(Ubuntu 8.04)にログインするときに、X11接続をssh転送することで、新たな厄介な問題が発生します。ssh -Xを使用してリモートマシンにログインし、そのシェルからX11ベースのアプリケーションを起動しても問題はありません。 最近起こったのは、転送されたディスプレイがブロックされているため(おそらく)、同じシェルからのX11アプリケーションの追加の呼び出しが、しばらく(数時間程度)後に開始できないことです。たとえば、xtermを起動しようとすると、次のような、不適切なDISPLAY設定に関する通常のメッセージが表示されます。 xterm Xtエラー:ディスプレイを開けません:localhost:10.0 しかし、ログインしてすぐに開始したX11アプリケーションは、以前に開始したものとまったく同じディスプレイ(localhost:10.0)を使用して、問題なく実行されています。 sshd_configで詳細ログをオンにしましたが、xtermの起動試行の失敗に応じて、/ var / log / auth.logファイルにこれが表示されます。 sshd [22104]:チャネル8:オープン失敗:管理上禁止:オープン失敗 サーバーに再度ssh -Xを実行して、新しいシェルを開始し、新しいディスプレイ(localhost:11.0)を割り当てた場合、同じプロセスが繰り返されます。 )、しかし数時間後、そのシェルから新しいものを開始できなくなります。 詳細:Ubuntu 8.04で実行されているOpenSSH sshdサーバー、ディスプレイは、デフォルトのApple XサーバーでLion(10.7.2)を実行しているMacに転送されます。システムは、1つのスイッチを介してイーサネットLANに接続されています。どちらのマシンもファイアウォールを実行していません。最近(数日前)まで、このセットアップは完全に機能したので、次にどこを見ればいいのか迷っています。私は決してX11やSSHの専門家ではありませんが、UNIX / Linuxの経験は豊富です。sshd_configのTCPKeepAliveをnoに設定したり、「host + localhost」を設定したり(私がグーグルしていることがわかります)など、これをデバッグするためにいくつかのオプションを変更しようとしましたが、クライアントまたはサーバーの構成に明らかな変更はありません。 Linux 11.10ラップトップから同じネットワークとスイッチを介して同じリモートホストにログインする場合、この問題は発生しません。Macからの同じ実験が失敗しても、同じsshログインシェルからxtermを数時間後に呼び出すことができます(確認のために今朝テストしました)、Mac固有の問題のようです。 「LogLevel DEBUG3」がリモートマシン(sshdサーバー)で設定されており、クライアント接続に変更が加えられていない場合、/ var / log / auth.logは、使用されているポート番号である接続ステータスレポートにわずかな変更を一晩表示します。 Linuxマシンからの1つの成功したsshセッション(私は思う)によって、以下の接続#7: sshd [20173]:debug3:チャネル7:ステータス:次の接続が開いています:\ r \ n#0 server-session(t4 r0 i0 / 0 o0 / 0 fd …
10 ssh  mac-osx  x11  display 

1
NGINXはHEADをGETリクエストに変換します
ひどい設計上の決定が原因で、HTTP HEADリクエストに応答できないアプリケーションがあります( 'Method Not Allowed'を返します)。HEADリクエストを正しく返すようにソフトウェアを変更するのは難しいです。不可能ではありませんが、余分な作業です。アプリケーションはNGINXプロキシの背後にあり、NGINXがクライアントから受信したHEADリクエストをバックエンドへのGETリクエストに変換して、ヘッダー以外の応答を破棄し、それをアプリケーションサーバーがHEADリクエストに応答できたかのようにクライアント。 現在の構成(かなり標準) upstream ourupstream{ server unix:/var/apps/sockets/ourapp.socket.thread1 server unix:/var/apps/sockets/ourapp.socket.thread2 server unix:/var/apps/sockets/ourapp.socket.thread3 [like 20 of these] } server { listen 1.2.3.4:80; server_name ourapp; access_log /var/apps/logs/ourapp.nginx.plog proxy; error_log /var/apps/logs/ourapp.nginx.elog info; gzip on; gzip_types text/plain text/html; proxy_intercept_errors on; proxy_connect_timeout 10; proxy_send_timeout 10; proxy_read_timeout 10; proxy_next_upstream error timeout; client_max_body_size 2m; error_page …
10 nginx 

3
Windowsサービスが再起動後に自動的に起動しないのですか?
.NETで記述されたWindowsサービスがいくつかあります。サービスmmc内で手動で正常に起動しますが、自動に設定されているにもかかわらず、マシンの電源を投入(または再起動)しても起動しません。 更新イベントログで、「xyzが開始されました」と表示される代わりに、他のすべてのサービスが開始されているのと同じように、「xyzサービスが停止状態になりました」と表示されます。また、「slsvcサービスからのトランザクション応答を待機中にタイムアウト(30000ミリ秒)に達しました。」という別のエラーが発生しました。 それらを手動で開始すると、期待どおりにイベントログに通常のエントリが表示されます。再起動を強制し、すべてのサービスを再びオフにする次のWindows Updateパッチまで、すべて正常です。 何か案は?私はそれらを遅延開始に設定してみましたが、明らかな違いはありません。
10 windows  service  .net 

2
IIS 7.5がエラーコードでCache-Control Max-Ageを送信しないようにする
キャッシュコントロールMax-Ageヘッダーが添付された静的コンテンツがいくつかあるので、クライアントは静的コンテンツをキャッシュします。ただし、IIS 7.5は、クライアントにこれをキャッシュするようにアドバイスするエラー応答がある場合でも、このヘッダーを送信します。 これは、一部のプロキシがそのエラー応答をキャッシュするという悪影響があります。私はできるVary: Accept,Accept-Encodingが、これは実際Max-Ageにはエラー応答に出かけるという根本的な問題に対処していない。 現在関連するIIS web.configセクションは次のとおりです。 <configuration> <system.webServer> <staticContent> <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="7.00:00:00" /> </staticContent> </system.webServer> </configuration> クライアントまたはプロキシに400/500エラーコードをキャッシュしないように指示する方法はありますか?
10 iis  http  iis-7.5  cache 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.