サーバー管理者

システムおよびネットワーク管理者向けのQ&A

7
WebサーバーのnmapでTCPポート554および7070が開いていることが表示される
さまざまなWebサイトをホストするWebサーバーがあります。外部からアクセスできる2つのサービスはSSHとApache2です。これらは、それぞれ非標準ポートと標準ポートで実行されています。他のすべてのポートは、arno-iptables-firewallを介して明示的に閉じられます。ホストはDebianテストを実行しています。 nmapを使用してホストをスキャンすると、PCごとに異なる結果が生成されることに気付きました。ホームネットワーク(BT Homehubの背後)のラップトップから、次のものを取得します。 Not shown: 996 filtered ports PORT STATE SERVICE 80/tcp open http 554/tcp open rtsp 7070/tcp open realserver 9000/tcp open cslistener 一方、nmap 5.00とnmap 5.21を実行しているノルウェーのLinuxボックスを使用する米国ベースのサーバーからスキャンすると、次のようになります。 Not shown: 998 filtered ports PORT STATE SERVICE 80/tcp open http 9000/tcp open cslistener 私の内部ネットワークまたはISPがうまくいっていることを願っていますが、確信が持てません。 を実行しnetstat -l | grep 7070ても何も生成されません。ポート554についても同様です。 誰もが私が見ている特異性を説明できますか?
11 security  debian  port 

5
sshにユーザーにプロンプ​​トを表示させる
login_name引数なしでsshを実行すると、ローカルユーザー名がlogin_nameとして自動的に使用されます。例えば: cogan@localhost$ ssh myserver cogan@myserver's password: sshにlogin_nameの入力を強制する方法はありますか?
11 ssh 

1
ファイルが見つからないというエラーを与えるmysql init-file configオプション
mysqlが起動するたびにSQLスクリプトを実行したいのですが、Ubuntu 11.10では動作しません。 mysql構成ファイルに「init-file」オプションを追加しました。 > sudo emacs -nw /etc/mysql/my.cnf ... [mysqld] init-file=/etc/mysql/mysqlinit.sql ... しかし、mysqlを再起動すると、「ファイルが見つかりません」というエラーで失敗します。 > tail /var/log/mysql/error.log 111111 7:41:06 [ERROR] /usr/sbin/mysqld: File '/etc/mysql/mysqlinit.sql' not found (Errcode: 13) 111111 7:41:06 [ERROR] Aborting ただし、ファイルは確かに存在し、読み取り可能です。 > ls -l /etc/mysql/mysqlinit.sql -rwxr-xr-x 1 mysql mysql 30 2011-11-09 05:06 /etc/mysql/mysqlinit.sql これを解決する方法はありますか?これはUbuntuの奇妙なことですか、それとも何かおかしいことをしましたか? 情報: Ubuntu 11.10とMySQL 5.1を実行しています。 > mysqld …
11 ubuntu  mysql  apparmor 

2
nginxのデフォルトホストを設定するにはどうすればよいですか?
私はnginxインストールのデフォルトホストを設定する方法を見つけようとしています。私はnginx Wikiでこの記事を見つけました: http://wiki.nginx.org/NginxVirtualHostExample#A_Default_Catchall_Virtual_Host 残念ながら、これは機能しません。再起動後、私はこれを取得します: Restarting nginx: nginx: [emerg] unknown directive "http" in /etc/nginx/sites-enabled/catchall:1 nginx: configuration file /etc/nginx/nginx.conf test failed httpディレクティブを削除した後、私はこれを取得します: Restarting nginx: nginx: [emerg] unknown log format "main" in /etc/nginx/sites-enabled/catchall:7 nginx: configuration file /etc/nginx/nginx.conf test failed 私は公式のnginx PPAを使用しているUbuntu 10.04.3を使用しています。nginxのバージョン1.0.9が実行されています。
11 ubuntu  nginx 

3
scpは「予期しない<newline>」エラーを返します
scpサーバーからローカルマシンにファイルを送信しようとしていますが、次のエラーが表示されます。 protocol error: unexpected &lt;newline&gt; これは私の構文です: scp user@server:/path/to/file . このサーバーでは機能しませんでしたが、他のサーバーで同じコマンドを試したので、scpコマンドの構文ではなく、サーバーに問題があると推測できます。 何か案は?
11 ssh  scp 

3
Exchange 2010 ActiveSyncのリモートワイプを無効にする方法
AndroidモバイルデバイスをExchange ActiveSyncに接続する場合、一部のデバイスでは、デバイス管理者権限を付与する必要があります。これにより、Exchange管理者は電話をリモートでワイプできます。警告メッセージは、一部のモバイルユーザーを怖がらせ、Exchange ActiveSyncを完全に使用することから遠ざけています。 Exchange Server 2010で彼の機能を無効にするにはどうすればよいですか?[セキュリティ侵害はここでは問題ではありません]

2
ブラウザが複数のIPを処理する方法[終了]
閉じた。この質問はより集中する必要があります。現在、回答を受け付けていません。 4年前に閉鎖されました。 ロックされています。この質問とその回答はロックされています。なぜなら、質問はトピックから外れていますが、歴史的に重要だからです。現在、新しい回答やインタラクションを受け入れていません。 ブラウザーが特定のホスト名(たとえば、ip1とip2)の複数のAレコードを取得し、そのうちの1つがアクセスできない場合、正確なブラウザーの動作に関する情報を誰かに教えてもらえますか。 次のような(ただしこれらに限定されない)EXACTの詳細に興味があります。 ブラウザはOSから2つのIPを取得しますか、それとも1つのみを取得しますか? ブラウザが最初に試行するIP(ランダムまたは常に最初のIP)さて、ブラウザが失敗したip1で起動したとしましょう ブラウザはどのくらいの間ip1を試行しますか? ユーザーがip1の待機中に「停止」をクリックしてから、「更新」をクリックした場合 ブラウザはどのIPを試行しますか? タイムアウトするとどうなりますか?ip2の試行を開始しますか、それともエラーを出しますか?(そして、エラーの場合、ユーザーが更新をクリックしたときにどのIPがブラウザーで試行されるか)。 ユーザーが更新をクリックすると、ブラウザは新しいDNSルックアップを試行しますか? ここで、ブラウザが最初にip2を動作させたと仮定しましょう。 次のページリクエストでは、ブラウザは引き続きip2を使用しますか、それともランダムにipsを切り替えますか? ブラウザがキャッシュにIPを保持する期間 ブラウザが新しいDNSリクエストを送信し、同じIPを取得した場合、同じ既知の動作しているIPを使用し続けるか、プロセスが最初から開始され、2つのうちのいずれかを試行しますか? もちろん、それはすべてブラウザに依存している可能性があり、バージョンやプラットフォーム間でも異なる可能性があります。詳細を最大限にお知らせいただければ幸いです。 この目的-ラウンドロビンDNSベースが使用され、ホストの1つが失敗した場合にユーザーが実際に経験することを正確に理解しようとしています。 DNS負荷分散がいかに悪いかについては尋ねません。「やらない」、「悪い考え」、「heartbeat / proxy / BGP / whateverが必要」などと答えないようにしてください。



5
AmazonのEC2無料利用枠の実際の費用はいくらですか?[閉まっている]
閉じた。この質問は意見に基づいています。現在、回答を受け付けていません。 4年前に閉鎖されました。 ロックされています。この質問とその回答はロックされています。なぜなら、質問はトピックから外れていますが、歴史的に重要だからです。現在、新しい回答やインタラクションを受け入れていません。 Amazonには無料のEC2ティアがあることに気付きました。私はそれを試すことに非常に興味がありますが、そこで自分のサイトをホストすることを恐れています。ユーザーに課金するすべての方法(帯域幅、ディスク容量、動作時間数に対する課金)を確認すると、頭が回転し始めます。私はdrupalサイトを運営してsshを持ちたいだけです。月あたり5,000ヒット未満ですが、頻繁に成長しています。現在のサイトに深刻な問題はありませんが、少しの節約をしようとしています。 私はこのような投稿を見て、どうにかして月に10ドルかそこらを払って動けなくなるのではないかと思っています。誰もが無料が本当に無料であることを確認できますか?人々がお金を払うことに陥る「trap」とは何ですか?
11 amazon-ec2 

5
UEFIネットブートメニュー
既存のPXE syslinux環境があり、同様のEFIベースのネットブート環境をセットアップしたいと思います。 下のスクリーンショットにあるように、私はさまざまなメニューの大ファンです。同等のものを見つけたいです。 理想的な機能は次のとおりです。 メニュー サブメニュー Linuxカーネル/ initrd TFTPロード(当然) 任意のEFIアプリケーションの負荷 次のブートオプションへのフォールスルー これらのニーズを満たすソフトウェアはどれですか?
11 netboot  tftp  uefi 


1
postfix sasl「saslauthdサーバーに接続できません:そのようなファイルまたはディレクトリはありません」
smtp認証でpostfixをセットアップしようとしました。/ etc / shadowをレルムとして使用したい 残念ながら、認証しようとすると「一般的なエラー」が表示されます # nc localhost 25 220 mail.foo ESMTP Postfix AUTH PLAIN _base_64_encoded_user_name_and_password_ 535 5.7.8 Error: authentication failed: generic failure ではmail.warnログファイル私は、次のエントリを取得します Oct 8 10:43:40 mail postfix/smtpd[1060]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory Oct 8 10:43:40 mail postfix/smtpd[1060]: warning: SASL …

2
tcpkillユーティリティを使用してTCP接続を強制終了する方法
を使用して、確立されたTCP接続を強制終了しようとしていますtcpkill。接続はオープンHTTPS接続です。netstatでは次のように表示されます。 tcp 0 0 X.X.X.X:55601 X.X.X.X:https ESTABLISHED だから、manページに従って、私は入力します: $ tcpkill -i eth1 -9 port 443 tcpkillユーティリティの出力: tcpkill: listening on eth1 [port 443] ...そしてハングします。約15分待った後、ここで何が起こっているのかわかりません。 私は何か間違っていますか?
11 linux  tcp  netstat 

3
TCPおよびUDPの送信元ポートは1024を超えてランダムである必要があるというドキュメントはどこにありますか?
ソースポートがランダムで、1024〜65535の範囲にあることが文書化されている場所を見つけるのに苦労しています。 これはどのRFCで文書化されていますか? 編集: 特権ポートの最初のリファレンスはRFC2623 にあります。これはTCP / IPの実装により依存しており、事実上の標準であるようです。 IANAはポート番号を割り当てています(RFC1700)
11 tcpip  udp  rfc 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.