サーバー管理者

システムおよびネットワーク管理者向けのQ&A

5
Windowsファイアウォールはポート80を開いていますが、Apacheが接続できないようにします
私は非常に少数の(しかし重要な!)ページを提供するWindows 7マシンを持っています。ポート80 *へのトラフィックを許可する例外がありますが、Apache 2.2はまだページを提供できません(ただし、マシン自体から見ることができます)。ただし、Windowsファイアウォールを完全に無効にすると、ボックスにpingを実行してページを読み込むことができます。 Apacheがその仕事を行えるように、他に何を設定する必要がありますか? *実際、例外を80だけではなく「すべてのポート」に変更しても、同じことが起こります。


2
IIS 7.5 FTPがプレーンFTPのパッシブポート範囲を尊重しないのはなぜですか?
私は今夜​​、IIS 7.0のパッシブポート範囲の取り引き全体に苦労しました。最終的に、これは明らかにFTP / ESまたはFTP / ISにのみ適用されることに気付きました。プレーンftpを実行しようとすると、PORT要求に応答するときに必要なポート番号を割り当てます。 まず第一に、私は何かが欠けていますか。第二に、私がそうでない場合、なぜ世界でこのように機能するのですか? TIA。
11 iis  ftp 

4
Graylog2サーバーへのログの送信
Graylog2サーバーをセットアップしたばかりで、メインサーバーからgraylogサーバーにすべてのログを送信したいと考えています。メインサーバーのログを有効にし、に追加*.* @logs.example.com:1337してログをグレーログサーバーに送信しています/etc/rsyslog.conf。 必要なのは、Graylog2にすべてのApacheログ、システムログ(SSHログイン、拒否されたログインの場合)、および監視する必要があるその他のログを収集させることです。 Apacheログについては、Railsログも必要です。私のサイトは、に位置している/srv/www/、その後、構造があるsitename.com/public_htmlとsitename.com/logs。サーバーには多くのサイトがあり、すべてのエラーを表示し、それらからいくつかの素晴らしいグラフを作成する簡単な方法が欲しいので、Graylog2を使用したい理由は... あるフォルダのログ内のログファイルaccess.logとerror.log。 Railsのログはにありsitename.com/public_html/logます。これにはが含まれますproduction.log。



7
CIFS資格情報ファイルのマウントに特殊文字が含まれる
XenServer(5.6 FP1)で共有をマウントできません。コマンドラインから私は試します: mount.cifs //server/share /mnt/share -o credentials=credfile credfileの内容は次のとおりです。 username=Administrator password=What@zR\!p3s 上記のマウントコマンドを実行すると、「アクセスが拒否されました」というメッセージが表示されます。ただし、次のコマンドを実行すると動作します: mount.cifs //server/share /mnt/share -o username=Administrator,password=What@zR\!p3s 「\」はバングを回避するためのものであり、資格情報ファイルでこれを使用してまたは使用せずにこれを試したことに注意してください。助言がありますか?
11 linux  mount  cifs 

2
ポート80を閉じてもポート443を使用できますか?
HTTPS経由でのみアクセスできるWebアプリケーションがあります。 ポート80を完全に閉じることは可能ですか? ブラウザーが暗号化されていない方法でポート80をヒットできないという事実以外に、ポート80を閉じることに欠点はありますか? 検索エンジンの可視性は優先事項ではありません。
11 apache-2.2  ssl  https 

1
NFS v3とv4
NFS v4がNFS v3よりもはるかに高速になる理由と、v3に調整可能なパラメーターがあるかどうかは疑問です。 ファイルシステムをマウントします sudo mount -o 'rw,bg,hard,nointr,rsize=1048576,wsize=1048576,vers=4' toto:/test /test そして実行する dd if=/test/file of=/dev/null bs=1024k 私は読むことができます200〜400メガバイト/秒 が、ときに私の変更バージョンにvers=3再マウント、と私は取得のみddを再実行して90メガバイト/秒。読み取り中のファイルは、NFSサーバー上のメモリ内ファイルです。接続の両側はSolarisであり、10GbE NICを備えています。すべてのテスト間で再マウントすることにより、クライアント側のキャッシュを回避します。私が使用dtraceNFS経由で提供されているどれだけ速くデータを測定するために、サーバー上で参照すること。v3とv4の両方について、次のように変更しました。 nfs4_bsize nfs3_bsize デフォルトの32Kから1M(v4では32Kで最大150MB / s)を調整しようとしました nfs3_max_threads clnt_max_conns nfs3_async_clusters v3のパフォーマンスを改善しますが、行きません。 v3で4つのパラレルを実行するとdd、スループットが90MB / sから70-80MBに低下するため、問題は共有リソースであると思われます。資源。 ウィンドウサイズを取得するdtraceコード: #!/usr/sbin/dtrace -s #pragma D option quiet #pragma D option defaultargs inline string ADDR=$$1; dtrace:::BEGIN { TITLE = 10; title …
11 solaris  solaris-10  nfs4  nfs 

1
topコマンドを使用したcronスクリプトとTERM定義の問題
サーバーでの現在のCPU使用を確認するためにcronプロセスを実行する際に問題があります。 私のスクリプトは次で始まります: top -c -n 1 -u www-data > /tmp/kill-cpu 私はコンソールで問題なく実行できますが、cronでは top:ttyの取得に失敗しました topに-bオプションを使用した場合 top -b -n 1 私は得る 「ダム」:不明な端末タイプ。 TERMとしてxtermを使用しています ご協力ありがとうございます:) リト。 解決策:私は次の方法で問題を解決できました。 ln -s /lib/terminfo/d/dumb /usr/share/terminfo/d/dumb
11 top  cron  xterm  term 

4
Ubuntu Server 11.04で78 GBとして表示されるDell T7500の96 GB RAM
Ubuntu Server 11.04を実行しています。12x8GB DIMMを搭載した新しいDell Precision T7500ワークステーションを使用しており、BIOSに96GBが表示されていますが、/ proc / meminfoを確認すると次の結果が得られます。 cat /proc/meminfo | grep MemTotal MemTotal: 82650584 kB 無料で提供します: free -m total used free shared buffers cached Mem: 80713 5254 75459 0 89 3304 -/+ buffers/cache: 1860 78852 Swap: 95365 2 95363 付属のWin7インストールでは、96 GBと80 GBが使用可能であることが示されました。 誰が何が起こっているか知っていますか?
11 ubuntu  memory 

3
8月8日の停止後、復旧スナップショットから有効なAMIを再作成する方法は?
Amazonの8月8日の停止後、すべての(EBSベースの)AMIが多くの ユーザーに対して機能しなくなりました。これは、AMIのベースとなっているスナップショットの一部のセクターが破損しているためです。 ただし、Amazonはディスクの問題を修正する必要があるリカバリスナップショットを作成しました。これらは、「vol-xxxxxxxxの回復スナップショット」の行に沿って名前が付けられています。 回復スナップショットから新しいAMIを作成しましたが、正常に機能しましたが、この新しいAMIから起動されたインスタンスは機能しません。それらの状態は「実行中」ですが、マシンにsshすることも、そこで実行されるWebサービスにアクセスすることもできません。要約すると、これは(AWS管理コンソールからアクセス可能なシステムログから): EXT3-fs: sda1: couldn't mount because of unsupported optional features (240). EXT2-fs: sda1: couldn't mount because of unsupported optional features (244). Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1) その回復スナップショットから作成されたボリュームをAWSの別のサーバーにマウントしましたが、すべてが非常に正常に見えます。たとえば、fsckのコメント: $ sudo fsck -a /dev/xvdg fsck from util-linux-ng 2.17.2 uec-rootfs: clean, 53781/524288 …

2
リモートAmazon RDS MySQLデータベースのローカルバックアップを作成する方法
リモートAmazon RDS MySQLデータベースのローカルバックアップを作成するにはどうすればよいですか?私が知る必要があるのは、MySQLサーバー(もちろん同じバージョン)のどこにいても新しいデータベースに復元するために使用できる(リモートAmazonスナップショットではなく)MySQLデータベースの完全なローカルバックアップを作成する方法です。 注:MySQL経由でフラットファイルからデータをインポートする方法を知っています。接続方法は次のとおりです。 mysql -h mydb.xxxxx.us-east-1.rds.amazonaws.com -u myuser -P 3306 -p 単一のデータベーステーブルを読み込む方法は次のとおりです。 mysql> LOAD DATA LOCAL INFILE 'C:/Temp/t1.tab' INTO TABLE t1 LINES TERMINATED BY '\r\n';

1
Apacheは、MaxClients設定に達した後にサービスを停止します
私は次のようにワーカーMPMで構成されたApacheサーバーを持っています: <IfModule mpm_worker_module> ServerLimit 20 ThreadLimit 50 StartServers 3 MaxClients 1000 MinSpareThreads 50 MaxSpareThreads 200 ThreadsPerChild 50 MaxRequestsPerChild 10000 </IfModule> サーバーは、毎日約200万件のリクエストを処理します。リクエストが発生すると、Apacheサーバーは新しい接続の受け入れを停止します(ブラウザーは接続できません)。また、プロセスはプロセスリストに残ります。メモリ使用量は約10%、CPUは0%です。Apacheサーバーは、必要なときにプロセスをリサイクルできなかったようです。 エラーログでクラッシュに関連するものを見つけました。 [Mon Aug 15 12:36:24 2011] [error] child process 11444 still did not exit, sending a SIGKILL [Mon Aug 15 12:36:24 2011] [error] child process 12090 still did not …
11 apache-2.2 


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.