サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
Intel EFIシェルでUSBドライブが検出されない
Intel S3420GPLCボードを更新する必要があります。BIOS、BMC、FRU / SDR、すべて。 Intelのダウンロードでは、すべてがほぼ自動化されています。統合されたEFIシェルを起動し、USBディスク/キーをマウントstartup.nshし、ダウンロードに含まれるスクリプトを起動することになっています。 つまり、4GBのUSBキーとより大きな60GBのUSBディスクの両方で試してみましたが、結果は良くありません。もちろん、どちらにもFAT32ファイルシステムがあります。 それらをプラグインしmap -rてEFIシェルから実行すると、キーはリストされません。ディスクが表示されblk0、それに切り替えることができます。問題はスクリプトに到達しています: lsまたはdirコマンドが戻ります"Cannot open current directory - Not found" cd update 戻り値 "Target directory not found" ディスクが正しくマウントされているようにも見えません。私が試すことができるコマンドや、オフになる可能性のあるBIOS設定へのポインタはありますか? 編集、新しい情報: さらに別のハードディスクで再試行しましたが、最初のハードディスクと同じ結果が得られました。 USBポート/コントローラーは問題ではないようです。私が使用したものはすべてキーボードで動作しました。 mount blk0 fs0エイリアスを作成しましたが、blk0読みやすくしませんでした。
11 mount  usb  intel  bios  uefi 

2
F5 BigIP構成でのノードIPアドレスの変更
約600台のサーバーを再IP化する必要がありますが、それだけでは十分ではありませんが、1つの部分を除いてプロセス全体を自動化しました:F5構成 私が見つけることができるすべてのドキュメントで、SOAPインターフェースを介してノードのIPアドレスを変更することについては何もありません、それは不可能のようです。ほとんどの人は、エクスポートされた設定ファイルにsedトリックを使用してそれらを再インポートすることを提案しますが、それは非常に脆すぎます。 SOAPを介してdelete-create-re-add-to-poolsダンスを行うことを検討していますが、それも壊れやすいようです。もっと良い方法はありますか? 注:BigIPのv10とv11の両方でこれを行う必要があります。
11 f5-big-ip 

2
コンシューマクラスのハードディスクはzfsで問題ありませんか?
最近、HP DL380 G6という新しいサーバーを購入しました。ストックスマートアレイp410コントローラーをLSI 9211-8iに置き換えました。 私の計画では、同じベアメタルで実行されるXENの基盤となるストレージとしてZFSを使用します。 スマートアレイコントローラーでSATAディスクを使用できると言われましたが、コンシューマードライブにはTLER、CCTL、およびERCがないため、お勧めしません。これは事実ですか? LSIコントローラーをJBOD(RAIDパススルーモード)で使用すると、使用するディスクの種類がスマートアレイコントローラーの場合と同じくらい大きな影響を与えるかどうか疑問に思いました。 仮想化のために書き込みキャッシュを使用しないRAIDシステムを使用しようとすると、パフォーマンスが低下することを認識しています。しかし、私はZFSにSSDを追加することを考えていました。それは違いを生むでしょうか? ZFSの使用に夢中になっているのは、重複除去と圧縮のためです。スマートアレイコントローラーがこれらの機能を実行できるとは思いません。

1
I / Oスニッフィングの方法
サイジングのために、アプリケーションがI / Oサブシステムに対してどのような要件を持っているかを理解する必要があります。私はI / Oスニッフィングと呼んでいることを行い、ブロックレイヤーから次のようなイベントのリストを取得したいと思います。 initiator XYZ requests block 4711 from device 0815 initiator BLA writes block 1234 to device 9876 blktraceは私が探しているものだと言われましたが、そのツールからこの情報を取得することはできません。
11 linux  io  block  trace 

5
ホスト名を正しく設定する-Amazon EC2のFedora 20
環境 Amazon EC2で実行されているFedora 20クラウドイメージがあります(以降、「インスタンス」と呼ばれます)。また、ホスト名を永続的に設定することについて不確実性があります。 ゴール この場合、インスタンスのホスト名をpenpen.homelinux.orgに設定したいとしましょう。(この名前はを使用してDynDNSでも登録されますddclientが、それはここでは興味のない別の側面です。) もちろん、ホスト名はブート完了後に手動で設定できます(hostnamectl特に使用中)。ただし、最初のログインの前に正しいホスト名を設定する必要があります。 従来、ホスト名を永続的に設定するには、の内容を変更します/etc/hostname。残念ながら、これはここでは機能しません。 デフォルトのシステム動作 デフォルトでは、インスタンスはホスト名を内部EC2名に設定します。起動後、ホスト名を生成する小さな場所をすべて確認できます。 Kernel hostname via 'sysctl' : ip-10-164-65-105.ec2.internal Kernel domainname via 'sysctl' : (none) File '/etc/hostname' : contains 'ip-10-164-65-105.ec2.internal' File '/etc/sysconfig/network' : exists but has no 'HOSTNAME' line According to the shell : HOSTNAME = ip-10-164-65-105.ec2.internal Nodename given by 'uname --nodename' : …

2
インターネットなしの起動後にntpが回復しないのはなぜですか?
インターネットにアクセスせずに起動する可能性のあるいくつかのLinuxデバイス(TOYチップがないため、ntpに完全に依存しています)があります(スイッチへのリンクがアップしています)。ntpサービスが開始されますが、明らかに何のピアが連絡されません。私はその後で終わるntp実行されているサービスが、どのピアと同期していない(ntpq -p与え .INIT.状態) 問題は、インターネットへの接続が確立されるとこれが変わることです。 ブート時に接続が利用可能な場合、すべてが正常に機能します。私が手動で発行するかどうかを確認しますservice ntp restart(ntpピアに接続し、時間が正しく同期されます) ntpは定期的に再接続を試みるべきではありませんか? 「はい」の場合:これは私が設定するものです(設定に何も表示されませんでした) そうでない場合:サービスの再起動またはサービスの開始遅延を処理するための良い方法は何でしょうか(起動後n分でインターネットへの接続が回復すると想定できます) 注:ドキュメントから、最大プール時間(ntpがあきらめる前にピアに接続しようとする最大時間ですか?)は1024秒= 17分であり、これは確立に必要な時間よりはるかに長いようですインターネットアクセス(約2〜5分、最悪の場合)
11 linux  ntp  ntpd 

2
Fail2banログには、「fail2ban.filter:警告DNSルックアップを使用して決定されたIP:..」というエントリが入力されています。
私のfail2banログ/var/log/fail2ban.logは、次のようなエントリで完全に満たされています: fail2ban.filter : WARNING Determined IP using DNS Lookup: [IP address] 私はsshポートを変更した後、これが始まったのではないかと思います... これの原因は何か、それを止める方法はありますか?

2
CentOSシステムクロックの修正
時間C関数(エポックからの秒数)を使用すると、現在のCentOS 6サーバーの時間が、正しい時間の別のサーバーと比較して約7時間遅れていることがわかります。システムクロックを修正するにはどうすればよいですか?数週間前にこのサーバーをセットアップしただけなので、ドリフトしているとは思わないが、そうかもしれない。ntpdをセットアップしましたが、時間の差が大きすぎるために役に立たないでしょう。

2
RAID(10)でSSD(Intel 530)の読み取り/書き込み速度が非常に遅い
説明: サーバーがあります: モデル:HP ProLiant DL160 G6 4 x 240GB SSD(RAID-10) 72GB DDR3 RAM 2 x L5639 HP P410 RAIDコントローラー(256MB、V6.40、Romバージョン:8.40.41.00) SSDドライブは、540MB / sの読み取り速度と490MB / sの書き込み速度を備えた4つの新しい2.5インチIntel 530です。 CentOS 6 ファイルシステムはext4です しかし、これはRAID 10の読み取り速度のテスト結果です。 hdparm -t /dev/sda /dev/sda: Timing buffered disk reads: 824 MB in 3.00 seconds = 274.50 MB/sec [root@localhost ~]# hdparm -t …

1
Internet Explorer 9および10のグループポリシー設定がありません
単一のドメインコントローラーネットワーク(Windows Server 2008 R2、2003フォレスト/ドメインレベルで実行)があり、クライアントは現在WinXP ProからWin7 Proに移行しています。 Internet Explorerのプロキシ設定を制御する必要がある:Windows XP + Internet Explorer 7および8で正常に動作するが、Windows 7 + Internet Explorer 10および11では動作しないポリシーを構築しました 管理テンプレートの代わりにポリシー設定を使用してプロキシを設定する必要があるため、これは理にかなっています ただし、[設定]に移動して[新規]を選択しようとすると、選択できるのは5と6、7、および8のみです。 IE 5-8 http://blogs.technet.com/resized-image.ashx/__size/550x0/__key/CommunityServer-Blogs-Components-WeblogFiles/00-00-00-52-58/7558.gpp1.jpg IE9とIE10もあると期待しています(IE11はIE10設定を使用することを知っています) IE8ポリシーを使用してプロキシ設定を適用しようとしましたが、これはXPクライアントでは正常に動作しますが、7クライアントでは動作しません。プロキシ設定は空です。 作業中の中央ADMXストア(\ [FQDN] \ SYSVOL [FQDN] \ Policies \ PolicyDefinitions)があり、最初にWindows 2008 R2 + IE 10ポリシーのセットをコピーし、次にWindows 2012 R2 +のセットをコピーしましたIE 11ポリシー。 ローカルサーバーの問題である場合に備えて、バックアップしてから2012 R2ポリシーをローカルサーバーのc:\ Windows \ PolicyDefinitionsにコピーし、gpupdate / forceを実行します。 …

2
EC2 MySQLをAmazon RDSに最初に移行しようとしてもうまくいかない-スーパー権限
私は、EC2で実行されているMySQLから新しいAmazon RDSインスタンスに既存のデータベースを移動しようと試みました(移動できるかどうかを確認するための実験)。これまでのところ、うまくいきません。レプリケーションをセットアップする前に、最初のインポートで立ち往生しています(手順はこちら)。 前述のようにRDSインスタンスを準備し、mysqlを使用してEC2インスタンスから接続できます。mysqldumpコマンドを次のように実行しました。 mysqldump --master-data --databases db1 db2 > dump.sql 次に、次を使用してRDSにアップロードしようとしました。 mysql -h RDSHost -P 3306 -u rdsuser --password=rdspassword < dump.sql 最初の問題は、ダンプの22行目にありました。 マスターをMASTER_LOG_FILE = 'mysql-bin.000002'に変更し、MASTER_LOG_POS = 106; この行によりエラーが発生しましたERROR 1227 (42000) at line 22: Access denied; you need (at least one of) the SUPER privilege(s) for this operation。問題ありません。その行をコメントアウトして、後でmysql.rds_set_external_master()で修正したいと考えています。アップロードを再試行しましたが、非常によく似たエラーが発生しました:ERROR 1227 (42000) at …

2
Office365 SPFレコードのルックアップが多すぎます
まったくばかげた管理上の理由から、Office365に1つのメールボックスを持つ分割ドメインinclude:outlook.comがあり、SPFレコードに追加する必要があります。これに関する問題は、そのルールだけで最大10の9つの DNSルックアップが必要なことです。 真剣に、それは恐ろしいです。それを見てください: v=spf1 include:spf-a.outlook.com include:spf-b.outlook.com ip4:157.55.9.128/25 include:spfa.bigfish.com include:spfb.bigfish.com include:spfc.bigfish.com include:spf-a.hotmail.com include:_spf-ssg-b.microsoft.com include:_spf-ssg-c.microsoft.com ~all 我々は我々自身の大っぽいメールシステムを持っていることを考えると、我々はのためのルール持っている必要がありa、mx、include:_spf1.mydomain.com、およびinclude:_spf2.mydomain.com13件のDNSの原因検索のプットたちをPERMERRORsの厳格なSPFのバリデータと、非厳密/ひどく実装バリデータと完全に信頼できない/予測不可能な検証を。 include:肥大化したoutlook.comの記録からこれらのルールのうち3つを何らかの形で削除することはできますが、それでもO365が使用するサーバーをカバーできますか? 編集: コメンテーターは、短いspf.protection.outlook.comレコードを使用する必要があると述べています。それは一方である私にニュース、そしてそれがある短い、それは1つのレコードだけ短いです。 spf.protection.outlook.com include:spf-a.outlook.com include:spf-b.outlook.com include:spf-c.outlook.com include:spf.messaging.microsoft.com include:spfa.frontbridge.com include:spfb.frontbridge.com include:spfc.frontbridge.com 編集² 技術的にこれを次のように切り分けることができると思います: v=spf1 a mx include:_spf1.mydomain.com include:_spf2.mydomain.com include:spf-a.outlook.com include:spf-b.outlook.com include:spf-c.outlook.com include:spfa.frontbridge.com include:spfb.frontbridge.com include:spfc.frontbridge.com ~all しかし、これに関して私が目にする潜在的な問題は次のとおりです。 親spf.protection.outlook.comとspf.messaging.microsoft.comレコードの変更に遅れないようにする必要があります。何かが変更されたり、[god forbid]が追加された場合、それを反映するために手動で更新する必要があります。 実際のドメイン名では、レコードの長さは260文字であり、TXTレコードに2つの文字列が必要になります。また、そこにあるすべてのDNSクライアントとSPFリゾルバーが255バイトを超えるTXTレコードを適切に受け入れるとは信じていません。

1
管理者はすべてのマップされたドライブを表示します
セキュリティに関する私の理解では、管理者は、すべてのプロセス/所有者、ネットワーク接続/所有プロセスを表示できるのと同じように、コンピューターとのすべての接続を表示できる必要があります。ただし、Windows 8はこれを無効にしているようです。 管理者が実行時にWin Vista +で昇格を実行net useすると、使用不可としてリストされているすべてのドライブがマップされます。Windows 8では、管理者特権のプロンプトから同じコマンドを実行すると、「リストにエントリがありません」が返されます。動作はpowershellと同じですGet-WmiObject Win32_LogonSessionMappedDisk。 永続的なマッピングの回避策は、実行することGet-ChildItem Registry::HKU*\Network*です。これには一時的なマッピングは含まれません(私の特定の例では、管理者アカウントのエクスプローラーで作成されたため、「サインイン時に再接続」を選択しませんでした) 管理者が任意のユーザーの接続を表示するための直接/簡単な方法はありますか(各ユーザーコンテキストで実行されるスクリプトの省略)。UACが有効になっていると一部のプログラムがネットワークロケーションにアクセスできないことを読みましたが、特に当てはまるとは思いません。 私はこの答えを見ましたが、それはまだ非永続的なドライブに対応していませんユーザーがマップしたネットワークドライブをどのように見分けることができますか?

3
Windows Server 2012で2つの同時(+1コンソール)セッションを有効にする方法
Windows AzureでWindows Server 2012 VMを実行しています。 リモートデスクトップ経由で2つの同時管理セッションの機能を有効にします。これは、Windows Server 2012のEULAで許可されています。これは、本格的なターミナルサービス(リモートデスクトップサービス)機能とは異なります。 Windows Server 2000および2003では、複数の同時セッション(最大2、およびルート/consoleセッション)がデフォルトで有効になっています(ログアウトせずにRDP経由でログインすると、最初に再接続するのではなく、新しいセッションが作成されます)古いセッション)。Server 2008以降では、デフォルトでシングルセッションを使用します。これにより、管理が簡素化されるため(ほとんどの人は古いセッションに接続したいため)。 Windows Server 2008 R2では、リモートデスクトップホスト構成用のMMCスナップインを追加して、同時セッションを再度有効にすることができます。 ただし、Server 2012では、サーバーマネージャーからリモート管理スナップインを追加した後、リモートデスクトップホスト構成スナップインが削除されたようです。 Windows Server 2012で管理用リモートデスクトップの複数の同時セッションを再度有効にするにはどうすればよいですか?


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.