サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
fsck後に破損したext4ファイルシステムを回復するにはどうすればよいですか?
ソフトウェアraid5上のluksにext4ファイルシステムがあります。私がスペースを使い果たし始めたとき、ファイルシステムは数年間「正常に」動作していました。6x2Tドライブに9Tボリュームがありました。アレイを大きくするまでmdadm fail、remove、add、rebuildを繰り返してプロセスを繰り返し、3Tドライブへのアップグレードを開始しました。その後、luksコンテナーを成長させ、マウントを解除してresize2fsを実行しようとすると、ファイルシステムが汚れていてe2fsckが必要であるというメッセージが表示されました。 考えずにe2fsck -y / dev / mapper / candyboxを実行しただけで、すべての種類のinodeが削除されるタイプのメッセージを吐き出しました(正確には覚えていません)e2fsckを強制終了し、懸念しているバックアップデータにファイルシステムを再マウントしようとしました。この時点でマウントしようとすると、次のようになります: # mount /dev/mapper/candybox /candybox mount: wrong fs type, bad option, bad superblock on /dev/mapper/candybox, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so 古いログを振り返ると、マシンが起動するたびにファイルシステムがこのエラーを出していることに気付きました。 kernel: …

4
IPv6 AAAAレコードに関連する遅延を防ぐ方法
WindowsサーバーはAAAA、Windows DNSサーバーにIPv6 レコードを登録しています。ただし、ネットワークでIPv6ルーティングが有効になっていないため、これによりストールが頻繁に発生します。 Microsoft RDPは最悪の犯罪者です。AAAADNSにレコードがあるサーバーに接続する場合、リモートデスクトップクライアントは最初にIPv6を試行し、接続がタイムアウトするまでIPv4にフォールバックしません。パワーユーザーは、IPアドレスに直接接続することでこの問題を回避できます。でIPv4アドレスを解決すると、ping -4 hostname.foo常に即座に機能します。 この遅延を回避するにはどうすればよいですか? クライアントでIPv6を無効にしますか? いいえ、MicrosoftはIPv6がWindowsオペレーティングシステムの必須部分であると言います。 これが一貫してどこにでも設定されるようにするためのクライアントが多すぎます。 後でIPv6を実装すると、さらに多くの問題が発生します。 サーバーでIPv6を無効にしますか? いいえ、MicrosoftはIPv6がWindowsオペレーティングシステムの必須部分であると言います。 IPv6スタック全体を無効にするには、不便なレジストリハックが必要です。 これをすべてのサーバーで正しく設定するのは不便です。 後でIPv6を実装すると、さらに多くの問題が発生します。 ユーザー向けDNS再帰のIPv6レコードをマスクしますか? いいえ、NLNet Unboundを使用していますが、それをサポートしていません。 Microsoft DNSサーバーへのIPv6 AAAAレコードの登録を禁止しますか? それが可能だとは思わない。 この時点で、DNSゾーンからすべてのAAAAレコードを削除するスクリプトの作成を検討しています。より良い方法を見つけてください。 更新: DNS解決は問題ではありません。@joeqwertyが答えで指摘しているように、DNSレコードは即座に返されます。どちらAとAAAAレコードがすぐに利用できます。問題は、一部のクライアント(mstsc.exe)が優先的にIPv6経由で接続を試行し、IPv4にフォールバックするまでに時間がかかることです。 これはルーティングの問題のようです。ping宛先アドレスがルーティング不可能であるため、コマンドは、「一般的な失敗」のエラーメッセージを生成します。 C:\Windows\system32>ping myhost.mydomain Pinging myhost.mydomain [2002:1234:1234::1234:1234] with 32 bytes of data: General failure. General failure. General failure. General failure. Ping statistics for 2002:1234:1234::1234:1234: …

2
cronジョブのタイムアウトの設定
Ubuntu Linux cron(Vixie cron?)は、ジョブのタイムアウト設定をサポートしていますか? 具体的には、それまでに正常に終了しない限り、プロセスはX秒後に強制終了されます。 ネットワーク接続やさまざまな問題が原因でタスクがハングしている場合があります。手動でクリーンアップして強制終了しない限り、プロセスは永久にハングアップしたままになります。
11 linux  ubuntu  cron  timeout 

4
Windows Serverバックアップを使用してSQL Serverデータベースをバックアップするにはどうすればよいですか?
どうやらWindows Serverバックアップは、SQL Serverデータベースのバックアップをある程度サポートしています。 アプリケーションを回復する機能。Windows Serverバックアップは、Microsoft®SQLServer®などのアプリケーションに組み込まれているVSS機能を使用して、アプリケーションデータを保護します。[ソース:TechNet ] さらに、Windows Server Backup はSQL Serverで何らかのバックアップ操作をトリガーしているようだと人々は報告しています。 ただし、Windows Serverバックアップを使用してSQL Serverデータベースを正確にバックアップする方法に関する(公式)ドキュメントを見つけることができません。 バックアップするだけ.mdfですか??.mdf.ldf オンラインですか、それともオフラインですか? この方法でバックアップされたSQL Serverデータベースを復元する公式の手順は何ですか? 増分/差分バックアップを行うときに考慮する特別なことはありますか? このすべてはどこに文書化されていますか? (SQL Serverメンテナンスプラン、sqlmaint.exeT-SQL BACKUP、およびSQL Server Agent を使用してバックアップを行う方法を知っています。WindowsServerバックアップ(明らかに)が提供する代替手段に興味があります。)

2
塩柱を介してマスターからミニオンにsshキーを展開する
ミニオンの1つに展開しようとしている2つのsshキーがあります。しかし、私はそれを展開させることができないようです。エラーが発生します。ここinit.slsに柱があります: /xxx/yyy/zzz/id_rsa: file.managed: - source: salt://private/id_rsa /xxx/yyy/zz/id_rsa.pub: file.managed: - source: salt://private/id_rsa.pub 私のinit.sls状態は次のとおりです。 ssh: file.managed: - name: {{ pillar['private'] }} 私は何か間違ったことをしているに違いありません(もちろん)。助言がありますか?

3
ストレスのかかったサーバーでのSSHアクセスの保証
ApacheとSnortがプロセッサの100%を占有しているサーバーで、リモートアクセスを介してsshdが応答しなくなるという問題がありました。ローカルTTYにログオンするためにサーバーに物理的にアクセスし、Apache / Snortを停止する必要がありました。 CPU /メモリが100%ロードされている状況でssh接続を保証する方法があるかどうか疑問に思っています。「いい」優先度を設定すれば十分でしょうか? ありがとうございました!

3
VMwareクラスターでバルーンRAMまたはスワップRAMを持つすべての仮想マシンを見つけますか?
vSphereクラスターまたはリソースプールを見て、特定のレベルのメモリバルーニングまたはスワッピングを確認した場合、どのVMが影響を受けているかをどのように特定できますか?私はそれらを見つけたら何をすべきか知っています:) 以下の例では、リソースプールに65の仮想マシンがあります。バルーンRAMは32ギガバイト未満です。RAMの一部がバルーニングまたはスワップされているVMを特定するにはどうすればよいですか?

5
ソフトウェアが/ usr / libにインストールされるのはなぜですか?
私はもう何年もLinuxサーバーを使用していますが、Filesystem Hierarchy Standardで混乱し続けています。通常、私は混乱に耐えることができます。しかし、Linux用に独自のソフトウェアを開発している今、パッケージマネージャーによってインストールされる場所を理解する必要があります。 / optが私のアプリケーションに最適な場所であると確信しました。しかし、私のDebianファイルシステムを調査した後、私はもうわかりません:多くのソフトウェアが実際に/ usr / libにインストールされています!いくつか例を挙げると、MySQL、MySQLWorkbench、Nautilus、Rythmbox ... FHSによると、は/ usr / libの「プログラミングとパッケージのライブラリ」を含むようになっていると(「ユーザーやシェルスクリプトによって直接実行されることを意図していないオブジェクトファイル、ライブラリ、および内部のバイナリを含む」ここを参照してください)。 私のdebianサーバーの/ usr / libにあるソフトウェアの多くは、ライブラリや内部バイナリではなく、本格的なユーザー実行可能ソフトウェアです! アプリケーションは/ optにインストールされる予定です。しかし、私は本当にこれが正しいかどうか、何よりも理解したいのです。 あなたの親切なアドバイスを事前に感謝します、 エリック。
11 debian  fhs 

2
DomainKeysのセットアップ
SPFおよびDKIMレコードを追加して、メールのセキュリティを向上させ(スパムとしてマークされないように)しました。そのため、両方を作成し、check-auth @ port25.comで結果をテストしました。これが結果です: ========================================================== Summary of Results ========================================================== SPF check: pass DomainKeys check: neutral DKIM check: pass Sender-ID check: pass SpamAssassin check: ham したがって、DomainKeys以外はすべて合格しました。詳細レポートは次のとおりです。 ---------------------------------------------------------- DomainKeys check details: ---------------------------------------------------------- Result: neutral (message not signed) ID(s) verified: header.From=myemail@mydomain.com DNS record(s): 次に_domainkey.mydomain.com、コンテンツ付きのTXTレコードを追加してt=y; o=~確認しましたが、結果は同じでした(mxtoolboxからDNSレコードを確認して取得したため、DNSは伝播しました)。 これを修正するにはどうすればよいですか?
11 email  domainkeys 

6
2つの建物間に光ファイバーケーブルリンクをセットアップする方法
速度(インターネット/ネットワーク)に問題があります。サーバー、モデム、ファイアウォールが建物にあり、400フィートのcat5ケーブルで接続されています。ケーブルが頭上およびtru pvcコンジット上を走っています。光ファイバーケーブルに交換する必要があることは知っていますが、光ファイバーに関しては、スイッチでcat5に接続するときは緑色です。これを実現する方法についての良い解決策は何でしょうか?
11 networking 

4
ZFSホストでVMを実行するとパフォーマンスにどのような影響がありますか?
LinuxでZFSを使用して、Debian Linuxホストのデータストレージ用にext3からZFSに移行することを検討しています。私が本当に欲しいZFSのすばらしい機能の1つは、データの整合性の保証です。ストレージのニーズの増加に合わせてストレージを簡単に拡張できることも楽しみです。 ただし、同じホストでいくつかのVMを実行します。(通常、私の場合、ホスト上で同時に実行されるVMは1つだけです。) ZFSのデータチェックサムとコピーオンライトの動作、およびVMディスクイメージが比較的大きなファイルである(私のメインVMのディスクイメージファイルは現在31 GBにある)ことを考慮すると、そのようなVMゲスト内のパフォーマンスへの影響はどうなりますか移行?パフォーマンスへの悪影響の可能性を減らすために、どのような手順を実行できますか 必要に応じて、VMディスクイメージのデータ整合性をあまり保証せずに生きることができ(VM内で実際に重要なことは何もしません)、ファイルシステムの残りの部分から簡単に分離できますが、そうしないといいでしょう(選択的にでも)別のファイルシステムに移行したいと思うほとんどの機能をオフにする必要はありません。 ハードウェアは、ワークステーションクラスのシステムにはかなり強力ですが、ハイエンドサーバー(32 GB RAMを使用することはめったにない> 10 GBを超える32 GB RAM、6コア3.3 GHz CPU、現在2.6 TB使用可能)ディスク容量に応じてdf、合計で約1.1 TBの空きがあります.ZFSに移行すると、さらに空き容量が追加される可能性があります)、データ重複排除の実行を計画していません(重複除去をオンにしても、私の状況ではあまり追加されません)。計画はJBOD構成から開始することです(明らかに適切なバックアップを使用します)が、条件が許せば、最終的には双方向ミラーのセットアップに移行するかもしれません。

4
Windows Powershellで2つのフォルダーを比較するにはどうすればよいですか?
Windows Powershellを使用して、2つのフォルダー構造のコンテンツの違いを見つけようとしています。次の方法を使用してファイル名が同じであることを確認しましたが、この方法ではファイルの内容が同じかどうかはわかりません。 $firstFolder = Get-ChildItem -Recurse folder1 $secondFolder = Get-ChildItem -Recurse folder2 Compare-Object -ReferenceObject $firstFolder -DifferenceObject $secondFolder このServerFaultの質問で説明されている手法は、単一のファイルを比較するために機能しますが、これらのフォルダーにはさまざまな深さの何百ものファイルが含まれています。 解決策は、必ずしもファイル内の具体的な違いを教えてくれる必要はありません-それだけです。日付などのメタデータの違いには興味がありません。
11 powershell  diff 

5
GitHubにGitHubをミラーリングする
ローカルgitlabで、プロジェクトnovaのコピー(https://github.com/openstack/nova)を作成しました。 ローカルnovaリポジトリをgithubと同期して、1時間に1回または1日に1回更新する方法を教えてください。 ここに記載されているbitnamiに似たソリューションが欲しい:http ://wiki.bitnami.com/Applications/BitNami_GitLab#Keeping_in_sync_with_the_GitLab_repository_at_GitHub (Devstackを使用してOpenstackをインストールしました。)
11 github  gitlab 

3
Linux + SSDのスワップパーティションでのバックグラウンド破棄
問題 LinuxのSSDディスク内のスワップパーティションでバックグラウンド TRIM操作を有効にしたい。この記事などのいくつかの記事によると、カーネルはこの構成を検出し、自動的に破棄操作を実行しますが、「破棄」マウントオプションを使用してこの動作を強制しても、テストでは動作していないようです。 シナリオ Linux 3.2.0を実行しているDebian Wheezy SSDディスク:1 x 120GB OCZ Vertex 3 MI 2GBスワップ「プレーン」パーティション、他のレイヤー(LVM、RAIDなど)なし バックグラウンド 以下は、バックグラウンドTRIMがスワップパーティションで動作しているかどうかを確認するために実行する手順です。 TRIMサポート:SSDディスクがTRIMコマンドをサポートし、カーネルがデバイスに非回転フラグを立てているかどうかを確認します。 # hdparm -I /dev/sda | grep TRIM * Data Set Management TRIM supported (limit 1 block) * Deterministic read data after TRIM # cat /sys/block/sda/queue/rotational 0 スワップフィルアップ:パーティションをマウントし、すべてのVMキャッシュを消去し、積極的にスワップするようにLinuxを構成して、vm.swappinessを100に設定します。次に、利用可能なすべてのメモリを割り当て、カーネルにスワッピングを開始させるスクリプトを実行します。 # swapon [--discard] /dev/sda2 # …
11 linux  debian  ssd  swap  trim 

1
sshのPermitUserEnvironmentのセキュリティリスク
env変数をsshシェルに渡すためのの使用PermitUserEnvironmentとファイルに関するかなりの数の記事を読みました~/.ssh/environment。公式のsshdドキュメントと他のいくつかのリソースは、これを行うことによるセキュリティ上のリスクを示唆しています。 環境処理を有効にすると、ユーザーはLD_PRELOADなどのメカニズムを使用して、一部の構成でアクセス制限をバイパスできます。 アクティベーションのセキュリティ上の問題はPermitUserEnvironment何ですか?これらの環境変数でDB接続の詳細を保持しようとしていましたが、これはお勧めですか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.