コンピュータユーザー

コンピュータ愛好家とパワーユーザーのためのQ&A

1
X11転送がしばらくすると機能しなくなる
Cygwinを使用してLinuxボックス(ubuntuサーバー12.04)をSSH経由で接続し、X11転送を使用します。sshを実行するたびに、しばらくXフォワーディングを使用できますが、その後動作しなくなります(たとえば、gvimはDisplayを開くことができないと言います)。終了して再SSHを実行すると、再び動作を開始します。そして、しばらくしてから再び停止します。 何か案は?

8
「送信先:メール受信者」コンテキストメニューが機能しない
Microsoft(WinRT)のMailアプリをDefault Programsのメールのデフォルトアプリケーションとして設定しました。しかし、私は、ファイルを右クリックして、選択Send to> Mail recipient私が言ってメッセージボックスを取得します:There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel. このアクションをMailで動作させる方法はありますか?

2
ファイル/フォルダーが変な名前になり、Samba共有でアクセスできなくなる
現在の設定は次のとおりです。 Mac OS X 10.5.8 Mac OS拡張(ジャーナリング)ファイルシステムを使用するファイルサーバー。AFP(Macデスクトップの場合)およびSamba(Windowsデスクトップ)で共有される共有があります。 ここで何が起こっているのですか: すべてのGFXデザイナーはMacを使用し、AFP経由でファイルサーバー上にフォルダー/ファイルを作成し、プログラマーはsambaを使用してそれらのファイルにアクセスします。時々、ファイルやフォルダーが変な名前で表示され、samba経由で接続しているユーザーがアクセスできなくなることがあります。 作成したフォルダーにアクセスできるようにする唯一の方法は、フォルダーの場所に移動したMacデスクトップに戻り、新しいフォルダーを作成して、壊れたフォルダーの内容を新しいフォルダーに移動することです。 Macデスクトップでは、フォルダーに完全にアクセスでき、フォルダー/ファイル名は作成時に表示されます。ファイル/フォルダーの問題があるのは、Samba経由でアクセスしているPCユーザーだけです。奇妙なことに、これはランダムに発生し、一部のファイルフォルダーがSambaユーザーに対して機能しなくなる理由を見つけることができません。Macユーザーは、Macファイルシステムと互換性があるがsambaで問題を引き起こすフラグやプロパティを追加するなど、そのファイル/フォルダーに何かをしていると思われます。 だから私の質問: この問題の原因は何ですか?永続的な修正はありますか?そうでない場合、私はMacを使用してそれらを停止し、sambaユーザーの問題を引き起こす方法を訓練することができますか?

3
MacBookの蓋を閉じるときにUSB電源をオフにする
MacBook Proの下にUSB駆動の冷却パッドがあります。MacBookをスリープ状態にするために蓋を閉じたときに、冷却パッドをオフにしたいのですが。言い換えれば、冷却パッドが差し込まれているUSBポート、または両方のUSBポートへの電力をMacBookからカットしたいのです。これが可能かどうか誰でも知っていますか? Windows 7でも同じ質問がされていることに気付きました。

3
練習用のサンプルADおよびLDAPサーバーはありますか?[閉まっている]
閉まっている。この質問はトピック外です。現在、回答を受け付けていません。 この質問を改善したいですか? 質問を更新することがありますので、上のトピックスーパーユーザーのために。 3年前に閉店しました。 LDAPとADへの接続方法を勉強しようとしていますが、ADが動作していません。 完全に機能するWindow 2008 Serverがあります。 練習に使用できるサンプルADおよびLDAPサーバーはありますか?


1
Proxifier for Linuxのようなソフトウェアですか?[閉まっている]
閉まっている。この質問はトピック外です。現在、回答を受け付けていません。 この質問を改善したいですか? 質問を更新することがありますので、上のトピックスーパーユーザーのために。 3年前に閉店しました。 SOCKSv4、SOCKSv5、HTTPSなどを介してすべてのトラフィックを渡すLinux用WindowsのProxifierに似たソフトウェアはありますか?

2
ネットワーク共有にアクセスするときに「hosts」ファイルエントリが効果を持たないのはなぜですか?
Windows7 hostsファイルに次の行を追加しました。 127.0.0.1 mecserver 使用しping mecserverても問題ありませんが、この名前を使用してノートブック(localhostなど)に接続してWindows共有を表示する場合、常にユーザー資格情報を入力する必要があります。ローカルのユーザー名とパスワードの入力は機能しません。これは、リモートホストが接続されていることを示しています。 ローカルシステムのWindowsエクスプローラアドレスフィールドで次を使用すると、次の結果になります。 \\mecserver 結果:ユーザー名とパスワードを入力する必要がありますが、ローカルユーザーは機能しません \\localhost 結果:ローカル共有が表示されます-これは私が望むものです\\mecserver \\127.0.0.1 結果:ローカル共有が表示されます-これは私が望むものです\\mecserver / \\mecserverの結果で使用したい。これはどういうわけか可能ですか?localhost127.0.0.1 編集:これまでにやったこと: 「testshare」という名前のネットワーク共有をノートブックで共有しました。ネットワークケーブル/ WLANを接続せずに、このノートブックからこの共有に接続しようとしました。これは\ localhost \ testshareおよび\ 127.0.0.1 \ testshareで機能します。しかし、私は\ mecserver \ testshareのようなサードパーティのプログラムのための特別なパスが必要です。そこで、ホストファイルに行127.0.0.1 mecserverを追加しました。ping mecserverは動作します(このノートブックのローカル)が、\ mecserver \ testshareで testshareにアクセスしようとするとログインウィンドウが表示されます。現在のノートブックユーザーを入力しましたが、パスワードが間違っています。名前testとパスワードtestを持つ新しいtestuserを追加し、これをこのログインウィンドウに追加しようとしましたが、機能しません(パスワードが間違っています)。ゲストアカウントを有効にしても効果はありません。共有は全員に開かれており、このフォルダ/ファイルのファイル/ディレクトリセキュリティアクセスも許可されています。 追加127.0.0.1 mecserverを lmhostsファイルには、hostsファイルに追加することと同じような効果があります-それは私にこのログインウィンドウをpromts。念のため、lmhostsファイルで遊んだとき、hostsファイルから127.0.0.1 mecserver行を削除しました。

2
名前と所有者でプロセスを強制終了しますか?
車輪の再発明を検討する前に、プロセス名とプロセス所有者の両方でフィルタリングしてプロセスを強制終了できるアプリケーション/ユーティリティを知っている人はいますか?あるいは、これはpowershellを介して行うことができますか?(私のpower-fuは残念ながら欠けています)。 との両方pskillを見てきましたtaskkill。が、pskillプロセス名で終了することができ、それはプロセスの所有者によって、さらにフィルターに私を許可していません。またwmic process、wmic()を介してWMIを調べましたが、WMIインターフェイスはプロセスの所有者を返さないため(少なくとも私の知る限り)、これも使用できません。 理由 Windowsで開発のチャンクを行います。これには、コンポーネントサービス(COM +)の処理が含まれます。COM +には、汎用(つまり、私が開発したもの)要素とシステムプロセスの両方に使用されるdllhost.exeというホストプロセスがあります。それらを実行する所有者によって区別できます。したがって、たとえば、私が所有するすべてのdllhost.exeプロセスを強制終了しますが、SYSTEMが所有するプロセスは無視します。 これにより、定期的にタスクマネージャーにアクセスし、それぞれを識別して手動で強制終了することができます:-)

3
Windowsは、プロセスが終了するときにソケットを閉じますか?
Linuxに関するこの質問を読みました。プロセスが終了したときにポートをバインドできますか? Linuxは、プロセスが終了し、開いているソケットを残した後にクリーンアップするようです。これがWindowsでどのように機能するかについての仕様があるかどうか疑問に思っていました。OSは、終了せずに終了するプロセスのソケットを常に閉じますか?

1
Mac OS X LionターミナルSSH接続共有エラー
リモートホストにSSH接続しようとすると、次のエラーが発生することがあります。 mux_client_request_session: read from master failed: Broken pipe 〜/ .ssh / configでMacbook Air OS X Lionを使用しています。 ControlMaster auto ControlPath /tmp/ssh_mux_%h_%p_%r ControlPersist 4h ForwardAgent yes Host [ex] HostName [example.com] User [somedude] 上記のエラーは、次の場合に発生します。 ssh ex ターミナルは約1分間ハングし、次を表示します。 mux_client_request_session: read from master failed: Broken pipe somedude@example.com's password: パスワードを入力すると、大丈夫です。また、別の[ターミナル]タブを開くと、接続の共有も問題ありません。どうすれば修正できますか?それはひどいものではありませんが、迷惑です。


3
スリープ後に(または接続が失われたときに)sshfsによってマウントされたフォルダーにアクセスできない
多くの場合、sshでファイルシステムをマウントすると: sshfs user@remote: ~/Mounts/Remote マシンを休止状態にする(ラップトップの蓋を閉じる)と、マシンを起動すると、マウントされたフォルダーにアクセスできません。さらに、ls親フォルダーでしようとすると、ターミナルがフリーズします。接続が何らかの形で失われた場合にも同じことが起こります。 を使用してアンマウントしようとした場合 fusermount -u ~/Mounts/Remote 私はこれを行うことができません: fusermount:/ home / yotama9 / Mounts / Remoteのアンマウントに失敗しました:デバイスまたはリソースがビジーです sshを強制終了しようとしましたが、フォルダを再度マウントできません。lsフォルダー内はまだフリーズします。 これを回避して修正するにはどうすればよいですか(Arch Linux)?


5
Mac OS X Lion 10.7.2でApacheの〜/ Sites /にあるシンボリックリンクへのアクセスを許可する方法
Apacheから〜/ Sites内のsym-linkedディレクトリへのアクセスを許可する必要があります。このようにディレクトリをシンボリックリンクしました ln -s ~/path/to/the/source/directory/ ~/Sites/source-link-here GETリクエストを実行するたびに、403応答が返されます curl http://localhost/~username/source-link-here/ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>403 Forbidden</title> </head><body> <h1>Forbidden</h1> <p>You don't have permission to access /~username/source-link-here on this server.</p> ... シンボリックリンクされたディレクトリへのアクセスを許可するようにApacheに指示するにはどうすればよいですか? どんな助けも大歓迎です。 宜しくお願いします ロベルティ

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.