サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
大規模なリポジトリでAtlassian Crucibleが非常に遅い
私の会社では、アトラシアンクルーシブルの試験を数か月間続けています。リポジトリが適切に機能している場合、ユーザーはツールについて非常に肯定的なフィードバックを提供しています。私が抱えている問題は、いくつかの異なるプロジェクトがあり、それぞれに独自のリポジトリがあり、それらのリポジトリの一部が非常に大きいということです。特に、1つのリポジトリには多数のブランチがあり、おそらくブランチごとに約9,000個のファイルがあります。Crucibleでそのリポジトリを参照すると、非常に遅くなります。 CrucibleはCentOS VMで実行されています。VMには4 GBのRAMがあり、私はCrucibleの最大値を3 GBに設定しました。そのうち、現在2 GBを使用しています。私はこれをアトラシアンのサポートチケットで取り上げ、次のことを提案しました。 特に、かなり大きなSVNリポジトリがあるため、Fisheyeがディスク上に大きなインデックスファイルを作成することに気付くでしょう。パフォーマンスを向上させるために、次のことを試してください。 Fisheyeで使用可能なメモリを増やします。 外部データベースへの移行。 不要なファイルやディレクトリをインデックスから除外します。 私はある程度これらすべてのものを試しましたが、これまでのところ、大きな助けにはなっていません。私は元々、組み込みのHSQL DBを使用して2GBのRAMを搭載したWindowsボックスでCrucibleを実行していました。CentOSでMySQLに移行すると、一部のリポジトリのパフォーマンスが向上し、Crucibleがはるかに安定しましたが、最大のリポジトリではあまり役に立たないようでした。ツールの有用性を維持しながら、索引付けから除外できるファイル/ブランチは非常に多くあります。 そうだとしたら、めちゃくちゃ強力なハードウェアに投資することなく、大規模なリポジトリでCrucibleを高速化する方法についてのヒントはありますか? ありがとう! 編集:私は、明示的に上記のことを言及しなかった私がいるので、明確にするのです FishEyeのを使用。 編集2:最初にこれを投稿して以来、パフォーマンスは新しいCrucibleリリースで多少改善されましたが、それでも決して素晴らしいとは言えません。この問題は、私たちが使用しているよりもはるかに強力なハードウェアを備えているユーザーを含め、多くのユーザーに影響を及ぼしているようです。したがって、それはハードウェアの問題ではなく、Crucibleに固有の非効率性の問題であると私は考えています。アトラシアンはこの問題を認識しており、今後のリリースでさらにパフォーマンスが改善される予定です。そのため、これらの変更により問題が解決されることを願っています。 編集3:いつまでこの質問をしたかを忘れていたので、以前の編集では、最初に質問されたときからハードウェアの状況も変化したことについては触れませんでした。現在、専用の物理サーバーでCrucibleを実行していますが、CentOSを使用しています。ハードウェアはまだ控えめです(4GB RAM、クアッドコアCPU、および外部バックアップを備えたRAID 1のデュアル500GBディスク)が、VMから移動したときにパフォーマンスがわずかに向上しました。
8 svn  fisheye  crucible 

4
SVNリポジトリの空き容量を増やす
最大リポジトリサイズのフリーミアムサイトでホストされているSVNリポジトリがあります。この容量に近づくと、チェックインしたファイルに気づき、ディスク領域を解放するために完全に削除できることを知っています。ファイルを削除できるだけでなく、その履歴もSVNに通知するにはどうすればよいですか?

5
WindowsにはZFSやBtrFSのようなチェックサムファイルシステムがありますか?
私はZFSを使用しており、とても気に入っています。BtrFSもチェックサムをサポートしていることを知っています。チェックサムがWindows 2008で利用できると言われましたが、これを確認できませんでした。 プラットフォーム、特にWindowsで、ZFSとBtrFS以外にチェックサムファイルシステムはありますか?
8 ntfs  zfs  btrfs 

3
ubuntuでredisの別のインスタンスを構成するにはどうすればよいですか?
基本的に、Ubuntuでredisの2つのインスタンスを使用したいと思います。/etc/init.d/redis-serverスクリプトを調べて、別の構成ファイル(新しいポートなど)を指す新しいスクリプト(redis-server-dev)を作成しようとしましたが、機能していないようです。 正しい手順は何ですか? ありがとう

1
syslogをテストするためのツール
syslogにメッセージを送信するために使用できるツールやスクリプトを知っている人はいますか?Syslog構成のトラブルシューティングを行っていますが、可能性を排除できません。私がしたいのは次のようなものです: ./testScript -f myFacility "testing testing 123" そしてそれをローカルマシンのsyslogに送信します。 提案を事前に感謝します。 リッチ
8 syslog 


5
中央のZFS Webサイトはどこにありますか?
オラクルは2010年秋にOpenSolarisを破棄しましたが、おそらく次のメジャーバージョンのSolarisがリリースされた後を除いて、オラクルがZFSへのアップデートの公開を継続するかどうかは不明です。 FreeBSD では、テスト用にZFS v28が利用可能になりました。 しかし、v28はどこから来たのですか?メインのZFS Webサイトにバージョン28が表示されていないことに気づきました。このウェブサイトは破棄されましたか?もしそうなら、ZFSプロジェクトの中心的なWebサイトはどこにあるので、私はリポジトリを閲覧したり、メーリングリストを読んだり、リリースノートを読んだりできます。 (OpenSolarisはOracleによってダンプされており、彼らはZFSリリースをコミュニティに制限していることを理解しています)。

2
SQL Serverのメモリは常に増加し、1 GBのRAMが使用され、1週間で7 GBになります。
急速に増加する約45 GBのデータベースがあります(毎週約1 GB)。 つまり、多くの挿入を行っています。Webアプリには多くのユーザーがいないため、現在の読み取り数は少なくなっています。 ただし、RAM sqlサーバーのユーザーが1週間後にサーバーを最初に起動したときに〜1GBから〜7GBのRAMを使用するようになることに気付きました。 何らかのメモリリークはありますか?SQLサーバーがキャッシュに使用するメモリを増やすことを示唆するMSDNの記事があり、それは常に増加し続けます。ただし、サーバーには7.5GBまたはRAMしかないため、毎週SQL Serverを再起動しないとメモリが不足するのではないかと心配しています...これは間違っているようです。 これは典型的な動作ですか?メモリ使用量に上限を設定するために設定できる設定はありますか?

2
SSHセッションをカウントしますか?
auth.logに次のメッセージが表示されることがあります。 sshd[8888]: error: no more sessions sshd_configで「MaxStartups 300」を設定しましたが、同時に接続するクライアントの数はそれほど多くないはずです。忙しい時には、sftp経由で小さなファイルをアップロード/ダウンロードしている間、数秒しか続かない約50〜60の同時接続ができると思います。 一部のクライアントが適切に接続を閉じていない可能性があり、接続が繰り返し頻繁に発生するため(各クライアントが1分間に数回接続しているため)、時間の経過とともに増加する可能性があります。これをトラブルシューティングするために、SSHセッションをカウントできるようにしたいのですが、netstatを使用して接続をカウントするよりも良い方法は考えられません。 netstat -an | grep 123.456.789.abc:22 | wc -l これはセッションではなく接続を数えるので、セッションが存続するケースがあるかどうかはわかりませんが、接続は閉じられますか? 現在の接続をカウントするより良い方法はありますか、またはすべてのセッションの現在の状態をよりよく出力しますか? 前もって感謝します!
8 ssh  linux 

3
違いは何ですか:Verisign Thawte Geotrust Rapidssl certs?
Verisignは、これらすべての証明書発行会社(Verisign Thawte GeotrustおよびRapidssl)を所有しています。 それらの違いは何ですか?なぜ価格差がそれほど大きいのですか? 更新:ここに私が遭遇したいくつかの違いがあります: GeoTrustはチェーン化されていません:チェーン全体を適切に検証しないデバイスは、これでうまくいく可能性があります。ActiveSyncは、チェーンされた証明書よりもチェーンされていない証明書の方がうまく機能することを確認しました。 RapidSSLおよびGeotrust証明書はサーバーごとにライセンスが付与されないため、Webファーム全体に対して1つの証明書を購入できます。 Verisign証明書には、毎日そのようなソフトウェアがサイトで見つかった場合に警告する無料のマルウェアスキャンが付属しています。 Verisignコード署名証明書のみがWinQualで機能します


2
途中でApache Proxyを使用して302 App Server ReDirect URLを書き換える
奇妙な設定があります。次のようになります。 Browser ----------> HTTPs Proxy ------> Apache HTTP -----> Tomcat AJP HTTPS HTTP AJP HTTPSプロキシ(非常にダムなプロキシ)では、URLはhttps://proxy.domain.com/appのようになります。次に、http://apache.domain.com/app(ホストproxy.domain.comを渡す)のように、HTTPを使用してApacheにトンネリングされます。Apacheは、AJPプロトコルを使用してローカルでajp:// localhost:8009 / app /にリクエストをトンネルします。 アプリサーバーがリクエストされたパスをリダイレクトしたい場合があります。たとえば、/ app /を/ app / webappにリダイレクトします。したがって、パスをリダイレクトする302をApacheに送り返します-おそらくajp:// localhost:8009 / app / webappのようなものです。次に、ApacheはリダイレクトURLをhttp://proxy.domain.com/app/webappに書き換えます。HTTPSプロキシはダムなので、リダイレクトを分析してhttpをhttpsに変更しません。 したがって、ユーザーをhttpsに送信するために302リダイレクトURLを書き換えるようにApacheを設定できるかどうかを考えたいと思います。 これが、Apacheのhttps.confでこれまでに使用した設定です。 ProxyPreserveHost on RewriteEngine on RewriteRule ^/app$ /app/ [PT] ProxyPass /app ajp://localhost:8009/app ProxyPassReverseを使用してみましたが、302リダイレクトURLをhttpではなくhttpsで強制的に書き換える方法を理解できませんでした。 何かご意見は?

3
Windows用のNTPサーバーソフトウェアを探す[終了]
現在のところ、この質問は、Q&A形式には適していません。私たちは回答が事実、参考文献、または専門知識によってサポートされることを期待しますが、この質問はおそらく議論、議論、投票、または拡張された議論を誘います。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 Windows Server 2003/2008用の、できれば無料のNTPサーバーを探しています。組み込みのWindows Time Serverを既に試してみましたが、テストではそれがあまり正確ではなく、最大500msの時間差があることがわかりました。アプリケーションで許容できる最大の時間差は〜100msです。 これで、Meinberg NTPd for Windows をすでに使用しました。クライアントとサーバーの間にネットワーク接続の問題がある場合、ntpサーバーはパニック状態にありますが、ntpサービスを再起動するまでクライアントに新しい時間を与えません。これは私たちにいくつかのトラブルを引き起こした大きな問題です。気付かなかったネットワークの問題が発生するまで、数か月間は問題なく動作していました。時差がすでに30秒である1週間後に初めて気づきました。クライアントで。 したがって、Windows用の代替NTPサーバーをいくつか提案してください。私はGoogleをしましたが、無関係な検索結果がたくさん出ます。 編集: これまでのところ、ntpdのWindowsバージョンは非常に正確であり、私はそれに固執したいと思います。唯一の問題は、ネットワーク切断後の「パニック状態」です。たぶん、これの原因が何で、どのように修正するかを知っている人もいるでしょう。また、次のようなサーバー/クライアントの設定があることを忘れていました。 サーバー1->サーバー2->サーバー3->クライアント1->クライアント2->クライアント3 したがって、Server2はServer1から時間を取得し、Server3はServer2から時間を取得し、クライアントはServer3から時間を取得します。また、Server2に直接接続されているクライアントもあります。すべてのサーバーとクライアントが正確に同じ時間(〜100ms以内)を持つことが重要です Server3とそのクライアントにネットワークの問題が発生しました。サーバーは、NTPサーバーおよびクライアントとして機能するWindowsのntpdポートを実行します。クライアントには、NTPクライアントとしてDimension4があります。ネットワークの問題が発生した後、D4のエラーメッセージは次のようになりました(頭上から、正確なエラーメッセージはありません)。 サーバーの応答:サーバーはパニック状態です(クロックを同期できませんでした) 私はntpdのドキュメントを読みましたが、「パニック」の唯一の言及は、時差が10000秒でntpdサーバーを終了する場合ですが、そうではありませんでした。また、パニック終了を無効にする「-g」コマンドラインスイッチもありますが、デフォルトではすでに設定されています。 パニック状態を引き起こす可能性があるアイデアと、次にそれを取り除く方法はありますか?
8 ntp 


4
ApacheからのSSL接続エラー
Ubuntu 10.04のApache / 2.2.14で(自己署名の)SSL証明書サイトを実行していますが、さまざまなブラウザが接続試行の半分でエラーを出しています。ちょうど今、Chromeからこの一時的なエラーを見ました: "Error 126 (net::ERR_SSL_BAD_RECORD_MAC_ALERT): Unknown error." リフレッシュを押すと、問題はしばらく消えます。 wgetも: $ wget --no-check-certificate https://dev.foo.com/deps/ --2010-09-08 19:30:26-- https://dev.foo.com/deps/ Resolving dev.foo.com... 184.72.53.220 Connecting to dev.foo.com|184.72.53.220|:443... connected. OpenSSL: error:0407006A:rsa routines:RSA_padding_check_PKCS1_type_1:block type is not 01 OpenSSL: error:04067072:rsa routines:RSA_EAY_PUBLIC_DECRYPT:padding check failed OpenSSL: error:1408D07B:SSL routines:SSL3_GET_KEY_EXCHANGE:bad signature Unable to establish SSL connection. すぐにもう一度実行すると、うまくいきます: $ wget --no-check-certificate …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.