サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
SNMP-だから私はMIBを持っています。それで?
MIBの目的に頭を抱えているようには見えません。ベンダーから提供された〜20のMIBファイルのコレクションがありますが、それらをどのように使用すればよいですか? また、ベンダーから提供されたOIDのうち、有効ではないものもいくつかあります。「snmpget -v1 -c public 192.168.0.123 .1.4.6.3.2.6.2」(有効なOIDであると想定)を発行すると、変数が不明であることを示すエラーが表示されます。これはハードウェア構成の問題のように聞こえますか?MIBをデバイスに「ロード」する必要がありますか? 残念ながら、ベンダーは私の質問にメールを返すことに完全に応答していませんので、どんな助けも大いに感謝します。
8 snmp 

1
IIS7から返された日付ヘッダーが間違っている
IIS 7からASP.NETアプリケーションを提供していますが、奇妙なCookieの問題が発生しています。コードは他の環境でも問題なく機能するため、これはこのサーバーに固有であると想定しています(関連する質問)。 私たちは返されたhttpヘッダーを調べており、日付のhttpヘッダーが今日の日付ではなくJanの1日を示していると誰かが指摘しました(これまでのところ、現在の日付に関係なく常にその日付が表示されています)。システムクロックが正しく設定されている(そして、DateTime.Nowを使用して現在の時刻/日付を正しく出力することもできる)ため、なぜ現在機能しているのかを理解できません。誰かアイデアはありますか?これは赤のニシンですか? ありがとう、ジェームズ
8 iis  asp.net  cookies 



4
Ubuntuクラウドバージョンでは、ssh経由で「rootログインなし」がどのように適用されますか?
rootログインを拒否するubuntuクラウドバージョンのデフォルト設定を微調整しようとしています。 このようなマシンに接続しようとすると、次のようになります。 maxim@maxim-desktop:~/workspace/integration/deployengine$ ssh root@ec2-204-236-252-95.compute-1.amazonaws.com The authenticity of host 'ec2-204-236-252-95.compute-1.amazonaws.com (204.236.252.95)' can't be established. RSA key fingerprint is 3f:96:f4:b3:b9:4b:4f:21:5f:00:38:2a:bb:41:19:1a. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added 'ec2-204-236-252-95.compute-1.amazonaws.com' (RSA) to the list of known hosts. Please login as the ubuntu user rather than root user. …
8 ubuntu  security  ssh  root  cloud 

3
Puppetを使用して独自のソフトウェアをデプロイしますか?
(この質問の愚かさをあらかじめお詫びします。私は通常、システム管理者ではなくプログラマーですが、いくつかのことを自動化し、自動化されているが最もきれいな方法ではない他のいくつかをクリーンアップすることに専念しています。 。:-) cfengine、Puppet、Chefなど、多数のサーバーへのソフトウェア展開を自動化するためのさまざまなツールを見てきました。これまでのところ、Puppetは最も魅力的に見えますが、私は確かにまだ何もコミットしていません。 これらのツールはすべて、事前にパッケージ化されたソフトウェアを使用して多数のサーバーを最新の状態に保つための優れた機能を果たしているように見えます。 取得できないのは、Puppetなどのツールを使用して、内部ソフトウェアの展開を管理する方法です。私は、Apacheを維持する方法を示すチュートリアルensure => latest(これはかなりかっこいいです)を何千も見てきたので途方に暮れていると思いますが、今日のユースケースに相当するものはありません。 人間がボタンを押すと バージョン管理リポジトリBからブランチAをプルする コマンドCを実行してコンパイルします バイナリーDをサーバーE1からE10にコピーする 各サーバーでコマンドFを実行して、すべての変更を有効にします。 Puppetは素晴らしい音で、一部のシェルスクリプトに対する宣言型のべき等構成の利点は完全にわかりますが、「シェルスクリプトをPuppet(またはChef、またはcfengine)に更新したいので、ここでのチュートリアルは確認していません。すべきだ」そんなことありますか?Puppetのドキュメントで提供されているものをどのように利用して、私が望む振る舞いを再現するかは他の人には明らかですか?届かないのですか? これまでのところ、人間(#1)はソフトウェア(#2および#3)をPuppetの外部に手動でパッケージ化し、Puppet構成を手動で更新して、Puppetがサーバーを更新するようトリガーします。 .. 多分?(あなたが言うことができると確信しているので、私はここで少し混乱しています。) ありがとう!

1
6 x ExchangeライセンスとTMG 2010を考慮したExchange 2010 HAトポロジのベストプラクティス
それを考慮した最良のトポロジーは何ですか? 6 x Exchange 2010 Standardライセンス リンクの問題が発生した場合に冗長性をサポートする2 x別の場所 Forefront SecurityおよびForefront Protection / Securityを備えた4 x Forefront TMG 2010 これらのExchangeを使用する世界中の複数の場所。ほとんどの場所はVPNトンネル(Exchangeを確実にホストしている場所)に接続されます。 私はこのようなことを考えていました: 場所メイン(約70-100人): NLBの2x TMG 2010 1x Exchange 2010 CAS / HUB Role 2x Exchange 2010メールボックスロール(アクティブ+パッシブ) ロケーションサポート(約20人): NLBの2x TMG 2010 1x Exchange 2010 CAS / HUB Role 2x Exchange 2010メールボックスロール(アクティブ+パッシブ) 管理者は、メインの場所(停電、リンクの喪失など)で問題が発生した場合に、2番目の場所で世界中からのすべてのトラフィックをサポートできるようにしたいと考えています。6〜7か所以上の場所があります(大きな場所ではありませんが、場所ごとに10人以上の人がいます)。 CAS / …

3
centos 100%disk full-ログファイル、履歴などを削除する方法
ディスク領域がいっぱいのため、mysqldは起動しません。 101221 14:06:50 [ERROR] /usr/libexec/mysqld: Error writing file '/var/run/mysqld/mysqld.pid' (Errcode: 28) 101221 14:06:50 [ERROR] Can't start server: can't create PID file: No space left on device 実行中df -h: Filesystem Size Used Avail Use% Mounted on /dev/sda2 16G 3.2G 12G 23% / /dev/sda5 4.8G 4.6G 0 100% /var /dev/sda3 430G 855M …

4
誰かが単一のスイッチでネットワーク全体をクラッシュさせた
これは本当の質問ではないかもしれませんが、申し訳ありませんが、それがあなたの終末のシナリオの楽しさを少しでもうまくいくと確信しています。 私の会社は、より大きな会社の請負業者を務めています。内部ネットワークにさまざまなデバイスを接続する必要があります。これらには(セキュリティ)制限があり、使用可能なイーサネットジャックにスイッチまたはルーターを接続できません。(なぜそれが理にかなっているのですか?) これで複数のジャックが必要になるため、その制限を解除するように依頼しました。彼らはそうしたと私たちに話しました。私たちが現場に到着したとき、1つのスイッチ(非常に基本的なもの)をジャックに差し込むと、世界全体が終わりました。彼らは大きなネットワーク障害を経験し、「重複したIP、重複したMac」などのログを受け取り、プラント全体が非常に停止しました。 もちろん、私たちはこの混乱に責任があると非難されています。私の同僚と私は、これがどのように発生するかを完全に理解できていません。なぜ単一のスイッチがネットワーク全体をクラッシュさせることができるかについて何か考えがありますか?

2
Linux RAID-0のパフォーマンスは1 GB /秒を超えてスケ​​ールアップしない
セットアップから最大スループットを取得するのに問題があります。ハードウェアは次のとおりです。 デュアルクアッドコアAMD Opteron(tm)プロセッサー2376 16 GB DDR2 ECC RAM デュアルAdaptec 52245 RAIDコントローラ 2つのRAID-6アレイ(256KBストライプ)+スペアとして設定された48個の1 TB SATAドライブ。 ソフトウェア: AMD-64用にコンパイルされ、NUMA用に最適化されたプレーンバニラ2.6.32.25カーネル。Debian Lennyユーザーランド。 ベンチマークの実行:disktest、bonnie ++、ddなど。すべて同じ結果になります。ここで矛盾はありません。 使用されるioスケジューラー:noop。ええ、ここではトリックはありません。 これまでは、基本的に、複数の物理デバイスをストライピング(RAID 0)すると、パフォーマンスがほぼ直線的に向上すると想定していました。ただし、ここではそうではありません。 各RAIDアレイは、約780 MB /秒の持続的な書き込み、および1 GB /秒の持続的な読み取りを実現します。 2つの異なるプロセスで両方のRAIDアレイに同時に書き込むと750 + 750 MB /秒、両方から読み取ると1 + 1 GB /秒になります。 ただし、mdadmまたはlvmを使用して両方のアレイを一緒にストライプ化すると、パフォーマンスは約850 MB /秒の書き込みと1.4 GB /秒の読み取りになります。予想より少なくとも30%少ない! ストライプアレイに対して2つの並列ライターまたはリーダープロセスを実行しても数値は向上しません。実際、パフォーマンスはさらに低下します。 ここで何が起こっているのですか?両方のドライブでddを同時に実行すると、総書き込み速度が実際に1.5 GB /秒に達し、読み取り速度が2 GB /秒を超えるため、基本的にバスまたはメモリの競合を除外しました。 つまり、PCIeバスではありません。それはRAMではないでしょう。RAWデバイスまたはXFSを使用してベンチマークの結果がまったく同じであるため、ファイルシステムではありません。また、LVMストライピングとmdストライピングのどちらを使用しても、まったく同じパフォーマンスが得られます。 どうしましたか?プロセスが最大可能なスループットに達するのを妨げているものは何ですか?Linuxストライピングに欠陥がありますか?他にどのようなテストを実行できますか?


3
Nginx + Php5-fpmがphpファイルをレンダリングしない
Nginx + Ruby Enterprise Edition + PHP5-fpmとMYSQLをインストールする方法を理解するのに何時間も費やしましたが、最後にすべてがインストールされ、すべて正常に起動したようです。 しかし、何らかの理由でphpファイルが処理されていません。 .htmlファイルは正常に機能しますが、.phpファイルを表示しようとすると、存在していても存在しないように見えます。興味深いことに、存在しない.htmlファイルを表示しようとすると、素晴らしいNginx 404メッセージが表示されますが、.phpファイルを表示すると表示されません。 私の初心者の理解では、設定に問題があるか、NginxとPHP-fpmが互いに通信していないようです。 私はnginx設定ファイルの他の多くの例を見てきましたが、物事の側面は大丈夫だと確信しています。さて...とにかく、これはconfファイルの関連ビットです: location ~ \.php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /var/www/eman/$fastcgi_script_name; include fastcgi_params; } そして fastcgi_connect_timeout 60; fastcgi_send_timeout 180; fastcgi_read_timeout 180; fastcgi_buffer_size 128k; fastcgi_buffers 4 256k; fastcgi_busy_buffers_size 256k; fastcgi_temp_file_write_size 256k; fastcgi_intercept_errors on; どんな助けでも大歓迎です。 編集:テストphpファイル「http://eman.id.au/test.php」から返されるヘッダーは次のとおりです。 HTTP/1.1 404 Not Found …
8 linux  nginx  php5  php-fpm 

8
CentOs 5でのPHP Pecl Intl拡張機能のインストール/有効化
元の質問: CentOs 5マシンにPHP Pecl Intl拡張機能をインストールできません。 両方icuをインストールした後libicu、次のコマンドを使用します。 $ yum install icu $ yum install libicu Intl拡張機能を次のようにインストールしようとしました: $ /usr/bin/pecl install intl ICUライブラリとヘッダーファイルのデフォルトの場所を検索することを選択しました。次のようにクラッシュします: checking whether to enable internationalization support... yes, shared checking for icu-config... no checking for location of ICU headers and libraries... not found configure: error: Unable to detect ICU prefix or …

1
nginxが何をしているかをどのように観察できますか?(解決するには:「1024 worker_connectionsでは不十分です」)
nginxで実行されている非常にトラフィックの少ないサイトで、4つのワーカーがあり、それぞれ1024の接続があります。 数時間ごとに「1024 worker_connectionsでは不十分」というエラーログが表示され、サイトの速度が低下したり、不安定になったりします。nginxの再起動により、次の数時間は問題が完全に解決されます。 明らかに奇妙なことが起こっています。アプリケーションの4k同時ユーザーにサービスを提供する方法はありません。 アクセスログ(正常に見える)を見る以外に、nginxが何をしているのかを詳細に観察する方法はありますか? 古い接続が開いたままになり、閉じられないという悪名高い設定の組み合わせはありますか? ありがとう。 編集 このルックス権利はありません # lsof |grep nginx |grep CLOSE_WAIT |wc -l 1271
8 nginx  lsof 

2
sql_errorの後でmysqlレプリケーションを再起動します
2つのmysqlサーバーがあり、1つはマスター、もう1つはスレーブです。 誰かがスレーブに行ってテーブルを作成し、次にマスターに行って同じテーブルを作成しました。もちろん、このDDLステートメントはスレーブに複製されたため、エラーが発生し、エラーの発生時に複製が停止しました。 スレーブのテーブルを削除した後、またはそのステートメントの後にレプリケーションを開始した後に、レプリケーションプロセスをどの程度再開する必要がありますか? スレーブステータス出力を表示します。 mysql> show slave status \G *************************** 1. row *************************** Slave_IO_State: Waiting for master to send event Master_Host: xx.xx.xx.xx Master_User: buildbot Master_Port: 3306 Connect_Retry: 60 Master_Log_File: mysql-bin.024536 Read_Master_Log_Pos: 33489509 Relay_Log_File: mysqld-relay-bin.049047 Relay_Log_Pos: 32575097 Relay_Master_Log_File: mysql-bin.024476 Slave_IO_Running: Yes Slave_SQL_Running: No Replicate_Do_DB: Replicate_Ignore_DB: Replicate_Do_Table: Replicate_Ignore_Table: Replicate_Wild_Do_Table: Replicate_Wild_Ignore_Table: Last_Errno: 1050 …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.