サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
グループポリシーの高速化、およびグループポリシーの基本設定の実装はログオン時間にどのように影響しますか?
ログオンシステムを高速化およびアップグレードして、より堅牢で高速にするためのアドバイスを探しています。 もともとNovell Netwareから移行された古いログオンシステムを継承しました。現在Windows Server 2008 R2を実行していますが、ドメインバージョンはWindows 2000のままです(理論的には、壊れていない場合は修正しないでください)。最終的にはWindows 7にアップグレードしたいと考えていますが、少なくとも数年間はWindows 7とWindows XP SP3が混在することになります。一部のSP2マシンがありますが、SP3にアップグレードできない場合は、置き換えることができます。 現在、主にログオンスクリプトに依存しています。ほとんどがKixtartで記述されていますが、一部はVBScriptで記述されており、Windows BATラッパーが使用されています。ログオンスクリプトは、ドライブとプリンターをマップし、公式のパッチ(最近のwinhelp.exeのセキュリティの問題など)がない場合に、セキュリティの問題やマイナーなバグの迅速な回避策をインストールし、ソフトウェアをインストールし、ケースマシンでIEのお気に入りなどのいくつかの設定をバックアップするなどのその他のタスクを実行します再イメージ化する必要があります。 また、少数のグループポリシーが有効になっています。それらは主にいくつかのセキュリティ設定を実装しています。GPOを使用してソフトウェアをインストールする実験をしていましたが、これが実用的であるとは思いませんでした。私たちのソフトウェアの多くはMSIを使用していません。MSIキャプチャを実行するために費やした時間は、一度試しただけでは報われませんでした。スクリプトを使用して無人インストールを行う方が簡単になりました。さらに、マシンの電源がオフになっている場合に、起動の遅延を処理するのと同じように、メンテナンスが面倒です。私はこれを再確認してもかまいませんが、スクリプトは正常に機能しているようでした。そのため、これにもっと時間を費やす必要がありませんでした。 私たちのシステムは問題なく動作しますが、少し柔軟性がありません。これは、ログインごとに中央に保存されたファイルにログインIDごとに情報を記録するように設計されており、アクセス許可の問題(1つのユーザー名での同時ログオンなど)により、頻繁にこの問題が発生します。フラグを使用して、ソフトウェアが以前にインストールされているかどうかを判断します。これは脆弱で、不必要なインストールが発生する場合があります(新しいユーザーがワークステーションにログオンした場合など)。それは、特にグループポリシーの面で、やや遅いです。プロファイルを試してみましたが、これには約300秒かかると思います(多少ずれている可能性があります)。一般的なユーザーには、約8つの小さなポリシーが適用されます。約12のOUがありますが、いくつかのグループポリシーにWMIフィルタリングを利用します。 約8台の共有ドライブ(OUではなくグループメンバーシップに基づく)と約20台のプリンター(誰もがすべてのプリンターを取得しますが、サイトごとに異なるプリントサーバーを取得します)をマッピングします。ソフトウェアのニーズは、主にOUに基づいてかなり劇的に変化しますが、OUの外部の数人がソフトウェアを必要とする場合もあります。 私の質問: GPPを展開するのはどれくらい難しいですか?Windows XPがこれをネイティブにサポートしていないことを考えると、そうですか?クライアント側の拡張機能をインストールする必要がありますか? Windows XP SP3のGPPは信頼できますか?グーグルで、バグやパフォーマンスの低下について言及しました。これはこの製品の現在のステータスと一致しますか? GPPのパフォーマンス/オーバーヘッドは、ドライブのマッピングやプリンターのインストールなどの目的で、kixtartまたはvbscriptを使用する場合とどのように違いますか? ログインの成功/失敗を追跡するために使用する良い習慣は何ですか?現在のシステムはオーバーヘッドが多すぎるようです。これをイベントログに保存する必要がありますか?どのマシンで?一元的に、またはローカルデスクトップに?現在、ログをデバッグツールとして使用しています。また、ユーザーがドメインに最後にログオンした日時を特定するためにも使用しています。 現在のグループポリシーインフラストラクチャを高速化するために何を試すべきですか?これが起動時に時間がかかると思います。これのトラブルシューティングをどこから始めるかについてのアイデアはありますか? 私が言及したタスクに対処するための最新のログオンシステムを作成するためのベストプラクティスは何ですか?ドライブの割り当て、プリンターの割り当て、ソフトウェアのインストール、パッチのインストール、その他のバックアップルーチンなどを実行します。この仕事にどんなツールが好きで、お勧めですか? まだMSIにきちんとパックされていないソフトウェアをインストールする最良の方法は何ですか?私たちは非営利団体であり、SCCMのようなもののTech Soupからいくつかのソフトウェア寄付を得ることができます。しかし、これが価値があるかどうかは本当にわかりません。 GPPを利用できるようにするために、ドメインをServer 2008 R2バージョンにアップグレードするとどのような影響がありますか?Windows NTを実行しているドメインに2つのメンバーサーバーがあることを述べておきます。これらは基本的に、ボイスメールシステムにのみ使用されるアプライアンスです。これらが壊れてほしくない。SMBを使用してドメインコントローラーをアップグレードすることには問題がありましたが、セキュリティ設定を下げる回避策を見つけることができました。ドメインバージョンをアップグレードする場合の落とし穴はありますか?答えはノーであるように思えますが、私はいくつかの現実の世界の経験について学びたいと思っています。 あまりにも長い間ごめんなさい、これは私が尋ねるだろうと思ったよりももっと複雑であることが判明しました。あなたの個人的な経験についてのどんな考えも役に立ちます。私はITチームで唯一の技術者です。

5
「高遅延ネットワーク」でのTCPパフォーマンスの向上
Linuxマシン間の「高遅延ネットワーク」を介してTCPスループットを改善しようとしています。 私はセットtcp_mem、tcp_wmemおよびtcp_rmem「8192 7061504 7061504」へ。 私が設定しrmem_max、wmem_max、rmem_defaultおよびwmem_default「7061504」へ。 私はセットnetdev_max_backlogとtxqueuelen10000への Iセットtcp_congestion_control「スケーラブル」へ。 「nist」(cnistnet)を使用して100ミリ秒の遅延をシミュレートしています。到達する帯域幅は約200 mbpsです(遅延なしでは約790 mbpsに到達します)。 テストを実行するためにiperfを使用し、結果を分析するためにTCPTraceを使用しています。 受信側: 最大勝利adv:5294720バイト 平均勝利adv:5273959バイト 送信されたsack pkts:0 送信側: 実際のデータバイト:3085179704 rexmtデータバイト:9018144 最大owin:5294577バイト 平均owin :3317125バイト RTT最小:19.2 ms RTT最大:218.2 ms RTT平均:98.0 ms なぜ200mbpsしか到達しないのですか?「owin」は何かと関係があると思いますが、よくわかりません(これらの結果は2分のテストの結果です。1分のテストの「avg owin」は1552900でした)… 遅延が100ミリ秒であっても、スループットがほぼ790 Mbpsであると誤解していますか? (私はウィンドウ構成でより大きな数を使用しようとしましたが、効果がないようです)

2
PowershellでLocalhostをテストしますか?
私はPowerShellのスクリプトの呼び出しその持っているGet-WmiObjectとします-Credential。ただし、これをローカルマシンに対して実行すると、エラーが発生します。 Get-WmiObject : User credentials cannot be used for local connections このエラーを回避するためにif localhostロジックを追加する適切な方法は何ですか?それとももっと良い方法がありますか?

5
サイト上のリソースのホットリンク(「画像の盗難」/「帯域幅の盗難」)を防ぐ方法
「究極の」アンチホットリンク.htaccessを記述しようとしています... あなたはネット上で多くの例/チュートリアル / ジェネレータを見つけることができますが、それらの多くは間違っているか不完全です(あるいはその両方です)。 これらは私が探している機能です: HTTP_REFERERが外部サイトである場合、ファイル拡張子のリストのホットリンクをブロックする必要があります。 .htaccessでハードコーディングせずに、現在のドメイン(duh)のホットリンクを許可する必要があります。 現在のドメインでは、httpおよびhttpsで動作する必要があります。 現在のドメインでは、wwwあり、wwwなしで機能する必要があります。 例外ドメインをこれらのルールに追加できる必要があります(友人のGoogleなど)。これらのドメインは、httpおよびhttpsで、wwwありまたはwwwなしで機能する必要があります。 これは私がこれまでに達成したことです: <IfModule mod_rewrite.c> Options +FollowSymlinks RewriteEngine On RewriteCond %{HTTP_REFERER} !^$ RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?mydomain.com/.*$ [NC] RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com/.*$ [NC] RewriteRule \.(gif|jpe?g|png|zipx?)$ - [NC,F] </IfModule> 私の質問: mydomain.com.htaccessのハードコードを回避する方法は?(この.htaccessをドメインごとに変更せずにすべてのドメインに展開できると便利です。) 私のRewriteRuleでは、右gif|jpe?g|png|zipx?と同等gif|jpg|jpeg|png|zip|zipxですか?(申し訳ありませんが正規表現ではまだ新しいです。) 私の知らない私の.htaccessに何か悪いことを見ますか? #1については、ある程度可能であることがわかっています。私が見つけた最も近いものは、ドメインをハードコーディングせずにURLからwwwを削除するこのスニペットです。この方法を私の質問1に使用する方法はありますか? RewriteCond %{HTTP_HOST} ^www\.(.+) RewriteCond %{HTTPS}s/%1 ^(on(s)|offs)/(.+) RewriteRule ^ http%2://%3%{REQUEST_URI} [L,R=301] 更新: 通常の画像の代わりに透かし入りの画像を提供するソリューションを知っています。しかし、私はこの種の解決策を探していません。すべての種類のバイナリファイル(zip、exe、iso、jpg、png、gif …

7
シェルスクリプトでのTelnetの使用
telnetコマンドを使用して、MySQLポートが応答しているかどうかを確認します。 telnet 10.10.10.24 3306 ctrl文字を使用して切断します。これは期待どおりに機能しています。このコマンドをシェルスクリプトで使用するにはどうすればよいですか?
8 shell 

5
Win7ワークステーションをWin2k8ドメインに参加させることはできません
Windows 7 UltimateマシンをWindows 2k8ドメインに接続しようとしていますが、機能しません。私はこのエラーを受け取ります: 注:この情報は、ネットワーク管理者を対象としています。ネットワークの管理者でない場合は、C:\ Windows \ debug \ dcdiag.txtファイルに記録されているこの情報を受け取ったことを管理者に通知してください。 ドメイン "example.local"のドメインコントローラーを見つけるために使用されるサービスロケーション(SRV)リソースレコードをDNSに正常にクエリしました: クエリは_ldap._tcp.dc._msdcs.example.localのSRVレコードに対するものでした 次のドメインコントローラーはクエリによって識別されました: dc1.example.local dc2.example.local ただし、ドメインコントローラーに接続できませんでした。 このエラーの一般的な原因は次のとおりです。 ドメインコントローラーの名前をIPアドレスにマップするホスト(A)または(AAAA)レコードがないか、正しくないアドレスが含まれています。 DNSに登録されているドメインコントローラーがネットワークに接続されていないか、実行されていません。 クライアントは、ドメインコントローラが存在するデータセンターにMPLS経由でリモート接続されたオフィスにあります。DCへの接続をブロックするものは何もないようですが、MPLS回路を完全に制御することはできないため、接続をブロックするものがある可能性があります。 1つのオフィスで複数のクライアント(Win7 UltimateとWinXP SP3)を試しましたが、すべてのクライアントで同じ症状が出ました。 確かに、可能なすべてのポートを試したことはありませんが、どちらのドメインコントローラーにも問題なく接続できます。ICMP、LDAP、DNS、SMB接続はすべて正常に動作します。 クライアントDNSはDCを指し、「example.local」はDCの2つのIPアドレスに解決されます。 NetLogon Testコマンドラインユーティリティからこの出力を取得します。 C:\Windows\System32>nltest /dsgetdc:example.local Getting DC name failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN MPLSの代わりにLAN-to-LAN VPNを介してDCネットワークに接続されているそのオフィスの構成をエミュレートする別のネットワークも作成しました。そのリモートネットワークからWindows 7コンピューターに参加することは正常に機能します。 2つの環境の違いを見つけることができる唯一の違いは、中間接続ですが、何をテストするか、またはどのように行うかについて、私は思いがけません。さらに何をすればいいですか? (これは実際にはクライアントワークステーションではなく、直接アクセスできないことに注意してください。リモートハンドアクセスを行う必要があるため、パケットスニッフィングなどの明らかなトラブルシューティング方法がさらに難しくなります。そこに、私がリモートでアクセスできるシステムをセットアップすることもできましたが、その効果に対する要求は未解決になりました。) 2011年8月25日更新: 私はしていたDCDIAG.EXEドメインに参加しようとしているクライアント上で実行します。 C:\Windows\System32>dcdiag /u:example\adminuser /p:********* /s:dc2.example.local …


4
FreeNASは企業の準備ができていますか?
私は少し意見が分かれています。 私は会社用のNASを取得することを検討しています。VMwareサーバー用に必要です。 当初のアイデアは、NAS(Netgear ReadyNAS)を購入することでした しかし、コミュニティ(ServerFault)からサーバーからNASを構築し、NextentaStor、Openfiler、FreeNASなどを使用するよう推奨されました。 いくつかの理由でOpenfilerを削除しましたが、NexentastorとFreeNASの間に残っています。 私が抱えている問題は、FreeNASが実稼働環境で信頼できるかどうかです。 FreeNASはVMwareのiSCSIバックエンドになるのに十分ですか?私が最後にFreeNASを使用したのはバージョン0.7でした。 有料版ではなくNexentastorコミュニティを使用します。 どんな洞察も素晴らしいでしょう。
8 zfs  freenas  nexenta 

4
静的データは毎回テープにバックアップする必要がありますか?
『バックアップとリカバリ』の本では、毎月完全バックアップを作成し、毎週増分または差分バックアップを作成することをお勧めします。 毎週800GBのデータと最大10GBの変更がある場合はどうなりますか? それでも毎月完全バックアップを作成する必要がありますか? つまり、LTOテープでは、30年間データの統合性が保証されます。 では、なぜ毎回完全なバックアップを作成するのでしょうか。
8 linux  windows  backup  tape 

3
php-fpm設定の何が問題になっていますか?
64ビットサーバーがありますが、RAMは256 MBしかありません。そこで、PHPに接続するためにfast-cgiを使用してnginxサーバーに移動しました。PHP 5.3.6を実行しています。 問題は、2〜3日ごとにPHPページにアクセスしようとすると、サーバーの内部エラーが発生することです。唯一の回避策は、php-fpmを手動で再起動することです。これは、チョークを引き起こしているいくつかの間違ったパラメータを設定する必要があったことを意味します。以下に、関連する構成をリストしました。 /etc/php-fpm.conf:- include=/etc/php-fpm.d/*.conf log_level = error ;emergency_restart_threshold = 0 ;emergency_restart_interval = 0 ;process_control_timeout = 0 /etc/php-fpm.d/www.conf:- [www] pm = dynamic pm.max_children = 10 pm.start_servers = 3 pm.min_spare_servers = 2 pm.max_spare_servers = 5 pm.max_requests = 500 /etc/nginx/php.conf:- location ~ \.php { fastcgi_param QUERY_STRING $query_string; fastcgi_param REQUEST_METHOD $request_method; fastcgi_param …

4
Fedoraの代わりにCentOSを使用する理由
私はFedoraの幸せなユーザーですが、私が知っているほとんどのSCADAシステムはCentOSを使用しています。LinuxでSCADAソリューションを提供します。CentOSに変換する必要がありますか、それとも友人のFedoraにとどまる必要がありますか?
8 linux  centos  fedora 

3
Linuxディレクトリサイズ/ブロック数の単調増加
Linuxでは(おそらくファイルシステムのブロックサイズの関数として)、ディレクトリを作成するとstat、4096のサイズが返されます。このディレクトリに、ある程度のサイズのファイルを作成できます。ディレクトリ(から報告stat)。 ある時点で、ディレクトリが多くのファイルでいっぱいになると、ディレクトリのサイズが膨らみます(ディレクトリの内容について話しているのではなく、ディレクトリ自体を表すために消費されるブロックについて話している)。ファイルを削除しても、ディレクトリのサイズは変わりません。 ここに簡単な例があります: [root@uxlabtest:/]$ mkdir test [root@uxlabtest:/]$ stat test File: `test' Size: 4096 Blocks: 8 IO Block: 4096 directory Device: fd00h/64768d Inode: 1396685 Links: 2 Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root) Access: 2011-07-26 14:06:04.000000000 -0400 Modify: 2011-07-26 14:06:04.000000000 -0400 Change: 2011-07-26 14:06:04.000000000 -0400 次に、一連のファイルをタップします。 [root@uxlabtest:/]$ for …
8 linux  inode  vfs 

2
ネットワークトラフィックがトランクを離れていないように見える
私はいくつかの新しい仮想化サーバーをステージングしている最中ですが、その一部は、より高い帯域幅のパイプをサーバーに取り込むことです。最終的な目標は、4つのGigEポートを、802.1qタグ付きトラフィックを運ぶ単一のトランクにバインドすることです。私はそれまでのところ得ることができますが、私は奇妙な問題に遭遇しました。しかし、最初に、図。 ---------- ---------- 1GbE trunks | | 10GbE | | ------------- -------- | SW1 |-------| SW2 | ------------- | VM1 | | | | | ------------- -------- ---------- ---------- | | 1GbE ----------- | 1GbE |--------| client2 | | ----------- ---------- | | 1GbE ----------- | SW3 |------| client1 | …

1
会社のファイル共有に対する破損またはブロックされた権限を修正するにはどうしますか?
最近、私はストレージ会社の1人と協力して、長年会社で使用されてきた大きなファイル共有の調査を伴うプロジェクトに取り組んでいます。多くの場合、次の1つ以上の理由により、(ドメイン管理者アカウントで)アクセスできないディレクトリまたはファイルに遭遇します。 破損したACL Administratorsグループ(またはSYSTEMユーザー)のアクセスが取り消されたか拒否されました ファイル名+パスが長すぎる(MAX_PATHを超える) このような状況に役立つツールの一握りは、マイクロソフト(例えばTAKEOWN.EXEとICALCS.EXE)、または第三者からの(例えば、存在するSETACL.EXE)。PSEXEC.EXEで SYSTEMアカウントの下でコマンドの1つを実行するなど、他のトリックが必要になる場合があります。どのステップをどのような順序で実行するかを理解するだけでも、課題です... たとえば、次のようなフローでトラブルシューティングできるようにしたいと思います。 パスが長すぎませんか?その場合は、\\?\プレフィックス付きのパスを作成してから、もう一度テストしてください。 ACLは壊れていますか?その場合は、ACEを正しく並べ替え、不明なものをすべて削除してから、もう一度テストします。 Administratorsグループはアクセスを拒否されていますか?その場合は、所有権を取得し、AdministratorsグループとSYSTEMアカウントのアクセス許可を元に戻し、もう一度テストします。 まだ失敗していますか?その場合は、すべてのACEを削除し、継承されたアクセス許可のみを適用してから、もう一度確認してください。(これは、より制限的であるはずの権限を頻繁に開くため、これは最後の手段の一種です。) ディレクトリですか?もしそうなら、プロセスは内部のファイルに対して再帰的に継続する必要があります... 上記の手順を手動で実行するのは面倒であり、何百ものディレクトリを修正する必要がある場合は不合理です。私はこれらを支援するスクリプトを作成してみましたが、スクリプトが行う決定についてスクリプトを「スマート」にすることは難しいため、継承されたアクセス許可のみを復元するなど、全体的な修復方法を実行する方が簡単であることがよくあります。 誰かがこのプロセスに役立つ他のソフトウェアやスクリプトを推奨できますか?または、このような権限の問題をどのように修正しますか?

3
Xenはvncでdom0に接続しますか?
Xを実行せずにVNCを使用してdom0に接続する方法はありますか?Xサーバーは必要ありません。コンソールの内容を確認したいだけです。 編集:背景を追加します。人々が私がそのような質問をすることや、この場合はsshがdom0に到達するための受け入れ可能な解決策ではないことに本当にイライラしているようです: コンソールでVNCを使用する理由は、このシステムを管理するためではありません(8月の会議で、Xenと複数のVMでDebian Squeezeを4日間実行している実際には600のラップトップ)。SSHはそのためにうまく機能し、管理のために他のものを使用することを夢見ません。しかし、私ができるようにしたい2つの主要なことがあります。 1)マシンの前に座っている人と話しているときに、実際の/ dev / consoleの内容を正確に確認します。少人数のチームが会議のためにこれらのシステムを準備する責任があり、私たち全員が地理的に同じ場所にいるわけではありません。この場合、これらのシステムは私から3000マイル、チームの別のメンバーから5000マイル、3人目から約100マイルです。特定のタスクが正しく機能していない理由を理解しようとするシステムの前に座っている「リモートハンド」で作業する場合、画面上にあるものを確認できることは非常に重要です。 2)/ dev / consoleに送信され、他には何も送信されていないエラーメッセージを確認します(このプロジェクトを開始する前に予想していたよりもずっと頻繁に発生します)。これが発生する主な理由は2つあると私は判断しました:1)時々、怠惰な開発者がエラーをログに記録するか、リダイレクトを介して/ dev / consoleに出力をデバッグします。ファイルに記録されます。2)なんらかの問題が発生したためにIOサブシステムが崩壊したが、ネットワークとCPUはまだ問題がない場合、システムがクラッシュして書き込みを行う直前にエラーメッセージがログファイルに記録されません。少なくとも/ dev / consoleで作業していた場合、 また、カンファレンス中に600台のマシンすべてに巨大なディスプレイ(多くのディスプレイ)に小さな小さなウィンドウを表示し、それぞれで何が起こっているのかを確認するのも非常にすばらしいと思います。
8 xen  vnc 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.