サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
linux-vserverのApacheが起動せず、ソケットを作成できません
stackexchangeにふさわしい適切な質問を書くための広範な調査とテスト中に、私は解決策を見つけました:libapr1ゲスト内でパッケージを再構築します。それでも他の人に役立つので、私はこの情報を投稿したいと思いました。 問題 libapache2-mod-php5Wheezyゲスト内にインストールして起動しようとすると、次のようになります。 root@test01:~# /usr/sbin/apache2ctl start [crit] (22)Invalid argument: alloc_listener: failed to get a socket for (null) Syntax error on line 9 of /etc/apache2/ports.conf: Listen setup failed Action 'start' failed. The Apache error log may have more information. root@test01:~# tail /var/log/apache2/error.log root@test01:~# root@test01:~# head -n 9 /etc/apache2/ports.conf|tail -n 1 Listen …

2
ネットワークケーブルが外れていないWindows ARGH
さて、これは私にナッツを運転しています。 サーバーは、再起動されるまで、「Unplugged」のネットワークステータスで長期間表示されます。これはランダムな時間(午前2時、午後10時、午前8時30分、午後3時など)に発生するようで、24〜48時間ごとに1回発生します。環境は、6つのワークステーションと1つの大型シャーププリンターを備えた小規模ビジネスです。 Win 2008 SBS 64ビット リンクできるスケジュールされたタスクはありません。 デュアルBroadcom BCM5708C NICを搭載したDell Poweredge 2900(1つのみ使用中) ドライバーはデルのサイトごとに最新です ケーブルは差し込まれています。 ケーブルは2回交換済み。 このサーバーが接続されているスイッチ全体が交換されました。 ルーターは最近交換されました。 すべてのインスタンスについて、ダウンしていることに気付きましたが、イベントログに相関関係はありません。 自動ネゴシエーションをオフにし、いくつかの設定を試しました。 使用されたことのないNICは、他のNICと同じアクティブな役割(同じIPとすべて)に交換され、最初のNICは無効にされました。 ルーターにいくつかのLAN RXエラーが表示されています(約3%はサーバーから発生しているようには見えませんが、完全に除外することはできません)。 今すぐWiresharkをインストールし、キャプチャしてログファイルに保存するように設定しました。 WinsockとIPリセットは、何もしません。

1
Ubuntuサーバー:ハードドライブが常にいっぱい
私は50GB vpsを持っています 私がdfを実行すると、 Filesystem 1K-blocks Used Available Use% Mounted on /dev/sda1 49982172 46580100 863064 99% / none 507212 172 507040 1% /dev none 511676 4 511672 1% /dev/shm none 511676 76 511600 1% /var/run none 511676 0 511676 0% /var/lock none 511676 0 511676 0% /lib/init/rw からdu -hを実行すると、 ... 20K …
8 ubuntu  du  df 

3
Centosをバージョン6.3に保つにはどうすればよいですか?
私は以下を持っています: Centos 6.3を実行しているゲストVMの束 Centos 6.3を実行しているホスト。 最近、私は何かをテストするために新しいCentos 6.3 VMを作成しました 蘭yum update新鮮後には、最小限のサーバーのインストール Centosが6.4になりました。 テストされていない変更には不安定性をもたらす可能性があることを理解しているので、バージョンを変更しないでください(さまざまな「ニーズ」を自動化する独自のアプリケーションを開発できるように、サーバーの管理者/ Centosを学習しています。そのようなニーズの1つはダウンロードすることです。データ、もう1つはダウンロードしたデータの分析を実行すること、さらにもう1つは分析に基づいて特定のアクションを実行することです。 私がいるよDevの位相Dev -> Test -> Prodしかし、私はアップを保証するために私ができるすべてをやったことを確認したいと思いますので、アップタイムと安定性は、この段階では、「必要」ではない、私がやっているの実装に関して-時間/安定性は、時間があるProd環境になると確実になります。したがって、アップグレードが必要である、または重要なメリットが得られると判断するまで、ゲストとホストKMを6.3で実行し続けたいと思います。 いくつかの質問: 実行時にサーバーOSのバージョンへの自動アップグレードが行われないようにするにはどうすればよいyum updateですか? バージョンのアップグレードで発生する変更を見つけるためのインターネット上の「標準」の場所はありますか? 安定性に関してサーバーのバージョンの変更について偏執的ですか?
8 centos  yum  stability 


1
「setspn -s」対「setspn -a」
Setspn OverviewによるとSetspn -A、SPNレコードを追加するために使用することはお勧めしませんSetspn -S。代わりに使用することをお勧めします。 Setspn -S新しいSPNを追加する前に、SPNが既に存在するかどうかを確認すると言われています。Setspn –Aこのチェックは実行されません。 Setspn -Aを使用してSPNを追加することもできますが、-Sは重複するSPNがないことを確認するため、代わりにSetspn -Sを使用する必要があります。 ただしWindows Serverの2012年に私がいることを確認Setspn -Sし、Setspn -A同じように動作:アカウントのSPNレコードがその後、存在する場合、私は両方の失敗を取得-Aし、-S引数を指定します。 との間に実際の違いはSetspn -SありSetspn -Aますか?

4
Debian-ポート80はブロックされていますが、何であるかわかりません
lighttpdにポート80をリッスンさせることができません。 ~# /etc/init.d/lighttpd start Starting web server: lighttpd2013-03-16 23:15:02: (network.c.379) can't bind to port: 80 Address already in use failed! 実際、サーバーにもapache2がインストールされています(ポート80をリッスンしています)が、アクティブではありません。 netstat / netstat -nplを使用しましたが、役に立ちませんでした どのようにしてポートを使用しているのかを知ることができますか?
8 debian  port  analysis 

2
BIND9のバイナリゾーンファイル
DNSマスターゾーンファイルがスレーブに転送されましたが、ゾーンファイルを読み取ることができません。 > less db.example.com "db.example.com "may be a binary file. See it anyway? これは私がこのコマンドを使用した後に起こりました: cp -r /usr/local/sbin/* /usr/sbin/. V.9.6ではなくbind V.9.9をインストールしました。ゾーンファイルをプレーンテキストとして読み取れるようにしたいと思います。

6
OUのユーザーを使用してActive Directoryで動的グループを作成する
Active Directoryの特定のOUのユーザーで動的グループを作成したいと思います。Exchange動的配布リストを使用してこれを完全に行うことができますが、もちろん、Ex DDLはメール専用です。 これを作成する方法はありますか?System Centerを使用してこれを処理するガイドをいくつか見つけましたが、System Centerはオプションではありません。 前もって感謝します、

5
LXC、ポート転送、iptables
10.0.3.2ホストでLXCコンテナ()を実行しています。ポート上のコンテナー内でサービスが実行されています7000。 ホスト(10.0.3.1、lxcbr0)から、サービスにアクセスできます。 $ telnet 10.0.3.2 7000 Trying 10.0.3.2... Connected to 10.0.3.2. Escape character is '^]'. コンテナー内で実行されているサービスを、外部の世界からアクセスできるようにしたいと思います。したがって、7002ホストのポート7000をコンテナのポートに転送したいと思います。 iptables -t nat -A PREROUTING -p tcp --dport 7002 -j DNAT --to 10.0.3.2:7000 結果は(iptables -t nat -L)になります: DNAT tcp -- anywhere anywhere tcp dpt:afs3-prserver to:10.0.3.2:7000 それでも、転送されたポートを使用してホストからサービスにアクセスできません。 $ telnet 10.0.3.1 7002 Trying 10.0.3.1... telnet: Unable …

3
Ubuntu 12.04にGearmanをインストールできない
次のコマンドでUbuntu 12.04マシンにGearmanをインストールしようとしています sudo apt-get install gearman-job-server libgearman-dev sudo apt-get install php-pear php5-dev 上記のコマンドは正しく実行されますが、実行すると sudo pecl install gearman 次のようにエラーを出している checking whether to enable gearman support... yes, shared found in /usr checking for gearman_client_set_context in -lgearman... yes checking for gearman_worker_set_server_option in -lgearman... yes checking for gearman_job_error in -lgearman... no configure: error: libgearman …

1
opensslの無効なCA証明書
PKIインフラストラクチャでサーバー間OpenVPNを設定していますが、機能させることができません。証明書チェーンに何かあるのではないかと思いますが、その方法を説明するのに途方に暮れています。オフラインのルートCAと証明書の階層があります。CAは、EJBCAと呼ばれる製品によって外部で管理されます。絵画的にはチェーンは次のようになります(名前が変更されています)。 RootCA -> OnlineSubCA -> SubCA1 -> VPNCA CA VPNCAを使用してサーバーとクライアントの証明書に署名し、それらのシステムに証明書チェーンを用意しました。OpenVPNのデバッグ中に、「openssl s_server」と「s_client」を使用してみたところ、CAチェーンであると私は確信しました。 openssl s_server -cert server.cert -key server.key -CAfile chained.pem -verify 5 そしてクライアント上で openssl s_client -cert client.cert -key client.key -CAfile chained.pem -verify 5 サーバーは、とりわけ、吐き出します。 depth=3 C = CA, O = My Company, CN = OnlineSubCA verify error:num=24:invalid CA certificate verify return:1 …

3
Powershellを使用して、Exchangeデータベースで2年以上前の電子メールのリストをユーザー別にソートする方法は?
現在、メールのアーカイブと保持ポリシーの見直しを検討しています。大きな問題は(法務部門にとって)どれくらい前に節約したいですか?現在、私たちのユーザーはメールボックスの制限が非常に大きく、以前はすべて適切であると見なしてアーカイブすることができました。したがって、Exchangeデータベースにはない数百GBのデータがありますが、最終的には検出のためにアーカイブデータベースに吸い込まれることになります。私がやりたいのは、法務チームが1年、2年、3年など前に戻った場合にどれだけの量になるかを定量化できることです。 TheDailyAdminで、ほとんどの部分で私がやりたいことを実行するかなり簡単なPowershellスクリプトを見つけましたが、それはすべてを1つの山にまとめています。結果を確認したいのですが、ユーザー別に並べ替えると、Sallyには2年以上前の47MB、Charlesには2年以上前の190MBがあることがわかります。 これが私が実行したスクリプトです: get-mailboxdatabase | get-mailbox -resultsize unlimited | get-mailboxfolderstatistics -folderscope all -includeoldestandnewestitems | export-csv mailbox_stats.csv すべてをファイルに保存することはできますが、メールがだれのものかはわかりません。特にメールボックスでも実行しましたが、時間がかかるので、すべてのユーザーに対して手動で実行することは避けます。私はPowershellの第一人者ではありませんが、誰かがしっかりと把握し、コマンドを正しい方向に向けて少し細かく分解できるようにしてほしいと思っていました。 前もって感謝します!

2
Chef(solo)レシピをループする正しい方法は何ですか?
誰かが私にシェフのしくみを説明してくれませんか?これはかなり大まかな質問なので、絞り込むために、ユーザーのリストをループして、まだ存在しない場合はそれぞれを作成するこの非常に単純なレシピを持っています。それは動作しません。 私が言うことができることから、ループは期待通りに起こっているようです。ループが完了すると、各ユーザーを作成するためのbashコマンドが実行されます(ループの各反復ごとに1回)。ただし、bashコマンドを実行すると、最初のループの繰り返しからのユーザー値しか表示されないように見えます。 この例のように変数データをループするレシピを書く正しい方法は何ですか? ここにレシピがあります: node[:users].each do |user| puts "in loop for #{user['username']}" bash "create_user" do user "root" code do puts "running 'useradd' for #{user['username']}" "useradd #{user['username']}" end not_if do puts "checking /etc/passwd for #{user['username']}" "cat /etc/passwd | grep #{user['username']}" end end end 私は次の設定でVagrantを使用してこれをテストしています: Vagrant::Config.run do |config| config.vm.box = "precise32" config.vm.box_url …
8 chef  chef-solo 

1
Outlook 2010は暗号化されたメールに返信できません
同僚と私は、暗号化された電子メールを使用してパスワードを送信することがあります。私たちは2人ともOutlook 2010を使用しており、両方のデジタルIDは同じ機関によって作成されました。同僚にとっては、暗号化された電子メールの作成、返信、読み取りは問題なく機能します。しかし、私にとっては、彼の暗号化された電子メールを読むことができ、暗号化された電子メールを送信できますが、彼の暗号化された電子メールに返信することはできません。標準のOutlook暗号化エラーメッセージが常に表示されます。 「Microsoft Outlookでは、次の受信者の証明書が見つからないか無効であるか、暗号化機能が競合しているかサポートされていないため、このメッセージの暗号化に問題がありました:」 次に、彼の正しい電子メールアドレスをリストし、暗号化されていない送信またはキャンセルを提案します。 これを引き起こす可能性のあるアイデアはありますか?[暗号化せずに送信]を選択するか、送信前に[暗号化]を選択解除すると、メールは送信されます。 更新:暗号化されたメッセージに返信するときに、[宛先]ボックスで電子メールアドレスを削除し、まったく同じ電子メールアドレスを再入力すると機能します。これにより、同僚のアドレスが重複していたと思い、連絡先リストから完全に削除しました。彼を送ろうとしても見つけられないので、彼がそこにいないことはわかっています。私は彼に新しい暗号化された電子メールを送って、それに署名してもらった。このメールに返信できます。その後、彼を再び連絡先リストに追加しましたが、それでも他の暗号化された電子メールに返信することはできません。彼のアドレスを右クリックすると、連絡先カードを表示して証明書がそこにあることを確認できますが、送信されません。また、上記のエラーメッセージが2回表示されます。(2回キャンセルする必要があります。) 更新2:エラーがポップアップ表示され、[暗号化されていないものを送信]オプションを選択すると、「操作に失敗しました。メッセージングインターフェイスから不明なエラーが返されました。問題が解決しない場合は、Outlookを再起動してください。受信者を解決できません。 」次に[OK]を押して再度送信しようとすると、正常に送信されます(暗号化されていません)。そのエラーメッセージの「受信者を解決できません」の最後の部分は、何が起こっているかに関係があると思います。[宛先]フィールドのメールは正常に動作していないようですが、返信で最初に入力された場合のみです。 更新3:関連する新しいシナリオがありました。通常の(暗号化されていない)電子メールに返信し、暗号化することを決定しましたが、同じ問題がありました。(同じ人です。)[宛先]ボックスのメールアドレスを消去し、同じように再入力して送信しました。したがって、この投稿のタイトルは、「Outlook 2010はメールの返信を暗号化できません」と表現する方がよいでしょう。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.