サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ドメイン境界を越えたNew-PSSession
新しいセッションを(New-PSSessionで)作成できる必要がある仮想マシンを起動しようとしています。もちろん、非常に魅力的なabout_Remote_Troubleshootingは私の常連です。 基本的なマシン(Win 8.1 Enterprise)を起動した後: 私の会社のプライマリドメインは、たとえばですmycompany.com。 開発ドメインがあるdev.mycompany.comので、開発者はサンドボックスで遊ぶことができます。 新しいVM(my-vmという名前)を開発ドメインに追加しましたdev.mycompany.com。 新しいVMにローカルアカウントがありmy-vm\msorens、ローカルマシンのAdministratorsグループにあります。 最初のハードル: New-PSSessionクロスドメインの問題が原因でアクセスが拒否され、実行に失敗しました。上記のトラブルシューティングページによると: 別のドメインのユーザーがローカルコンピューターのAd​​ministratorsグループのメンバーである場合、そのユーザーは管理者特権でリモートからローカルコンピューターに接続できません。 私はこれが真実であるとは確信していませんが(ドメインの問題における私の未経験のため)、そのレメディのレシピを適用することで基本New-PSSessionが機能することを可能にしました: New-ItemProperty ` -Name LocalAccountTokenFilterPolicy ` -Path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System ` -PropertyType DWord ` -Value 1 (そして、それは単なるサンドボックスVMなので、安全性は低くなりますが問題ありません。) 2番目のハードル: 上記のパッチを配置すると、次のいずれかを正常に実行できます。 PS> New-PSSession PS> New-PSSession -ComputerName localhost PS> New-PSSession -ComputerName my-vm ただし、実際に必要なのは、マシンのFQDNを指定することです。 PS> New-PSSession -ComputerName my-vm.dev.mycompany.com 資格情報がないために失敗します。これは私たちにこれをもたらします: PS> New-PSSession -ComputerName my-vm.dev.mycompany.com -Credential (Get-Credential) …

2
Powershell Get-Processの負のメモリ値
私はPowershell Get-Processコマンドレットを使用していくつかの検証を行っていて、一部のプロセスについていくつかの奇妙な値を得ました。SQL Serverインスタンスを実行し、リソースモニターが報告するように3 GB以上のRAMを消費するサーバーでテストしました。Get-Processを実行すると、SQLサーバープロセスでWorkingSetの値が負になり、別のプロセスが2 GB以上のPrivateMemorySizeを消費し、同じ結果が得られました。 PMの負の値。 以下は結果のスクリーンショットです。 OSはポルトガル語です。申し訳ありません。 パワーシェル: sqlservrと最後のscvhostを確認してください... 幸いなことに、私のスクリプトはWMI(Win32_Processクラス)​​を使用してプロセス情報を取得し、そこにある値は正しく、すべてが一致しています。 バグですか?大きな価値があるのでしょうか?Powershell v3を使用しています。

3
サーバーにSSDではなくSASがあるのはなぜですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 サーバーにSSDディスクではなくSASディスクが付属しているのはなぜですか?SASは通常のハードドライブより高速ですが、SSDよりもはるかに低速であることは知っています。私も彼らはもっと高価だと思います:s ここでの取引は何ですか?

1
サーバーの再起動の原因を特定する
VMWare ESXi 5.5を実行しているHP ProLiant DL380p Gen8があります。過去24時間、ランダムに見える間隔で再起動しています。実行中のVMは1つだけで、シャットダウンしてもホストは再起動します。サーバーのメモリまたはディスク領域が不足しておらず、私が知る限り、過熱していません。ログファイルを調べてみましたが、調べるべきことがたくさんあります。 この問題を診断する上で最も重要なステップは何ですか(確認する設定、確認するファイル、問題を示す特定のメッセージ、メモリのプルを開始する必要があるかどうか、これをすべて行う診断CDがあるかどうかなど) ? これは非常に広範な質問であることを知っています。これを自分の状況にもっと具体的にするために、必要に応じてログファイルを提供できてうれしい。

4
RHEL6サーバーを「コピー」できますか?
私の会社では開発サーバーをセットアップする必要があり、L4スイッチで動作する2つの運用RHEL 6サーバーが既にあります。 開発サーバーをセットアップするためのソリューションの1つは、本番サーバーの1つからすべてのファイルを単純にコピーし、少し調整することでした。 私はこれまでにやったことはありませんが、ゴーストイメージングと同じように聞こえます... お勧めですか?エラーが発生しやすいでしょうか?

3
エクストラネットとDMZの違い[終了]
休業。この質問は意見に基づいています。現在、回答を受け付けていません。 この質問を改善してみませんか?この投稿を編集して、事実と引用で回答できるように質問を更新してください。 3年前休業。 私はイントラネット、エクストラネット、DMZ、VPNについて読んでいますが、エクストラネットとDMZに関連する説明が必要です。私はそれらがさまざまなタイプの概念であることを理解しています-エクストラネットは一部のイントラネットリソースへの制限付きアクセスを許可しますが、DMZはインターネットとイントラネットの間に位置し、外部向けのサービスをホストするサブネットです。ただし、通常の設定で実際にそれらの違いは何ですか?エクストラネット上のWikipediaの記事は、彼らが同じ目的のために使用されているので、エクストラネットは、(全体のイントラネットを公開せず、一部のサービス/リソースへのアクセスを提供する)のDMZに似ていると言います。この記事では、エクストラネットはVPNの一部であると述べており、このTechNet記事また、エクストラネットアクセスは、リモートイントラネットアクセスと同様に、たとえばVPNを使用して実装されることが多いと述べています。TechNetの記事では、一般的にエクストラネットはDMZ内でホストされているとも述べています。このピアソンの記事は、「[DMZ]は技術的にはイントラネット内にありますが、[それ]はエクストラネットとしても機能します」と述べています。これは少し混乱します。 次のシナリオを検討してください。ある企業がDMZでホストされているB2C Webサイトを持っています。ウェブサイトはどこからでもアクセスできますが、ユーザー認証が必要です。基盤となるWebアプリは、イントラネット内にデータベースを持ち、イントラネット内でホストされている一部のWebサービスとも対話します(つまり、イントラネットリソースにアクセスします)。私の見たところ、このWebサイトはイントラネットへの制限付きアクセスを効果的に提供しています。しかし、それはエクストラネットと考えることができますか?ウィキペディアでエクストラネットの定義を文字どおりに解釈すると、「エクストラネットは、組織のイントラネットの外部から制御されたアクセスを可能にするコンピューターネットワークです」と私は思います。 上記はエクストラネットと見なすことができないとしましょう。シナリオを少し変更して、B2B Webサイトであるとすると、アクセスは、たとえば特定のビジネスパートナーからの接続に制限されます(たとえば、サイト間VPNを使用して)。この場合、それは確かにエクストラネットですよね?これが事実である場合、エクストラネットサービスとDMZでホストされている他のサービスとの違いは、単にアクセス制限ですか?
8 vpn  dmz  intranet 

2
Postfix:キューに入れられたメッセージの送信者を変更する
完全な再インストール後、設定に問題が発生しました:送信者アドレスが間違っていて、一部の受信者(メールサーバー)が拒否しました。 そのため、Postfixキューで大量のメールがスタックしています。 理想的には、キューに入れられたメールで送信者アドレスを直接変更してから、キューをフラッシュするのが最適です。 私はこの非常に問題に対処するこの答えを試しました。しかし、私が持っているバージョン(2.11.0)ではメッセージを簡単に変更できないようです。 たとえば、/var/spool/mqueuedir はありませんが、代わりに、/var/spool/postfix/... active bounce corrupt defer deferred dev etc flush hold incoming lib maildrop pid private public saved trace usr 関心のあるディレクトリはですdeferred。いくつかのファイルを修正して、間違ったドメインを正しいドメインに変更しようとしました(変更されたファイルのみが変更されるように注意しました)。 しかし、その後、それらのメールはに移動されましたcorrupt。つまり、単純なテキスト変更は機能しないようです(で行われますvi)。 キューに入れられたメールの送信者を変更する他のよりきれいな方法はありますか?
8 postfix  queue 

1
xen:balloon:reserve_additional_memory:add_memory()failed:-17
EC2仮想マシンでUbuntu 14.04を実行しています。カーネルログにこれらのエラーの多くが表示されています。 [ 704.032085] xen:balloon: reserve_additional_memory: add_memory() failed: -17 [ 736.096102] xen:balloon: reserve_additional_memory: add_memory() failed: -17 [ 768.160075] xen:balloon: reserve_additional_memory: add_memory() failed: -17 [ 800.224082] xen:balloon: reserve_additional_memory: add_memory() failed: -17 [ 832.288094] xen:balloon: reserve_additional_memory: add_memory() failed: -17 仮想マシン内でXenを実行していないことは明らかであるため、これらはホストのメモリ割り当てに関係があることを示している必要があります。それが当面の問題を引き起こしているとは思いませんが、私たちが心配すべきことは何ですか?

1
高IO負荷でrrdgraph生成が失敗する
私たちは4コアのCPUプロダクションシステムを使用しており、多くのcronジョブを実行します。一定のprocキューと通常の負荷は〜1.5です。 夜間は、postgresでIOを集中的に使用します。負荷/メモリ使用量を示すグラフを生成します(rrd-updates.sh)。これは、高IO負荷の状況で時々「失敗」します。ほぼ毎晩発生していますが、すべての高IO状況では発生しません。 私の "通常の"解決策は、postgresを適切にイオン化し、グラフ生成のプリオを増やすことです。しかし、これはまだ失敗します。グラフ生成は、flockを使用したセミスレッドプルーフです。私は実行時間をログに記録します。グラフ生成では、高IO負荷時に最大5分であり、結果として最大4分間グラフが失われるようです。 タイムフレームはpostgresアクティビティと正確に一致します(これは1日中に発生することもありますが、それほど頻繁ではありません)。 )は問題を解決しませんでした。 データが収集されないと仮定すると、追加の問題は、どういうわけかまだ機能していないiceice / niceです。 90%のIOwaitと100のロードがあっても、5秒以上の遅延なしで(少なくともテストでは)、データ生成コマンドを無料で使用できました。 悲しいことに、テストでこれを正確に再現できませんでした(仮想化された開発システムのみ) バージョン: カーネル2.6.32-5-686-bigmem Debian Squeeze rrdtool 1.4.3 ハードウェア:ハードウェアRAID1 マウントオプションのLVMを備えたSAS 15K RPM HDD :ext3とrw、errors = remount-ro スケジューラー:CFQ crontab: * * * * * root flock -n /var/lock/rrd-updates.sh nice -n-1 ionice -c1 -n7 /opt/bin/rrd-updates.sh RetcacheのgithubにOetiker氏からのsomhowに関連している可能性のあるバグがあるようです:https : //github.com/oetiker/rrdtool-1.x/issues/326 これは実際には私の問題(同時書き込み)である可能性がありますが、cronジョブが失敗しないことを説明していません。仮定では、実際に2つの同時書き込みflock -nがあると、終了コード1が返されます(テストで確認されたmanページごと)。出力も電子メールで届かず、cronjobが他の時間に実際に正常に実行されるという観察どういうわけか失われました。 出力例: コメントに基づいて、更新スクリプトの重要なソースを追加しました。 rrdtool …
8 linux  debian  io  rrdtool  ionice 

1
VPC EC2からのクラシックRDS
私の古いRDSインスタンスはVPCではなく「クラシック」にデプロイされています。 一部のEC2インスタンスを含む新しいVPCがありますが、これらのVPC EC2インスタンスからRDSインスタンスに接続できません。 VPCのセキュリティグループはRDSセキュリティグループ構成に表示されず、IPアドレスによるアクセスの許可も機能しません。 どうすればよいですか?現在、RDSインスタンスをVPCに移動することはできません。

3
Dell Poweredgeサーバーで120vから240vに切り替えるために必要な電源ケーブル
サーバーとその他のハードウェア(スイッチ、ファイアウォールなど)のキャビネットがあり、現在120vで実行されています。すべてのデバイスの電源が120vと240vの両方をサポートしていることを確認しました。240vPDUを取得する必要があることを理解しています。私の質問は、120から240に切り替える場合、一方の端のPDUに接続し、もう一方のサーバーの電源装置に接続するために購入する必要のある電源ケーブルは何ですか?参考までに、主にDell Poweredgeサーバーを使用しています。

1
CentOS 7のPostfixがcyrus saslauthdに対して認証できない
Postfixはcyrus saslauthdに対する認証に失敗します。ただし、saslauthd自体は認証する用意があります。何が欠けていますか? Syslog mailファシリティから: Aug 5 14:47:26 centos7-msa-test postfix/postfix-script[20286]: starting the Postfix mail system Aug 5 14:47:26 centos7-msa-test postfix/master[20288]: daemon started -- version 2.10.1, configuration /etc/postfix Aug 5 14:47:34 centos7-msa-test postfix/submission/smtpd[20291]: connect from client.example.com[192.0.2.2] Aug 5 14:47:34 centos7-msa-test postfix/submission/smtpd[20291]: Anonymous TLS connection established from client.example.com[192.0.2.2]: TLSv1 with cipher ECDHE-RSA-AES128-SHA (128/128 …

5
DNSサーバーとWebサーバーを同じIP上に置くことはできますか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 私はラズベリーパイを買ってそれをウェブサーバーにしました。1つのIPを持つネットワークがあります。DMZを作成しました。インターネットからラズベリーpi Webサーバーにアクセスできます。Webサイトで使用する予定のドメインを購入しましたが、いくつかのネームサーバー(プライマリとセカンダリ)を作成し、それらのネームサーバーのIPをドメイン名の購入元に提供する必要があることに気付きました。 私の質問は次のとおりです。DNSサーバーとWebサイトで同じIPを使用できますか?セカンダリネームサーバーが本当に必要ですか(IPが1つしかないので、セカンダリネームサーバーはあり得ないと思います)?次に行うことは何ですか?ラズベリーにDNSサーバーをインストールして構成する必要がありますか?1つのIPと1つのラズベリーpiだけでWebサイトを稼働させることはできますか?これらすべてをどのように達成できますか(私のラズベリーに私のウェブサイトを立ち上げて実行し、私のドメイン名がそれを指している)? ありがとう!

2
btrfsスナップショットを削除する方法?
私はbtrfsを初めて使用し、数か月前に作成したいくつかのスナップショットを削除しようとしています。それらは約20GBのスペースを占有しており、そのスペースが必要です。 これはスナップショットをリストするようです: ↪ sudo btrfs subvolume list / ID 257 gen 82021 top level 5 path @ ID 258 gen 82021 top level 5 path @home ID 263 gen 81983 top level 5 path @home/.ecryptfs/mlissner/.Private/ECRYPTFS_FNEK_ENCRYPTED.FWa8iOdaTukmNEROkGj4b5OZHZ0bKOqrvAQxu4dgX.2jUELJL22wpV94oU--/ECRYPTFS_FNEK_ENCRYPTED.FWa8iOdaTukmNEROkGj4b5OZHZ0bKOqrvAQxHunTlBS-30iHyukjeY9-EE--/root_post_install_2014-04-29 ID 364 gen 81986 top level 5 path @home/.ecryptfs/mlissner/.Private/ECRYPTFS_FNEK_ENCRYPTED.FWa8iOdaTukmNEROkGj4b5OZHZ0bKOqrvAQxu4dgX.2jUELJL22wpV94oU--/ECRYPTFS_FNEK_ENCRYPTED.FWa8iOdaTukmNEROkGj4b5OZHZ0bKOqrvAQxHunTlBS-30iHyukjeY9-EE--/root_post_install_2014-05-04 ID 376 gen 81996 top level …
8 snapshot  btrfs 

6
リモートデスクトップを使用してログインしているユーザーの最大数
リモートデスクトップを使用して、同時に2人のユーザーのみに制限されたWindows 2012サーバーにログインしています。しかし、時にはもっと多くのことをする必要があります。 これは、サーバーが再インストールされる場合にのみ可能であると主張しているサーバー担当者と話し合いました。どういうわけか私はこれを信じるのは難しいと思いますが、初心者であるために私は来る引数はありません。 それで-それは本当ですか、それとも偽ですか?これが事実であることを確認するために確認できるサーバーの構成はありますか?官僚制度で混乱している初心者を助けてください。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.