サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
sendmailがハンドシェイクの失敗で一部の接続を拒否:SSLアラート番号40
CentOS 5上の私のsendmailサーバーは、次のメッセージがログに記録され、一部の接続を拒否し始めました。 error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure:s3_pkt.c:1092:SSL alert number 40 CentOS 6サーバーからopensslを使用して接続しようとすると、次のエラーが発生します。 $ openssl s_client -starttls smtp -crlf -connect hostname.example.net:smtp (...) error:14082174:SSL routines:SSL3_CHECK_CERT_AND_ALGORITHM:dh key too small:s3_clnt.c:3331 (...) Server Temp Key: DH, 512 bits (...) CentOS 6サーバー上のメールは、で一時的に拒否されDeferred: 403 4.7.0 TLS handshake failedます。 CentOS 6 / RHEL 6からCentOS6 / RHEL5サーバーにメールを送信できるようにするにはどうすればよいですか?

1
rx_missed_errorsのトラブルシューティング方法は?
すべてのサービスを設定した後、古いサーバーから新しいサーバーに移行すると、NICで大きなrxパケットがドロップされていることに気づきました。 $ ifconfig eth2 | grep 'RX.*drop' RX packets:2059646370 errors:0 dropped:7142467 overruns:0 frame:0 しかし、/sys/class/net/eth2/statistics/rx_dropped何も示さない: $ cat /sys/class/net/eth2/statistics/rx_dropped 0 次に、それがわかりますrx_missed_errors: $ cat /sys/class/net/eth2/statistics/rx_missed_errors 7142467 どのようにトラブルシューティングを行い、どのような原因を見つけることができrx_missed_errorsますか? 私はUbuntu 12.04.5 LTSを実行しています: $ ethtool -i eth2 driver: ixgbe version: 3.15.1-k firmware-version: 0x800003e1 bus-info: 0000:07:00.0 supports-statistics: yes supports-test: yes supports-eeprom-access: yes supports-register-dump: yes

1
Active DirectoryでOUを移動できません(アクセスが拒否されました)
バックグラウンド 今日、Active DirectoryでOUを移動しようとしたところ、アクセス拒否エラーが表示されました。 ADユーザーアカウントをさらに詳しく調べたところ、オブジェクトを移動するために必要なアクセス許可があり(使用していたOUのセットに対する完全なアクセス許可がありました)、ITキャリアの過程でAD内のアイテムを複数回移動しました。また、初めてこれに遭遇したのも少し奇妙ですが、それでもなおです。 私が試したもの 特定のOUに個人のADユーザーアカウントのアクセス許可を与える。これは、私がその一部であったADセキュリティグループだけではなく、すでにOUに対するアクセス許可を持っている ドメイン管理者アカウントを使用して移動を試す ユーザーアカウントのパスワードをリセットしてからログオフしてログオンし、ADを開いてOUを移動する 別のドメインコントローラに接続して移動を実行しようとしました RSATがインストールされている別のサーバーを介してADに接続し、移動を実行しようとした これらはすべて成功せずに終わりました。 質問 両方のOUに対する完全なアクセス許可があるのに、なぜActive DirectoryのOUを別のOUに移動できないのですか

1
HTTP OPTIONSメソッドはIIS 8.5で許可されるメソッドをどのように決定しますか?
TRACEIIS 8.5(Windows Server 2012 R2 Datacenter)のWebサイトからメソッドを削除しようとしています。以下のように、リクエストフィルタリングを使用してこれを実装しました。 <system.webServer> <security> <requestFiltering> <verbs allowUnlisted="true"> <add verb="TRACE" allowed="false" /> </verbs> </requestFiltering> </security> </system.webServer> これはTRACEリクエストを防ぎますが、OPTIONSリクエストを送信した場合でもTRACE、AllowおよびPublicヘッダーにリストされます。IISをリセットしましたが、から抜け出すTRACEことができませんOPTIONS。否定したくないOPTIONS。 これは、私たちが遵守しているコンプライアンススキャンが、有効化さOPTIONSれているインジケーターとして使用されているように見えるため、問題がありTRACEます。私はこれが正しくないことを知っていますが、それは私が満たさなければならない基準です。 利用可能なメソッドを正しく報告するオプションを取得する方法はありますか?
8 iis  iis-8.5 

4
私たちはカスタムTLDドメイン名を所有しておらず、それがローカルドメイン名です
私は現在、骨の折れるミスを犯した会社で働き始めており、それを修正するために最も苦痛の少ない方法を探しています。 私が始める前に、彼らは登録していないTLDを使用してローカルドメインに名前を付けました。この質問では、内部ドメインがと呼ばれているとしましょう example.com。 ここから始めて、DNSに関するあらゆる種類の問題と、ローカルおよび外部での名前解決に関する問題が発生していることに気付きました。私はabcコンピュータにpingを実行し、通常は192.168.x.xIP規則に従って適切なアドレスを返します。 ただし、頻度が高くなると、コンピューターで外部IPアドレスが返されるという問題に気づくでしょうname.example.com。数時間いじった後、私は自分で考えました...いいえ、それはできません...確認させてください。さて、whois example.comを実行しましたが、TLDを所有していないことがわかりました。他の誰かが所有しています。 私がこれに関連する力に直面したとき、私は解決策と私が思いついた悪いシスオペであることを求められました: この間違いをしないでください。 ドメインの名前を変更し、それに伴うすべての作業を行う 登録するのを「忘れた」ドメインに求められ、二度と忘れないようにしたいお金を支払います。 私は今度は別の方法を見つけるように言われ、それよりも多くの解決策が必要でした...残念ながら、使用したいドメインを所有している方がいいので、このようなnoobの間違いをする人を見たことがありません。 提案はありますか?

2
自分のSMTPサーバーをセットアップしてメールを送信するのは、配信に関して時間の無駄ですか?
私が管理するいくつかのドメインにサービスを提供する専用のホストがあります。私は自分のメールとIMAPサーバーをホストしています。 サーバーはbuildoneforme.comにあり、IPアドレスは144.76.81.247です。リバースDNSが機能していると思います: $ host 144.76.81.247 247.81.76.144.in-addr.arpa domain name pointer buildoneforme.com. また、独自のドメイン名とWebサイト(同じマシンでホストされている)を使用してコミュニティグループを実行し、数百人のメンバーがいるメールマンディスカッションリストを実行したいと考えています。 メールを送信するようにMTA(exim4)を設定しましたが、特にMicrosoft(例:hotmail.com、outlook.com)への配信に関する問題が発生しています。 当初、MicrosoftはIPアドレスを完全にブロックしていましたが、フォームを使用して、ブロックを解除してリクエストを承認するように要求しました。 ただし、このサーバーから送信するすべてのメールが自動的に迷惑メールフォルダに入れられることがわかりました。 まだいくつかのテストメールを送信しており、メーリングリストやバルクメールはまだ送信していません。また、2つのMicrosoftテストアドレスにしか送信していません。 私は次のすべてを行いました: 迷惑メール報告プログラムに参加 スマートネットワークデータサービスプログラムに参加 SPF DKIM DMARC TLSが利用可能です オープンリレーなし(TLS経由でメールを送信するには認証が必要です) 次の結果でcheck-auth@verifier.port25.comにテストメールを送信しました。 SPF check: pass DomainKeys check: neutral DKIM check: pass Sender-ID check: pass SpamAssassin check: ham マイクロソフトに、このIPアドレスからのすべての電子メールを自動的にスパムとしてマークすることをやめるように依頼しましたが、次のような標準的な応答が返ってきました。 残念ながら、ご提供いただいた情報を確認し、メールポリシーに準拠した後は、お客様の配信に関する問題をすぐに軽減することはできません。ただし、時間の経過とともに配信可能性を向上させるのに役立つ、考慮すべきいくつかの特定の推奨事項があります。 これに続いて、私には当てはまらない一般的な推奨事項がいくつかあります。 だから私の質問はこれです:私のような小さなオペレーターが自分の送信SMTPサーバーを使用して良い電子メール配信を達成することはほとんど絶望的ですか?Amazon SESのようなサードパーティのサービスを使い始めるべきですか? 偽のhotmailアカウントをたくさん作成して送信を開始し、すべてのメールを迷惑メールではないとマーク付けした場合、このIPアドレスをホワイトリストに登録できますか? 私のセットアップで見つけることができる唯一の潜在的な問題は、サブドメインではなくトップレベルドメインからメールを送信していることです。たとえば、サーバーはmail.buildoneforme.comではなくbuildoneforme.comとしてアドバタイズします。 mxレコードはmail.buildoneforme.comです(これは同じIPアドレスを指します)。これは大きな違いをもたらすでしょうか?

8
Tmuxの新しいセッションが返す:「ソケットを作成できません」
byobuセッションを誤って終了してしまい(kill -9 byobuSessionId)、別のbyobuコマンドを開始しようとすると、「ソケットを作成できません」で失敗します。 また、tmux new-session「ソケットを作成できません」を返します 私はsudo service screen-cleanup start成功せずに試しました! どうすれば解決できますか?
8 tmux  byobu 


2
dig出力の「net.c:577:sendmsg()failed:Operation not allowed」
CentOS 6.6マシンでBind 9.10.2バージョンを実行しています。digコマンドの実行中に「」というnet.c:577: sendmsg() failed: Operation not permitted"通知が表示されます。 digユーティリティは私に答えを与えていますが、上部にはこの通知が表示されます。 $dig nkn.in +short **net.c:577: sendmsg() failed: Operation not permitted** 164.100.129.98 System Information :- cat /etc/*-release CentOS release 6.6 (Final) LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch CentOS release 6.6 (Final) CentOS release 6.6 (Final) 誰かがこの通知を受け取る理由を教えてください。 IPv6ファイアウォールルールセット:- *filter :INPUT DROP [0:0] :FORWARD DROP [0:0] :OUTPUT DROP [0:0] :LOGGING …

3
PowerShell:åäöを使用したGet-ADUserプロパティ
Get-ADUserを使用して、選択したユーザーのセットを抽出しようとしています。ユーザーは、 "Gåäördet"のように、名前に非ASCII文字を含む会社に属しています。残念ながら、このタスクには会社のプロパティを使用する必要があり、スクリプトから作業するためにも必要です。 以下は、インタラクティブセッションでうまく機能しますが、スクリプト内で実行してもデータは返されません。 $Company = "Gåäördet" Get-ADUser -Filter "company -eq '$Company'" 回避策は見つかりましたが、信頼性が十分ではありません(間違ったオブジェクトを選択するリスク): # Work-around 1: $Company = "Gaaordet" # Replace åäö with aao in the variable Get-ADUser -Filter "company -eq '$Company'" # Matches the company "Gåäördet", but why? ...または... # Work-around 2: $Company = "G...rdets" # Use regex for åäö …

3
SHA-1よりも強力な自己署名証明書を作成するにはどうすればよいですか?
開発環境では、IIS7.5で自己署名証明書を作成できます。しかし、その証明書はSHA-1であり、最近ブラウザーはそれについて不満を言っています。FireBugを開くと、次の警告が表示されます。 「このサイトではSHA-1証明書を使用しています。SHA-1よりも強力なハッシュ関数を使用する署名アルゴリズムを備えた証明書を使用することをお勧めします。」 だから私の質問は: 1)SHA-1よりも強力な自己署名証明書を作成する方法はありますか? 2)そうでない場合、ブラウザにこれらの警告の表示を停止するように指示する方法はありますか? 更新 結局、@ vcsjonesの回答を使用することになりましたが、それだけで今のところ私になりました。機能させる前に解決しなければならない問題がいくつかあります。 1)何らかの理由で、パスワード付きの証明書をインポートできませんでした。だから私はそれなしでそれを作成することになりました。 2)IIS経由で.pfx証明書をインポートすると、バインディングの編集で新しい証明書を適用しようとすると、「指定されたログオンセッションが存在しません」というメッセージが表示され続けました。だから私はほとんど研究をしなかったが、このSOの答え、特にマイクLの答えが役に立つことがわかった。 もう1つ追加したいのは、証明書をインポートするときは、必ず.pfx証明書を選択してください。インポートウィザードのデフォルトの選択は* .cerであり、インポートできます(間違えて作成しました)が、IISサーバー証明書に証明書が表示されませんでした。よく見ると、アイコンに小さなキーがありませんでした。今、私はKB-889651の記事を介してそれを修復することができたという研究をしました。したがって、必ず.pfxをインポートしてください。インポートすると、修復しなくても機能します。 また、この証明書に信頼の問題がある場合は、「信頼されたルート認証局」にもインポートしてください。

2
Windows 7には、重複する同一の組み込み印刷フォーム(レター、リーガル)が含まれていますが、正常に印刷できるのは2つのうちの1つだけです。
Lexmark E360dnプリンターを搭載したWindows 7 64ビットマシンを使用しています。ユーザーが何かを印刷しようとすると、プリンタはデフォルトで「レター」サイズに設定されます。ユーザーが[印刷]をクリックすると、プリンタは、「カスタムサイズ6」をロードするように求めるエラーを表示します。問題は、ユーザーのマシンには実際には2つのフォームがあり、どちらも「レター」という名前が付けられていることです。2番目のものを選択すると、どういうわけか印刷ジョブが成功します。 印刷サーバーのプロパティで、2つの「レター」サイズ、2つの「リーガル」サイズ、および決して使用されないその他の重複するフォーム(エグゼクティブなど)が表示されます。私の知る限り、これは不可能であるべきです。また、2番目の「レター」をデフォルトの印刷サイズとして設定できません。何があっても、最初の「レター」を常に試行します。ドロップダウンメニューの文字列は一意であることが期待されているためです。 これは、重複する「リーガル」サイズのスクリーンキャップです。 DELETEボタンと測定値は、組み込みフォームの場合と同様に無効になっていることに注意してください。 これが私の複製した「レター」フォームのスクリーンキャップです。 DELETEボタンと測定が有効になっていることに注意してください。値を変更したり、[削除]ボタンをクリックしたりすると、「定型書簡を削除できませんでした。操作を完了できませんでした」というエラーコード0x00000057が表示されます。プリントマネージャーのコンテキストでエラーコードをグーグル化することは無益でした。 最悪なのは、私の2つの「レター」サイズが同じ寸法であることです。なぜ一方が機能し、もう一方が機能しなくなるのかは、私を超えています。これは、Windowsフォームリストを使用するプリンターにのみ影響します。私が試した他のものは、コニカの豪華なプリンターのように、独自のドライバーですべてのフォームを管理するので、そこに問題はありません。 で説明されているように、スプーラサービスを停止し、プリンタ関連のレジストリ設定を削除してみました community [DOT] spiceworks [DOT] com / topic / 171096-interesting-printer-issue-error-0x000003e3?page = 1#entry-1047526(リンクは2つまでしか投稿できません。申し訳ありません)。 これにより、Windowsのインストール以降に行ったプリンター関連の操作がほとんど取り消されるはずですが、フォームの重複が残ります。仮想プリンターを含むすべてのプリンターを数回アンインストールしましたが、フォームは常に残ります。 ANSI A / B / Cサイズのどれも複製されず、「名前付き」のサイズのみが複製されることに注意する価値があります。マシンにはフランス語のパックがインストールされていますが、英語で実行されています。他のユーザーがこの問題を抱えていなくても、言語と組み込みのフォームに問題があるのではないかと思いますか? 私が言うことができることから、ウィンドウズが同じ名前を持つ2つの別々のフォームをリストに追加しているようです。リストに入ると、ドロップダウンリストの動作方法のため、実際に表示または変更できるのは1つだけです。私の質問は「Windowsが組み込みであると考えている印刷フォームを削除するにはどうすればよいですか?システムのデフォルトのプリンタフォームを削除する方法によると?これは確実に行うことはできません。さらに、組み込みのフォームを実際に削除しようとしているのではありません。

3
DNSルートレコードがハードコーディングされているのに、なぜそれがttlになっているのですか?
再帰的なネームサーバーをローカルでホストしているため、名前解決にサービスプロバイダーや他のパブリックDNSサーバーは必要ありません。ルートネームサーバーのIPアドレスは、(Bind /etc/bind/db.rootファイル内の)構成ファイルにハードコードされていnslookupますが、のルートネームサーバーに対して複数の連続したコマンドを実行すると.、TTLフィールドが減少します。 設定ファイルでharcodeされていると、TTLが減少するのはなぜですか? そして、なぜそれがハーコード化されているとき、最初にルートレベルのTTLが必要になるのでしょうか?

3
シャットダウン中にsshdが最後に停止するサービスであることを確認するにはどうすればよいですか?
rebootコマンドを発行すると、CentOS 7でSSH接続がすぐに閉じられることに気付きました。pingを実行できるため、サーバーが再起動したわけではありません。 systemdがsshdを強制終了するのが早すぎるようです。場合によっては、サービスがシャットダウンしたり、単に遅くなったりすることがあり、サーバーが起動していても、ログインして問題を確認することができなくなります。 他のすべてのサービスが停止した後にのみsystemdにsshdを強制終了するように指示する方法はありますか?

2
Apacheの非推奨のSSLCertificateChainFileディレクティブ(AH02559)
最近、Apacheを2.2から2.4にアップグレードしましたが、SSLCertificateChainFileディレクティブを廃止する方法がわかりません。 エラー: me@jessie:~$ sudo apache2ctl configtest AH02559: The SSLCertificateChainFile directive (/etc/apache2/sites-enabled/https.conf:103) is deprecated, SSLCertificateFile should be used instead Syntax OK 私の現在の設定: SSLCertificateFile /etc/apache2/cert/ssl.crt SSLCertificateKeyFile /etc/apache2/cert/ssl.key SSLCertificateChainFile /etc/apache2/cert/sub.class1.server.sha2.ca.pem SSLCACertificateFile /etc/apache2/cert/ca.pem 証明書はStartCOMによって署名されています。マニュアルによれば、チェーン全体がSSLCertificateFileディレクティブで指定された1つのファイルにあるはずですが、どのキーをどの順序でこのファイルに連結する必要があるのか​​わかりません。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.