サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
CentOS 7-VSFTPDを介して作成されたディレクトリがSELinuxコンテキストを継承しない
当社にはCentOS 7を搭載したウェブサーバーがあり、お客様はFTP(vsftpd)を介してウェブサイトを管理しています。SELinuxは強制モードです。 問題は、VSFTPDを介して作成/アップロードされたデータが適切なSELinuxコンテキストを継承しないことです。説明させてください。 たとえば、WordPressサイトの場合、サーバーにはそのままの状態で、を使用して表示できるいくつかのルールが既にsemanage fcontext -l |grep '/var/www'あります。 /var/www/html(/.*)?/uploads(/.*)? all files system_u:object_r:httpd_sys_rw_content_t:s0 /var/www/html(/.*)?/wp-content(/.*)? all files system_u:object_r:httpd_sys_rw_content_t:s0 したがって、WordPressサイトをコピーするときに、別のサーバーから/var/www/html/SSHでにあるディレクトリに、フォルダーwp-content/とwp-content/uploads/適切なhttpd_sys_rw_content_tセキュリティコンテキストがあるとしましょう。ただし、これらのフォルダーがFTPを介して作成される場合、それらが取得するコンテキストはhttpd_sys_content_t(rwなし)です。これは、顧客がサーバーにアップロードするサイトは、apacheユーザー/グループに書き込み権限を与えても、それらのディレクトリに書き込むことができないため、WordPress管理者が機能しないことを意味します。そのため、サイトをアップロードするときに、これを修正するためにサポートをリクエストする必要があります。これは関係者全員にとって時間の無駄です。 お客様が自分のサイトをhttpdocsにアップロードしたとします。SSHを使用しmv httpdocs/ httpdocs.2/ && cp -pr httpdocs.2/ httpdocs/ && rm httpdocs.2/ -frて問題が解決した場合、データに問題はありません。 またrestorecon -Rv httpdocs/、問題を修正することもできます。 つまり、質問は、VSFTPDを介して作成/アップロードされたディレクトリに、SSHを介してディレクトリが作成/アップロードされたときに継承されるように、適切なSELinuxコンテキストを継承させるにはどうすればよいですか?

1
nginxログのSSLエラー
nginxエラーログでこのログエントリを取得しています: 2016/03/19 09:46:33 [crit] 14355#14355: *7761 SSL_shutdown() failed (SSL: error:140E0197:SSL routines:SSL_shutdown:shutdown while in init) while SSL handshaking, client: 178.63.105.85, server: 0.0.0.0:443 どういう意味かわかりません。私はグーグルしようとしましたが、成功しませんでした。

2
OverlayFS:ファイルを非表示にせずに削除するにはどうすればよいですか
2つのマウントポイントを1つのディレクトリに集約して、両方のファイルを1つのマウントポイントに結合しようとしています。overlayfsでいくつかのテストを行っており、マージされたマウントポイントを作成できましたが、このマージされたディレクトリからファイルを削除すると問題が発生します。 overlayfsには上部と下部のファイルシステムがあり、下部から何かを削除した場合、上部のファイルシステムに「ホワイトアウト」が作成され、基本的にファイルが「シャイニングスルー」からマージされたレイヤーに隠されるだけであることを理解しています。ファイルはまだ下位ファイルシステムのスペースを占めています。利用できるものとして提示されていないだけです。 私の質問は、どうやってファイルを上位と下位の両方のファイルシステムから削除し、削除したファイルが使用していたスペースを再利用し、単に非表示にするだけではないのですか?私は手動でマージされたディレクトリからファイルを削除してから、下のディレクトリから(これが行うには悪いことだ?)ことができますがdf -ha、まだスペースを取るようマージされたディレクトリを示しています。 none 6.8G 1.9G 4.6G 30% /var/www/merged /dev/loop0 380M 2.3M 354M 1% /mnt/lower1 /dev/loop1 380M 2.3M 354M 1% /mnt/lower2 /dev/loop2 380M 2.3M 354M 1% /mnt/upper none 380M 2.3M 354M 1% /mnt/merged overlayfsファイルシステムからファイルを削除し、正確なディスク使用量を適切に報告する正しい方法は何ですか?

1
Ansibleはスーパーバイザの再起動に問題があります
Ansibleプレイブックを使用してスーパーバイザを再起動しようとしていますが、Ansibleのスーパーバイザモジュールの問題に遭遇しているようです。 私のスーパーバイザー構成で、プログラムを定義しました: [program:process] process_name=%(program_name)s_%(process_num)02d command=/home/box1/workers/bin/process numprocs=64 directory=/home/box1/workers/bin autostart=true autorestart=true startretries=5 stderr_logfile=/tmp/%(program_name)s-err.log stdout_logfile=/tmp/%(program_name)s-out.log user=root そして、これはうまくいきます。しかし、Ansibleを介してスーパーバイザを再起動しようとすると、次のエラーが発生します。 failed: [box1] => {"failed": true} msg: program:process: ERROR (no such process) program:process: ERROR (no such process) 私のAnsibleタスク構成は次のようになります。 - name: Restart Supervisor sudo: yes supervisorctl: name=program:process state=restarted config=/etc/supervisor/supervisord.conf name私が試してみましたパラメータprogram:process、program、program:そしてprocessどれも仕事に思えません。現在、Ansible 1.5.4を使用しています。

4
低コストストレージのためのEBSスナップショットのS3へのコピー
目標:EBSスナップショットをS3にコピーして、必要に応じてローカルのオンプレミスマシンにダウンロードできる任意のオブジェクトのように処理できるようにする。 EBSスナップショットは実際にはS3によってサポートされていることを理解しています-それらは「通常の」バケットに表示されません。スナップショットをコピーするために私が見るコンソールとCLIのメカニズムは、ある領域から別の領域に「スナップショットとして」スナップショットをコピーすることに焦点を当てているようですが、「任意のオブジェクト」としてのS3には焦点を当てていません。 私が読んだことから、EBSスナップショットの$ / GB料金は、S3のオブジェクトの料金よりも高いので、いくつかのスナップショットがある場合、長期間保持したいのですが(すぐに時間は必要ありません)、オブジェクトとしてS3に「アーカイブ」したいと思います...基本的に: オブジェクトとしてスナップショットをS3にコピー EC2のスナップショットを削除 5〜6か月 S3のオブジェクトをスナップショットとしてEC2にコピー EC2に表示されるスナップショットからボリュームを作成します これはできますか?

2
Metasploit:モジュールデータベースキャッシュはまだ構築されていません。スローサーチを使用しています
kalilinux 2016の新しいメタスプロイト(最新の安定版) systemctl start postgresql OK msfconsoleの場合 msf > db_status [*] postgresql connected to msf 検索を開始したとき msf > search samba [!] Module database cache not built yet, using slow search だから私はキャッシュを再構築します... msf > db_rebuild_cache そして、検索を開始すると msf > search samba [!] Module database cache not built yet, using slow search この問題を解決するにはどうすればよいですか?
8 linux  security 

2
Dockerの公式Wordpressコンテナー内でLet's Encryptを使用する
Let's Encrypt を公式のDocker Wordpressコンテナに入れようとしています。 環境をセットアップする $ cat docker-compose.yml wordpress: hostname: some.fqdn.com image: wordpress links: - db:mysql ports: - 80:80 - 443:443 db: image: mariadb environment: MYSQL_ROOT_PASSWORD: example $ docker-compose -f docker-compose.yml up -d $ docker exec -ti root_wordpress_1 bash Let's Encryptをインストールする $ apt-get update && apt-get install -y git-core [...] …

1
find.exeコマンドへのPowerShellパイプ
好奇心旺盛ですが、なぜこれが起こるのですか?実行した場合: netstat -an | find "443" コマンドプロンプトに「443」接続が表示されます。PowerShellコンソールまたはISEで同じコマンドを実行すると、「FIND:Parameter format not correct」というエラーが表示されます。PSで見つけるためにnetstat出力が適切にパイプ処理されていませんか? 注:PSで実行したnetstat -an | findstr "443"場合netstat -an | select-string "443"、これらは期待どおりに動作します。

2
`crontab -`がcrontabを削除するのはなぜですか?キャンセルできますか?
急いでヒットする前にeを忘れてしまいました。 crontab -eEnter プロンプトが表示されたため、通常は入力プロンプトを終了するのと同じように、Ctrl+ Dで閉じました。 警告なしで、私のcrontab全体が空になりました。 どうして?これが発生した原因は何ですか?Ctrl+ 以外のプロンプトを閉じDて、何も保存されないようにするにはどうすればよいですか?
8 bash  cron 

1
systemdのjournalctl:メッセージでフィルターする方法?
journalctlは、ログを調べるのに最適なツールのように見えますが、単純な質問のように感じられることに行き詰まっていますupdate-ipsets。 もちろんこれはできます journalctl -u cron.service | grep update-ipsets しかし、その後、journalctlの出力の他のすべての利点(カラーコーディング、自動ページング、ライブビューなど)を失います。 私はもう試した: journalctl -u cron.service MESSAGE=update-ipsets journalctl -u cron.service "MESSAGE=*update-ipsets*" journalctl -u cron.service "MESSAGE=.*update-ipsets.*" journalctl -u cron.service "MESSAGE=/.*update-ipsets.*/" そして、あなたはtab後に打って実験したくないMESSAGE=-(zsh / Debian Jessie)シェルをハングさせて、Ctrl-Cどちらも助けにはならなかった! この基本的な機能が組み込まれていないとは信じられないので、何かを見逃していたに違いないと思いますか? ありがとう。

2
Amazon EC2でのOpen VPNクライアントのセットアップ
Amazon EC2にOpen VPNサーバーをセットアップすることについてアドバイスするさまざまなページがありますが、必要なのはクライアントをセットアップすることだけです(そのため、インターネットアクセスはAWS IPから直接ではなく、VPN経由でルーティングされます)。.ovpnファイルをそれに転送して、 openvpn --config client.ovpn しかし、これを実行するとすぐにssh接続が失われるため、何もできなくなります。Googleは広範囲に渡り、特定のポートまたは特定のIPアドレスのいずれかをバイパスすると主張するさまざまな提案を見つけました。どちらでもかまいません。つまり、実行中にssh経由で接続する特定のIPに制限されてうれしいです。 ただし、これらのいずれもAmazons環境では機能しないようです。たとえば、Amazon EC2のOpenVPNクライアントを参照してください。その新しいインスタンスなので、これが役立つ場合はVPCに配置されます。

1
Windowsは、名前を解決してVPNに接続するときに使用するDNSサーバーをどのように決定するのですか?
VPNネットワークに接続すると、Windows DNSクライアントは、ローカル接続用に構成されたDNSサーバーとVPN用に静的に定義されたサーバーの間で、優先DNSサーバーをどのように選択しますか? 私は答えを見ているの名前を解決するときに、Windowsが使用するDNSサーバーを決定し、どのように?インターフェイスメトリックを使用して優先アダプター、つまり優先DNSを選択することを説明していますが、VPNに接続している場合はそうではないようです。

1
Linuxでsystemdを使用してIP転送を適切に永続的に有効にする方法は?
私は、IP(間の転送有効にしようenp0s3とtun0のインタフェース)と書き込みをnet.ipv4.ip_forward = 1して/etc/sysctl.conf。再起動後、 $ cat /proc/sys/net/ipv4/ip_forward 1 しかし、転送はまだ機能していません。追加しようとしnet.ipv4.conf.default.forwarding=1てい/etc/sysctl.confます。今再起動後、私は持っています $ cat /proc/sys/net/ipv4/ip_forward 1 $ cat /proc/sys/net/ipv4/conf/default/forwarding 1 $ cat /proc/sys/net/ipv4/conf/all/forwarding 1 $ cat /proc/sys/net/ipv4/conf/enp0s3/forwarding 0 $ cat /proc/sys/net/ipv4/conf/tun0/forwarding 0 私は有効にすることはできません/proc/sys/net/ipv4/conf/enp0s3/forwardingと/proc/sys/net/ipv4/conf/tun0/forwardingでsysctl.confこれらのファイルは、このような初期ブート時に存在していないため。 systemd-sysctl[85]: Couldn't write '1' to 'net/ipv4/conf/enp0s3/forwarding', ignoring: No such file or directory systemd-sysctl[85]: Couldn't write '1' to 'net/ipv4/conf/tun0/forwarding', ignoring: No such …

2
リンク例外のハードリセットEmask 0x50 SAct 0x0 SErr 0x4090800アクション0xeフリーズ
次の状況: カーネルを備えた生産的なLinux Debian 7サーバー 3.2.0-4-amd64 #1 SMP Debian 3.2.68-1+deb7u2 x86_64 GNU/Linux メーカー:Supermicro 製品名:X10SLL-F バージョン:1.02 SATAコントローラ: Intel Corporation Lynx Point 6-port SATA Controller 1 [AHCI mode] (rev 04) SSD x 2、HDD x 2 各ドライブはSata Rev3(6.0Gb / s)を実行できます hdparm -I /dev/sd[a-d]|egrep "Model|speed|Transport" Model Number: TOSHIBA THNSNH128GBST Transport: Serial, ATA8-AST, SATA 1.0a, SATA …

3
1つのターミナルサーバーユーザー(RDS)の異常に高いOutlook 2010 RAM使用率
特定のユーザーのOutlookセッションが2 GB〜4 GBのRAMを消費する多忙なWindows 2008R2ターミナルサーバーで作業しています。 プロセスが開いた直後にRAMが使用されるため、プロセスはメモリリークが遅いようには見えません。 今日まで私は以下を試しました: ユーザーのセッションにログインし、Outlookの設定を確認します。異常はありません。デフォルトのメールクォータが設定されており、ユーザーのメールボックスアイテムは5,000のみです。クォータは3GBです。ユーザーは1.2GBを使用しています。受信トレイはほとんど空です。削除されたアイテムはよく剪定されます。 セーフモードのOutlook。変わりはない。 アドインを削除しています。変わりはない。 新しいOutlookプロファイルを作成します。変わりはない。 別のアカウントからユーザーのメールボックスを開く。変わりはない。 ユーザーを別のターミナルサーバーに移動する。変化なし。 この時点で、ユーザーのOutlook RAM使用量は他のユーザーの10倍から20倍です。他に注意すべき点はありますか? NewRelicによるプロセス情報と統計: タスクマネージャー: プロセスエクスプローラー: 編集: VMMAP出力: 「ワーキングセット」を空にした後:
8 memory  outlook  rds 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.