サーバー管理者

システムおよびネットワーク管理者向けのQ&A

13
HP Proliant DL380 G4-このサーバーは2011年も稼働しますか?
HP Proliant DL380 G4シリーズサーバーは、2011年のITの世界でも高品質で実行できますか? これは奇妙な質問のように聞こえるかもしれませんが、私たちの主なビジネスがIT関連ではない非常に小さな会社です。したがって、私のIT費用は長い道のりをたどる必要があります。 優れたWebサーバーとデータベースサーバーが必要です。しばらくの間、負荷と需要はかなり低くなるので、真新しいHP Dl380 G7シリーズのボックスを$ 6Kで購入するだけのお金も見ていません。今日周りを検索していると、ATLでビジネスリースからサーバーを購入し、それらを部分に分割する会社を見つけました。彼らは、各部分をクリーニング、チェック、テストしてから、要求に応じてサーバーをカスタム「再構築」します。興味深いのは、販売しているすべてのサーバーに3年間の保証を提供していることです。 次の2つを購入することを考えています。 HP Proliant DL380 G4デュアル(2)Intel Xeon 3.6 GHz 800Mhz 1MBキャッシュプロセッサー 8GB PC3200R ECCメモリ 73 GB U320 15K rpm SCSIドライブ×6 Smart Array 6iカード デュアル電源 さらに、通常のCD-ROM、デュアルNICなど... これらすべては、それぞれ750ドル、または2台の非常に適切に装備されたサーバーでは1500ドルです。その後、価格は次のモデルであるG5シリーズで値上がりします。同等のサーバーでは、750ドルから2000ドル程度です。現在、2台のサーバーを購入するための$ 4000はありません。 元の質問に戻ります。Windows2008 R2サーバーとIIS 7をいずれかのマシンにロードし、Windows 2008 R2サーバーとMS SQL 2008 R2サーバーを別のマシンにロードすると、これらのマシンからどのようなパフォーマンスが期待できますか? 事実は、このシリーズがG7の3つのバージョンになりました。このシリーズのサーバーは、Windows 200 Serverが主流のOSであり、Windows 2003 Serverが発売されたときに作成されました。 スペックが同等かそれ以下のG4でWindows 2008 …

3
postmap:fatal:open database /etc/postfix/sasl_passwd.db:Permission denied
外部のSMTPを使用するようにPostfixを構成しています。このため、私はこのチュートリアルを使用しました それを追跡した後、私はログを/etc/postfix/sasl_passwd.db読むことができなかったことがわかりました。ファイルは存在しませんでした。ルートとしてpostmap hash:/ etc / postfix / sasl_passwd(http://postfix.state-of-mind.de/patrick.koetter/smtpauth/smtp_auth_mailservers.html)を使用しましたが、次のようになります: postmap: fatal: open database /etc/postfix/sasl_passwd.db: Permission denied なぜ私はこれを手に入れるのですか? OS: Fedora 14 User "postfix" exists. 更新: sudo ls -l /etc/postfix/sasl_passwd.db ls: cannot access /etc/postfix/sasl_passwd.db: No such file or directory touch /etc/postfix/sasl_passwd.db chmod 640 /etc/postfix/sasl_passwd.db chown postfix:root /etc/postfix/sasl_passwd.db sudo ls -l /etc/postfix/sasl_passwd.db -rwxr--r--. 1 …
9 postfix  gmail 



5
ポートが開いているかどうかを確認するための同等のping
ポートが一貫して生きているかどうかを確認するにはどうすればよいですか?たとえば、私は ping 192.168.1.1 -t > results.txt これにより、192.168.1.1に継続的にpingが送信され、監視できるようになります。 これに使用できる同等のツールまたはコマンドはありますか? 現在私はtelnetを使用していますが、ホストが切断することもあります。Windowsソリューションが必要です。

1
HAProxyでの基本的な体重の質問
サーバーに割り当てられた重みは、その特定のバックエンド内のバランスにのみ影響しますか? 重みを初めて実装するときに、バックエンドのすべてのサーバーに同じ数を指定すると、重みがない場合と同じになりますか? 特定の量でウェイトを調整して、シフトするトラフィックの量を計算するにはどうすればよいですか。例えば: サーバーweb1 10.10.10.10重み100 サーバーweb2 10.10.10.11重み100 サーバーweb3 10.10.10.12重量90 サーバーweb4 10.10.10.13重量90

3
システムの再起動後にIIS6仮想SMTPサーバーが自動的に復旧しない
Win2008 RC2を実行する仮想サーバーがあります。仮想SMTPサーバーを備えたIIS6を、そこでホストしているWebサイトのメールプロバイダーになるように設定しました。それはすべて正常に動作しますが、何らかの理由でサーバーが再起動した場合(自動更新はまだ有効です-多くのクライアントがあるため、これをできるだけ少なくするようにしています)、IIS6は再起動しませんSMTPサーバー。この失敗により、現在のセットアップで500エラーが発生するため、謝罪の半分の日を費やしています。 何か案は? サービスでは、すべてが自動的に戻るように設定しましたが、まだサイコロはありません。 SMTPを再起動するとすぐに、問題なくすべてのメールが送信されます。それは完全に動作しています、それだけでは再起動しません。 私たちは本当に小さな会社なので、自動更新をオフにしたくないのです。セキュリティパッチがあるとMSが判断するたびに、Windowsの15のコピーを手動で更新する時間を割くことができません。 すべてのアドバイスに感謝します!ところで、私はこれらのフォーラムの完全な新人です。調べてみましたが答えが見つかりませんでしたのでよろしくお願いします。しかししっかり。ここで学ばなければなりません。
9 windows  iis-6  smtp 

1
「-」記号はrsyslog.confで意味がありますか?
RsyslogはSyslog構成ファイルと下位互換性があります。 syslog.confのmanページには以下が含まれています。 各エントリの前にマイナス ``-''記号を付けると、すべてのロギング後にファイルの同期を省略できます。書き込みの直後にシステムがクラッシュすると、情報が失われる可能性があることに注意してください。それでも、特に非常に詳細な方法でロギングを使用するプログラムを実行する場合は、これによってパフォーマンスがある程度戻る可能性があります。 しかし、-サインインについて何かを見つけることができませんでしたman rsyslog.conf。 構成-ファイルを読み取る場合、rsyslogは何をしますか?

3
sshd:特定のユーザーに対してPAM認証を有効にする方法
私はsshdを使用しており、公開鍵認証でのログインを許可しています。 選択したユーザーがPAM 2要素認証モジュールでログインできるようにしたい。 特定のユーザーにPAM 2要素認証を許可する方法はありますか? 同じように-特定のアカウントのパスワード認証のみを有効にしたい。誰かが私の重く守られた秘密口座、知っている場合を除いて-私は、パスワード認証を受け入れないことを考えることになるはずハッカー私のSSHデーモンを阻止するために、パスワード認証の試行を拒否したいです有効なパスワードを。SSHクライアントでシークレットキーまたは2要素認証を実行できない場合に、これを実行します。
9 linux  ssh  pam 

1
Usenet用にNNTPサーバーをセットアップする方法
内部のusenetサーバーをセットアップする必要がありますが、チュートリアルやアドバイスが見つかりません。Linuxを使用する必要があります。 チュートリアルや無料(ビール:-)などのソフトウェアを教えていただけますか? ありがとう
9 linux 

5
WindowsでバイナリBLOBを含む大きなMySQLダンプファイルのインポート中にエラーが発生しました
ホスティング会社から入手したMySQLダンプファイルをWindows開発マシンにインポートしようとしていますが、問題が発生しています。 これをコマンドラインからインポートすると、非常に奇妙なエラーが発生します。 3118行目のエラー2005(HY000):不明なMySQLサーバーホスト '╖?*á±dÆ╦N╪Æ・h ^ ye "π╩i╪Z +-$▼₧╬Y.∞┌|↕╘l∞/ l ╞⌂î7æ▌X█XE.ºΓ[;╦ï♣éµ♂º╜┤║].♂┐φ9dë╟█'╕ÿG∟═0à¡úè♦╥↑ù♣♦\ '╔NÑ'(11004) バイナリデータが失われることを想定しているので、スクリーンショットを添付しています... 私は問題が何であるかは正確にはわかりませんが、2つの潜在的な問題は、ファイルのサイズ(2 Gb)であり、それはめちゃくちゃ大きくはありませんが、それほど小さくもありません。それらのJPG画像(これがファイルの大部分が2GBである理由です)。 また、ダンプはLinuxマシンで取得され、Windowsにインポートしていますが、それが問題に追加される可能性があるかどうかはわかりません(理解できないはずです) さて、そのバイナリガベージが、ファイル内の画像が問題であると思う理由ですが、過去に同じホスティング会社から同様のダンプをインポートできたため、何が問題なのかわかりません。 また、このファイル(特に3118行目)を調べようとするのは、そのサイズを考えると不可能です(grepやsedなどのLinuxコマンドラインツールではあまり便利ではありません)。 ファイルが破損している可能性がありますが、確認方法は正確にはわかりません。ダウンロードしたのは.gzファイルで、WinRarで "テスト"したところ、問題ないように見えます(gzになんらかのCRCがあると仮定しています)。あなたがそれをテストするより良い方法を考えることができるなら、私はそれを試してみたいと思います。 何が起こっているのか/このエラーを乗り越える方法はありますか? 特にデータに執着しているわけではありません。これは単にdevのコピーとして必要なので、いくつかのレコードを失う必要がある場合でも、スキーマが完全に健全である限り、問題はありません。 ありがとう! ダニエル
9 mysql  import  binary 

1
vsftpdユーザーのアップロードのデフォルトグループを設定するにはどうすればよいですか?(ubuntu 10.04)
vsftpdユーザーのアップロードのデフォルトグループを設定するにはどうすればよいですか? ファイルをアップロードすると、filesグループがユーザー名に設定されます...特定のグループに自動的に設定するにはどうすればよいですか?

7
「ストリーム」コマンドへの永続的なSSH接続を一定期間作成するにはどうすればよいですか?
SSH経由でコマンドをネットワーク上の別のPC(両方のマシンでLinuxを実行しているマシン)に送信しているPCでアプリケーションを実行しているとしましょう。 たとえば、#1で何かが発生するたびに、#2でタスクを実行したいと思います。このセットアップでは、コマンドごとにSSH接続を作成する必要があります。 カスタムクライアント/サーバーアプリケーションをプログラミングせずに、基本的なUNIXツールでこれを行う簡単な方法はありますか?基本的に私が望んでいるのは、SSH経由の接続を確立してから、次々にコマンドを送信することです。
9 linux  ssh 


3
Rsyncが一部のファイルのバックアップに失敗し、エラー22が発生する
'/ nas'にNFSマウントされたボリュームで単純なrsyncを使用してサーバー全体をバックアップしようとしています これが私のrsyncコマンドです rsync -sav -S --stats -H --numeric-ids --delete -D --exclude-from="/usr/local/bin/rsync_nas1_exclude" / /nas1/ 次のエラーが発生しました: rsync: chown "/nas1/home/8003/.local/share/icons/application-x-wine-extension-its.png" failed: Invalid argument (22) または rsync: chown "/nas1/home/8003/.local/share/applications/wine/Programs/FxPro - Trader" failed: Invalid argument (22) なぜか?'-s'パラメータを使用してファイル名を保護します
9 backup  rsync 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.