サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
Memcachedは選択したインターフェースでリッスンします
Memcachedを、eth0(パブリック)とeth1(プライベート)の2つのインターフェースを持つDebianサーバーにセットアップしています。 Memcachedでeth1とlo(ループバック)の両方をリッスンして、プライベートネットワークがダウンしてもeth0(パブリック)がダウンしていなくてもアクセスできるようにしたいと思います。 memcached のmanページから、この-lオプションは1つのIPアドレスしか使用できないことを理解しています。ローカル接続にUNIXソケットを使用することを考えましたが、マニュアルページには -s リッスンするUnixソケットパス(ネットワークサポートを無効にします)。 私が知っている他の唯一の方法は、IPTablesを使用してeth0経由の接続をブロックすることです。ファイアウォールを利用しない他のソリューションはありますか?
9 memcached 

6
Squid透過プロキシのクライアントをセットアップする方法
サーバーの詳細 Squid Transparent Proxy Version: 3.3.8 OS: Ubuntu Server 14.04 Server IP: 192.168.1.3 Squid設定ファイル (grepを使用したコメントを除く) root@ubuntu:~# grep -v '^$\|^\s*\#' /etc/squid3/squid.conf acl SSL_ports port 443 acl Safe_ports port 80 # http acl Safe_ports port 21 # ftp acl Safe_ports port 443 # https acl Safe_ports port 70 # gopher acl Safe_ports …

3
再起動を試みる前にX秒待機するようにスーパーバイザ管理プログラムを構成するにはどうすればよいですか?
一度に1つのRabbitMqメッセージを処理するワーカープロセスがあります。現在、ワーカーが終了するとすぐに、supervisordが再起動しています(次のメッセージが処理されます)。 X秒間隔を設定して、supervisordがすぐに再起動しないようにしますが、別のワーカーを開始する前に一定の時間待機します。 これは可能ですか?どうやって?

3
curl:(35)SSL接続エラー
Twitter APIにcURL HTTPSリクエストを送信しようとすると、次のエラーが発生します。 [root@webscoming httpdocs]# curl -v https://api.twitter.com About to connect() to api.twitter.com port 443 (#0) Trying 199.16.156.199... connected Connected to api.twitter.com (199.16.156.199) port 443 (#0) Initializing NSS with certpath: sql:/etc/pki/nssdb CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none NSS error -5990 Closing connection #0 SSL connect error curl: (35) SSL connect error 別のサーバーからこれを試しましたが、期待どおりに動作します。このエラーの意味と解決方法を教えてください。 …
9 curl 

4
FTP 550:アクセスが拒否されました
新しいディレクトリを作成しようとすると、Filezillaで突然エラー550:Permission Deniedが発生します。 数日前に、sslとimapの設定に関してサーバーの一部の設定を変更しましたが、これがFTP設定に影響を与えたとは思いません... とにかく、長いグーグルの後、何も機能しないようです。主なアイデアは、ユーザーに権限がないことですが、興味深いのは、次のことができるということです。 ファイルを作成する ファイルを削除する ディレクトリを削除する ただし、ディレクトリは作成しません。メインディレクトリに「550 Permission denied」というエラーが表示され、サブディレクトリに「550 access_log:No such file or directory」というエラーが表示されます。 エラーがどこにあるか誰でも知っていますか?ありがとう
9 ssh  permissions  ftp 

1
ProxyPassリクエストにカスタムヘッダーを追加する
私は単純なapache vhostを持っています: <VirtualHost *:80> ServerName hello.local ProxyPass / http://localhost:8810/ ProxyPassReverse / http://localhost:8810/ </VirtualHost> hello.localへのすべてのリクエストはにプロキシされhttp://localhost:8810/ます。私がやりたいのはhttp://localhost:8810/、外部コマンドから返された値を含むヘッダーをhttp要求に追加することです。何かのようなもの Header set MyHeader ${/usr/bin/an_external_program} これを達成する方法はありますか?

2
OSX 10.9をActive Directory 2008にバインドできません
OSX 10.9を2008 r2 Active Directoryにバインドするのに苦労しています。同じマシンからWindowsを起動すると、ドメインに参加できます。OSXからドメインコントローラーを正常に見つけ、Active Directoryサービスレコードの整合性を確認できました(dig -t SRV _service._tcp.fqdn.example.comを使用して_ldap、_kerberos、_kpasswd、または_gcを確認します)が、ドメインにバインドできません。DCが1つだけの小規模ネットワークに参加しようとしています。 「認証サーバーに接続できませんでした。(5200)」というメッセージが表示されます。 これは、私が使おうとするあらゆる方法に当てはまります([ユーザーとグループ]設定ペインから参加、オープンディレクトリユーティリティからバインド、ターミナルからdsconfigadを使用)。 クライアントとDCの時間が同じなので、システム時間の問題ではないと思います。 ログファイルで注意すべき点についての問題または方向性に関する他の提案はありますか?

1
SoftEther経由ですべてのインターネットトラフィックをトンネルする方法
私の意図は、すべてのインターネットトラフィックを複数のNATの背後にあるリモートマシン経由でルーティングすることです。ISPのNATサーバーは私の管理下にありません。私は自分のNATサーバー(ローカルルーター)を制御しています。サーバーとクライアントの両方がWindows 7を実行しています(クライアント-x64およびサーバー-x86)。 この目的のために、SoftEther VPNサーバーをセットアップし、SoftEther VPNクライアント経由でそれに接続しました。ISPのNATに穴を開けることができないため、サーバーはVPN Azureを使用するように構成されています。これは、VPN Azureを理解しないため、クライアントで組み込みのIPSec / L2TP VPNを使用する可能性を排除します。 私が発見したいくつかのテストを実行することによって、しかし、これはこのセットアップで私のクライアントのインターネットトラフィックはまだローカルインターネットゲートウェイを経由します。クライアントのルートテーブルを調べたところ、SoftEtherはいくつかのリモートLAN IPに対してのみルートを設定しており、すべてのインターネットIPに対してルートを設定していないことがわかりました。私は手動で新しいルートを追加してこれを修正しようとしました: route add 0.0.0.0 mask 0.0.0.0 0.0.0.0 metric 2 if 22 ここで22-はSoftEtherクライアントによって作成されたインターフェースです。ただし、サーバーはリモートLAN宛てでないパケットをドロップするようです(これについてはよくわかりません)。 SoftEtherクライアントがすべてのIPのルートを自動的に作成し、SoftEtherサーバーがリモートゲートウェイ経由ですべてのインターネットパケットをルーティングするように構成するにはどうすればよいですか?または、そのようなタスクの代替ソリューションはありますか? PS私はNAT32を使用してみましたが、サーバー上のインターネット接続と何らかの形で混ざり合って、ローカルユーザーが使用できないようです。
9 route  vpn 

1
クロスケーブルはまだ必要ですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 6年前休業。 2台のPCを直接接続するためのクロスケーブルはまだ必要ですか?(NIC <-> NIC)? そうでない場合、なぜこれが過去に必要であり、いつこれが使用されたのですか?具体的には、2台のPCを直接接続するためにクロスオーバーケーブルが必要でなくなったのはいつですか。
9 cable 


1
IQN命名規則
IQNのフォーマット方法に関する多くの情報を見てきましたが、それらを構築する方法に関する多くの情報はありません。iSCSIに関しては初心者ですが、問題なく機能していますが、これを作成するだけなのか、または何らかの標準に従う必要があるのか​​と考えています。 例として、これは(wikipedia http://en.wikipedia.org/wiki/ISCSI#Addressing)がIQNをフォーマットする必要があると言っている方法です。 Naming String defined by Type Date Auth "example.com" naming authority +--++-----+ +---------+ +-----------------------------+ | || | | | | | iqn.1992-01.com.example:storage:diskarrays-sn-a8675309 iqn.1992-01.com.example iqn.1992-01.com.example:storage.tape1.sys1.xyz iqn.1992-01.com.example:storage.disk2.sys1.xyz[10] 私の質問は特に、なぜ日付ですか?それは何でもいいのですが、何か意味があるのでしょうか?ここに何か強制はありますか?「間違った」日付を入力すると私に噛み付くような点に遭遇することはありますか? ドメインの例は(dnsのように)逆になっていますか?starkindustries.priのようなドメイン名を持っている場合、私のiqnは次のようになります。 iqn.2006-05.pri.starkindustries:Linux:array0 これはDNSに依存しますか?(経験はそうではないと私に言っていますが、それは微妙な方法で失敗している可能性があります)そしてそれがDNSに依存している場合、ホスト名を使用するのですか、それともドメイン名だけですか?つまり、Jarvis.starkindustries.priまたは単にstarkindustries.pri? また、IPアドレスを使用している場合(DNSを使用していない場合はDNSがなくても機能するため、混乱を招く可能性があります)、DNSのように逆にしますか?つまり、10.1.2.0 iqn.2006-05.0.2.1.10:Linux:array0 また、(iSCSIターゲットの)ホストアドレスまたはネットワークアドレスを使用していますか。 「「example.com」の命名機関によって定義された文字列」の適用はありますか。つまり、何か便利なものを使用できない理由がありますか?わかりやすい名前の方がわかりやすいと思いますが、技術的な理由はありますか?また、私は自分が「ネーミング・オーソリティ」であるという大きな信念を持っています。 何よりも、私はこれらのIQNのためにたくさんのものを作り上げており、それらは機能しているようです。IQNSの実際の生成に関しては、少なくともいくつかのベストプラクティスを見つける場所を知りたいだけです。いつか私がストレージを担当する唯一の人ではなくなることを考えているだけなので、いくつかの標準を渡す必要があります。 IQNの新しいブロックが必要です。

2
サーバー側のコピーをサポートするファイル転送プロトコルはどれですか?
Linuxで利用可能なファイル転送プロトコルがサーバー側のコピーをサポートしている(そしてファイルを内部でダウンロードおよび再アップロードしない)と思います。私が持っている最も単純な使用例は、同じ共有上の1つのディレクトリから別のディレクトリに大きなファイル(VMなど)をコピーする場合です。 私はSamba 4.1.0がSMB2プロトコルでFSCTL_SRV_COPYCHUNKのサポートを最近実装したことを知っていますが、私の知る限り、これをサポートするクライアント側のツール/ファイルマネージャーはまだありません(リンク)。私もAFPを見てきましたが、AFP共有をマウントするためのLinuxツールは2つだけgvfs-afpでafpfs-ng、どちらもあまりにも優れています。afpfs-ngはメンテナンスされておらず、netatalk(segfaults)とうまく連携しませんが、gvfs-afpは、afpfs-ngと比較してスループットが非常に低いため、機能します。更新: NFSの次のバージョンもこれをサポートするようです。 サーバー側のコピーをサポートする他のプロトコルはありますか? 前もって感謝します!

3
物理CD / DVD Hyper-v 2012 R2からのゲストOSインストール
物理CD / DVDドライブを使用して、Hyper-V 2012 R2にゲストOSをインストールできるかどうかを探していました。ゲストOSをインストールする唯一の方法は、ISOをマウントすることです。hyper-vはホストの物理CD / DVDにアクセスできますか? Hyper-V Windows 8.1 proで同じ動作。 何か不足していますか、それともISOが唯一の方法ですか?

1
mp4静的ファイルに対する部分的なコンテンツ要求/範囲要求が機能するようにIIS 7を構成する方法。
IIS 7がmp4ファイルを提供するための部分的なリクエスト/範囲リクエストを処理してChromeがシークおよびループビデオを配置できるようにセットアップする方法についてサポートが必要です。 私が読んだことによると、IISはそのままでこれをサポートすることになっていますが、私のセットアップではこれを尊重していないようです。また、ASP.NETサイトをホストしている場合、範囲の要求を受け入れないことも読みました。ASP.NET機能は必要ありませんが、IISでこれを変更する方法もわかりません。


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.