サーバー管理者

システムおよびネットワーク管理者向けのQ&A

23
お気に入りのLinuxディストリビューションは何ですか?[閉まっている]
現在のところ、この質問はQ&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、議論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 11年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 サーバーとデスクトップでお気に入りのLinuxディストリビューションは何ですか?それはなぜですか?
9 linux 

13
DNSの変更にかかる時間
ドメインのAレコードのDNSを変更する(あるIPから別のIPに変更する)場合、人々が新しい情報に移動するまでにどれくらいの時間がかかりますか?それは単に<= TTLですか?以前は時間がかかっていたことがわかっていますが、2009年にはどれくらいの期間を期待できますか?

28
電子メールでzipファイルを送信する最も信頼できる方法は何ですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 8年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 クライアントにzipファイルを電子メールで送信して、企業のファイアウォールが添付ファイルを削除したことを確認することがよくあります。圧縮ファイルを電子メールで送信し、過度のファイアウォールによって添付ファイルが取り除かれることを回避する最も簡単な方法は何ですか? 明確にするために、ダウンロードのために自分のWebサーバーでファイルをホストできるので、ファイルの送信について心配していません。クライアントにファイルをメールで送信するための優れたシンプルなソリューションを探しています。 さらに明確にするために、私はオフラインのクライアントシステムで実行しているソフトウェアを制御し、データファイルの作成方法を制御しているので、可能な限り簡単にするためにデータをパッケージ化する方法のオプションを検討したいと思います。特にメール。クライアントが追加のソフトウェアをインストールしたり、クライアント側でサードパーティのWebサイトを使用したりすることを避けたいです。

1
ifconfigがUPを示し、IPリンクがDOWNを示す
Linuxシステムのインターフェースの状態を見ています。ifconfigコマンドを使用すると、リンクがアップしていることが表示されます。 master $ ifconfig docker0 docker0 Link encap:Ethernet HWaddr 02:42:b9:25:be:2d inet addr:172.18.0.1 Bcast:0.0.0.0 Mask:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) しかし、ip linkコマンドを実行すると、ダウンしています。 master $ ip link show docker0 3: …

2
サーバーのディスククラスターのRAIDを超えて調査すると、ダイナミックディスクプールは同等ですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 昨年休業。 ハイパーコンバージドシステムの開発により、分散ストレージを処理するためのRAID以外のテクノロジー(たとえば、ceph、VSAN、nutanixのような分散ストレージ)を見ることができます。 しかし、大きなディスクがたくさんある単一のサーバーで使用できるオブジェクトストレージから派生したオープンソーステクノロジーはありますか?たとえば、12To sataディスクの数十は、データの安全性を保証しますが、ディスク。したがって、ダイナミックディスクプールは、クラスター化されていないRAIDの一種であり、iscsiのようなブロックレベル、またはzfsやbrtrfsのようなファイルシステムレベルで使用できます。 SYNOLOGYベイ(NFS、iscsiターゲット、SMB)に似た機能を提供したいのですが、ブロックストレージ用のRAIDはありません。 ご指摘ありがとうございます。

3
切り離されたEBSボリュームは毎月充電し続ける必要がありますか?
まず、AWSやDevOps / adminに慣れていないのですが、学びたいと思っています。そこで、数か月前に何かをテストするために、EC2インスタンスをセットアップし、数か月前にEBSボリューム(15 Gb)を接続しました。 次に、インスタンスをアクティブのままにしたため、月額料金が満杯(EC2 + EBS)であることに気付き、ボリュームを切り離してインスタンスを停止しましたが、EC2インスタンスはもう充電されませんでした。 しかし、今では、EBSボリュームは、切り離された場合でも、依然として1.5 USD /月を請求していることがわかります。請求を回避するためにボリュームを削除する必要がありますか?またはボリュームに何らかの停止または無効化がありますか?

1
AWS CloudFormationスタックインスタンスにSSH接続できません
私は現在、スケーラブルなロードバランサーを設定していますが、これは主にこのテンプレートに従っています: https://github.com/satterly/AWSCloudFormation-samples/blob/master/LAMP_Multi_AZ.template AWS::AutoScaling::AutoScalingGroup.CreationPolicy.ResourceSignal.Countキーを調整した後0(基本的に、成功シグナルを受信せずにスタックを読み込むことができます)、スタックを読み込むことができ、利用可能なすべてのリソースを確認できます。 作成中のキーのパブリックDNSを確認できますが、インスタンスにSSH接続できません。 私はインスタンスルール内のすべてのユーザーに対してSSHアクセスを開いていますが、これはAWSコンソールで確認できます。 AWSの公式ドキュメント内で推奨されているように、VPCのルートも構成しました:https : //aws.amazon.com/premiumsupport/knowledge-center/ec2-linux-ssh-troubleshooting/ インスタンスが存在することは確認できますが、自分のアクセスをどこかに制限しているようです。ただし、AWS EC2コンソール内では、設定はインスタンスにSSH接続できる場合と同じように見えます。 VPC、サブネット、セキュリティグループなどを含むすべての設定を表示できる場所で使用しているJSONテンプレートを次に示します。https://gist.github.com/dambrogia/e4cd93a64ae6f3a79d4a58d466f144f8 次のコマンドからタイムアウトエラーが表示されます:(私のid_rsaキーはec2内で有効です) ssh -i ~/.ssh/id_rsa ec2-user@<ec2_instance> インスタンスにSSH接続するにはどうすればよいですか?助けてくれてありがとう!

1
セキュリティグループ(AWS)とiptablesの違い
サーバーをセットアップして、ファイアウォールを2回設定する必要があるかどうか疑問に思っています。たとえば、80、443、22のポートが開いているセキュリティグループがあるとします。 次に、UFW(iptablesのフロントエンド)を使用してサーバーをセットアップします。私のポートをここで再度設定する必要がありますか、それともセキュリティグループなしまたはその両方でiptablesに設定するだけですか? 違いや利点/欠点はありますか?

1
certbotとDNSチャレンジを使用してドメインを更新する
スタンドアロンの方法を使用して、いくつかのドメインのSSL証明書をいくつか作成しました。サーバー統合なしで、証明書のみに関心があります。 彼らは今更新のためです。だから、私は走った: certbot -d example.com --manual --preferred-challenges dns certonly そして、各ドメインの指示に従いました(各ドメインに必要なDNSエントリを追加します)。このようにして、サーバーを停止して新しい証明書を取得する必要がなくなりました。 私の(漠然とした)すべてについての理解は、DNSチャレンジを使用して証明書を自動的に更新する現在の方法がないことです。または、「手動」の方法で証明書を自動的に更新できないのでしょうか。 とにかく、私はこのスクリプトを書きました。 #!/bin/bash for i in renewal/*;do n=${i:8:-5}; echo $n; # echo "\n" | certbot --text --agree-tos -d $n --manual --preferred-challenges dns --expand --renew-by-default --manual-public-ip-logging-ok certonly; done この時点で、renewalディレクトリ内のすべてのドメインには以下が含まれています。 オーセンティケーター=手動 そして: pref_challs = dns-01 質問: さて...「certbot renew」を実行すると、スクリプトを使用せずにすべて自動的に更新されますか? DNSチャレンジを使用して新しい証明書を実際に作成するにはどうすればよいですか?

1
OpenDKIMがメールに署名しない
そのため、OpenDKIMでメッセージに署名するのに問題がありますが、何が原因であるかについて壁にぶつかっています。 Debian Jessieで、PostfixとOpenDKIMを使用。 私/etc/opendkim.conf: Syslog yes SyslogSuccess Yes LogWhy yes UMask 002 Canonicalization relaxed/simple Mode sv SubDomains no #ADSPAction continue AutoRestart Yes AutoRestartRate 10/1h Background yes DNSTimeout 5 SignatureAlgorithm rsa-sha256 UserID opendkim:opendkim Socket inet:12301@localhost KeyTable refile:/etc/opendkim/KeyTable SigningTable refile:/etc/opendkim/SigningTable ExternalIgnoreList refile:/etc/opendkim/TrustedHosts InternalHosts refile:/etc/opendkim/TrustedHosts 私/etc/opendkim/KeyTable: default._domainkey.example.com example.com:default:/etc/opendkim/keys/example.com/default.private 私/etc/opendkim/SigningTable: example.com default._domainkey.example.com SigningTableで次のバリエーションを試しましたが、SMTPが無効になりました。 *@example.com …

1
ZFSは相互依存性とクローンを含むスナップショットを削除します
以下は、ZFSボリュームとスナップショットのリストと、それぞれのオリジンとクローンです。 すべてのスナップショットを削除したいが、すべてのファイルシステムは保持したい。これどうやってするの? 私はzfs promote、ファイルシステムの多くの異なる組み合わせについて、各ファイルシステムを削除することを試みることを試みました。これにより、スナップショットが「ライブ」になる場所が変わります。たとえば、zfs promote tank/containers/sixスナップショットをFからtank/containers/three@Fに移動しますtank/containers/six@F。ファイルシステムのライブデータは変更されていませんが(これは私が望んでいることです!)、スナップショットを削除することはできません(これは私が望んでいるものではありません)。 典型的なzfs destroy試みでは、依存クローンがあり、そのうちのいくつか(スナップショット)は破棄したいが、他のもの(ファイルシステム)は破棄したくないことがわかりました。 例えば。 # zfs destroy tank/containers/six@A cannot destroy 'tank/containers/six@A': snapshot has dependent clones use '-R' to destroy the following datasets: tank/containers/five tank/containers/two@B tank/containers/two 上記の例では、tank/containers/fiveまたはを破棄したくありませんtank/containers/twoが、zfs promote5と2の場合、スナップショットを破棄することはできません。解決策はありますか? # zfs list -t all -o name,origin,clones NAME ORIGIN CLONES tank - - tank/containers - - tank/containers/five tank/containers/two@B …
9 zfs 

2
Azureバックアップとスナップショット
私は紺碧の初心者で、Azureをよりよく理解しようとしています。私の質問は、AzureでのLinux VMのバックアップに固有です。それをよく理解するのを手伝ってください。 Azureバックアップがスナップショットを取得し、それをコンテナーにアップロードすることを読みました。「Azureバックアップ」を使用してVMをバックアップする方法が、「az vm」CLIコマンドを使用してOSディスクのスナップショットとazure VMのデータディスクを取得する方法とどのように異なるのかを理解しようとしていますか? ここの保管庫は正確には何ですか?内部的にBLOBコンテナーのストレージアカウントとして実装されていますか、それともAWSのGlacierに似ていますか? コストの面で優れているのは、紺碧のバックアップとosdiskスナップショットのどちらですか。 両方のオプションが類似している場合、つまりAzureバックアップを使用するか、OSディスク/データディスクのスナップショットを取得する場合。どちらか一方を使用する利点はありますか? OSディスクのスナップショットはAzureで取得されたもので、本質的にグローバルですか、それとも何らかの方法でリージョンに関連付けられていますか?リージョンがダウンした場合、それらは使用できなくなりますか? Azureポータル、スナップショットで、「スナップショットの状態」とは何ですか?スナップショットディスクからVMをスピンオフした後でも、スナップショットの状態が「未接続」になるのはなぜですか?

1
PHP7 opcacheを強制的に完全にクリアする方法は?
私のウェブサーバーのopcacheは、私が設定した制限に達し続けていますが、 PHPコードはそれほど多くなく、十分なスペースがあるはずです。 これは、opcacheをクリアした場合でも、すぐに使用可能なスペースの2/3を超えていると表示されるという事実によってさらに悪化します。 今からの例: opcache_reset()を実行する直前のphpinfoスニペット: Used memory 122958472 Free memory 5552 opcache_reset()を実行した直後のphpinfoスニペット: Used memory 90691312 Free memory 43526416 PHP7では、opcacheが(どうやら)ディスクにバックアップされているので、何かが自動リロードされているのでしょうか?しかし、それはopcacheをリセットする目的に反しているようで、私はディスク上のどこにopcacheがバックアップされているかわからないので、確認できません。 私はnginx、正確にはバージョン7.0.15-0ubuntu0.16.04.4でPHP-FPMを実行しています。
9 php  php-fpm  php7  opcache 

3
「NSA」パッチがインストールされた後に接続を試みているリモートデスクトップの「内部エラー」
最新のWindowsアップデート(NSA脆弱性パッチ火曜日)をインストールしたばかりで、リモートデスクトップに接続できません。 サーバーはリモートでホストされています。物理的にアクセスできません。サーバー2012 R1。 幸い、すべてのWebサイトは再起動後に正常に動作しています。 少し怖いので、2回目の再起動はまだ試していません。 接続しようとすると、次のメッセージがすぐに表示されます。 「リモートデスクトップ接続:内部エラーが発生しました」 複数のクライアントから試してみました。それらはすべて失敗します-さらに、0x00000904エラーが発生するiOSアプリを含みます。 実行telnet servername 3389すると接続が開始されるため、ポートが開いていることがわかります。 Win 10(パッチされていない)マシンから他のサーバーに問題なく接続できます。 2つ目のラップトップ(Win 10 Creators Edition)からも接続できません。 イベントビューアで有用なものが見つかりません。 私は何も役に立たないことを示さないwiresharkを試してみました。 私が診断しなければならない最高のものは、ASPXページをアップロードして実行する機能です。 最近の「NSAエディション」パッチのまとめにはRDPの修正がいくつかあったことは理解していますが、週に突然問題が発生した人は他にいません。 ホスティング会社に連絡する前に、何が問題なのかを知りたいので、ここに投稿します。 更新: 私はまだ物理サーバーにアクセスできませんが、サーバー自体でホストされているWindows 7 VMがあることを思い出しました。10.0.0.1ローカルIPに接続することで、これにアクセスしてサーバー証明書スナップインを開くことができました。 これは、RDP証明書が実際に期限切れであることを示しています-そのように提案を接続してもエラーは発生しません。私は確かに毎日接続しており、2か月前に有効期限が切れたため、リモートデスクトップストアにある他の証明書はなんらかのセキュリティ更新プログラムによって削除され、更新されなかったと思います。 そこで、ここで別の証明書をインストールする方法を見つけようとしています。 アップデート2 最後にこれを(管理イベント)の下のイベントログで見つけました(VM経由でリモート接続することにより): 「ターミナルサーバーは、SSL接続でのターミナルサーバー認証に使用する新しい自己署名証明書の作成に失敗しました。関連するステータスコードはオブジェクトが既に存在しました。」 少し異なるエラーですが、これは役に立ちそうです。今夜は再起動できないので、明日もう一度確認する必要があります。 https://blogs.technet.microsoft.com/the_9z_by_chris_davis/2014/02/20/event-id-1057-the-terminal-server-has-failed-to-create-a-new-self-signed-certificate/

3
記憶域スペース非常に低い使用可能なスペース
S2Dをテストしています。2つのVMからクラスターを作成し、PowerShellを呼び出しました Enable-ClusterStorageSpacesDirect -SkipEligibilityChecks -Confirm -CacheState Disabled ストレージのリスト Type Node Size Used Percent ---- ---- ---- ---- ------- HDD 1 21GB 0 0% HDD 1 129GB 0 0% HDD 1 107GB 0 0% HDD 1 140GB 0 0% HDD 1 118GB 0 0% HDD 1 11GB 0 0% HDD 2 21GB …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.