サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
squeezeでwheezyからパッケージをインストールする最良の方法
Debian Squeezeサーバーでdoxygenを使用したいのですが、必要なバグ修正が含まれているため、Debian Wheezyのバージョンが必要です。 バックポートにはありません-packages.debian.org/search?suite=squeeze-backports&searchon=names&keywords=doxygenを確認してください(私はここに新しく、適切なリンクとしてこれが許可されていません!) 私はsources.listファイルにWheezyを追加して実行しようとしましたapt-get install -t wheezy doxygenが、wheezyからのインストールが多すぎます。これは本番サーバーなので、このリスクを負うことはできません。 ソースからコンパイルすると、上記の残りすべてもソースからコンパイルしたいと思うでしょうか? 他の解決策はありますか?(例:仮想化またはchrootしますか?)など
9 debian  apt  patch 

3
Windows 2008 R2の再起動後にiSCSIドライブがマウントされない
Win2008R2を搭載したサーバーとSynology NASを持っています。Nasには、Windowsサーバーにマウントされている6つのiSCSIパーティションがあります。WindowsサーバーはHyper-Vで仮想化されています。 クライアントマシンを再起動した後、6つのパーティションのうち2つが再マウントされず、毎回手動で再マウントする必要があります... それぞれに同様の構成があり、CHAP認証で構成されています。6つすべてがお気に入りリストに表示されます。 イベントログには、iSCSIに関するエラーは表示されません。他の4つのパーティションは問題なくマウントされます。 さらにデバッグするための提案はありますか? 編集:synologyと話した後、彼らはchap認証を無効にし、マスキングと呼ばれるものを有効にすることを提案しました。これは基本的に、各LUNに接続できるノードをブロックするフィルターです。これは問題に大きな違いをもたらしました。それは停電などの後でも時々発生しますが、再起動後は、lunが再マウントされることはほぼ確実です。認証のネゴシエーションにおけるWindows iscsiイニシエーターとターゲット間の問題だと思います。

3
NGINXがPHPファイルを実行しない
これに対する答えは見つかりませんでした。PHP5 + NGINX + PHP-FPMをインストールし、phpファイルを実行できない場合、「おっと!このリンクは壊れているようです」と表示されます。CHROMEのエラー。貴重なエラーログレポートはありません。ルートにindex.phpがあり、カスタムphpinfo.phpファイルを作成しようとしましたが、どちらも機能しませんでした。 HTMLファイルを読み込むことはできますが、PHPはできません。 これがNGINXの私のローカルサイト設定です: server { listen 80; server_name im; access_log /var/www/website/access.log; error_log /var/www/website/error.log; location / { root /var/www/website; index index.html index.htm index.php; } location ~ \.php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /var/www/website$fastcgi_script_name; include /etc/nginx/fastcgi_params; } } すべてのディレクトリの所有権をwww-data:www-dataに変更し、phpファイルに777を作成しました。nginx、FPM、何も再起動しませんでした。 助けて?:(
9 php  nginx 

4
Apache 2.2サーバーが応答するまでの待機時間が長い(Gentoo LAMP)
最近、クライアントのウェブサイトを(concrete5 CMSを使用して)Gentoo、Apache 2.2、PHP5、MySQL 5を実行するVPSに移動しました。Apacheの応答時間がかなり悪いことに気付きました(古いサーバーでも同じでした) 、場合によっては最大8〜9秒、多くの場合300ミリ秒から3秒(300ミリ秒までは気にしない)。サーバーは約30ミリ秒の(私の場所からの)pingを送信するため、これはネットワーク遅延ではないことがわかります。 時間の例を次に示します(最初の待機の後で急になっていることがわかります)。 私はAPC(それが正しく機能しているかどうかはわかりませんが ...)とSuExecを実行しています。Apacheモジュールは次のとおりです。 core_module (static) authn_file_module (static) authn_default_module (static) authz_host_module (static) authz_groupfile_module (static) authz_user_module (static) authz_default_module (static) auth_basic_module (static) include_module (static) filter_module (static) deflate_module (static) log_config_module (static) env_module (static) expires_module (static) headers_module (static) setenvif_module (static) version_module (static) ssl_module (static) mpm_prefork_module (static) http_module (static) mime_module (static) …

2
キックスタートファイルの何がデスクトップGUIをデフォルト(ランレベル5)に設定しますか?
Scientific Linux 6を使用しており、次のデスクトップ関連のパッケージグループをインストールしています。 @basic-desktop @desktop-platform @general-desktop @x11 ただし、インストール後/etc/inittabもマルチユーザーコンソールランレベル(id:2:initdefault:)に設定します。 ここで何が欠けていますか?

2
Amazon EC2インスタンスでメモリを何が使用していますか?
現在、インスタンスごとに22 GBのRAMがあると記載されているAmazon EC2で単一のGPUクラスターコンピュートノードを実行しています。topインスタンスには確かに22 GBのRAMがあることを確認していますが、アイドルシステムでは、5〜6 GBのRAMが一貫して使用されているようです。また、この使用が原因であるプロセスを特定することtopもps auxできません。 5-6 GBはOSには大きすぎるように見えますが、おそらく私は間違っています。これは、Amazonでの仮想化によるオーバーヘッドになる可能性がありますか?これを追跡する方法に関する他のアイデアや提案はありますか?

3
TCPホストからのトラフィックを簡単に「編集」する方法(Linux)
接続を処理するプロセスがストリームを取得する前に、既知のtcp host:portからの着信トラフィックに小さな変更を加える必要があります。 たとえば、192.168.1.88をWebサーバーを実行するリモートホストとします。 ローカルホストのプロセスが192.168.1.88:80(例:ブラウザー)からデータを受信すると、データはまず次のようにに置き換えtext-Aられて変更されtext-Bます。 127.0.0.1:...は192.168.1.88:80に接続します 127.0.0.1:...は192.168.1.88:80に送信します。 GET / 192.168.1.88:80は127.0.0.1に送信します:...: HTTP/1.0 200 OK Content-Type: text/plain Some text-A, some other text そのデータはシステムによっていくらか傍受され、出力が次のようなプログラムに渡されます。 HTTP/1.0 200 OK Content-Type: text/plain Some text-B, some other text システムは、変更されたデータを、192.168.1.88:80からのように、127.0.0.1:...を処理するプロセスに渡します。 ストリームベースの方法でこの変更を行う(sedたとえば、使用する)と仮定すると、着信tcpストリームを前処理する最も簡単な方法は何ですか? これにはが含まれると思いますが、iptables私はあまり得意ではありません。 アプリケーションは元のホストを処理するように感じる必要があるため、プロキシの設定はおそらく解決策ではないことに注意してください。

1
rkhunterエラーメッセージ、修正方法?
rkhunterから次のエラーが表示されます。最近、サーバーをlennyからsqueezeにアップグレードしましたが、これにより問題が発生した可能性があります。これを修正したり、エラーメッセージを非表示にするにはどうすればよいですか? Warning: The modules file '/proc/modules' is missing. Warning: Suspicious file types found in /dev: /dev/shm/network/ifstate: ASCII text Warning: Hidden directory found: /dev/.udev 2通目のメールも届きPlease inspect this machine, because it may be infected.ません。これらのエラーの原因を見つけるために、誰かが私を正しい方向に向けることができますか?

3
nginx:(アプリケーションではなく)nginxからランダムな500を追跡する方法 潜在的に負荷と関係がありますか?
最近、なんとかログに記録されなかったnginx自体から約500がありました(スクリーンショットがありますが、ログには何もありません)。通常はエラーが表示されるため、それ自体は奇妙です。とにかく、接続プールのサイズのように、最大​​化すると500になるようなものがあるのでしょうか。最近のトラフィックの急増と潜在的に相関していますが、決定的なものではありません。 誰もがそのような問題に取り組み始める方法について何か考えがありますか?

2
停電時のext4 / Linuxドライブでのデータ破損を防止
私は、OSとしてlinuxを組み込んだAmerican Megatrends biosを実行する組み込みボードをいくつか持っています。私が抱えている問題は、産業用フラッシュIDEが電力損失で破損することです。私はそれらをext4としてフォーマットしています。これが発生するときはいつでも、通常fsckでフラッシュを修正できますが、私たちの展開ではこれは不可能です。書き込みキャッシュを無効にすると効果があると聞きましたが、その方法がわかりません。また、他に何かすべきことはありますか? より詳しい情報 ドライブは4GB IDEフラッシュモジュールです。ext4のパーティションが1つあります。OSはそのパーティションにインストールされ、grubは私のブートローダーです。 fdisk -lは/ dev / sdaをフラッシュモジュールとして表示し、/ dev / sda1をプライマリパーティションとして表示します。 停電後は、通常、起動初期化スクリプトで完全に行うことはできません。 ドライブを別のPCにマウントするとき、fsck / dev / sda1を実行します。常に次のようなメッセージが表示されます "zero datetime on node 1553 ... fix (y)?" 私はそれらを修正し、次の停電まで正常に起動します。 明日オフィスに着いたら、fdisk -lの実際の出力を投稿します。 これが、システムがどのように機能するかについて私が知っているすべてです。私はシステムの専門家ではありません。職務内容の範囲外の窮地に陥る傾向のあるソフトウェアエンジニアです。ドライブのフォーマット、ブートローダーのインストール、ソフトウェアの作成、オペレーティングシステムのハッキングの方法を知っています。 これはdumpe2fsからの出力です #sudo dumpe2fs /dev/sda1 dumpe2fs 1.41.12 (17-May-2010) Filesystem volume name: VideoServer Last mounted on: / Filesystem UUID: 9cba62b0-8038-4913-be30-8eb211b23d78 …

4
TARファイルをISOファイルに変換する方法
Linux TARファイルがあり、直接ISOに変換したい。最初にファイルの内容を抽出する必要なく、これを行う方法はありますか? これは次の質問に似ています。ただし、これはプレーンまたはストレートアップのtarファイルに焦点が当てられており、bzipまたはbzip圧縮されたtarとは関係ありません。 これもスクリプト内で使用するつもりであり、最初に抽出したくない理由です。

3
Jenkins CI-メモリを割り当てることができません
ローカルコンピューターのubuntu 10.4(vmware fusionを使用)でjenkins-ciを正常にテストしました。これをhosteuropeの仮想サーバーにインストールして使用したいと思います。基本的なインストールは問題ありませんでしたが、ビルドプロジェクトで問題が発生しました。 リポジトリから水銀アップデートをプルした後、antが呼び出され、ビルドプロジェクトで次のエラーをスローします。 "ビルドファイル:/var/lib/jenkins/workspace/concrete5-seed-clean/build.xml [プロパティ] java.io.IOException:プログラムを実行できません" / usr / bin / env ":java.io.IOException:error = 12、メモリを割り当てることができません」 hosteurope(http://faq.hosteurope.de/index.php?cpid=13918)の仮想サーバーのヒープサイズに既知の問題があるため、手動でヒープサイズを設定しようとしました。 # for ant export ANT_OPTS="-Xms512m -Xmx512m" # jenkins # edited /etc/default/jenkins, added line JAVA_ARGS="-Xms512m -Xmx512m" # restarted jenkins via /etc/init.d/jenkins restart これをantに設定すると、コマンド「ant -diagnostics」が実行されてエラーは発生しませんが、プロジェクトをビルドしようとするとエラーが発生します。 サーバーの詳細:-http: //www.hosteurope.de/produkt/Virtual-Server-Linux-L Ubuntu 10.4 LTS RAM:1GB /ダイナミック2GB 私の質問:-Jenkinsには1GBで十分ですか、それともサーバーをアップグレードする必要がありますか?-このエラーはantまたはjenkinsが原因ですか? 更新:Antオプション-Xmx128m -Xms128mで実行しましたが、エラーが再度発生することがあります。(これは私を驚かせます、私は今ではそれを再現できないので:/) …
9 java  jenkins 

2
MySQLのメモリ使用量を最適化するにはどうすればよいですか?
私のセットアップ(例) 次の仕様のAmazon High CPUエクストララージEC2インスタンスでLinuxを実行しています。 7 GBのメモリ 20 EC2コンピューティングユニット(それぞれ2.5 EC2コンピューティングユニットを備えた8つの仮想コア) 1690 GBのローカルインスタンスストレージ 64ビットプラットフォーム MyISAMストレージエンジンで2つの大きなMySQLデータベースを実行しています。1つは2 GB、もう1つは500 MBです。MySQLがクエリ速度を最大化するためにできる限り多くのRAMを使用していることを確認したいのですが。私のようなMySQLのメモリ設定オプションの束があります知っているkey_buffer_sizeとMyISAM_sort_buffer_size,私は、これらの最適化に慣れていないんです。 質問 MySQLがLinuxシステムで現在使用しているメモリを確認するにはどうすればよいですか? MySQLのメモリ使用量を最大化/最適化するにはどうすればよいですか? クエリとスキーマが最適化されている場合、他にどのような変更を検討する必要がありますか?
9 mysql  linux  memory 

5
このSQL Serverライセンスは合法ですか?
私の妻が最近彼女の新しい中小企業のドメイン固有のオフィス管理ソフトウェアを購入したソフトウェアベンダーから得た情報は、私を忍び寄らせています。私の印象では、これは比較的少量のソフトウェアですが、彼女の分野でよく知られている大企業によって開発および販売されています。このソフトウェアはデータベースとしてMS SQL Serverを使用しており、購入契約にはSQL Server 2008 Standardの1サーバーライセンスと5 CALが含まれています。 奇妙なことに最初に私を驚かせたのは、彼らのインストーラーアプリがサーバーのSAパスワードをはるかに安全でないものに変更する自由を奪っていることを発見したときでした。これについて尋ねたところ、マイクロソフトとの特定のリセラー契約により、特別にライセンスされたインスタンスをアプリケーションでのみ使用できるようにSAパスワードを変更する必要があると言われました。私はWindowsログインを介してdboアクセスをまだ持っているので、実際にはこれは問題ではありませんが、説明は非常に疑わしいように思えました。 次に、今日まで、MSDNメディアからインストールしたインスタンスで実行していて、MSDNプロダクトキーの1つを使用して一時的にアクティブ化していたため、公式のSQL Serverプロダクトキーをいつ受け取ることができるかについてもう一度尋ねました(ビジネスは、まだ開いていないので、この時点で有効なプロダクトキーがあるはずです。彼らの担当者が私たちのサーバーにリモートアクセスして、「埋め込みキー」を持つメディアを使用してSQL Serverを再インストールできるようにする必要があると言われました。MSSQLは事前設定済みのメディアでも提供されますか?提供されている場合、事前設定済みのメディアを再販することはできますか?彼はリモートで自分自身をインストールすることを主張しているので、私が想定しているのは、独自のプロダクトキーが埋め込まれたこの事前に準備されたメディアのコピーで終わることはないということです。 私は偏執狂ですか、またはこの音は怪しいですか?私は.NET開発者であり、MSライセンスの経験はほとんどありませんが、複雑になる可能性があるので、これはすべて正常であると思います。この時点で私は、有効なプロダクトキーとサーバー/ CAL証明書を送ってくれるか、購入のMSSQL部分について払い戻しをするかを主張することに傾倒しています。 更新日2011年3月21日:ベンダーは現在、以下の@Sergeyが言及するISVロイヤルティプログラムに参加すると主張しています。しかし、彼らはそのプログラムの要件に準拠しているようには見えません。具体的には、SQL Server EULAは契約に組み込まれていません。SQLは、不可欠な部分ではなく、ソリューションのオプションの追加コストコンポーネントとしてSQLを提供します。私はMSFTライセンスに問い合わせ、さらに調査するためにはベンダーのISV契約番号が必要だと言われました。ベンダーのITディレクターは、ISV契約のコピーを私に送信することに同意しましたが、私はそれ(またはその件についての対応)をまだ確認していません。 最後に、約2週間前にBSAにレポートを提出しました。今後数週間のうちに調査を開始するかどうかを確認する必要がありますが、私が話した担当者は楽観的ではないようです。通常、エンドユーザーの従業員が報告しているケースが優先されると述べました雇用者。 とにかく、MSFTライセンス担当者は、妻の事業がISVからの請求書に必要な数のSQLライセンスが購入に含まれていることを示す請求書がある限り、ベンダーがコンプライアンスに準拠しているかどうかに関係なく、カバーされていると教えてくれました。

3
Debian:依存関係をアップグレードせずに「apt-get install」を使用する方法?
すでにパッケージBがあり、新しいパッケージAをインストールしたい。インストールでBを変更したいが、そうしたくない。 パッケージAをインストールする必要があります。 パッケージBへの依存関係があり、(> 2.0)である必要があります。 バージョン2.1のシステムにBをすでにインストールしているので、現在のセットアップはすでに依存関係を満たしています。 しかし、DebianリポジトリにはBパッケージの新しいバージョン(2.2)があり、他のものと競合するため、私はそれを望まない。 したがって、Aパッケージをインストールすると、aptもBをアップグレードしようとします。 パッケージを編集せずに、依存関係のアップグレードを無効にしたり、依存関係のバージョンを明示したりするにはどうすればよいですか? apt-getで一部の依存関係を無視するにはどうすればよいですか?を読みました。、しかしそれは私を助けません。そこでの質問では、依存関係(B)はリポジトリマネージャによってまったく処理されるべきではありません。私の場合、リポジトリマネージャーは既に依存関係を処理しており、この特定のアクションではなく、引き続き依存関係を処理する必要があります。 レビューアを再開する:そもそも答えであったはずのvictorgpのコメントをご覧ください。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.