サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ESXi-デフォルトコンソールとしてのシリアルコンソール
ESXi 5としてIPMIを備えたヘッドレスSupermicroサーバーがありますが、IPMI VGAコンソールリダイレクト経由でアクセスする代わりに、シリアルコンソールをESXiのデフォルトコンソールとして使用したいと思います。IPMIでJavaに問題があり、テキストUIも好みます:) vSphere Clientを使用してダイレクトコンソールをシリアルポートにリダイレクトする手順を実行しようとしましたが、成功しませんでした。 私の目標は: ESXiのシリアルポートブートローダーで確認(これはsyslinuxです) シリアルポート経由での起動を参照してください(ロギングではなく、インターナティブなもの) シリアルポート経由でログインするために使用できるシェルを参照してください サーバーにシリアルコンソールがあります。次のステップは、IPMI SOLのセットアップです。 誰でもそれを行う方法を共有できますか?上記の手順ではうまくいきませんでした。 ESXiがシリアルポートをコンソールとして起動していたことを確認するにはどうすればよいですか?

1
RPM仕様以前のRPMが削除されるようにパッケージで指定する方法
質問: RPMがインストール前に以前のRPMを削除するように、foo.specファイルには何を入れますか? 説明: 同じソースを使用し、同じサービスを提供するいくつかのパッケージのrpmを作成するスペックファイルを作成しました。たとえば、それぞれが同じ「機能」を提供する これは、私の.specファイルが次のようになっている基本的な要素の例です。 %define version 1234 %define name foo %define release 1 %define pkgname %{name}-%{version}-%{release} Name: %{name} Version: %{version} Release: %{release} Provides: %{name} %package one Summary: Summary for foo-one Group: %{group} Obsoletes: %{name} <= %{version} Provides: %{name} = %{version} %description one Blah blah blah %package two Summary: Summary …
9 rpm  specfile 

1
パペットでsystemdのインスタンス化されたサービスを有効にする方法は?
次のパペットサービスがあります。 service { "getty@ttyUSB0.service": provider => systemd, ensure => running, enable => true, } この構成をクライアントに適用しようとすると、次のエラーがスローされます。 エラー:/Stage[main]//Node[puppetclient]/Service[getty@ttyUSB0.service]/enable:falseからtrueに変更できませんでした:getty@ttyUSB0.serviceを有効にできませんでした: サービスは正常に実行されており、getty.target.wantsにシンボリックリンクを追加することで、システムの起動時にサービスが開始されていることを確認できます。 ln -s /lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@ttyUSB0.service ソースについては、先に進んでサービス定義から「enable => true」を削除し、手動でシンボリックリンクをパペット構成に含めることができますが、パペットがこれを処理するべきではありませんか?私はひどく悪いことをしていますか?
9 puppet 

2
接続が不足しているNginxとPHP-FPM
私はこのようなエラーに遭遇し続けます、 [02-Jun-2012 01:52:04] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 19 idle, and 49 total children [02-Jun-2012 01:52:05] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 16 children, there are 19 idle, and …
9 nginx  php-fpm 


2
WakeOnLANフレームがブロードキャストに送信される理由
最も単純な形式でLANフレームでウェイクがイーサネットブロードキャストアドレス(FF:FF:FF:FF:FF:FF)に設計され、電源がオンになるマシンのアドレスに設計されない理由を理解しようとしています。 MACアドレスをポートに割り当てるネットワークスイッチの内部テーブルと関係がありますか?

1
CPUとIOに異なるプロセス優先度を設定する使用例?
Linuxプロセスは、異なるCPUとIOの優先順位(niceとionice)を持つことができます。 CPUとIOの優先度を変える必要があるのはなぜですか? それらを異なるものにするための実際の使用法はありますか? 異なるCPUとIOの優先順位が必要な実世界のユースケースは何ですか?通常のCPU優先度よりも高いが、通常のIO優先度よりも低い、ま​​たはその逆。
9 linux  nice  ionice 

2
DNS設定が原因で一部の送信者からメールを受信しない
私のグーグルアプリドメインの奇妙な振る舞いに気づきました。ほとんどのメールは予想どおりに届きますが、ある期間、特定の送信者からのメールが届かないという結論に達しました。メールが届かない送信者を1人特定した後、私にメールを送信して「配信失敗」の応答を通常のGmailに転送するように依頼しました。 配信失敗の応答には、次のスニペットが含まれていました。 -----セッションのトランスクリプトが続きます----- <myusername@GHS.L.GOOGLE.COM>...遅延:ghs.l.google.comで接続がタイムアウトしました。 これは、Google Appsヘルプフォーラムのこのページに私を導いたクイック検索を行うことによって問題を特定するのに役立ちました。実際、ドメインのDNSレコードを確認したところ、@ghs.google.comに設定されていました。(CNAME)、それをすべきではありません。これを@ 74.125.93.121 (A)*に変更すると、問題は解決しました。 メールが届かない場合は、CNAMEルックアップによってドメイン名が正規の名前に置き換えられたため、myusername@ghs.l.google.comではなくにメールが送信されたと理解していますmyusername@mydomain.com。しかし、それが送信者の大多数で機能したのはなぜですか?メールが届かない送信者は、別の種類のメールプロトコル、奇妙なDNS設定を使用していましたか、それとも何ですか? グーグルで問題を調査することで私が見ることができたものから、これは広範囲にわたる問題であるように思われます(battle.netからの電子メールが届かないという多くの人々は、1つの人気のある例です)、人々はそうではないようです問題は送信者側ではなく、独自のDNS設定にあることに注意してください。 これはどのように説明できますか? * ここで読んだことから、このIPを使用しましたが、どのIPでもうまくいくと思います。誰でもこれを確認できますか?単に@レコードを削除しても問題は解決せず、変更する必要があったことに注意してください。

2
Amazon RDS:IOリクエストとは何ですか?
RDSインスタンスを持っているので、かなりの費用がかかります。アマゾンでの私のアカウントアクティビティから、インスタンスには過去7日間で約800,000,000のIOリクエストがあったことがわかります。 少し見方を変えると、私のアプリは1日に約6,000回のユニークアクセスしか獲得できず、それほど多くのデータベース接続を確立することはありません。 それでは、IO要求とは正確には何であり、なぜその数はそれほど多くないのでしょうか。必要に応じて、コストを削減するためにアプリに必要なことは何でもするつもりですが、実際に何が起こっているのかわかりません。 よろしくお願いします。
9 mysql  io  amazon-rds 

2
すべてのcPanelユーザーにパスワードを一度変更するよう強制する方法はありますか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 私が実行しているcPanelサーバーの1つで、侵害された電子メールアカウントに関する問題が常に発生しています。このサーバーのユーザーの多くは非常に弱いパスワードを持っていると思います。最小限のパスワードセキュリティを強化しましたが、それはパスワードが変更された場合にのみ有効になります...すべてのcPanelアカウントとcPanel電子メールアドレスのワンタイムパスワード変更を強制する方法はありますか?このようにして、すべてのユーザーに新しい安全なパスワードを生成させることができます。 更新:各アカウントには~/etc/domain.name/{passwd,shadow}、すべての電子メールアカウントのUnixスタイルのpasswdファイルとshadowファイルを含むファイルがあることがわかりました。ただし、手動で編集した場合でも、メールを送信できます:-( eximがユーザーの認証に使用するファイルを見つけて、そこでパスワードを壊すことができれば、私の問題は解決します...
9 security  email  exim 

1
iptables:マスカレードを使用したポート転送が機能しない
ポートフォワードで問題が発生しています。NATは問題なく動作しているようで、ポート転送のうち1つが動作しているようです(UDPポート7887からマシン192.168.1.100へ)。しかし、他のものではありません。 重要ではないかと思いますが、eth1とeth2はデュアルポートNICにあります。 WANインターネットアクセスはdhcpで提供されるため、可能であればソリューションはWAN_IPに依存しないようにする必要があります。 /opt/firewall.sh #!/bin/sh WAN="eth1" LAN="eth2" #ifconfig $LAN up #ifconfig $LAN 192.168.1.1 netmask 255.255.255.0 echo 1 > /proc/sys/net/ipv4/ip_forward sysctl -w net.ipv4.ip_forward=1 iptables -F iptables -t nat -F iptables -t mangle -F iptables -X iptables -P INPUT DROP iptables -P OUTPUT DROP iptables -P FORWARD DROP iptables -A INPUT -i …

5
シェルからbase32へのエンコード
シェルから直接、入力文字列をbase32エンコーディングにエンコードしようとしています。私はこれをubuntuで行うつもりですが、ここでは特にフレーバーは重要ではないと思います。 これを簡単に行うための既存のlinux / unixツールはありますか? 以下の線に沿った何か: -bash-3.2$ echo -n 'hello' | base32


4
openwrtルーターのLANポート間で通信できません
最新のOpenWRTソフトウェアをインストールしたWBMR-HP-G300H Buffalo Airstationルーターを持っています。 1つのニグルを除いて、すべてが正常に機能しています(ADSL、WIFIなど)。LANポート間で通信できません。つまり、1つのコンピュータをLANポート1に接続していて、LANポート2で別のコンピュータにpingを実行しようとすると、「宛先に到達できません」というメッセージが表示されます。 ルーター自体から両方のコンピューターにpingを送信でき、ワイヤレスで接続された別のラップトップから各コンピューターにpingを送信することもできます。すべてのコンピューターが同じサブネット範囲(10.0.0.?/24)にある。 スイッチでvlanを構成する必要があるのではないかと思いますが、さまざまなGoogle構成でこれを実行しようとするたびに、すべてのlanポートをフリーズし続け、ワイヤレス接続されたラップトップを使用して元に戻す必要があります。 これが私の/ etc / config / networkです: config interface 'loopback' option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0' config interface 'lan' option type 'bridge' option proto 'static' option netmask '255.255.255.0' option ipaddr '10.0.0.1' option _orig_ifname 'eth0 wlan0' option _orig_bridge 'true' option …

1
Ubuntuサーバー、gptパーティションテーブル、mdadm、grubブートが失敗する
基本的な作業システムの詳細: Ubuntu 12.04サーバーCDを使用してサーバーをインストールしました。 4つのディスクがあります。すべてのディスクで、このhowtoと同様に、次のことを行いました。 2GBのスワップパーティションを作成しました 256 GBの/ bootパーティションを作成 64 GB RAID10パーティションを作成(ルート用) 残りのスペースを占める大きなRAID10パーティションを作成 ブートをext3としてフォーマットしました。ルートと大きなパーティションにRAID10をセットアップしました。ルートをext4でフォーマットしました。大きなボリューム上に論理ボリュームを作成し、ext4でフォーマットしました。 結果のシステムは正常に動作し、正常に起動します。 問題の詳細: 次に、失敗の手順を文書化することにしました。最初のステップとして、grubを再インストールすることにしました。 # grub-install /dev/sda warn: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!. error: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, …
9 ubuntu  raid  mdadm  grub2  gpt 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.