サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
IISが詳細なPHPエラーを表示しない-代わりにサーバー障害500が表示されます
私はApacheからサイトを提供することに慣れていますが、現在はIISサーバーを使用することを余儀なくされています。 多くのPHPページがエラー500を返し、IISがエラーメッセージを抑制しているためデバッグできません。私はini_set('display_errors',1);コードで試しましたが、役に立ちませんでした。 一部のサイトでエラーが表示されますが、デバッグしたいサイトではないため、グローバルなPHP設定ではなく、そのサイトのサイト設定と関係があると思います。 PHPエラーの表示を有効にする方法について明確な答えが見つかりません。 このリンクは見つかりましたが、「system.webServer-> httpErrors」の場所がわかりません。 IISでPHPの表示エラーを有効にするにはどうすればよいですか?
9 php  iis 

1
ファイルがPHPの場合、mod_headersがヘッダーを送信しない
.htaccessファイルを次のように設定しました。 Header set MyHeader "I'm Set!" http://example.com/test/デフォルトのインデックスファイルのないそのディレクトリ()に移動し、ネットワークアクティビティ(この場合はChrome)を表示すると、ヘッダーが送信されていることがわかります。PHPファイル(http://example.com/test/test.php)に移動すると、ヘッダーが送信されません。 index.htmlを(単に<pre>Hiコンテンツとして)作成し、送信されます。ファイル名を.phpヘッダーなしに変更します。orignal test.phpをに変更するtest.htmlと、ゴミのようなコードが出力され、ヘッダーが送信されます。に変更test.phpするtest.pngと、壊れた画像アイコンが表示され、ヘッダーが送信されます。 したがって、mime-typeとファイル拡張子に関して上記以外のテストを行わないと、.phpファイル(legitまたはその他)のみが.htaccessルールを適用しないように設定されているか、具体的にはmod_headersディレクティブが設定されているようです。しかし、これをテストする方法がわかりません。これは共有サーバーであるhttpd.confため、ざっと見回すことはできません。 Apacheがphpファイルのヘッダーの送信をスキップする理由に関するアイデアはありますか? 私も試しました: <FilesMatch "\.(php)$"> Header set MyHeader "I'm Set!" </FilesMatch>

1
RDSライセンスは実際にはライセンスされていません
2つのADドメインに広がるいくつかのRDSホストがあります。最上位ドメイン(enets.local)のRDSサーバーは問題なく、ライセンスを取得し、正常な速度で使用します。 ただし、子ドメイン(myflo.enets.local)のRDSホストはライセンスを消費していないようです。現在、Server 2008 R2の「誠実な」ライセンスシステムのため、これは実際にはサービスの中断を引き起こしていませんが、ライセンスを監査するときに懸念の原因となる可能性があります。 ライセンスサーバーはアクティブで使用可能ですが、上記のスクリーンショットで確認できるように、ライセンスがなく、問題があることを示しています。ただし、診断画面には何も表示されず、イベントログには何の報告もありません。 2つのドメイン間には双方向の信頼があります(子ドメインのデフォルトです)。 親ドメインからライセンスを消費する子ドメインのRDSホストを取得するために他に何を探すことができますか?

2
Windows 7からASA 5520へのL2TP / IPSec
私たちのASA5520でL2TP / IPSecをセットアップして、開発者の1人のフリンジケースをサポートしようとしています。組み込みのvpnサブシステムを使用すると、Windows VPNサブシステムはログイン用のkerberosまたはNTLM cookieを格納するように見え、Cisco VPNクライアントとAnyConnectクライアントはこれを行いません。 Windows 7経由でVPNに接続しようとすると、接続が失敗します。 %ASA-5-713257: Phase 1 failure: Mismatched attribute types for class Group Description: Rcv'd: Unknown Cfg'd: Group 2 %ASA-5-713257: Phase 1 failure: Mismatched attribute types for class Group Description: Rcv'd: Unknown Cfg'd: Group 2 %ASA-5-713257: Phase 1 failure: Mismatched attribute types for class Group …

2
既知のCAで検証することなく、クライアントのSSL証明書をApacheに要求するにはどうすればよいですか?
apache2(2.2.3)を使用して、クライアントに証明書で認証してもらいたいサイトにサービスを提供しています。特定の証明書を提示するユーザーが過去にその証明書を提示したユーザーと同じであることを確認する必要があるだけなので、証明書に署名するCAは無関係です。ただし、使用SSLVerifyClient requireするにはSSLCACertificateFile ...(またはSSLCACertificatePath ...)が必要であり、apacheはそのファイル/パスでCAによって署名された証明書のみを受け入れるようです。発行/歌うCAに関係なく、Apacheがクライアント証明書を受け入れる方法はありますか?(つまり、クライアントが提示された公開鍵に対応する秘密鍵を持っていることを確認しますが、発行/署名CAを確認する必要はありません)

2
iSCSI / NFSのパフォーマンスが非常に低い場合のトラブルシューティング戦略
3つのWindows 2008 R2ボックスにiSCSIターゲットを提供し、1つのOpenBSD 5.0ボックスにNFSを提供する新しいSynology RS3412RPxsがあります。 sshでRS3412にログインし、ddとさまざまなブロックサイズを使用して小さなファイルと6GBファイルの両方を読み書きすると、優れたディスクI / Oパフォーマンスが示されます。 iSCSI / NFSクライアントでddまたはiometerを使用すると、最大20Mbpsに到達します(これはタイプミスではありません。20Mbps)。Synologyの複数のGbit NICをより有効に活用したいと思っていました。 スイッチとNICポートの設定が自動ネゴシエートではなくギガビットに設定されていることを確認しました。ジャンボフレームを使用した場合と使用しない場合で違いはありません。pingでMTUが現在9000であることを確認しました。2つのファームウェアアップグレードが展開されています。 スイッチの問題を除外するために、iSCSIターゲットとイニシエーター間の直接リンクを試しますが、他のオプションは何ですか? 私はwireshark / tcpdumpを壊した場合、何を探しますか?


1
会議招集のテキスト/プレーン部分を入力するようにExchangeを構成できますか?
私はMicrosoft Exchangeを使用している人と使用していない人がいる環境で働いています。Exchangeから送信される会議の招待状には、iCal形式の会議情報を含むテキスト/カレンダーの添付ファイルが含まれています。また、空のtext / plainと空のtext / htmlパーツも含まれます。 Exchangeを構成して、text / plainまたはtext / html部分のいずれか(または両方)に、人間が読める形式の会議概要を入力する方法はありますか?これは、テキスト/カレンダーの添付ファイルをネイティブでサポートしていないメールクライアントを使用している人々を助けるでしょう。
9 email  exchange 

1
perfmon Windows Server 2008 R2の合計RAM%
perfmonから使用可能なRAMの割合を取得するための良い方法を見つけようとしています。Available Mbytesを取得できますが、サーバーにインストールされているメモリの合計や、perfmonを介して何が使用されているかを取得する方法が見つかりません。私は明らかにGBでアラートを出すことができますが、私のサーバーのそれぞれは異なる合計RAMを持っているので素晴らしいアラートではありません。 %Committed Bytesを理解する方法には、ディスク上のページファイルが含まれるため、これは良い指標ではありません。 任意の助けいただければ幸いです。

3
Outlook 2011クライアント、Exchange 2010サーバー。送信済みアイテムのテキストに欠落している文字
Exchange 2010サーバーに接続されたOutlook 2011を実行しているMacクライアント:突然、送信メールメッセージで文字が欠落します。クライアントマシンが再起動されましたが、これはメッセージが送信されるたびに繰り返し発生します。 誰がこれを引き起こすのか考えていますか?BBS時代への逆戻りのように感じます。 送信済みアイテムに表示され、受信者が受信したテストメッセージ: [送信]をクリックする前に撮ったスクリーンショット:

4
UbuntuでIRQBALANCE_BANNED_CPUSを使用してハードウェア割り込みを禁止する方法
特定のCPUからの割り込みを禁止したいのですが。IRQBALANCE_BANNED_CPUSオプションについて聞きました。マシンのバックグラウンドでirqbalanceが実行されているのがわかります。どこで編集し、そのオプションをどのように設定しますか?たとえば、割り込みからcpus 2、3、4、5を除外します。引数記述子は次のとおりです。 irqbalanceが無視し、割り込みを割り当てないCPUのマスクを提供します マスクとはどういう意味ですか?そして、そのオプションでどこでirqbalanceを構成しますか? 編集1:私の構成が有効であること、つまり私のCPUが割り込みを受け取っていないことを知る方法は?/ proc / interruptsを確認していますが、いくつかの数値が増加しています。 EDIT2:今度はIRQBALANCE_BANNED_CPUS = 3eでマシンを起動したため、CPU 0のみが割り込み禁止になりません。だから私はcpo0が多くの割り込みを受け取り、他のcpusが割り込みを受け取っていないことを期待するべきですよね?これが私の/ proc / interruptsです。太字の行はすべてのCPUで変更されています。行22、24、35およびLOCは変更されています。 CPU0 CPU1 CPU2 CPU3 CPU4 CPU5 0: 26 0 0 0 0 0 IO-APIC-edge timer 1: 2 0 0 0 0 0 IO-APIC-edge i8042 6: 3 0 0 0 0 0 IO-APIC-edge floppy 8: 1 …

2
すべてのディレクトリ要求をnginxの単一のファイルにエイリアスできますか?
特定のディレクトリに対して行われたすべてのリクエストを取得し、リダイレクトなしでjson文字列をnginxで返す方法を理解しようとしています。 例: curl -i http://example.com/api/call1/ 期待される結果: HTTP/1.1 200 OK Accept-Ranges: bytes Content-Type: application/json Date: Fri, 13 Apr 2012 23:48:21 GMT Last-Modified: Fri, 13 Apr 2012 22:58:56 GMT Server: nginx X-UA-Compatible: IE=Edge,chrome=1 Content-Length: 38 Connection: keep-alive {"logout": true} これが私のnginx confにこれまでにあるものです: location ~ ^/api/(.*)$ { index /api_logout.json; alias /path/to/file/api_logout.json; types { } …

2
特定のユーザーのすべてのファイルの所有権を変更できますか?
ユーザーが所有するすべてのファイルを再帰的に検索し、それらをGnu / Linuxの別のユーザー/グループに変更する方法はありますか? 私はいくつかの魔法のワンライナーがあるはずだと思いますが、私のコマンドラインウィザードのスキルはそれまでではありません:) ありがとう!

2
API管理ソリューション[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 6年前休業。 私は現在APIを構築しており、(GUIで)監視してレート制限の使用を可能にするツールを探しています。私はいくつかのエンタープライズソリューションに出くわしました。 http://apigee.com/ http://mashery.com/ http://www.layer7tech.com/ http://www.3scale.net/ Apigeeエンタープライズプランはまさに私が探しているものですが、プランは月額3000ドルから始まり、これは私の価格帯を超えています。他のソリューションはすべて高すぎるか、私が探しているソリューションを提供していません。 これにより、以下を含むいくつかのオープンソースオプションを検討するようになりました。 http://apiaxle.com/ https://code.google.com/p/varnish-apikey/wiki/UsageManual ワニスはかなり完全なソリューションのようです。ただし、データを視覚化するGUIを構築する必要があります。 私の最後のオプションは、EventMachineとrubyを使用してゼロからソリューションを構築することです。 何かアドバイス?

2
OpenStreetMapデータを効率的にスケールアウトする方法
1年以上の間、OSMデータで満たされた社内PostGISサーバーを実行しています。これは、Mapnikベースのタイル生成とNominatimベースのジオコーディングの両方に使用され、日ごとの複製で更新されます。これはかなりうまくいきます。 ただし、使用量が飛躍的に増加しているので、PostgreSQLサーバーを追加して、信頼性とパフォーマンスを向上させたいと考えています。そして、私はちょっと迷っています。 PostgreSQLはそれ自体ではレプリケーションを処理しないようなので、PgPool-IIなどのミドルウェアを使用して、サーバーの同期を維持することを検討します。しかし、私はそれがこの使用法に必要なものに過ぎないと思います:すべての書き込みが毎日正確に同じ時間に行われる非常に高い読み取りと書き込みの比率。 私の質問は単純です。これらのサーバーの同期を保つにはどうしますか?そして、OpenStreetMap Foundation、MapQuest、Mapbox、またはCloudMadeでこれのために何が行われますか? ありがとう。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.