サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
子ドメインと親ドメインのOUが同じ名前を共有することは可能ですか?
このQ / Aを追加したのは、この制限に今日遭遇したばかりで、それに関するドキュメントが見つからなかったためです。この問題に関する古いKB記事があります が、それは現在Googleによってインデックスに登録されていません(おそらくそれが何年も前に発行され、更新されなかったためです)。この問題が他の場所で言及されることはありません。 親ドメインに子ドメインと同じ名前のOUを作成することはできますか? 親ドメインのOUと同じ名前の子ドメインを作成することはできますか?

2
Azure ADを使用してグループポリシー設定をプッシュする
従来のドメインコントローラーではなく、Azure Active Directoryを使用しようとしています。 Azure ADを使用してユーザーを認証し、フォルダーリダイレクト、ドライブマッピング、Windows 10プライバシー設定などのGPO設定をプッシュしたいと思います。 Office 365アカウントを作成しました。これにより、ADバックエンドが作成されます。また、Azureアカウントを作成し、O365 / Azureユーザーの詳細を使用して、テスト用のWindows 10 PCをAzureドメインに追加しました。 また、Azure AD Premium試用版も購読しています。 この時点で行き詰まっています。追加したPCはAzureのどこで確認できますか? また、Azure ADを使用して従来のグループポリシー設定をテストPCにプッシュできますか?プッシュする場合、どこでこれを構成しますか? または、Windows Intuneなどを使用する必要がありますか?

1
現実のインターネットでは何が起こりますか-BGPとOSPF
私は顧客の構内で働いたことはありませんが、私の仮定は、1つのサービスプロバイダーが内部的にIGPサービスを実行していることです-たとえば-OSPFまたはIS-IS。これで、あるサービスプロバイダーが別のサービスプロバイダーに到達して、3番目のサービスプロバイダーのサーバーと通信する必要がある場合、別のISPを通過または通過します。 私の例では-ISP-2。私の質問は- エリアごとに50台のルーターを制限するという複数のOSPFエリアとは別に、インターネットが実際に機能しているのはそのためです。IS内またはAS内の他のigpプロトコルである可能性があるという事実は無視できます。簡単に言えば、これは一種のインターネットの実際のトポロジーでしょうか。 次に、私のコンテキストベースの質問は、これが典型的なシナリオであるかどうか、そしてR2から11.11.11.11にpingを実行する方法です。 私はこれを言っている- AS-100にはすべての内部ルート情報(OSPF 1)があり、11.11.11.11に到達する方法がわかりません。 AS -200にはすべての内部ルート情報があります-OSPF 2 AS -300にはすべての内部ルート情報があります-OSPF 3 EBGPを使用してAS 100をAS 200に接続しました。同様に、AS 200とAS-300。これは、neighborコマンドを使用して行いました。 質問- ISP-2のすべてのネットワーク情報をISP1およびISP-3にアドバタイズして、それらすべてが通信できるようにする必要がありますか?もしそうなら、それは実際のネットワークで同じ方法で行われますか?これは、ISPのありとあらゆるネットワーク情報を宣伝するのは大変な仕事です。これを自動的に行うにはどうすればよいですか?CISCOを使用しています。GNS3のciscoコマンドが役立ちます。私は再配布について調査しましたが、あまり理解していません。また、実際のネットワークでは、すべてのルーティング情報を他のISPにアドバタイズすると、ルーティングテーブルが非常に大きくなります。私たちは通常これをしますか?しかし、そうしなければ、他のISPの内部ネットワークとどのように通信できるでしょうか。だから私たちはそうしなければならないと私は信じています。これは、ルーティングテーブルが非常に大きくなることを意味します。私はここで正しいですか?
9 cisco  internet  bgp  ospf 

2
不可解なメモリリーク。このシステムで最大10 GBのメモリを使用しているものは何ですか?
約18時間実行した後、このシステムは約10 GBのメモリを使用しているため、通常のタスクを実行するとOOMキラーがトリガーされます。 # free -h total used free shared buffers cached Mem: 14G 9.4G 5.3G 400K 27M 59M -/+ buffers/cache: 9.3G 5.4G Swap: 0B 0B 0B # cat /proc/meminfo MemTotal: 15400928 kB MemFree: 5567028 kB Buffers: 28464 kB Cached: 60816 kB SwapCached: 0 kB Active: 321464 kB Inactive: 59156 kB …

1
なぜr10kはr10kと呼ばれるのですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 しばらくr10kを使っています。r10kとはどういう意味ですか。 ご質問 ツールがr10kと呼ばれるのはなぜですか?それはどこの略ですか? 質問に答える試み Puppet docsもインターネットも、r10kが何を表すのかを示していません
9 puppet  r10k 

1
IPv6では、HTTP(S)を介して提供される各ホスト名に個別のIPアドレスを割り当てる必要がありますか?
IPv4では、IPベースの仮想ホスティングを保証する特定のニーズがない限り、名前ベースの仮想ホスティングを実行して、アドレススペースが不必要に使い果たされないようにする必要があります。 ただし、IPv6の場合、現在の推奨事項では、ホームサイトでも複数の/ 64s相当のアドレススペースを受け取る必要があるということですが、特定の状況で運用慣行がないため、これを困難または禁止するため、個別のIPv6アドレスを各Webサイトは、それらのWebサイトが同じサーバーで共同ホストされている場合でも? アドレスの割り当てを処理できるような、適切なアドレス管理インフラストラクチャが整っていると仮定すると、各Webサイトに独自のIPv6アドレスを与えることについて、または反対することについて、何が良い議論になるでしょうか? 完全を期すために、RFCの上記で参照されたセクションの関連部分は次のとおりです(強調は私のものです。これは比較のためだけであり、この引用はホームネットワークに関する問題ではありません)。 同時に、ホームサイトに単一の/ 64を与えるのは魅力的かもしれません。これは、今日のIPv4のプラクティスと比較して、すでにかなり多くのアドレススペースであるためです。ただし、これにより、ホームサイトでさえも将来的に複数のサブネットをサポートするように成長するという期待は排除されます。したがって、デフォルトでは、ホームサイトにも複数のサブネットに相当するスペースが与えられることが強く意図されています。したがって、このドキュメントでは、単一の/ 64よりも大幅に多くのホームサイトを提供することを推奨していますが、すべてのホームサイトに/ 48を提供することも推奨していません。 また、完全性のために:関連するネットワークにはまだIPv6割り当てがありません。また、行われる可能性のある割り当ての正確なサイズはわかりませんが、次の6〜12以内にIPv6を設定して実行することを望んでいます数か月かかります。それが発生した場合に備えて、少し前に計画を立てたいと考えています。
9 ipv6  web-hosting  web 

4
RHEL7でクラッシュと再起動をどのように区別できますか?
RHEL7サーバーがsystemctl(または再起動/シャットダウンエイリアス)経由で再起動されたかどうか、またはサーバーがクラッシュしたかどうかを判断する方法はありますか?事前にシステム化されていることは、でかなり簡単に判断できましたlast -x runlevelが、RHEL7ではそれほど明確ではありません。

2
ZFSチェックサムエラー、いつドライブを交換しますか?
私はZFSにかなり慣れていないので、8つのドライブを備えたシンプルなミラー化ストレージプールをセットアップしました。数週間実行した後、1つのドライブで多くのエラーが発生するようだったので、交換しました。 さらに数週間経つと、プール全体に小さなエラーが発生するようになりました(zpool status以下の出力を参照)。これについて心配する必要がありますか?エラーがドライブを交換する必要があることを示しているかどうかをどのように判断できますか? # zpool status pool: storage state: ONLINE status: One or more devices has experienced an unrecoverable error. An attempt was made to correct the error. Applications are unaffected. action: Determine if the device needs to be replaced, and clear the errors using 'zpool clear' or replace the …

4
各仮想マシンにウイルス対策プログラムが必要ですか?
System Centerエンドポイント保護を実行している2012 R2 Hyper-Vホストがあります。それによってホストされている2つの仮想Windowsサーバーがあります。 すべての.vhdxドライブをd:/ server /のフォルダーに持っています アンチウイルスがこれらのファイルをスキャンしてウイルスを検出することを信頼できますか、それとも各仮想マシンにウイルス対策プログラムが必要ですか? これらのファイルを手動でスキャンした場合、エンドポイント保護はほとんどすぐにウイルスを返さないため、スキャンしようとしていたのではないかと思います。

2
AWSでDocker / AnsibleとAnsible、Puppet、Foremanを使用した不変サーバーモデル?
私たちは興味深い議論にぶつかり、2つの陣営に陥っています。見落としている可能性のあるアイデアや落とし穴に関する特定の問題に興味があります。本当に、私たちが決定を下したり、私たちが説明していないことを指摘したりするのを助けることができるものは何でも。私はこれが「意見なし」のルールを少し厳密に回避していることを知っていますが、それでもまだ受け入れ可能な質問であることを願っています。長さについても申し訳ありませんが、かなりのニュアンスがあります。 1)一方(私-偏見がないわけではない)は、不変サーバーモデルがクラウドシステムにとって非常に興味深いものであると考えています。そのために、インフラストラクチャのすべてのコンポーネントをDockerに移動するプロトタイプを作成しました。私たちのカスタムアプリケーションは、ローカルDockerレジストリにデプロイするDockerイメージに、Jenkinsを介して直接構築されます。次に、Ansibleロールの大規模なセットと、空のサーバーに到達できるプレイブックを作成し、Dockerをインストールして、必要に応じてすべてのコンテナーをインストールするようにDockerに指示しました。数分後、アプリ全体とそれをサポートするすべてのインフラストラクチャが接続され、機能します-ロギング、モニタリング、データベースの作成/入力など。完成したマシンは、完全にコピーされた自己完結型のQAまたは開発環境です応用。これをスケールアウトするための計画は、新しいPlaybookを作成して、ベースの信頼できるAMI(おそらく非常に最小限のイメージ)から新しいAWSサーバーを構築し、本番アプリケーションのローリングデプロイを実行して構成管理とリリースを処理し、通常はサーバーを再び編集しないことです。それらを新しくするだけです。私が説明したものを実際に機能させることについては心配していません-それが妥当なモデルである場合でも。 2)他のキャンプは、Puppetを使用して構成管理を処理したい、Ansibleはビルドプロセスから生成されたtarballであるカスタムアプリケーションをデプロイし、Foremanはプロセス全体のトリガーと管理を処理し、Kateloはある程度のベースを実行したい画像管理。リリースには、必要に応じてPuppetが構成を変更し、Ansibleが更新されたコンポーネントをある程度のForemanの調整でデプロイすることが含まれます。新しいサーバーが必要になった場合、サーバーはかなり迅速に構築されますが、その意図は、標準プロセスの一部としてサーバーを使い捨てにすることではありません。これはフェニックスサーバーモデルに近いですが、長寿命です。 だから私の質問は本当にこれに帰着します:私が上でそれらを説明したように、ツールを備えた不変のサーバーモデルは実際にそれが現れるのと同じくらい現実的ですか?私のステージングプロセスは、文字どおりアプリケーションのクローン全体をライブで構築することができ、QAでそれをハンマーに任せて、データベースストレージとDNS設定を反転させてライブにすることができるというアイデアが大好きです。 または、不変サーバーモデルは実際には失敗しますか?AWSとクラウド環境の両方でかなりの経験を持っているので、それは本当に問題ではありません-合理的に洗練されたアプリを今後確実にデプロイする方法の問題です。非常に頻繁にリリースされるため、これは特に重要です。 実際にEC2サーバーを作成することを除いて、Ansibleは必要なほとんどのことを行っていますが、それは難しくありません。このモデルでパペット/フォアマン/カテロが実際に必要な理由を理解できません。Dockerは、私が知ることのできる実際のツールでは、カスタムデプロイスクリプトよりもはるかにクリーンでシンプルです。Ansibleは、その場で構成する必要がないか心配する必要がなくなり、新しい構成で再構築するだけの場合、Puppetよりもはるかに簡単に使用できます。私はKISSプリンシパルのファンです-特にマーフィーの法則が蔓延している自動化で。機械が少ないほど、IMOは向上します。 アプローチについての考え/コメントまたは提案は大歓迎です!

1
Systemdタイマーがサービスユニットを開始しない
状況 Let's Encryptからの証明書を更新するために、カスタムsystemdサービスユニットとその付属シェルスクリプトを記述しました。私が実行すると、すべてが正常に動作しsystemctl start letsencrypt-example_com.serviceます。60日ごとに自動実行したいので、systemdタイマーユニットを作成しました。 問題 systemctl enable letsencrypt-example_com.timerその後走りましたsystemctl start letsencrypt-example_com.timer。タイマーは開始したようですが、サービスは開始していません。 # systemctl status letsencrypt-example_com.timer Created symlink from /etc/systemd/system/timers.target.wants/letsencrypt-example_com.timer to /etc/systemd/system/letsencrypt-example_com.timer. # systemctl start letsencrypt-example_com.timer # systemctl list-timers --all # systemctl list-timers NEXT LEFT LAST PASSED UNIT ACTIVATES n/a n/a ven. 2016-05-06 13:10:13 CEST 1h 51min ago letsencrypt-example_com.timer letsencrypt-example_com.service # …
9 systemd 

1
「定義済みのコンピューターのセット」、どこで定義しますか?
Windows 8/10 / Server 2012 / Server 2016の「セキュリティが強化されたWindowsファイアウォール」で、許可されるアドレスを定義するときに、「事前定義されたコンピューターのセット」でアドレス/サブネット、アドレス範囲、またはプルダウンを選択できます すべての外部サイトを「Remote Corp Network」にバンドルしたいのですが、アドレスはどこに定義すればよいですか? 私のグーグルはこのようなスレッドにつながるだけです。回答なし https://social.technet.microsoft.com/Forums/office/en-US/8c4c6b4a-dc24-4a66-920f-4df0f4e283ed/windows-firewall-with-advanced-security-scope-of-rules-remote-コンピューターのアドレス事前定義セット?forum = winserverPN

1
メールサーバーをセットアップしようとすると、ポート(25、587)が機能しない
私はあらゆる場所を検索してきましたが、これに本当に苦労しています。私はすべてを試してみたと思います。 背景情報 CentOS 6.7のVPS Postfix 2.6.6 dovecot、amavis、mysql、fail2ban 私のVPSプロバイダーは、ポートをブロックしないことを確認しました。 私がやったこと ストックsendmailを削除 完全なメールソリューションのためにpostfix、dovecot、mysqlなどをインストールしました STARTTLSでimap、smtpのみを許可しています(ポート143および587) SSHログインは無効になり、キーのみ メールを受信できる(ポート143経由) localhostから両方のポート(587、25)にtelnetで接続でき、Postfixグリーティングが表示されます 587または25(メールクライアントまたはtelnet)に接続しようとすると、応答がゼロになります(接続タイムアウト)。 私が試したもの 1)ポートは開いていますか?はい、iptables: Chain INPUT (policy DROP 11 packets, 1375 bytes) pkts bytes target prot opt in out source destination 0 0 ACCEPT tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:587 0 0 ACCEPT tcp …
9 centos  email  postfix  smtp 

4
ワンライナーをバッシュして、ファイルが存在しない場合にアトミックに作成します
ファイルが存在しない場合に自動的にファイルを作成するBashワンライナーが必要です。つまり、「ファイルが存在しない場合は作成する」ということですが、ifを実行してからファイルを作成するまでの間に、他のユーザーが小さなスペースでファイルを作成できないようにします。
9 bash  files 

1
このタスクでは、指定されたユーザーアカウントにバッチジョブとしてログオンする権限が必要です
Windowsサーバー2008 r2タスクスケジューラで基本的なタスクを作成しましたが、タスクを保存しようとすると、次のエラーが発生しました。 This task requires that the user account specified has Log on as batch job rights. 現在、この権限がActive Directory内で定義されているユーザー権限の一部であるかどうかはわかりません。または、これはローカルWindows VMで個別に定義する必要がある権限ですか?誰かこれについてアドバイスできますか? ありがとう

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.