サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
Windows Server 2008R2とUbuntu 12.04を実行しているゲストの間でクリップボードを共有するにはどうすればよいですか?[閉まっている]
休業。この質問には詳細または明確さが必要です。現在、回答を受け付けていません。 この質問を改善してみませんか?詳細を追加し、この投稿を編集して問題を明確にしてください。 6年前休業。 Windows Server 2008 R2とHyper-VおよびUbuntu 12.04 LTSを実行するゲストを使用しています。 Windows Server 2008R2とUbuntu 12.04を実行しているゲストの間でクリップボードを共有するにはどうすればよいですか? 更新 これらのマシンを接続するには、どのプロトコルが必要ですか?Ubuntuではctrl+ を押しc、次にWindows Serverではctrl+ vを押して、この方法でテキストをコピーします。 今日私はWinSCPを使用しています。そこで、テキストを含むファイルを作成し、このファイルをコピーします。それは簡単で速くはありません。

4
OpenVPNパフォーマンスの向上
私はOpenVPNのパフォーマンスを改善しようと試みており、これが私の現在のセットアップです。 cat /etc/openvpn/server.conf port 443 #- port proto tcp #- protocol dev tun #tun-mtu 1500 tun-mtu-extra 32 #mssfix 1450 tun-mtu 64800 mssfix 1440 reneg-sec 0 ca /etc/openvpn/easy-rsa/2.0/keys/ca.crt cert /etc/openvpn/easy-rsa/2.0/keys/server.crt key /etc/openvpn/easy-rsa/2.0/keys/server.key dh /etc/openvpn/easy-rsa/2.0/keys/dh1024.pem plugin /etc/openvpn/openvpn-auth-pam.so /etc/pam.d/login #plugin /usr/share/openvpn/plugin/lib/openvpn-auth-pam.so /etc/pam.d/login #- Comment this line if you are using FreeRADIUS #plugin /etc/openvpn/radiusplugin.so …

2
浮浪者のパブリックIPにアクセスできません
私はこの構成を持っています: config.vm.network "public_network", ip: "192.168.56.101", :mac => "0022334455DA" そしてvagrant upifconfigが出力した後: eth0 Link encap:Ethernet HWaddr 08:00:27:12:96:98 inet addr:10.0.2.15 Bcast:10.0.2.255 Mask:255.255.255.0 inet6 addr: fe80::a00:27ff:fe12:9698/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1141 errors:0 dropped:0 overruns:0 frame:0 TX packets:861 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:115407 (115.4 KB) TX bytes:98490 (98.4 …

4
/ etc / environment内の環境変数、値にシャープ記号(ハッシュ)記号
Ubuntu 12.04では、次のように環境変数が定義されています/etc/environment。 FOO="value_before#value_after" サーバーにsshして値を確認すると、次のようになります。 $ env | grep FOO FOO=value_before 私はそれを#コメントとして扱い、それを取り除いていると思いますが、これはうまくいきます: $ . /etc/environment $ export FOO $ env | grep FOO FOO=value_before#value_after 私は#このようなエスケープを試みました: FOO="value_before\#value_after" しかし、それはうまくいきません、代わりに私はこれを取得します: FOO=value_before\ ハッシュを値の一部のように扱う方法についてのアイデアはありますか?どんな助けでも素晴らしいでしょう。 /etc/environmentファイルで試した値: FOO='value_before#value_after' FOO="value_before#value_after" FOO='"value_before#value_after"' FOO="value_before\#value_after" FOO='value_before\#value_after' 上記の他のさまざまな組み合わせ。これらの多くは、通常シェルで設定するだけで機能します。しかし、それらは/etc/environmentファイルで機能していないようです。

1
nginxはDER形式の証明書をサポートしていますか?
私はそれを使ってみましたが失敗しました。PEMへの変換は正常に機能します。ユーザーが証明書をサーバーにアップロードし、nginxが両方をサポートするように構成できるかどうか疑問に思っています。そうでない場合、証明書ファイルがDER形式かPEM形式かをプログラムで判別する方法はありますか?
10 nginx 

1
Chefを使用してサービスが実行されていることを確認するにはどうすればよいですか?
Chefがサービス(postgres)を開始する可能性がありますが、その後、帯域外で停止される可能性があります。後続のChef実行でサービスを実行させたい。私はこれを試しました: service "postgresql" do action :start end しかし(up to date)、シェフが起動したことをシェフが認識しており、停止したことを認識できないためと考えて、効果はありません。(おそらくservice ... statusこのサービスでどのように動作するためですか?)これを書いた場合: # anti-pattern warning! execute "force-start-postgresql" do command "service postgresql start || /etc/init.d/postgresql start" action :run end 私は望ましい振る舞いをします。また、action :restartそれを実行させます。ただし、これらは移植性のため(そして後者の場合は再開する前に停止する可能性があるため)、アンチパターンのように見えます。 では、Chefがすでに実行されていると考えている場合でも、サービスを強制的に開始するように指示するにはどうすればよいですか? これは、OpsCodeによってホストされているChef 11.6とデフォルトのpostgresqlレシピを使用しています。(これは似ていますが、Chefで「最新の」リソースにアクションを強制する方法とはまったく同じではないと思いますか?) --- 編集(jtimberlandポストに続く説明)--- -l debugここに示しています: DEBUG: service[postgresql] supports status, running DEBUG: service[postgresql] is running それが実行されていないときでも。だからそれは一つのバグのように聞こえます、そして私はそれに興味があります。ただし、私は主にChefに「ステータスチェックをスキップして、常にサービス開始コマンドを呼び出す」ように指示する方法があるかどうかに興味があります。それがここでの質問です。 (私は専門家だが、私はサービスが実行されていることを確認するための最もポータブルな方法は、サービスとそのほとんど常に冪等ですを開始することだと思います。大藤チェックサービスが実行されているかどうかはあまり一致しており、私たちは気にしなければならない理由は、私が表示されません!)

2
最新のansibleエラーログはどこにありますか
私はansibleスクリプトを使用してサーバー構成を起動しました。サーバー内からスクリプトを実行し、localhostインベントリですべてを実行していました。 これで、サーバーへのssh接続が閉じられ、ログファイルが見つかりません。これの標準ログパスはどこにありますか?/ var / logの下にansibleファイルはありません。 スクリプトを再度実行していて、エラーが再び発生することを期待していますが、スクリプトがエラーポイントまで実行するのに数時間かかるため、これは優れた解決策ではありません。
10 ansible 

2
Initサービスを永続的に無効にする
CentOS 6を実行する新しいVPSをプロビジョニングしたところ、Apacheが付属しています。 代わりにNginxを使用するため、Apacheを無効にします。 /etc/init.d/にあるスクリプトを削除するだけでよいことはわかっていますが、システムに付属している標準的なものであるため、削除したくありません。サービスを無効にするための優雅な方法が欲しいです。 / etc / inittabに何かを置くことができると思いましたが、inittabには次のものが含まれています。 # inittab is only used by upstart for the default runlevel. # # ADDING OTHER CONFIGURATION HERE WILL HAVE NO EFFECT ON YOUR SYSTEM. # # System initialization is started by /etc/init/rcS.conf # # Individual runlevels are started by /etc/init/rc.conf # # …
10 centos  httpd  upstart  init 

2
OpenStackがスナップショットとイメージを区別するのはなぜですか?
通常、https://serverfault.com/a/268727/126950: スナップショット=すべてのデータを含む、ボリュームが特定の瞬間にどのように見えたかの正確なキャプチャ。 画像=システムの合計スナップショット(ユーザーデータは保存されません) ただし、http://docs.openstack.org/folsom/openstack-ops/content/snapsnots.htmlは言う OpenStackでは、インスタンスのスナップショットはイメージです。glanceに直接アップロードした画像とスナップショットで作成した画像の唯一の違いは、スナップショットで作成した画像にはglanceデータベースに追加のプロパティがあることです。 では、なぜOpenStackはイメージとスナップショットを区別するのですか?

3
netsh int ip resetは正確には何をリセットしますか?
だた、この問題を、見つかったこのソリューションを、私は、おそらくしようとすべきだと思うnetsh int ip reset resetのコマンドを私はそれはいくつかの重要な設定をリセットし、リモートサーバーに達することから私を無効にすることができ怖いです。それで、それは正確に何をリセットしますか?

2
異なるサーバー上の単一ドメインの複数のSSL証明書
当社のウェブサイトは、共有ホスティングプランのドメインDの下でホスティング会社HAによってホストされています。ホスティングプロバイダーをHB社に切り替えたいのですが、そのために新しいSSL証明書を購入したいと思っています。HA上のサーバーにアクセスできないため、既存の証明書を明示的に移行したくありません。 私の質問は、HAとHBの両方が同時に同じドメインDの独立した証明書をインストールできるかどうかです。 もしそうなら、ドメインをHBに切り替えるとすぐに、新しいサイトはSSLの下でシームレスに動作しますか、またはHBに新しい証明書をインストールする前に、HAの証明書を「登録解除」する必要がありますか?

1
監視およびstdout / stderr
Supervisordのプログラム構成ブロックで、redirect_stderrがtrueの場合、stderr_logfileを設定する必要がありますか? stderror_logfile=/path/to/logfile/stderr.log stdout_logfile=/path/to/logfile/stdout.log redirect_stderr=true redirect_stderrがtrueであるため、これはstderr.logが空になり、stderrとstdoutストリームの組み合わせがsdtout.logに表示されることを意味します。私の理解は正しいですか?

3
tarでCentOS全体をバックアップしているときにエラーが発生する
私はこのコマンドを試しています tar cvpzf /TEMP_BACKUPS/backup.tgz --exclude=/proc --exclude=/lost+found --exclude=/tmp --exclude=/TEMP_BACKUPS --exclude=/mnt --exclude=/sys / > /TEMP_BACKUPS/mylog.txt そして、私はこのエラーを受けています。私は2回試しました tar: Removing leading `/' from member names tar: /dev/log: socket ignored tar: Removing leading `/' from hard link targets tar: /selinux/policy: Cannot open: Invalid argument tar: /var/spool/postfix/public/flush: socket ignored tar: /var/spool/postfix/public/cleanup: socket ignored tar: /var/spool/postfix/public/showq: socket …
10 linux  centos  tar  logging 

2
db_datareader / db_datawriterスキーマの所有権の割り当てを元に戻す方法は?
私が意味するSQL Serverログインを割り当てるには db_datareader db_datawriter データベースロール。しかし、お腹が痛くて疲れている瞬間に、そのユーザースキーマの所有権を誤ってユーザーに付与します。 現時点では、ユーザーがこれら2つの組み込みスキーマを「所有」することの概念的な意味を無視します。また、ユーザーがこれら2つのスキーマを所有している場合でも問題がある場合は、当面は無視します(たとえば、ユーザーを削除する場合は、組み込みのスキーマがそれに伴います)。 私の質問は、どうやって元に戻すのですか? 私は、ランダムに私のキーボードのキーを押すと、それが出てきました: スキーマの承認を変更:: [db_datareader] TO [db_datareader]F5 しかし、それは何もしませんでした。だから今は専門家に相談する時間です。 Microsoft SQL Server 2005-9.00.5057.00(Intel X86)Mar 25 2011 13:50:04 Copyright(c)1988-2005 Microsoft Corporation Standard Edition

9
VPNに接続しているときにローカルネットワーク共有に接続できません。エラー:「ユーザー名が見つかりませんでした」
私の小さな会社のLAN(7ユーザー、3サーバー)で、ファイル共有の目的で一部のサーバーが「アクセス不能」になっていることに気づきました。「\ SERVERにアクセスできません。このネットワークリソースを使用する権限がない可能性があります。ユーザー名が見つかりませんでした」というメッセージが表示されます。しかし、すべてのマシンが同じドメインにあり、PDCとBDCが問題なく動作しているように見えるので、「ユーザー名が見つからなかった」理由はわかりません。 編集: VPNが原因のようです: IPアドレス(\\ 1.2.3.4 \など)またはFQ Active Directory名(例:\ server.domainname.local)を使用するとサーバーが表示されますが、サーバー名を単独で使用したり、もともと「短い」名前から作成された、マップされたネットワークドライブ。奇妙なことに、マシン名はpingできるのでサーバーのDNS名を解決しても問題はなく、すぐにIPが返されますが、nslookupは失敗するようです。 VPNに接続したときにWindowsがマシン名を検索する方法に問題があるようです。VPNに接続しているとき、Windowsはドメインコントローラ上のDNSではなく、VPNに関連付けられているDNSを使用しているようです。この動作は私には正しくありません。確かに、VPNに接続すると、サーバーやプリンターなどのローカルマシン名を検索できなくなる可能性があるためです。 VPNに接続されている場合でも、Active Directory DNS(PDC)ですか? 以下の私のコメントに詳細情報があります。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.