サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
Linux kdumpが/ var / crashに書き込まないのはなぜですか?
再び起こった!定期的にクラッシュするサーバーが4台あり、システムログやシリアルコンソールに情報が出力されません。 さらに、Linux kdumpサービスはコアダンプをデフォルトの場所に書き込みません/var/crash。 理由を教えてください。 ルートファイルシステムがLVMボリュームであるかどうかは重要ですか? これが私が試したものです。 私のシステムは、最新のカーネルを備えたScientific Linux 6.5です。 [root@host1 ~]# uname -r 2.6.32-431.11.2.el6.x86_64 [root@host1 ~]# cat /etc/issue Scientific Linux release 6.5 (Carbon) このファイル/etc/kdump.confは、デフォルト設定を含む標準的なファイルです。ほとんどの行はコメント化されており、pathおよびのアクティブな行は2つだけcore_collectorです。 #net my.server.com:/export/tmp #net user@my.server.com path /var/crash core_collector makedumpfile -c --message-level 1 -d 31 #core_collector scp kdumpサービスが実行中であることを確認します。これkdumpにより、を再構築する必要はありませんinitrd。 [root@host1 ~]# chkconfig --list kdump kdump 0:off 1:off 2:off 3:on …

4
WindowsのMIT Kerberosでの複数のレルムと複数のTGT
私のローカルコンピューターはWindows 7 Proを使用し、ADサーバーによって管理されるレルムLRに属しています。そのレルムのネットワークに接続しているときに自分のコンピューターにログインします。Windows版のMIT KerberosでTGTを表示できます。4.0.1。 FRの外部レルムのリソースにアクセスしたい。LRとFRの間にはKerberosの信頼関係はありませんが、相互間のTCPトラフィックを許可します。KDC(Red Hat IdM / FreeIPA)を使用してFRのTGTを要求し、要求されたときにパスワードを正常に入力しました。繰り返しますが、Windows版MIT KerberosでTGTを表示できます。4.0.1。LRを起源としているにもかかわらず、パスワードを要求されることなくSSH経由でFRのリソースにアクセスできるようになりました。 問題は、FRのTGTを取得すると、LRプリンシパルのTGTが消えてしまうことです。FR TGTのみがMIT Kerberosで表示されます。コンピューターをロックしてからパスワードでロック解除すると、FR TGTはなくなり、新しいLR TGTに置き換えられます。 MIT Kerberos for Windowsは一度に1つのTGTしか保存できないようです。各TGTは、すべての意図と目的のためにその領域で完全に機能します。MIT Kerberosを構成して、各レルムに1つずつ、同時に2つのTGTを持たせるにはどうすればよいですか?それぞれが異なるKRB5_CONFIGおよびローカルキータブを指す複数のクライアントインスタンスで「コンパートメント化」することは可能ですか?私ができない場合、レルム間の信頼がない場合でも、クライアント側のKerberos 5の代替Windows実装はありますか? PS-信頼したくない。信頼を得ることができません。 更新:問題を混乱させるかもしれないと思ったので、これらの詳細の一部を先に省略しました。しかし、ブラッドの答えに基づいて、それは正当化されるかもしれません。ほとんどのローカルソフトウェアはKerberosの組み込みのWindows実装を使用し、常にLRキータブを使用することを期待しています。 ただし、私のようなパワーユーザーはCygwinの下でheimdalを使用してFRにSSH接続します。Cygwin DLLを通過するものはすべてheimdalを使用し、LR TGTを表示しないことを期待しています(少なくともデフォルトではそうではありません)。私は明示的にkinitして次に進みます。 Cygwinを使用せずにPuTTYを使用する、サポートしなければならない非パワーユーザーには、注意が必要な部分があります。PuTTYでは、GSSAPI実装で使用するライブラリパスとDLLの両方を指定できます。たとえば、組み込みのWindows DLLではなくMIT Kerberos DLLを使用するようにSSHセッションを構成しています。LR TGT(heimdalのような)を見つけようとしないか、複数のレルムからの複数のTGTを許可しないDLLがそこにあると期待していました。MIT KerberosのようなGUIウィンドウは必要ありませんが、役立ちます。
10 kerberos 

9
RDPが壊れている場合、リモートのWindowsサーバーに接続するにはどのようなオプションが必要ですか?
RDPが壊れている(応答しない)場合、コンソールアクセスがなく、サーバーが物理的に近くない場合、リモートWindowsサーバーに接続するにはどのようなオプションが必要ですか? Linuxでは、VNCが機能していなかった場合、通常はSSHデーモンを使用できました。Windowsはそれを拾いませんでした(なぜ、私は知りません)-同等のものはありますか?

3
サービスで「(サービスチェックが正しく終了しませんでした)」および「(null)」の結果を解決するにはどうすればよいですか?
NagiosのサービスチェックにいくつかのPerlベースのスクリプトを使用していますが、その結果、Nagiosで取得(Service check did not exit properly)し(null)ましたが、スクリプトはコマンドラインで適切に機能します。 enable_embedded_perl=0Nagios構成で設定するか、インタープリターへのパスを明示的に指定して、内部Perlインタープリターを無効にすることを提案するソリューションをオンラインで見ました。これは問題を解決しませんでした。 他に何ができるでしょうか?

4
dhcpdでMACアドレスによってIPを割り当てる方法
dhcpdを使用してMACアドレスに固有のIPアドレスを割り当てるにはどうすればよいですか? これまで私は試しました host blah { hardware ethernet <mac address>; fixed-address <ip address>;} 私のdhcpd.confで。しかし、dhcpdと問題のMACアドレスを持つマシンを再起動すると、ランダムIPが再び表示されます。
10 linux  dhcpd 

2
ApacheでJSONに適切なヘッダーを設定するにはどうすればよいですか?
静的JSONファイルを提供するApacheサーバーがあります。コンテンツタイプは、ヘッダー付きのContent-Type: application/jsonヘッダーで正しく表現されています。 ヘッダーに正しい文字セットを追加するにはどうすればよいですか? 私には次の行がありますhttpd.conf: AddDefaultCharset utf-8 しかし、この行を使用しても、Apacheはヘッダーに文字セットを設定しません。 JSONファイルにはフランス語のデータが含まれており、JavaScriptコードでアクセントが正しく読み取られていないため、これは重要です。 では、ApacheでJSONに適切なヘッダーを設定するにはどうすればよいですか?

2
sendmail.mcファイルの「dnl」と「dnl#」の違いは何ですか?
違いは何であるdnlとdnl #中/etc/mail/sendmail.mcのファイルは?何かを有効にしたい場合、前に何が必要ですか?同様に、何かを「コメントアウト」したい場合、どの接頭辞が必要ですか? 例えば: dnl # masquerade not just @mydomainalias.com, but @*.mydomainalias.com as well dnl # dnl FEATURE(masquerade_entire_domain)dnl dnl # dnl MASQUERADE_DOMAIN(localhost)dnl dnl MASQUERADE_DOMAIN(localhost.localdomain)dnl dnl MASQUERADE_DOMAIN(foo.com)dnl dnl MASQUERADE_DOMAIN(foo2.lan)dnl MAILER(smtp)dnl MAILER(procmail)dnl dnl MAILER(cyrusv2)dnl
10 sendmail 


3
Apacheがファイルシステム上のフォルダを見つけられません。ファイルパスの最後に「\ xe2 \ x80 \ x9d」を追加
私は、OS X Mavericksを実行している個人のMacintoshのapache2で3つの仮想ホストを実行しており、混乱のもとに遭遇しました。これらは、httpd-vhosts.confファイルで次のように構成されています。 <VirtualHost *:80> DocumentRoot "/Library/WebServer/Documents" ServerName localhost ServerAlias localhost </VirtualHost> <VirtualHost *:80> DocumentRoot "/Library/WebServer/Documents/dev1" ServerName dev1.local ServerAlias www.dev1.local </VirtualHost> <VirtualHost *:80> DocumentRoot "/Library/WebServer/Documents/dev2" ServerName dev2.local ServerAlias www.dev2.local </VirtualHost> <VirtualHost *:80> DocumentRoot "/Library/WebServer/Documents/dev3” ServerName dev3.local ServerAlias www.dev3.local </VirtualHost> 注:最初のエントリでは、「localhost」と入力して、仮想ホストが実行されていなくても期待どおりにロードすることができます。 dev1とdev2は正常に動作しますが、「要求されたURL /はこのサーバーで見つかりませんでした」というエラー404が表示されます。ローカルマシンにdev3をロードしようとすると、3つのDevフォルダーすべてに同じ名前があり、名前を確認しました。error_logを確認したところ、次のことがわかりました。 [Fri Jan 24 12:55:07 2014] [error] [client 127.0.0.1]ファイルが存在しません:/ …

2
PostfixはいつIPv6を使用し、いつIPv4を使用しますか?
私はメールサーバーをIPv6とIPv4用に構成しましたが、ほとんどの場合、リモートホストでIPv6を使用できるのにIPv4を使用します。私はバージョン2.9でPostfixを使用しています。だから私の考えは、postfixが利用可能であればIPv6を使用し、IPv4へのフォールバックがあるということでしたか、それとも間違っていますか?
10 email  postfix  ipv6 


1
ssh:id_rsaは機能しませんが、名前を変更すると機能します
〜/ .sshフォルダーにこのid_rsaがあります。しかし、それは認証されません。それをコピーしてid_rsa以外の名前に変更すると、機能します。 [qfan@mycomputer .ssh]$ ls -al id_rsa id_rsa_good -rw------- 1 qfan qfan 1766 Dec 3 18:35 id_rsa -rw------- 1 qfan qfan 1766 Nov 20 19:43 id_rsa_good [qfan@mycomputer .ssh]$ sha1sum id_rsa id_rsa_good 8cc7f68170038b184bba0541be7d105bb36f7d11 id_rsa 8cc7f68170038b184bba0541be7d105bb36f7d11 id_rsa_good [qfan@mycomputer .ssh]$ ssh localhost -i id_rsa qfan@localhost's password: [qfan@mycomputer .ssh]$ ssh localhost -i id_rsa_good Enter …
10 ssh  login  rsa 

2
ローカルのfail2banフィルター定義にルールを「追加」する方法は?
私の管理下にあるサーバーにDebianによってパッケージ化されたfail2banをインストールしました。以前からいくつかのfailregexeがあるので、それらもローカルフィルター定義ファイルに入れて、それらも考慮されるようにします。したがって、たとえば/etc/fail2ban/filter.d/sshd.confや/etc/fail2ban/filter.d/sshd.localなどになります。これは、セットアップすることをお勧めする方法であり、それが何であるかについて問題なく機能しているように見えます。 ただし、.localファイルでは、実際に.confファイルのfailregexeのリスト全体を置き換えています。ドキュメントにはそれを行う他の方法があることは示されていないようで、それを機能させるために、ディストリビューションで提供された.confファイルを.localファイルにコピーし、いくつかの追加を行いました。 ディストリビューションで管理されているログエントリフィルターの正規表現への変更に遅れをとらないようにするアップストリームとDebianのメンテナの仕事の恩恵を受けて、リストを単純に修正できたら本当に素晴らしいです。 私が考えることができる唯一の本当の回避策は、実際に2つのjailを作成することです。1つはディストリビューション提供の構成を使用し、もう1つは自分のjailを使用します。これには、独立した刑務所として扱われる(かなり重要な)欠点があるように思われます(このような設定では予想されます)。 確かに、メンテナンスの手間を最小限に抑えながら、既存のコレクションに自分のいくつかのfailregexeを追加したいのは私だけではありません。 対応するグローバルファイルまたは配布提供ファイルに変更を加えずに、サイトローカルファイルまたはホストローカルファイルを使用して、fail2banフィルター定義内のfailregexおよびignoreregexのリストを修正することは可能ですか?もしそうなら、それを行う方法は?
10 debian  fail2ban 

6
winrmのネゴシエート認証を有効にする方法
次のコマンドを実行して、サーバー上のwinrmサービスのネゴシエート認証を無効にしました。 winrm put winrm/config/service/Auth @{Negotiate="false"} そして今、私はwinrmであらゆる操作を実行できます。エラーが発生します: Message = The WinRM client cannot process the request. The WinRM client trie d to use Negotiate authentication mechanism, but the destination computer (local host:47001) returned an 'access denied' error. Change the configuration to allow Negotiate authentication mechanism to be used or specify one …

1
powershellフォントフェイスとサイズのカスタマイズ
次のコマンドを使用して、PowershellがデフォルトのシェルとしてセットアップされたWindows 2012サーバーコアシステムがいくつかあります。 $RegPath = "Microsoft.PowerShell.Core\Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\winlogon" Set-ItemProperty -Confirm -Path $RegPath -Name Shell -Value 'cmd.exe /C start /max PowerShell.exe -noExit' c:\ Windows \ System32 \ WindowsPowerShell \ v1.0 \ profile.ps1にある特別なpowershellスクリプトを使用して、powershellフォントの色をカスタマイズできることを理解しました。このスクリプトは、すべてのユーザーが使用します。 ただし、今は永続的なフォントフェイスとフォントサイズ(すべてのユーザーに対して)をカスタマイズしたいと思います。IEサーバーからログアウトして再度ログインすると、設定が保持されます。同様に、管理者としてログインした場合、または自分のアカウントのpowershellは同じに見えるはずです-同じフォントの色、フォントフェイス、フォントサイズを使用してください。 Powershell ISEでは、次を使用してフォントフェースとフォントサイズを設定できるようです。 $psISE.Options.FontName = 'Lucida Sans Console' $psISE.Options.FontSize = 14 powershell自体に相当するものは何ですか?
10 powershell  color  font 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.