サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
PPAからPHP5.6をインストール中にUbuntuでUnicodeDecodeErrorが発生する
Ubuntu 14.04 LTS x64のクリーンなVPSを持っています。そして、以下を試しました: # Upgrade The Base Packages apt-get update apt-get upgrade -y # Add A Few PPAs To Stay Current apt-get install -y software-properties-common apt-add-repository ppa:nginx/stable -y apt-add-repository ppa:rwky/redis -y apt-add-repository ppa:chris-lea/node.js -y apt-add-repository ppa:ondrej/php5-5.6 -y しかし、最後の1つで失敗します。 root@xxx:~# apt-add-repository ppa:ondrej/php5-5.6 -y gpg: keyring `/tmp/tmp9jdzm9kw/secring.gpg' created gpg: keyring `/tmp/tmp9jdzm9kw/pubring.gpg' …

4
最小限の構成ですべてのドメインを管理するにはどうすればよいですか?
これは、DNSサーバーの管理に関する正規の質問です。 私は100ほどのドメインを持っています。これらのドメインはすべて同じように構成する必要がありますが、これらのドメインごとに新しいゾーンやゾーンファイルを構成しなければならないのは、非常に時間の無駄のようです。これを自動化するより良い方法がなければなりません! 私は何かに取り組んでいると思います...というゾーンを作成.するか、DNSソフトウェアで他の機能を使用して、Aレコードが要求されたときに常に特定のIPを返す場合、これにより、希望する目的にかなり近づくようです結果。私のサーバーはリクエストに対して信頼できる応答をしており、管理がとても簡単です! ネームサーバー検証ソフトウェアがこれらのドメインのチェックを開始するまで、これはうまく機能していました。NSレコードを追加することでほとんどのエラーを解消できることを理解しましたが、私のソフトウェアではSOA、同じゾーンファイルに複数のレコードを配置できません。 この複数SOAレコードの問題を回避するにはどうすればよいですか?

2
Windows Serverバックアップエラー-16.7TBを超えるボリュームは保護できませんか?
Windows Serverバックアップを使用して、新しいサーバーのRAIDアレイをバックアップしようとしています。しかし、私がそうすると、私はこのエラーに遭遇します: サーバーはWindows Server 2012 R2を実行しており、問題のアレイのサイズは20 TB(18 TBが使用可能)です。現在1 TB未満が使用されています。 Windows Server 2008では、VHDの制限により2TBを超えるボリュームをバックアップできなかったが、Microsoftが64HDボリュームをバックアップできるVHDXに切り替えたことを知っている。これを利用するためには、問題のドライブはGPTでなければならないことも知っています。 私のディスクが実際にはGPTであることを確認しました。 Windows Serverバックアップを実行すると、「一度だけバックアップ」オプションを使用して、ネットワークドライブにバックアップします。また、標準設定と思われるものを使用しています。しかし、バックアップを実行しようとすると、上記のエラーが表示されます。 Windows Serverバックアップでは最大64 TBのボリュームをバックアップできるため、これが16.7 TBで上限に達している理由はわかりません。なぜこれが起こっているのか、または私が間違っているのかについて誰かが私にいくつかの洞察を与えることはできますか? 更新:新しいドライブを受け取り、アレイを再度作成しましたが、それでも同じエラーが発生します。クラスタ数が2 ^ 32未満であることを確認できます。 この質問を読んだところ、どうやらWindowsバックアップは512または512eバイトセクターのないディスクへのバックアップまたはディスクからのバックアップをサポートしていないようです。バックアップしようとしているファイル共有を見ると、4kセクターを使用しています。これは根本的な問題でしょうか?それが役立つ場合は、バックアップ先の共有がCentOSサーバーでホストされています。

2
ESXi環境でEFIファームウェアとGPTブートディスクを使用することには、顕著な利点(または欠点)はありますか?
タイトルが尋ねるように、私の基本的な質問は:ESXi環境でEFIファームウェアとGPTブートディスクを使用することには、顕著な利点(または欠点)はありますか?「注目すべき」とは、MBRディスクの既知の2 TB制限、およびBIOSブートファームウェアがMBRディスクを使用してブートする必要があるという制限以外のことを意味します。 特定のVMオプションは以下のスクリーンショットにあります。 それが違いを生む場合、私の特定の環境の背景と詳細を以下に示しますが、私は一般的なケースだけでなく、具体的にまたはWindows環境にのみ関連するすべてのものに興味があります。 最近のプロジェクトの結果、$ [day_job]にある企業の大君主を現在の10年に引き込むことに成功したため、ホームオフィスシステムの多くを置き換えます。これらのシステムは、置き換えられるシステムと同様に、主にESX 5.5で仮想化されたWindows Server OSです(今すぐアップデート1、間もなくアップデート2、VMFS5、大容量サポート)。VMおよびVMがアクセスするすべてのストレージは、NFS共有を介してESXiホストに提供されるSAN(EMC VNX 5400)上にあります。すべてがシンプロビジョニングされています。 ほとんどの場合、大規模で複雑なPITAシステムを新しいプラットフォームにアップグレードするだけです。たとえば、現在Server 2003 R2で実行されており、DFSを使用していないマルチTBファイルサーバーは、サーバーにアップグレードされます。 2012 R2、DFS名前空間に配置し、DFSレプリケーションを利用して、Server 2012データ重複排除の使用を開始します。現在サーバー2003 R2およびSQL Server 2005で実行されているSharePointシステムは、サーバー2012 R2を実行するSharePoint 2013にアップグレードされ、2008 R2以上のSQL Serverエンジンに配置されます。等々。 ファイルサーバーを調べて、それらのデータ量を処理する方法(ホームオフィスの各ファイルサーバーには2 TBを超えるデータが含まれている)を調べて、サーバーのデータ重複排除機能を調べました。これはボリュームごとに機能するため、現在の混乱のように複数のボリュームに分割するのではなく、すべてのデータが1つのボリュームである場合に最適に機能します。これにより、GPTディスクがデータボリュームに最適であるという問題が発生し、EFIとBIOSファームウェアの問題が発生しました。私たちのすべてのサーバーには、データボリュームとは別の50 GBのOS [仮想]ディスクがあり、少なくとも現在のところ、それを維持することを計画しています-新しいVMにデータボリュームをアタッチできることは非常に便利です。 したがって、そのことを念頭に置いて、2 TBのMBRディスク制限を超えるためにGPTである必要があるボリュームからVMを起動する必要がある、またはVMを起動するシナリオを想定することはできません。環境が純粋に仮想であるという事実は、GPTディスクの回復可能性の利点を打ち消しているようです。そのため、EFIブートファームウェアやGPTブートボリュームを使用して新しいVMを構築し始める説得力のある理由を思い付くことができません。もちろん、BIOSブートファームウェアとMBRディスクに固執する説得力のある理由も思いつきません。そのため、私の質問は次のとおりです。 ESXi環境でEFIファームウェアとGPTブートディスクを使用することには、顕著な利点(または欠点)はありますか?(「注目に値する」とは、MBRディスクの既知の2 TB制限、およびBIOSブートファームウェアがMBRディスクを使用してブートする必要があるという制限以外のことを意味します。)

4
特権Dockerコンテナーを使用したカーネル調整
ロードバランサーのカーネル設定を調整するコンテナーを構築しています。単一の特権コンテナーを使用して、これらの変更をイメージ内のホストにデプロイしたいと思います。例えば: docker run --rm --privileged ubuntu:latest sysctl -w net.core.somaxconn=65535 テストでは変更が有効になりますが、そのコンテナに対してのみ有効です。完全に特権のあるコンテナーを使用すると、/ procを変更すると、実際に基盤となるOSが変更されるという印象を受けました。 $docker run --rm --privileged ubuntu:latest \ sysctl -w net.core.somaxconn=65535 net.core.somaxconn = 65535 $ docker run --rm --privileged ubuntu:latest \ /bin/bash -c "sysctl -a | grep somaxconn" net.core.somaxconn = 128 これは特権コンテナがどのように機能することになっていますか? 私はばかげたことをしているだけですか? 永続的な変更を行うための最良の方法は何ですか? バージョン情報: Client version: 1.4.1 Client API version: …
10 linux  docker  su  sysctl 

2
Windows 10 sshはパスワード認証を無効にしますか?
Windows 10は最近、オプションのWindows機能としてOpenSSHを追加しました。構成ファイルC:\ Windows \ System32 \ OpenSSH \ sshd_configを見つけて、変更する権限を自分に与えました。 これが私が持っているファイルです: # $OpenBSD: sshd_config,v 1.84 2011/05/23 03:30:07 djm Exp $ # This is the sshd server system-wide configuration file. See # sshd_config(5) for more information. # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin # The strategy used for options in the default …
10 ssh  windows-10 

4
ローカルマシンからシェルスクリプトを実行してリモートマシンでコマンドを実行し、ローカルマシンで続行する
問題はこれです:私はリモートマシンからファイルをコピーしたいです。 リモートマシンに接続し、保存されたファイルの場所を取得するシェルスクリプトを作成する方法を探しています。リモートサーバーから切断された場所を取得し、取得した場所を使用してローカルマシン内からscpを使用します。ファイルをコピーします。 具体的には、スクリプトからリモートマシンに接続し、そのマシンでタスクを実行する方法を知りたいです。切断し、ローカルで実行を継続します。
10 ssh  sh 

1
指向性無線リレーを使用すると、スループットがほぼゼロに低下します
次の1Gbit / s無線リンク設定を使用しています:場所A: 1Gbits / s symのインターネットゲートウェイ。ファイバ dhcp、dns、fileservers(smb)、voip-server、exchange-serverなどのほとんどのサーバー 55クライアント/ユーザー 指向性無線リレーA(Lightpointe AireLink 60 SX)-1Gbits / s 場所B: 1つのファイルサーバー(smb) 30クライアント/ユーザー 指向性無線リレーB(Lightpointe AireLink 60 SX)-1Gbits / s ロケーションAとBの間の距離は177メートルです。両方の場所が1つのサブネットを共有しています。クライアントとサーバーでは192.168.0.0/24、VoIP電話はサブネット10.6.3.0/24にあります(両方の場所で共有されています)。したがって、両方のロケーション間にルーティングはなく、無線リンクはブリッジとして機能しています。 指向性無線リレーAの設定: Link Status: UP Mode: Data RSSI, dBm: -46 RSSI Alarm Thrshld, dBm: -60 RSSI Alarm Clear, dBm: -50 RF Link: high TX RF Band, …

2
RAID 5ハードディスクの破損
IBM x3650 M4サーバーを持っています。これはRAID 5で構成されており、それぞれ容量が500 GBの4つのSASハードディスクが含まれています。2つのハードディスクが不良として表示されています。したがって、2つのハードドライブを新しいものに交換することで、データが自動的に再構築されますか、それとも他の変更を行う必要がありますか。私はレイドの設定についてあまり知りませんので、助けてください。
10 raid5 

3
USBからHyper-v 2016を実行しようとしています
今日の午後にHyper-v 2016をテストしようとしましたが、次の手順を使用して構成したUSBからR630を起動できませんhttps://technet.microsoft.com/library/ee731893(ws.10).aspx 問題なくHyper-v 2012 R2でまったく同じガイドを使用しました。 誰もがこれで運がありますか?

1
mysqlサービスを開始できません[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 ubuntuサーバーからmysqlサービスを再起動できません。ここにエラーがあります: ● mysql.service - LSB: Start and stop the mysql database server daemon Loaded: loaded (/etc/init.d/mysql; bad; vendor preset: enabled) Active: failed (Result: exit-code) since mer. 2016-06-08 17:31:06 CEST; 54s ago Docs: man:systemd-sysv-generator(8) Process: 4087 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE) juin 08 17:31:06 SRV-OVH-GIC03-V /etc/init.d/mysql[4569]: 0 processes …
10 mysql  service  socket 


3
2-PSUサーバーを120ボルトから240ボルトにホットスワップできますか?
2つのPSUを搭載したサーバーを120ボルトから240ボルトに移行していますが、オフラインにしたくありません。PSUは相互に接続されていないため、一度に1つずつ新しい電圧に移動できるように思えます。 1つのPSUを120ボルトで実行し、1つのPSUをPDUのラックにかかる時間の間に240ボルトで実行すると問題が発生しますか?

2
AWSでsftpインスタンスの負荷を分散する方法
でsftpサーバーの負荷を分散できることを知りたいですAWS。2台のサーバーがあり、各サーバーがs3fs-fuse同じサーバーをS3 bucketマウントポイントにマウントするために使用しています。私のec2インスタンスはどちらもマウントポイントに対して読み取り/書き込みを行うことができ、からはS3、両方のサーバーのファイルを表示できます。 私が探しているのは、SFTPファイルを転送しAmazon S3、ファイルを保存するために使用することです。ファイルは毎日アップロードされ、ダウンロードされます。 https://github.com/s3fs-fuse/s3fs-fuse 次のステップとして、sftpサーバーの負荷を分散する方法を知りたいので、ユーザーが特定のIPアドレスに接続すると、sftpサーバーの1つにリダイレクトされます。を調べましたがelastic load balancers、特定のポートしか許可していないようです。私も調査しましたがHAProxy、そのソリューションがどれほど安全かはわかりません。私はHIPAAコンプライアンスを考慮に入れなければなりません。ベンダーがサポートしていないため、ロードバランサーは静的IPアドレスである必要がありますDNS hostnames。

3
数ヶ月で切れていく新しいUPSバッテリー
これは1年以上私を困らせてきたものです。サーバールームに3台のAPC SmartUPS 3000といくつかの非APCユニットがあります。各ユニットには、ブレーカーパネルへの専用接続があります。 これらのユニットのバッテリーは4か月に1回程度交換する必要があるようです。前回電池を交換して以来、1回も停電にならないなど、停電が発生することはほとんどありません。電源電圧が悪いのではないかと思ったので、UPSの出力をログに記録しましたが、この4か月間にたるみや過電圧のシナリオは1回もありませんでした。 たぶん、配線が間違っていましたか?私はそれらをテストし、それらをパネルまでたどって、すべてチェックアウトしました。 唯一の可能性は、私が使用していた交換用バッテリーがそれほど大きくないことだと判断しました(Duracell)。もちろん、新しいAPCバッテリーを搭載した2つの真新しいAPC UPSユニットを購入することにしました。4か月後、どちらも死亡しました。 ユニットは、バッテリー電源に切り替わるイベントを登録することはなく、4〜6か月後に不良バッテリーを報告するだけです。これは、モデルやバッテリーのブランドが異なる複数のユニットに影響を与える繰り返し発生する問題です。私はここで何が起こっているのか手がかりがありません、私は電気技師とプロバイダーにさまざまなことをテストしてもらいました、そしてそれはいつもきれいに戻ります。 この時点で私はプロバイダーレベルで何か問題があると考えることができます(悪い変圧器?)、しかし通常それは電圧問題を引き起こします。位相シフトの問題があると聞いたことがありますが、私には単相電力があるので、それが関連しているかどうかはわかりません。 注:私は以前は電気技師でしたが、これがどのように機能するかについてかなり高いレベルの理解を持っています。だからあなたはあなたの答えを黙らせる必要はありません:)

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.