サーバー管理者

システムおよびネットワーク管理者向けのQ&A

8
SSHによるネットワークの再起動
サーバーAで、sshを介してサーバーBに次のコマンドを発行します。 service network stop sleep 5 service network start 問題は、ネットワークを「停止」したため、現在のSSH接続も失われたためです。そのため、後続のコマンドを実行できません(sleep 5とservice network start)。(サービスネットワーク再起動)は使用できませんのでご注意ください。 誰かがこれの回避策/解決策を持っていますか?
11 linux  networking  ssh 

4
複数行にわたるSED交換
私はこれらの3行を見つけようとしています: <!-- <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" /> --> そしてそれらを次のものに置き換えます: <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" /> 私がしようとすると sudo sed -i 's:<!-- <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" /> -->:<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />:' /myfile.xml 見つかりませんでした。\ nも挿入しようとしましたが、それでも機能しませんでした。 sudo sed -i 's:<!--\n <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />\n -->:<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />:' /myfile.xml これらはエラーをスローせず、行のコメントを解除しません。どんなアドバイスでも感謝します!
11 linux  bash  sed 

3
Powershell $ profileディレクトリを変更する
$ profile変数が指す場所を変更する方法を教えてください。 PS H:\> $profile H:\WindowsPowerShell\Microsoft.PowerShell_profile.ps1 H:\はネットワーク共有なので、プロファイルファイルを作成してpowershellをロードすると、次のようになります。 セキュリティ警告信頼できるスクリプトのみを実行してください。インターネットからのスクリプトは有用ですが、このスクリプトはコンピュータに害を及ぼす可能性があります。H:\ WindowsPowerShell \ Microsoft.PowerShell_profile.ps1を実行しますか?[D]実行しない[R] 1回実行[S]一時停止[?]ヘルプ(デフォルトは "D"): Microsoftによると、$ profileの場所は%USERPROFILE%環境変数によって決定されます。本当じゃない: PS H:\> $env:userprofile C:\Users\username たとえば、私は私が望むように動作するXPマシンを持っています: PS H:\> $profile C:\Documents and Settings\username\My Documents\WindowsPowerShell\Microsoft.PowerShell_profile.ps1 PS H:\> $env:userprofile C:\Documents and Settings\username PS H:\> $env:homedrive H: PS H:\> $env:homepath \ $ profileが間違った場所を指しているVistaマシンからの同じ出力は次のとおりです。 PS H:\> $profile H:\WindowsPowerShell\Microsoft.PowerShell_profile.ps1 PS H:\> $env:userprofile …

4
サーバーのrootユーザーにパブリックSSHキーを設定するにはどうすればよいですか?
Slicehost Documentに従ってサーバーをセットアップしようとしています。SSHセクションに到達しました。記述どおりに作成しましたが、rootからログアウトすると、root @ IP_ADDRESS -p 30000に再びアクセスできません。しかし、user @ IP_ADDRESS -p 30000にアクセスできます。 では、問題は、rootユーザーの公開SSHキーを設定する方法ですか?
11 ssh  ssh-keys 

1
DNSサービスの検出、マルチキャストDNS、Bonjourはどのように関連していますか?
用語で少し迷っています。Bonjourを使い始めたかった。最初のステップとして、私はそれを使用する簡単な方法を見つけようとしました。そして、おそらくコマンドラインからBonjourを呼び出して、サービスを登録および検出できると思いました。 他の人にその方法を尋ねると、mDNS(MacとLinuxでは機能しますが、Windowsでは機能しません)について聞かれました。「dns-sd」(Windowsで動作)を使用できると人々からも言われました。「dns-sd」はmDNSの単なるエイリアスであると言われました。 だが!後で私は、DNSサービス検出とマルチキャストDNSが2つの異なるものであることを発見しました(これらは互換性があり、一緒に使用した場合に特にうまく機能しますが、互いに必要としません)。 さらに、mDNSとDNS-SDはBonjourの3つの主要コンポーネントのうちの2つであるように思えます。正しいですか?Bonjourなしで使用できますか?Windows 7にBonjourをインストールし、コマンドラインで「dns-sd」を実行できました。しかし、mDNSを実行できません。 だから、今はちょっと混乱しています。誰かが、状況を少し明確にできますか?

5
新しいユーザーのタブのオートコンプリート
私は新しいLinuxユーザーを追加して useradd -d /var/www/mywebsite.com -m newuser passwd newuser 次のコマンドでサーバーにログインしてアカウントをテストしました ssh newuser@mywebsite.com ログイン後、シェルではタブのオートコンプリートを実行できません。たとえば、/ var / www / myweb {tab}と入力しますが、タブボタンはシェルにスペースを入れるだけです。また、上下の矢印キーを押しても、入力された最新のシェルコマンドは表示されません。 rootとしてsshログインすると、すべてが完璧に機能します。しかし、newuserとしてsshログインすると機能しません。 私は何か見落としてますか? ありがとう
11 linux  useradd 

4
シャドウパスワードファイルでパスワードハッシュはどのようにエンコードされますか?
Linuxのパスワードセキュリティについて学習しています(何よりも好奇心が強い)。実際のパスワードはハッシュされ、シャドウパスワードファイルに保存されることを理解しています。私が確信が持てず、簡単なグーグル検索で見つけることができなかったのは、ハッシュ値(およびソルトの値)をエンコードするために使用されるエンコードです。明らかに16進数ではなく、:文字を除いてテキストです。ここの誰かがそのエンコーディングが何であるかを教えてもらえますか? 編集:私はハッシュ(MD5、SHA-X)、ソルト、およびハッシュ指定子を理解しています。私が探しているのは、ハッシュ結果(バイト配列(byte []))をファイルに表示される文字のシーケンス、つまりエンコードに変換する方法です。

3
IIS 7でアプリケーションプールにカスタムアカウントを使用すると500エラー
Windows Server 2008 SP2上のIIS 7に静的ファイルのみがある非常にシンプルなサイトがあります。 静的ファイルにアクセスしようとすると、500エラーが発生します。HTMLファイルの名前をaspx拡張子に変更すると、正常に機能します。 アプリケーションプールの組み込みIDを使用する場合も、サイトは正常に機能します。この問題は、アプリケーションプールにカスタムアカウントを使用するように切り替えると発生します。ローカルとドメインの両方のアカウントを使用して、アプリケーションプールを実行しようとしました。 私はウェブサイトのディレクトリとファイルでこれらのアカウントを完全に制御しました。 トレースをオンにすると、次のエラーメッセージが表示されます 。ModuleName :IIS Web Core Notification:2 HttpStatus:500 HttpReason:Internal Server Error HttpSubStatus:0 ErrorCode:2147943746 ConfigExceptionInfo Notification:AUTHENTICATE_REQUEST ErrorCode:Eso 無効です。(0x80070542) 私はエラーコードをグーグルで動かすことに全く運がありませんでした。


5
CentOS:起動時にeth0が起動しない
CentOS Hyper-V VMを再起動しても、eth0自動的に起動しません。私がする必要があるのは実行することifup eth0とすべてが修正されますが、それはsshからは実現不可能です!ランレベル3から始めています。 [root@localhost ~]# cat /etc/*release* CentOS release 6.2 (Final) ifup eth0コンソールで実行した後: [root@localhost ~]# ifconfig eth0 Link encap:Ethernet HWaddr 00:15:5D:2B:2B:07 inet addr:10.10.0.3 Bcast:10.10.0.255 Mask:255.255.255.0 inet6 addr: fe80::215:5dff:fe2b:2b07/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:34 errors:0 dropped:0 overruns:0 frame:0 TX packets:49 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 …

5
Roundcube&Postfix SMTP:SSLルーチン:SSL3_READ_BYTES:tlsv1アラート不明ca:s3_pkt.c
個人的に使用するだけでなく、他のユーザーに提供するPostfix / Dovecot / Roundcubeセットアップがあります。このセットアップ全体を新しいボックスに転送しようとしていますが、いくつかの問題があります。 メールの受信は正常に機能しています(内部でのみテストされており、ドメインはまだ転送されていません)。また、TLS / SSLを使用して外部IMAPとSMTPがうまく機能しています(Thunderbirdなど) 問題は、127.0.0.1へのIMAPを使用でき、ユーザーの電子メールを素晴らしく表示できるラウンドキューブのセットアップにありますが、電子メールを送信することはできません。 "SMTP Error (220): Authentication failed." 奇妙なことに、現在のサーバーで使用したのと同じPostfix / Dovecot構成では、Roundcubeは新しいサーバーでアクセスできなくなりました。関連するラウンドキューブの構成は次のとおりです。 $config['smtp_server'] = 'tls://localhost'; // Log SMTP conversation to <log_dir>/smtp or to syslog $config['smtp_debug'] = true; // SMTP port (default is 25; use 587 for STARTTLS or 465 for the // deprecated SSL over …

3
SpamAssassinで不適切な単語フィルターを編集する方法
SpamAssassinに複数のカスタム「悪い」単語を追加して、その単語を含むメールをスパムとしてマークするにはどうすればよいですか? 更新 キーの1つは、/ etc / mail / spamassassinファイルを編集し、次の説明に従ってbadwordフィルターを追加することです。 http://linuxguruz.wordpress.com/2008/09/16/spamassassin-example/ しかし、この場合、メールはスパムとしてマークされているだけで、まだ受信トレイに送信されます... 悪い言葉を含むメールをまったく受け取らないようにするにはどうすればよいですか? 更新2 メールがスパムとして分類された場合、私のSpamAssassinは件名を変更しますが、現在は正常に動作します。/etc/mail/spamassassin/local.cfファイルは次のようになります。 ok_locales all skip_rbl_checks 0 required_score 5 report_safe 1 rewrite_header Subject ***SPAM*** use_pyzor 1 use_razor2 1 use_auto_whitelist 0 use_bayes 1 use_bayes_rules 1 bayes_auto_learn 1 blacklist_from *@kupiizaradi.cjb.net blacklist_from *@hallmark.com whitelist_from *@*hrgworldwide.com whitelist_from *@bluehost.com #blacklist_from *@greekajob.com header CONTAINS_VIG Subject =~ …

2
SSL証明書の署名要求に使用するFQDNホスト名-CNAMEレコードを使用する場合
別のホスト名(CNAMEレコードで定義)のエイリアスであるサブドメイン(https://portal.company.com)があります。 この動的DNSホスト名(https://portal.dlinkddns.com)は、オフィスのパブリック(動的)IPアドレスに解決されます。オフィスでは、スタッフが自宅からアクセスできる(Spiceworks)Webポータルを実行しているサーバーにポート443を転送するようにルーターが構成されています。オフィスのパブリックIPアドレスが変更された場合でも、サブドメインは引き続きスタッフをWebポータルに誘導します。(予想される)SSL証明書のエラースタッフがサイトに最初に接続したときを除いて、すべてがうまく機能します。 SSL証明書を購入しましたが、現在サーバー上で証明書署名要求を完了しています。 それが私の質問につながります... 「共通名(サーバーFQDNまたはあなたの名前)」の証明書署名要求を完了するとき、何を入力すればよいですか? 正規名(https://portal.dlinkddns.com)またはエイリアス(https://portal.company.com)を入力する必要がありますか?サーバー自体のFQDNは "servername.companyname.local"であるため、使用できません。 提案やアイデアは大歓迎です!

1
組み込みプラグインを使用してSLURMを実行しているクラスターの汎用リソースとしてGPUをリクエストすると失敗するのはなぜですか?
免責事項:すべての関連する構成情報を提供しようとしたので、この投稿はかなり長くなります。 ステータスと問題: 私はgpuクラスターを管理しており、ジョブ管理にslurmを使用したいと考えています。残念ながら、slurmの各汎用リソースプラグインを使用してGPUをリクエストできません。 注:test.shは、環境変数CUDA_VISIBLE_DEVICESを出力する小さなスクリプトです。 でのジョブの実行--gres=gpu:1は完了しません 実行srun -n1 --gres=gpu:1 test.shすると、次のエラーが発生します。 srun: error: Unable to allocate resources: Requested node configuration is not available ログ: gres: gpu state for job 83 gres_cnt:4 node_cnt:0 type:(null) _pick_best_nodes: job 83 never runnable _slurm_rpc_allocate_resources: Requested node configuration is not available でジョブを実行して--gres=gram:500います srun -n1 --gres=gram:500 test.shしかし、私が呼び出すと、ジョブが実行されて印刷されます CUDA_VISIBLE_DEVICES=NoDevFiles ログ: …


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.