サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
UREのためにRAID5 / 6が危険な場合、フルバックアップ/復元スキームも危険にさらされますか?
私が理解しているように、タスクを実行するために大量のデータを読み取る必要があるため、再構築中にUREに遭遇する可能性が高くなります。 この問題は、大量のデータのバックアップと復元のシナリオにも影響しますか?10TBのバックアップから完全な復元を行う必要がある場合、UREも同じように思えます。
11 backup  raid 

2
Ext4の使用法とパフォーマンス
CarbonとGraphiteを実行しているマシンのクラスターを持っているので、ストレージを増やすためにスケールする必要がありますが、スケールアップする必要があるか、スケールアウトする必要があるかはわかりません。 クラスターは現在、次のもので構成されています。 1リレーノード:すべてのメトリックを受信し、関連するストレージノードに転送します 6ストレージノード:すべてのWhisper DBファイルを収容 問題は、ディスクの使用率が80%近くになると、パフォーマンスが崖から落ちたように見えることです。クラスター書き込みIOPSは、ほぼ一定の13kから約7kのより混aroundとした平均に低下し、IOwait時間の平均は54%です。 構成レポを確認しましたが、4月上旬以降変更はないため、これは構成変更の結果ではありません。 質問:ディスクサイズを増やすとIOパフォーマンスが制御下に戻りますか、それともストレージノードを追加する必要がありますか? 注:ここにはSSDはありません。たくさんのスピンドルがあります。 関連グラフ: 統計ともの: e2freefrag: [root@graphite-storage-01 ~]# e2freefrag /dev/vda3 Device: /dev/vda3 Blocksize: 4096 bytes Total blocks: 9961176 Free blocks: 4781849 (48.0%) Min. free extent: 4 KB Max. free extent: 81308 KB Avg. free extent: 284 KB Num. free extent: 19071 HISTOGRAM OF FREE …

2
SFTPサーバー:SSH内部sftpサブシステムまたはProFTPDプラグインを使用する方が良いですか?
新しいSFTPサーバーをインストールするように依頼されました。本質的に、これは非常に簡単な操作です。internal-sftpユビキタスSSHサービスの役割(chroot を使用)を使用するだけで、信頼性の高いSFTPサーバーを使用できます。 しかし、同じ問題に対して少なくとも2つの異なるアプローチを常に試みることは私の性質でありProFTPD、より詳細なファイル転送関連オプションの追加の利点を使用して、同じことを行うためにsftpプラグインで使用できることに気付きました(例:帯域幅調整)。一方、このプラグインはデフォルトではコンパイル(およびバンドル)されていません。「おそらくテストされていない」ソリューションを(おそらく)回避したいと思います。 現時点では、必要なサービスはSFTPのみです。ただし、事前にプレイしているので、SFTPだけでなくFTP / Sでも機能するソリューションを実装したいと考えています。 私は彼らの家の中でユーザーをchrootするつもりであることを考えると、より良い解決策は何だと思いますか? FTP / SサービスにSSH internal-sftpとスタンドアロンFTPサーバー(vsftpdまたはproftpd)を使用する 関連するプラグインでのみProFTPDサービスを使用する
11 ssh  ftp  sftp  proftpd 

1
SSL接続を切断せずにApacheを正常に再起動するにはどうすればよいですか?
次のようなコマンドを使用して、Apacheを適切にリロードしようとしています。 apache2ctl -k graceful これはHTTPユーザーに対して期待どおりに機能し、Webサイトのユーザーに影響を与えることなくApache構成が再ロードされます。 ただし、HTTPS経由でサーバーにアクセスしているユーザーは、正常なリロード中に切断されることがわかりました。 SSL接続に影響を与えずにApacheを正常にリロードするにはどうすればよいですか? 役立つ場合は、Apache 2.4.20でHTTP 2を使用しています。
11 ssl  apache-2.4  http2 

3
NTPにもかかわらず、スイッチの1つが2分間オフになるのはなぜですか?
Cisco 4500スイッチの1つでクロックが正しく動作しないという純粋なチャンスに気付いたのです。機能しているように見えるにもかかわらず、2分以上遅れています。私の意見では、1秒でも、関連するシステムに受け入れられると見なされるべきではありません。また、単純な壁時計と比較していなければ、診断との違いに気付かなかったでしょう。 いくつかの詳細 フォールバックのために部分的に相互に参照しているホストの一部(10.0.99.1、10.0.99.2、10.0.1.119、10.0.99.241)のntp情報は次のとおりです。外からの時間。したがって、時間の不一致は、異なる元の時間ソースに起因することはありません。観察がやや妄想的になったので、次の意味で「正しい時間を持っています」:(show clockまたはdate)ウォールクロックとローカルシステムクロック(http://time.isによると問題ありません)に一致する出力を生成しました間違いなく1秒未満のエラー(ローカル時計を見ながらEnterキーを押す精度) 10.0.1.119(Ubuntu)には正しい時間があります $ ntpq -np remote refid st t when poll reach delay offset jitter ============================================================================== +10.0.99.1 10.0.0.1 3 u 855 1024 377 0.904 -2.658 0.113 *10.0.0.1 130.149.17.8 2 u 266 1024 377 0.253 0.909 0.127 10.0.99.241(Cisco 2960)には正しい時間があります #sho ntp associations address ref clock st when …

3
docker、alpine、およびmatplotlib
現在、アルパインを使用してドッカー画像の1つを縮小しようとしています: FROM python:2.7-alpine ただし、matplotlib.hをインストールするpipの問題があります。 EOF warning: no previously-included files matching '*.pyo' found anywhere in distribution warning: no previously-included files matching '*.pyd' found anywhere in distribution numpy/core/src/multiarray/numpyos.c:18:21: fatal error: xlocale.h: No such file or directory compilation terminated. numpy/core/src/multiarray/numpyos.c:18:21: fatal error: xlocale.h: No such file or directory compilation terminated. Traceback (most recent …
11 python  docker 

1
グループポリシーを介してWindows 10 ProでDSCPを設定できない
Windows 10で「ポリシーベースのQoS」を設定しても、DSCP値は発信トラフィックに適用されません。特定のプロセスのDSCPトラフィックの値を設定できるようにします。 gpedit.mscグループポリシーエディターを使用して、[コンピューターの構成]> [Windowsの設定]> [ポリシーベースのQoS]でポリシーを作成し、DSCP値を「10」に設定しました。実行可能ファイル名を使用して、または使用せずに試しました。NetMonのトラフィックを見ると、DSCP値0が表示されます。 これは、「NLAを使用しない」レジストリキーhttps://support.microsoft.com/en-gb/kb/2733528を適用した後、Windows 7で機能しました。 ただし、これを追加しても、DSCPは常に0です。

3
SSL証明書は一部のクライアントでのみ機能しますか?
ホスティングプロバイダーは、古いドメインのSSL証明書を誤って失効させた後、最近ドメインのSSL証明書を再発行して再インストールしました。 これで、HTTPSを介してWebサイトを再度閲覧できるようになりました。ホストも同様に、他の多くのユーザーも同様です。 ただし、一部のユーザー(少なくとも数百人のうち数十人)がYour connection is not secure、さまざまなブラウザやプラットフォームでエラーメッセージを受け取っています。(再現できない問題を診断するのは難しいことが証明されています。) ブラウザごとに認証局(CA)のリストが異なることを理解しています。 私と同じバージョン(OS Xの45.0.1)のFirefoxを実行しているユーザーが、SEC_ERROR_UNKNOWN_ISSUER(私のサイトのみで)エラーを受け取っているのに、どうしてですか?何がそれを可能にしますか?ユーザーはキャッシュをクリアし、ラップトップを再起動しました。 私は走ったdigicert.com上のSSLチェックを。結果は次のとおりです。 SSL証明書は信頼されていません 証明書は、信頼できる機関によって署名されていません(Mozillaのルートストアと照合)。信頼できる機関から証明書を購入した場合は、おそらく1つ以上の中間証明書をインストールする必要があります。サーバープラットフォームでこれを行うには、証明書プロバイダーに問い合わせてください。 この場合、SSLエラーなしでサイトに接続できるのはなぜですか?

4
VMware ESXi 5.5サーバー上のDELLハードウェアを監視する
このトピックをかなりオンラインで調査しているにもかかわらず(公平を期すと、私はフルタイムのシステム管理者ではありません)、これを理解することはできません。 多くのVMWare ESXi 5.5サーバーがあり、その一部はvSphereに統合されており、一部は(コスト上の理由で)統合されていません。 DELL VMWare ESXiイメージを実際に実行している1台のマシンを除き、それらはすべて標準のESXiイメージを実行します。 私が達成したいことは簡単に思えます:SNMPホスト、SNMPウォーク、Nagios、PRTGなど、リモートホストからSNMP経由でクエリできるようにシステムを設定します、ファン速度、PSUステータスなど。 DELLからVMWareバージョンをインストールすると、必要なモジュールが自動的に有効になります(最も重要なのはOpenManage)と思われましたが、そうではないようです。 これがまったく可能かどうかについては矛盾する情報があります。一部の文書では、SNMPを介してDELL VMWare ESXiサーバーにクエリを実行できず、CIMクライアントを使用する必要があると書かれています。次に、インストールできるOMSA VIBなどがあります。 これはかなり一般的な要件であると思いますが、利用可能なドキュメントはすべての異なる方向に1つを引き出します。 (完全なvSphere環境なしで)私がしようとしていることは可能ですか?

3
/ etc / hostsのサイズ制限(Linux)
パフォーマンスの低下が見られる前に、Linuxシステムでの/ etc / hostsの理論上のサイズ制限が誰かに気付いたことがありますか? さらに、予想される制限が何であるかを述べている公式ソースに誰かを向けることができますか?
11 linux  hosts 

2
DNSサーバーが不明なドメイン要求に応答することを要求するRFC
現在、ドメインレジストラーとDNSは、不明なドメインへのDNS要求を無視します。無視するということは、ブラックホールを意味し、応答しないことを意味します。これにより、DNSクライアントとリゾルバライブラリは再試行、バックオフ、最後にタイムアウトします。 dig @NS3.DNSOWL.COM somedomainthatdoesntexist.org ... ;; connection timed out; no servers could be reached 他の一般的なドメインネームサービスを調査すると、他のプロバイダーは5(拒否)のRCODEを返すため、この動作は非常にユニークです。 dig @DNS1.NAME-SERVICES.COM somedomainthatdoesntexist.org dig @NS-284.AWSDNS-35.COM somedomainthatdoesntexist.org dig @NS21.DOMAINCONTROL.COM somedomainthatdoesntexist.org すべて次のようなものを返します。 ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 64732 または ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 31219 サーバールームのフロアにリクエストを単にドロップするのではなく、返すREFUSEDかNXDOMAINすぐに返すことが適切です。 サーバーが応答しないことについてプロバイダーに不平を言うと、サーバーが違反しているというRFCを引用するように頼まれます。サーバーがすべての要求に応答する必要があることを証明するように彼らが私に求めているのは奇妙ですが、それはそうです。 質問: 私の規定では、リクエストIDが重複していないか、何らかのDOS応答がない限り、サーバーは常にリクエストに応答する必要があります。これは正しいです? 規定をサポートするには、どのRFCと特定のセクションを引用すればよいですか? 私にとって、DNSクエリに応答しないのは悪いことです。ほとんどのクライアントはバックオフし、同じクエリを同じDNSサーバーまたは別のサーバーに再送信します。クライアントの速度が低下するだけでなく、権限のあるネームサーバーとNSエントリに応じて、独自のサーバーまたは他のサーバーによって同じクエリが再度実行されます。 ではRFC 1536および2308 …

2
システムがWake-on-LAN(WoL)のせいで起動したのか、電源ボタンのせいで起動したのかをどのように確認できますか?
Windows 10では、Wake-on-LAN(WoL)パケットを受信して​​電源がオンになったため、または電源ボタンを押したためにオンになったためにシステムが起動したかどうかをスクリプトで確認する方法を知りたい。 Win32_ComputerSystemクラスのWakeUpTypeプロパティを見つけました。「システムの電源を入れるイベント」を返すように文書化されています。可能な戻り値は9つあり、そのうちの1つは「5」です(「LANリモート」を意味します)。 残念ながら、私のシステムでは常に「6」(「電源スイッチ」を意味する)を返すようです: PS C:\WINDOWS\system32> echo $(Get-WmiObject -class win32_computersystem).wakeuptype 6 システムをスリープ状態にし、WoLを使用してスリープを解除した後、Windowsはソース「Power-Troubleshooter」とテキストを含むイベントID 1を使用してシステムイベントログにイベントを投稿します。 ウェイクソース:デバイス-Intel(R)82579Vギガビットネットワーク接続 また、powercfg /lastwake起動の理由としてNICを報告します。そのため、少なくともスリープから復帰した場合、WakeUpTypeプロパティがまだ「6」(電源スイッチ)を返していても、WindowsはWoLパケットが原因で起動したと判断できます。 残念ながら、システムがS5状態でWoLパケットを受信すると、適切に電源が投入されて起動しますが、WoLが原因で起動したとは言えません。powercfg /lastwake電源ボタンを押したためにシステムがS5から電源オンになったときとまったく同じ出力を表示します。 C:\WINDOWS\system32>powercfg /lastwake Wake History Count - 0 WoLが原因でシステムの電源がオン/ウェイクアップしたことを、どのような電源状態(S5まで)から確実に知ることができますか?

2
バックエンドがダウンしている場合、nginxはプロキシキャッシュを使用します
バックエンドサーバーがダウンした場合、nginxプロキシはキャッシュを使用する必要があります。 これが私の構成です。しかし、バックエンドサーバーをチェックせずにnginxがキャッシュを使用しているようです。 http { # ... proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_cache_path /tmp/nginx levels=1:2 keys_zone=tmpzone:10m inactive=60m; proxy_cache_key "$scheme$request_method$host$request_uri"; server { server_name _; location / { proxy_connect_timeout 5s; proxy_read_timeout 5s; proxy_cache tmpzone; proxy_cache_valid 200 304 1d; proxy_cache_use_stale error timeout invalid_header updating http_500 http_502 http_503 http_504; proxy_set_header X-Real-IP …
11 nginx  proxy  cache  failover 

4
AWS SQS + SNS +ラムダ
SQSキューにメッセージを送信し、SNSトピックをサブスクライブして、電子メールを送信するためのラムダをトリガーできるかどうか疑問に思っていました。 SQS-> SNS->(ラムダ)-> SES SNSメッセージをSQSに送信できることは知っていますが、他の方法が可能かどうか興味があります

5
特定のドメインにサービスを提供するサーバー機能のテスト
Server Aお気に入りのwebserver-daemonを使用して設定したとしますwww.example.com。次に、これをに移動しServer Bます。大量のコピーと構成を行った後、新しいサーバーは準備ができているようです。最後のテストは順番に行われます。DNSレコードを変更する前www.example.comに、DNSレコードがまだサーバーAを指しているときに、サーバーBにどのように要求しますか。 私の主な質問に答えましたが、/ etc / hostsが私の影響下にない場合、代わりに生のHTTP1.1をWebサーバーに伝えることでtelnetでテストすることは可能ですか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.